PDA

View Full Version : Loss of control of Keyboard/Mouse for entire system while running WoW



Rhainik
March 2nd, 2008, 06:35 PM
Hello all!
I've got a bit of an odd problem occurring with what I suppose might be the ever popular WoW for Wine. At random times, I will suddenly lose total control of both my mouse and keyboard (for my entire system, not just WoW), which certainly causes a bit of inconvenience. The only remedy for this is to reboot, which I can accomplish two ways due to my setup (this makes it even stranger): either the power switch or a second keyboard I have plugged in which for some reason is unaffected by the loss of control. I cannot say for certain if this is WoW specific because I do not have any other applications that I use frequently with Wine.

I'd be grateful for any help!

My system setup:
Ubuntu Gutsy
Wine 0.9.46
Athlon XP 2900+ processor
1 GB DDR RAM
256MB GeForce 6600 graphics
Cordless desktop Logitech keyboard/mouse (the malfunctioning ones)
IBM Rapid AccessKeyboard (the working one)

scrabbleship
May 20th, 2008, 06:39 PM
I stumbled upon this while looking for a solution to the same problem. Any ideas on how to fix this?

AtticusG3
September 27th, 2008, 04:11 AM
I third this motion. Though for me it only occurs on the opening menu screens, IE it can happen if I need to accept the EULA's again, or on the login screen, or the Character Selection Screen.

Once I am past those it hasn't happened too me. It is very random but seems to occur more frequently than not. I am using PS2 Keyboard and Mice. THey don't have any issues with Linux apps or When I boot into /shudder Windows. WoW is the only app I run with Wine. I installed Wine 1.0 with apt-get. WinXP compatibility mode is default. I haven't been able to figure out any likely causes.

Any suggestions from the comunity would be appreciated.

forrestcupp
September 27th, 2008, 10:28 PM
I'm not running Linux right now, but try going into your wine configuration and find the option to let your window manager control things.

spydon
September 27th, 2008, 10:30 PM
Why do you use such an old version of wine?

wtiz
February 18th, 2009, 06:39 PM
I have the same issue. Except with me it happens everytime I use the mouse at all. The game doesn't crash and freeze up. It just kills the keyboard and mouse and I have to reboot. I'm using wine 1.1.15 currently. I've tried several past builds but all have the same problem. The weird thing is, It actually started working for about an hour and ran great. Any advice would be greatly appreciated. I'd hate to have to go back to windows because of this.

Mmmbopdowedop
February 18th, 2009, 06:45 PM
I had a similar problem some time ago, before I set in winecfg to emulate a virtual desktop.

This may be completely irrelevant though.

Before I did this, the problem I had was because of an addon with Compiz so if I was planning on spending ages playing i'd just disable Compiz and it would play fine.

Hated it when it happened and then it would give me back control once I had died. :(