View Full Version : .net almost there...

February 25th, 2008, 03:44 AM
Its exciting to me how close i have come to running .net programs! (wow i need a life) anyway....

i could not see the loading bar but the .net 2.0 installer started that it installed successfully.

the only thing i did from the wine web site to make this work is the reg fonts suggestion here: link (http://appdb.winehq.org/objectManager.php?sClass=version&iId=3754) and i copied all the dlls from my windows vista to the system32 folder in wine

Here is what i get when trying to run a .net program:

~$ wine '/pathto//Engineer.exe'
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC80.CRT"
err:module:import_dll Library MSVCR80.dll (which is needed by L"C:\\windows\\Microsoft.NET\\Framework\\v2.0.50727\ \fusion.dll") not found
err:module:import_dll Library fusion.dll (which is needed by L"C:\\windows\\Microsoft.NET\\Framework\\v2.0.50727\ \mscorwks.dll") not found

And this popup:

The only other thing i can think of is patching and recompiling wine (witch is what wine suggests)

Any help/suggestions is greatly appreciated
If there are any questions please ask

Oh and does anyone have a .net working in wine?

January 1st, 2009, 05:00 PM
Hi there,

This is the exact same problem I am receiving when trying to get .Net 1.1 to work. mscorwks.dll is missing and will not load.

Any help on this would be appreciated,


January 1st, 2009, 06:51 PM
Did you try using mono instead of wine ?