PDA

View Full Version : Sins of a Solar Empire says I need to download IE



skroops
February 21st, 2008, 11:19 PM
Sins of a Solar Empire is listed as atleast somewhat playable on appdb but when I try to start it under Ubuntu Gutsy with the latest Wine, it gives me an error message that I need to download msxml or IE. I have IE installed and I can't get XML 6 to install (error with the msi file). Attached is an image of the error. Can someone help me figure out why other people can run it and I can't?

Thanks

Nameless_one
February 22nd, 2008, 12:27 AM
Have you tried winetricks (http://kegel.com/wine/winetricks) to install msxmsl6?

By the way, I am trying to run Sins of a Solar Empire myself, on wine. The game installs fine, but when I run it, everything is extremely choppy and slow. I have to wait about four second after I press the Options button, for the Options screen to appear. And sound staggers too.

Deten
February 24th, 2008, 12:07 PM
Same problem for me, sorry i cant help, but im lookin for an answer

Nameless_one
February 25th, 2008, 12:45 AM
Btw, my problem was the version of the fglrx driver that ships with Gutsy -- it was too old. I installed the latest driver from ATi and the game isn't choppy anymore. Still though, the game doesn't run very well. Video is going fine, but audio is still choppy. Besides that, most of the text in the game (and in menus) is distorted.

@Deten
Are you having my problem, or the OP's? If you have the OP's, did you try winetricks?

Nameless_one
February 25th, 2008, 05:30 PM
Bump?

skroops
February 27th, 2008, 11:33 PM
My problem was that you have to launch Sins directly from the main executable. The link that is added to the wine programs group links to the launcher, which does not run. The game still doesn't work but it atleast tries.

Nameless_one
February 28th, 2008, 12:34 AM
What problems does it have for you?