PDA

View Full Version : Fullscreen Wine Apps Problem



Kingfield
February 19th, 2008, 11:43 AM
Okay so I Have a problem with fullscreen apps (specifically warcraft III), But i am quite sure that it would apply for all fullscreen apps.

I have a widescreen laptop so my default resolution is : 1680x1050

However in Warcraft III The max resolution I can set it to is 1024x768

So whenever I alt tab (or change virtual desktops), The screen starts flickering (It quite rapidly changes from 1680x1050, a black screen, and a very low resolution (I don't think that it is actually 1024x768 looks more like 800x600).

After it flickers for 5-8 seconds it stays in the low resolution and it is VERY annoying and unpractical especially the flickering part. This is stopping me from using ubuntu often right now, since the old desktop when i used default 1024x768 never encountered a problem like this.

Thanks in advance, Kingfield.

If this is a bit hard to understand just tell me and i will try to clarify.

Kingfield
February 20th, 2008, 09:21 AM
ummmm. Bump?

Faud
February 20th, 2008, 11:53 AM
Why dont you just change your virtual desktop size on wine to 1024x768 ?

Toffeeapple
February 20th, 2008, 03:27 PM
You can set a custom resolution for warcraft III in the registry (see the below link).. and then set 'emulate a virtual desktop' to the same within wine.. (I find I get better results with games in wine when run in virtual desktop mode)

Mine for example is set to 1430x865 which enables it to fit quite snugg onto one of my 1440x900 monitors..

For info on setting widescreen resolutions for many games go here (http://www.widescreengamingforum.com/wiki/index.php/Master_Games_List_-_A)

Kingfield
February 21st, 2008, 08:44 AM
uhm the problem with that is virtual desktops wont stop the mouse from leaving the app... so its really annoying, since i need to scroll the screen by putting the cursor at the edges of the screen, if you know what I mean. Or is there a way to stop the mouse from leaving the window as well?

Toffeeapple
February 21st, 2008, 09:42 AM
I feel your pain...

If there is one thing about wine/linux and windows games, it's that getting one thing to be how you want it invariable makes something else become a niggling problem, this is my experience anyhow.

Personally I'd rather have my mouse able to leave the game window as I have duel monitors and do other stuff in one of them while playing games..

With games that 'edge of the screen scroll' I use the keyboard where possible.

: )

Kingfield
February 23rd, 2008, 01:04 AM
Hmm, i'll try getting Warcraft to work at my resolution, i will post the results.

FANTASTIC, it works, no more annoying flashing THANKYOU VERY MUCH. :D