View Full Version : Wine bluetooth com setup (and urgent help needed for overwritten file)

February 18th, 2008, 09:42 PM
I am trying to get "MyPhoneExplorer" working under Wine, as detailed in this forum:http://www.fjsoft.at/forum/viewtopic.php?t=2838 (http://www.fjsoft.at/forum/viewtopic.php?t=2838)

I have managed to get the actual program running but am having trouble with the Bluetooth steps:

Start the bluetooth-services:

# /etc/init.d/bluetooth start

Then you have search for your mobile phone. For that you should turn of bluetooth at every other device, if there are any. Turn it on on your cell phone and make it visible. Then type the command:

# hcitool scan

This command returns a hex-adress which should displace the "00:11:22:33:44:55" in the next command.

# rfcomm bind 0 00:11:22:33:44:55

Usually you have to do this every time after restarting. To avoid this, we change a few things in the bluetooth-config file. Therefore open the file with your common texteditor, I'm using kwrite:

# kwrite /etc/bluetooth/rfcomm.conf

My rfcomm.conf (I've changed my hex-adress!):

# RFCOMM configuration file.

rfcomm0 {
# Automatically bind the device at startup
bind yes;

# Bluetooth address of the device
device 00:11:22:33:44:55;

# RFCOMM channel for the connection
channel 2;

# Description of the connection
comment "Example Bluetooth device";

Then you have to restart the bluetoot-services:

# /etc/init.d/bluetooth restart

Now we're going to link the device file with a wine device:

# cd ~/.wine/dosdevices


# ln -is /dev/rfcomm0 com1


# yes


# chmod 777 com1

Now it should work, but it often doesn't. So start YaST > Hardware > Bluetooth. The Bluetooth-services should be activated and you should set the security-manager to "Local PIN..." und insert a user-defined PIN.

Now the great moments comes closer: the first contact with your mobile phone:

# echo "ATZ" > /dev/rfcomm0

Then your phone should ask, if the incomming connection should be permitted. Say yes and if there are any other questions, say also yes. Then the phone should ask for a PIN: Now type the SAME PIN than in YaST.

I think the problem may be because the author of the post used SUSE, so some things may be different in Ubuntu. For starters, I do not have a file in /dev/ called rfcomm0... I did a search and found a file in /usr/bin/ called rfcomm and stupidly tried the steps with that instead, resulting in the file being replaced with an executable text file reading "ATZ" rather than the 26.2kb executable it was before. It doesn't seem to have broken anything and bluetooth still works, but i'm a bit worried...

Can anyone please:
a) tell me how to restore my rfcomm file
b) tell me how to do it properly

Thank you!

February 18th, 2008, 10:00 PM
The crisis is (hopefully) over - I copied the rfcomm file from the live CD back into my /usr/bin folder.

But I'm only back where I started, and still need help with actually making the bluetooth com settings work! Thanks in advance, helpful Ubuntu people :p

February 19th, 2008, 04:51 PM
Still haven't figured this out... help appreciated :)

February 25th, 2008, 06:38 PM
bump... :(

February 28th, 2008, 05:35 PM

March 23rd, 2008, 10:15 PM
in case anybody gets similar problems and finds themselves here, i should probably note that i fixed the issue (no thanks to these forums...)

Fixed it using this page: http://ubuntology.com/2007/10/27/access-your-phone-via-bluetooth-with-ubuntu-gutsy/

Before I run MyPhoneExplorer I have to run "rfcomm connect 0 XX:XX:XX:XX:XX:XX 2", but that's a minor inconvenience, and I've made a keyboard shortcut for it.

January 20th, 2009, 07:32 PM
thank you! i will try your fix....

January 31st, 2010, 04:26 AM
The link suggested above:

Fixed it using this page: http://ubuntology.com/2007/10/27/acc...-ubuntu-gutsy/

Does not work anymore. Does anyone know what it said? I have the problem the OP had and I need to know what he did to fix it.

For my specific problem see this thread: this tread (http://ubuntuforums.org/showthread.php?p=8751370&posted=1)

January 31st, 2010, 04:25 PM