View Full Version : Transmission SVN script!

December 28th, 2007, 08:37 PM


echo "\nThis script will download & compile Transmission to your home dir.\n"
echo -n "Downloading latest Transmission trunk..."
svn -q co svn://svn.m0k.org/Transmission/trunk transmission-svn
echo " Done"

cd transmission-svn
sh autogen.sh
./configure -q
make -s

echo -n "\nMoving binary to /home/`whoami` and removing svn dir..."
mv gtk/transmission ../transmission
rm -rf transmission-svn
echo " Done"

echo "\nTransmission has been built from SVN. Have a nice day `whoami`."

NOTE: The script doesn't install libs needed if you havn't got those. The reason is because this will only have to be done one time. Not each time you want a new transmission binary.

December 29th, 2007, 08:28 PM
Thanks, but what does "Transmission" do, please?

December 29th, 2007, 08:42 PM
The best bittorrent client, if you ask me ;) MUCH better than the one that comes with Ubuntu

December 29th, 2007, 09:27 PM
Thanks, but what does "Transmission" do, please?

Transmission is a lightweight BitTorrent client, It is one of many bittorrent programs available for linux.

Some others include

January 1st, 2008, 03:52 AM
No one else found this useful? :( :lolflag:

January 1st, 2008, 04:25 AM
I may find a use for it someday, but right now I am happy with the one that comes with Opera.

January 1st, 2008, 07:54 AM

That script looks great and I've been searching for a way to install transmission on ubuntu edgy 6.10. Could you please tell me if your script will work well on edgy? I'm a bit stuck. What do I save this transmission.sh script to and how can I do that? After I save transmission.sh to something, then do I type:

sudo ./transmission.sh

and that's it?

I'm a bit confused because I also saw another example of a shell script in which someone advised that it be run like:

$ chmod 777 checksplash.sh
then fire the script
$ ./checksplash

But in this case, can you confirm that I don't need the chmod 777 line?
Since I am using 6.10 (edgy), I believe that I am using the dash shell. Is this a dash or bash script and how can I use it using dash?

And after the script runs and transmission is installed, can I find transmission in my home folder (from "places" at the top menu)?

Since I'm on edgy, do I have to worry about dependency problems when running this?

Thanks in advance for helping me out. I just installed ubuntu a few days ago but I'll be reading more linux books in the future.


January 1st, 2008, 11:15 AM
Thanks for the script! Transmission is a good bittorrent client.

January 1st, 2008, 12:51 PM
transmission.sh to something, then do I type:

sudo ./transmission.sh

and that's it?

You can save it anywhere and start it in a terminal with sh transmission.sh
When it is done you will have a transmission binary file in your home dir!

This script doesn't install libs that you may need, so watch where it stops if it fails.

January 2nd, 2008, 01:06 AM
I saved transmission.sh to a folder in my home folder.
Then I opened terminal:

user1@user1-desktop:~$ sh transmission.sh
sh: Can't open transmission.sh
user1@user1-desktop:~$ sudo ./transmission.sh
sudo: ./transmission.sh: command not found
user1@user1-desktop:~$ sudo sh transmission.sh
sh: Can't open transmission.sh

I don't understand why I'm not able to execute this script.
Please help?


January 2nd, 2008, 01:18 AM

I think I'm good when it comes to dependencies b/c I got this from


* A version of the `getopt' library with getopt_long(). Most systems already have this.
* intltool 0.23 or later
* gettext 0.14.1 or later
* OpenSSL 0.9.8 or later. (See note)
* GTK+ 2.6 or later. (See note)
* Note: if installing OpenSSL or GTK+ from a package manager, you'll also need to install their corresponding development packages. These are usually named $PACKAGENAME-devel or $PACKAGENAME-dev, depending on which distribution and/or repository you use.

I used this command to check each item:
dpkg -l | grep gettext

All were good except
When typing:
dpkg -l | grep getopt
nothing happened. It just skipped down to another prompt. But I figure I probably have that one since I had the others (at later versions).

So if you could let me know how to execute the script I think I'll be cool.

January 2nd, 2008, 12:51 PM
chmod +x transmission.sh
sh transmission.sh

January 3rd, 2008, 02:00 AM
I still get an error message when trying to run the script:

user1@user1-desktop:~$ sh transmission.sh
sh: Can't open transmission.sh
user1@user1-desktop:~$ chmod +x transmission.sh
chmod: cannot access `transmission.sh': No such file or directory

Help, I'm failing at life!

January 3rd, 2008, 02:03 AM
im sorry, maybe im missing something here. whats the point of downloading and compiling this if its already in the repos? :confused:

January 3rd, 2008, 02:06 AM
I switched to Xubuntu 7.04 feisty and I still can't get the script to run.

I tried your last commands in Xubuntu 7.04 and it doesn't run.
I'm sorry to bother you, but could you please help me out a bit more?


January 3rd, 2008, 02:09 AM

user1@user1-desktop:~$ aptitude show transmission
Package: transmission
State: not installed
Version: 0.91.dfsg-1~feisty1
Priority: optional
Section: net
Maintainer: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
Uncompressed Size: 53.2k
Depends: transmission-cli (>= 0.91.dfsg-1~feisty1), transmission-gtk (>=
Description: free, lightweight BitTorrent client
Transmission is a simple BitTorrent client. It features a very simple,
intuitive interface (gui and command-line) on top on an efficient,
cross-platform back-end.

Homepage: http://transmission.m0k.org/


Only a really old version appears to be in the repos and I heard the latest versions are great

January 3rd, 2008, 03:31 AM
You have to make sure you have set the script up like this: right click the sh file choose properties then rights and check allow this to be run as a program now you can sh transmission.sh if you are in the right dir.

January 3rd, 2008, 04:58 AM
OK, I did what you said and checked off "allow this file to be run as a program." So that's good. But in terminal, I still get the same error messages I just got. But I noticed that in the file manager on the desktop I had another option by right-clicking the file like I did to get to permissions and there is an execute command when I right click the file. But I get this error message from clicking execute:

Failed to execute "transmission.sh".

Failed to execute child process "home/user1/Apps_temp/transmission.sh" (No such file or directory).

That's weird. user1 is just my account I created when installing xubuntu and Apps_temp is just a folder I created in home to store this script.

Also, this is what my permissions tab in the transmission.sh properties thing looks like:

Owner: namelater (user1)
Access: read & write

Group: user1
Access: read only

Others: read only

Program: and here I checked to allow it to run as a program

For all the access options I can choose: read & write, read only, write only, or none

January 3rd, 2008, 02:02 PM
Hm ok looks like you have problems. Here is the latest SVN compiled as a binary only for you, Hope things work out!

Transmission from SVN 0.96+ (BUILD 4435) compiled for Ubuntu 7.04 or later.

January 4th, 2008, 06:38 AM
Thanks, man!

January 4th, 2008, 07:08 AM
why ./n ?