PDA

View Full Version : Call of duty 4 3D/OpenGL issue



Pages : 1 [2]

thefishki345
June 29th, 2008, 02:24 AM
wait piratesmack...you said that wine 1.10 doesn´t work with 3dmark, then you went and posted a deb of it with 1.10...that doesnt make sense...
and congrats shivans!

piratesmack
June 29th, 2008, 09:24 AM
wait piratesmack...you said that wine 1.10 doesn´t work with 3dmark, then you went and posted a deb of it with 1.10...that doesnt make sense...
and congrats shivans!

yeah I said it doesn't work, but then I said I got the patch to apply by copying and replacing Wine 1.0's directx.c over Wine 1.1.0's
So it's basically Wine 1.1.0 without the changes they made to directx

Seems to have worked out pretty well, actually. I was pretty proud of myself when I came up with that idea =P

pegmag
June 29th, 2008, 10:47 AM
Well I don't know, if changing the directx.c is a good idea, because obviousely they changed something.

Well I did this:
I looked in the 3dmark patch and searched for the lines causing problems. Then I searched for this Lines in the directx.c and replaced them manually, and deleted the lines in the patch file.
Then applied the patch and compiled.

(Sorry for my bad English.. I'm not a native Speaker)

piratesmack
June 29th, 2008, 01:13 PM
Well I don't know, if changing the directx.c is a good idea, because obviousely they changed something.

Well I did this:
I looked in the 3dmark patch and searched for the lines causing problems. Then I searched for this Lines in the directx.c and replaced them manually, and deleted the lines in the patch file.
Then applied the patch and compiled.

(Sorry for my bad English.. I'm not a native Speaker)

Thanks, I'll try that

Your English is pretty good for not being a native speaker :)

pegmag
June 29th, 2008, 08:29 PM
Thanks
I just created a new patch.. works on my machine

piratesmack
June 29th, 2008, 11:01 PM
Thanks
I just created a new patch.. works on my machine

Awesome good job :)

I added a link to your patch in the AppDB:
http://appdb.winehq.org/objectManager.php?sClass=version&iId=10429

thefishki345
June 30th, 2008, 01:07 AM
cool, although I dont think I will be compiling wine 1.10 for a while since I just got wine 1.0 lol. are they going to be releasing a new wine ver every 2 weeks again?

piratesmack
June 30th, 2008, 10:58 AM
cool, although I dont think I will be compiling wine 1.10 for a while since I just got wine 1.0 lol. are they going to be releasing a new wine ver every 2 weeks again?

I think so

But Wine 1.0 is considered the first stable release, Wine 1.1.0 and later will be development releases up until Wine 2.0. I think I'll be sticking with 1.0 for quite a while, too

thefishki345
June 30th, 2008, 12:09 PM
yeah...hopefully by wine ver 100 they will have every window program runable in linux, but by then there will prolly be a cooler open source OS lol...

piratesmack
June 30th, 2008, 02:05 PM
yeah...hopefully by wine ver 100 they will have every window program runable in linux, but by then there will prolly be a cooler open source OS lol...

haha the world will already end by Wine 100

It took like 15 years just to get to 1.0, I can't imagine living to see even Wine 3.0 =P


For anyone who wants it, here is a 32bit deb for Wine 1.1.0 with pegmag's 3dmark patch. Seems to be working for me, let me know if it works for you. I'm pretty new to this debian package making thing

http://files.filefront.com/wine+110+i386deb/;10865887;/fileinfo.html

superppl
June 30th, 2008, 09:50 PM
Thanks for the patch. :)

Sneaky07
July 2nd, 2008, 01:33 AM
Hi Im sort of new to Ubuntu but I keep trying to get it to work but when I run the .exe I get this:


err:wgl:X11DRV_ChoosePixelFormat No libGL on this box - disabling OpenGL support !

I got that error A LOT!! (meaning it displayed it a lot)



err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
err:d3d:InitAdapters Failed to get a gl context for default adapter
err:wine_d3d:WineDirect3DCreate Direct3D9 is not available without opengl


Then it dumps a bunch of stuff... I looked around and asked some people but I just can't seem to get this working... I know it has to be a graphics issue but I can't seem to find the problem. Also the Nvidia logo doesn't come up on startup which I believe means that the good drivers aren't installed (according to the tut). Is there something wrong with Wine or is it really my graphics?

hofa
July 3rd, 2008, 12:20 PM
Im still having trouble with wine 0.9.50...

I followed the tutorial on page 2 (copy paste tutorial :) ) and I get an error when I run checkinstall

Anyone know how I could fix this?


========================= Installation results ===========================
make[1]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools'
make[1]: `makedep' is up to date.
make[1]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools'
make[1]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/libs'
make[2]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/libs/port'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/libs/port'
make[2]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/libs/wine'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/libs/wine'
make[2]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/libs/wpp'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/libs/wpp'
make[1]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/libs'
make[1]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools'
make[2]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/widl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/widl'
make[2]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/winebuild'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/winebuild'
make[2]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/winedump'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/winedump'
make[2]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/winegcc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/winegcc'
make[2]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/wmc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/wmc'
make[2]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/wrc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools/wrc'
make[1]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/tools'
make[1]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/include'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/include'
make[1]: Entering directory `/home/hofa/Desktop/winesource/wine-0.9.50/include'
../tools/mkinstalldirs -m 755 /usr/include/wine/windows/ddk
mkdir /usr/include/wine
chmod 755 /usr/include/wine
chmod: changing permissions of `/usr/include/wine': No such file or directory
make[1]: *** [/usr/include/wine/windows/ddk] Error 1
make[1]: Leaving directory `/home/hofa/Desktop/winesource/wine-0.9.50/include'
make: *** [include/__install__] Error 2

**** Installation failed. Aborting package creation.

Cleaning up...OK

Bye.

zabzoo
July 3rd, 2008, 01:20 PM
Thanks
I just created a new patch.. works on my machine

SEE EDIT BELOW:

Hi there

The file doesn't appear to download correctly, when I try to tar xvf the file i get the following error -



$ tar xvf wine-1.1.0-3dmark.patch.gz
tar: This does not look like a tar archive
tar: Skipping to next header
tar: Error exit delayed from previous errors


EDIT:
Noob here - soz; used gunzip!!!! :D

Am I doing something wrong?

thefishki345
July 4th, 2008, 12:35 PM
so zabzoo, does that mean your problem is sorted by your edit?

Hofa: try the command ¨makeinstall¨ instead of ¨checkinstall"and see if that works,

Sneaky: I think it might be your graphics or that wine doesnt recognise your hardware or you havent compiled properly. Try reinstalling your graphics drivers with the program ¨envy¨
http://albertomilone.com/envyngfaq.html#A

Hope that helps guys, but I am no expert on this.

thefishki345
July 5th, 2008, 04:56 AM
Hey guys, now I would like you to help me with a little problem I am having in cod4.
The problem is I get no background sound (the cool music) in the menus or in game, which makes the game kind of boring, I dont know how it stopped working because it used to work fine... any ideas?

EDIT: nevermind, its just when i changed msmp3.asi to msmp3.bak I forgot to change it back...

jmr257
July 5th, 2008, 03:59 PM
Hello all

Could someone kindly tell me how to patch my version of Wine.
I have installed 1.1.0 and have the right patch for it (from this thread).
But what am I supposed to do then? I mean, what do I do with those.

I tried a bit of googling and I came to the answer that I have to download the source code and compile it??? Is that right or what do I have to do?

Thanks in advance

EDIT: thanks thefishki345, did as it said in guide and it works like charmed now :)

n3ga
July 5th, 2008, 04:43 PM
hi all
i'm newbie and i cant compile wine 1.1.0 on ubuntu
this is the error
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc -m32
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

i have just instlled build-essential and i don't know where is the problem
some one could help me please?

someone have tested cod4 1.7 with previous wine version? works ok?

thefishki345
July 6th, 2008, 09:26 AM
@ n3ga: sorry, I do not know why that is happening, but if it works on previous vers (wine 1.0) then why bother changing it. But, if you want someone else to help, please post the exact command you put in which gave that output.

@jmr257: You have to actually compile it from the wines source code, not install plain wine and then patch it. again, there have been problems with wine 1.10 and cod4 so I dont see why people want the latest version of wine so badly, I am still on wine 1.0 and is fine. What you have to do is in my guide (which is ripped from ahaslams) here on this page, halfway down:

http://ubuntuforums.org/showthread.php?t=641987&page=24

hope that helps!

desertboy
July 6th, 2008, 02:01 PM
I installed these deb's to play C&C 3 which needs a cursor patch but they have the 3dmark patch as well and work fine with COD4 I've been playing it most of the day, performance is below windows but still 20-30fps at 1680x1050.

http://oliverdeisenroth.de/index.php?option=com_remository&Itemid=85&func=select&id=3

he keeps them up to date, great for CNC3 and Kane's wrath as well.

TheCoach
July 8th, 2008, 01:02 PM
-delete-

thefishki345
July 12th, 2008, 03:58 AM
-Why?-

and bump

superppl
July 25th, 2008, 10:45 PM
Well, looks like it's broken again.

Bellegueulle damien
July 26th, 2008, 12:18 PM
Hello ,

For information : 3Dmark patch not work with Wine 1.1.2

patching file dlls/wined3d/directx.c
Hunk #1 succeeded at 852 (offset 1 line).
Hunk #2 succeeded at 2981 (offset 9 lines).
Hunk #3 succeeded at 3250 (offset 9 lines).
Hunk #4 FAILED at 3268.

bye ,

cowboyup6983
August 7th, 2008, 02:58 AM
i got really far with no problems of the installation of COD4, the final part after i cut and past the no DVD patch, was to actually run the program..

i go to wine>programs>cod4

this is my error message i get, seems like i might not have the right directX installed. could someone please help with this

ahaslam
August 7th, 2008, 04:18 PM
May I ask what gfx card you have & the driver you're using?

Nice wallpaper btw. ;)

cowboyup6983
August 7th, 2008, 05:46 PM
May I ask what gfx card you have & the driver you're using?

Nice wallpaper btw. ;)

thanks.. i have 2-xfx 8600 doing SLI i guess. i installed the drivers using ENVY. it says version 173.14.09 and im using wine version 1.1.2

in the library section of wine i have existing override of d3dx9_34 (natitve)

ahaslam
August 7th, 2008, 06:09 PM
Ok, get rid of that dll, you don't need it with the newer versions of Wine.

;)

cowboyup6983
August 7th, 2008, 06:23 PM
Ok, get rid of that dll, you don't need it with the newer versions of Wine.

;)

same message! i just went into the libraries and removed the dll thing. how do i know if i have the proper directx patch or anything with directx to play games

here are all the screen shots of my wine configuration

ahaslam
August 7th, 2008, 07:14 PM
You shouldn't have installed directx & there's no need for any MS dll's. What patch did you use? Should be: http://ubuntuforums.org/showpost.php?p=5286516&postcount=255

I'd be interested to see how it goes with only one gfx card installed as I've not heard of others with SLI. Failing that, follow my original guide on page 2 to the letter. That still works best for me, tho not had time to try 1.0 yet.

cowboyup6983
August 8th, 2008, 04:17 AM
You shouldn't have installed directx & there's no need for any MS dll's. What patch did you use? Should be: http://ubuntuforums.org/showpost.php?p=5286516&postcount=255

I'd be interested to see how it goes with only one gfx card installed as I've not heard of others with SLI. Failing that, follow my original guide on page 2 to the letter. That still works best for me, tho not had time to try 1.0 yet.

first of all i just want to say thanks for helping. how can i completely start over. i wanna play COD4 real bad on this system.

please someone tell me what should i do, first uninstall COD4, and uninstall wine?? i want this to work and im willing to try any way.

ahaslam
August 8th, 2008, 07:31 AM
Follow my guide on page 2 to start from scratch.

hofa
August 8th, 2008, 02:12 PM
I got single player working, up until the point that I actually have to start playing, thank you very much for that (page 2 guide). Then I get 1fps if not worse...

I get a lot of this in terminal:

fixme:d3d:state_separateblend (WINED3DRS_SEPARATEALPHABLENDENABLE,1) not yet implemented



edit: I got it working after setting all graphics options to the lowest setting. :)
I still get a lot of the errormessage above and it's not running 100% smooth but it's still cool

ahaslam
August 8th, 2008, 05:25 PM
Glad it works for you. ;)

Errors are to be expected, you can prevent debugging & gain 1 or 2 fps with "WINEDEBUG=-all". You can also gain a few more fps by over clocking your gfx card. If you proceed with overclocking, do so with caution.

Here's an old launch script of mine:


#! /bin/bash

nvidia-settings -a GPUOverclockingState=1 -a GPU3DClockFreqs=720,1080
cd ~/.wine/drive_c/Program\ Files/Activision/Call\ of\ Duty\ 4\ -\ Modern\ Warfare && WINEDEBUG=-all wine iw3sp.exe
nvidia-settings --load-config-only && nvidia-settings -a GPUOverclockingState=0

Don't just use that, read up & test first. Your settings may be different & xorg.conf will need editing.

Happy fragging ;)

hofa
August 8th, 2008, 07:05 PM
Got it working in Wine 1.0 just now, same quality as the version 0.9.50
Just thought you'd be pleased to know :)

edit: It doesn't run as smoothly as 0.9.50, the boat level (first mission) is unplayable, got like 10 fps I think.
WINEDEBUG=-all really did some good things for the intro-level (shooting range etc.)
I'm really not gonna go and try overclocking, I'm using a laptop with GeForce go 7900gtx 512mb so
#1: it's gonna get too warm in there because it's still a laptop
#2: My graphics card is good enough for playing on 800x600 =D

ahaslam
August 8th, 2008, 08:57 PM
Ok, just keep gfx & res at a min with 0.9.50 & no debugging.

When writing the guide I had a 7950gt oc'd to the level of a 7900gtx & running smoothly @ 1440x900.

What are the other spec's of your laptop? My laptop can't even run a screensaver...

hofa
August 9th, 2008, 11:34 AM
I've got a Dell XPS 1710

- Intel T7200 Core 2 Duo @ 2GHz
- 2Gb memory
- 600 MHz fsb I think
- geforce go 7900 gtx @ 512 mb

Maybe It'll run better if I turn off Compiz, or wouldn't it?

BTW It will only run when I turn off everything that uses sounds: MPD, thwirl... or else I get the Miles Sound Driver error.
Also: Multiplayer doesn't work :(


edit: Turning off compiz fusion did the trick, smooth gameplay now ^^
Now I still have to be able to run multiplayer, it's the only reason why I still use Windows in my spare time...


edit again: Multiplayer does work ^^
Still I'm gonna reboot to Windows for playing online. It's just nog the same :)

thanks for all your help!

Vadi
August 10th, 2008, 11:54 PM
getdeb.net built .debs: http://www.getdeb.net/search.php?keywords=wine

telemetry9
August 30th, 2008, 10:20 AM
Actually - wine 1.0 works very well with the latest HD 4850. Just add some entries into the registry by creating Direct 3D key and you will be amazed.

Actually - my HD 4850 plays half life 2 and shadow of chernobyl without a glitch and performance is impressive. You are as likely to have as many problems with an Nvidia card.

rashwan
September 11th, 2008, 05:04 PM
cowboyup6983 rather than patching and compiling here is a prepatched and precompiled version 1.1.0
http://www.archive.org/download/wine-1.1.0/wine_1.1.0_i386.deb

(http://www.archive.org/download/wine-1.1.0/wine_1.1.0_i386.deb)

also i think the latest version does not need to be patched
cheers

Dabblo
October 30th, 2008, 06:40 AM
Hi, I'm not sure if I'm posting this in the right place.. I been trying to install COD4 in wine with no luck.. I can get it installed, however I get this error when I try starting it up: Error during initialization:
Miles sound system initialization failed.
Make sure you have your sound card's latest drivers and DirectX installed.

I have tried following various guides, and tried different versions of wine with 1.1.3 - 1.1.4 - 1.1.7 - 0.9.56 version including ones with 3DMark patch.. I've tried a guide with d3dxp_34.dll and streamci.dll + mscoree.dll.. And I even tried installing DirectX 9c With all the required native dlls. I have the iw3sp.exe I installed COD4 with Gmount IS0, And I even tried installing DirectX with wine doors.. No luck. I turned to help now it's telling me DirectX has an irrecoverable error.. Please someone help :confused:

System:
Pentium 4 @ 2.533 Ghz
Ram 768 Mb
Nvidia 7300 256 Mb (video)
Ubuntu hardy 8.04 upgraded from 7.10

ahaslam
October 30th, 2008, 08:20 AM
Start a fresh, rm -r ~/.wine

Wine no longer needs patching or extra dll's & directx should not be installed.

If you have no luck, follow my original guide on page 2. A patched Wine 0.9.50 is still the best way of running COD4 on Linux.

hofa
October 30th, 2008, 12:05 PM
I've had that error with some Windows games on Linux (CoD4, NFH2, ...)

It always works when I just shut down everything that can address your sound card. (Music player, Firefox, twhirl, pidgin, emesene... ). It's all ALSA's fault I think

dvergur
November 23rd, 2008, 06:45 PM
Thanks a lot ahaslam.
This easy to follow guide is unfortunately all too rare.
I am quite new to Linux and this guide was great and I think I even learned something about Linux in the process.
Best regards,
dvergur.

IOmega666
November 25th, 2008, 02:21 AM
well, i was trying the new wine, 1.1.9 , i compiled it, and then install cod4, patched it with the 1.6 version of the patch, run it with the command

wine iw3sp.exe

and then, i got a black screen, but sound, and i can hear the mouse going over the options, and the sound when you are over the options.

something i can do ? to have image ?

piratesmack
November 25th, 2008, 07:54 PM
Hi guys. Been without internet for a while, but I'm back now. Not sure if this has been posted yet (only checked back a few pages), but according to this page:
http://appdb.winehq.org/objectManager.php?sClass=version&iId=12804

Those patches are supposed to make Punkbuster work on Wine 1.1.5. I just applied them and am compiling it right now, I'll post back the results. (Note: those patches won't apply to the latest wine, so I'm not sure if PunkBuster will work with an unpatched Wine 1.1.9)

Wow wine doesn't need the 3dmark patch anymore? Awesome

ahaslam
November 25th, 2008, 09:00 PM
Thanks a lot ahaslam.
This easy to follow guide is unfortunately all too rare.
I am quite new to Linux and this guide was great and I think I even learned something about Linux in the process.
Best regards,
dvergur.

You're welcome :)

piratesmack
November 25th, 2008, 09:32 PM
Update:
No luck with punkbuster

It still gave me the same error as usual with the patches. I tried updating punkbuster, but that just gave me this:
http://www.vulomedia.com/images/30805snapshot1.png
:(

I tried it on Slackware 12.1. The howto in the WineHQ was for Ubuntu, so maybe it'll work on Ubuntu.

Allochtoon
January 17th, 2009, 05:39 PM
vanilla wine-1.1.6
card=ati HD4850


----- Initializing Renderer ----
----- Client Initialization Complete -----
Attempting 44 kHz 16 bit [Windows default] sound
----- R_Init -----
Getting Direct3D 9 interface...
Pixel shader version is 3.0
Vertex shader version is 3.0
Video card or driver doesn't accelerate dynamic textures.
Video card or driver doesn't support separate alpha blend, glow will be disabled.


Error during initialization:
Video card or driver doesn't support separate alpha blend, glow will be disabled.

then it just hangs.

pmasterp
February 21st, 2009, 05:21 AM
vanilla wine-1.1.6
card=ati HD4850


----- Initializing Renderer ----
----- Client Initialization Complete -----
Attempting 44 kHz 16 bit [Windows default] sound
----- R_Init -----
Getting Direct3D 9 interface...
Pixel shader version is 3.0
Vertex shader version is 3.0
Video card or driver doesn't accelerate dynamic textures.
Video card or driver doesn't support separate alpha blend, glow will be disabled.


Error during initialization:
Video card or driver doesn't support separate alpha blend, glow will be disabled.

then it just hangs.

I've got the same issue under the same card ATI Radeon HD4850, damn ATI and Linux are not talking each other.

tkdzj
March 2nd, 2009, 04:06 PM
I personally think that halo 3 is a good game, as far as fps,along with call of duty... their both great games,and i don't know why people always have to say something negative about the other game. it's just retarded. but i think call of duty is much more fun to play online rather than halo 3 be it self adicting me to playing it all night with my neighbor,lol, if you guy's have xbox live you can add me if you want: Xbz Pro
and Yourobesemother is my neighbors gamertag. Thank you!

Jimmy92
March 23rd, 2009, 10:40 PM
Hi, when i try to install cod4 from the guide on page 2 i get to "make depend && make" when i get this:


signal_i386.c: I funktion "merge_vm86_pending_flags":
signal_i386.c:502: fel: "VIF_MASK" är odeklarerad (första förekomsten i denna funktion)
signal_i386.c:502: fel: (Varje odeklarerad identifierare rapporteras bara en gång
signal_i386.c:502: fel: för varje funktion den finns i.)
signal_i386.c:513: fel: "VIP_MASK" är odeklarerad (första förekomsten i denna funktion)
signal_i386.c: I funktion "raise_vm86_sti_exception":
signal_i386.c:1084: fel: "VIP_MASK" är odeklarerad (första förekomsten i denna funktion)
signal_i386.c: I funktion "__wine_enter_vm86":
signal_i386.c:1484: fel: "VIF_MASK" är odeklarerad (första förekomsten i denna funktion)
signal_i386.c:1485: fel: "VIP_MASK" är odeklarerad (första förekomsten i denna funktion)
make[2]: *** [signal_i386.o] Fel 1
make[2]: Lämnar katalogen "/home/jimmy/wine/wine-0.9.50/dlls/ntdll"
make[1]: *** [ntdll] Fel 2
make[1]: Lämnar katalogen "/home/jimmy/wine/wine-0.9.50/dlls"
make: *** [dlls] Fel 2

ahaslam
March 23rd, 2009, 11:01 PM
The newer versions of Wine don't need patching. I'm currently using version 1.1.14 & it runs COD4 perfectly. Try a pre built package: http://wine.budgetdedicated.com/archive/index.html

Jimmy92
March 23rd, 2009, 11:26 PM
The newer versions of Wine don't need patching. I'm currently using version 1.1.14 & it runs COD4 perfectly. Try a pre built package: http://wine.budgetdedicated.com/archive/index.html

Thanks :) Now i installed everything. But when i start, a black screen appears and i cant do anything but i have the sound. Any idea?:-k

slovix
April 28th, 2009, 04:19 PM
Hello guys.

can someone just put a working tutorial how to install and play the game, becouse I believe since 2007 something has changed :)

I sadly cant install, wine setup.exe says:
fixme:msi:MSI_OpenDatabaseW open failed r = 80030050 for L"C:\\windows\\temp\\msie1b.tmp"

And I get an isntallation error:
Error 1628: Failed to complete the instalation.

Using ubuntu 9.04, newest wine, clean .iso. Any comments welcome..

Terdog
May 26th, 2009, 04:07 PM
Ok, so for the newer versions of Call of Duty 4, does that mean I should install Direct X, or not? Also, does Punkbuster work?

Vrekk
May 26th, 2009, 05:07 PM
Ok, so for the newer versions of Call of Duty 4, does that mean I should install Direct X, or not? Also, does Punkbuster work?

Install Direct x.

Punkbuster will not work :'(

Snyper64
June 15th, 2009, 05:25 AM
I looked through a few pages but have not seen my problem here. I have gotten the single player working with no problem but when I go to launch the multiplayer portion it shows the COD4 logo and than the screen flashes and I get a fatal error message. I than have to ALT+F4 and close the game. it also changes my resolution down to 800*600 and I have to change everything back to my normal resolution.

Does anybody have a fix for this. I installed wine right from the repository and am running the most current version 1.1.23(I have had this problem on earlier versions of wine also). Also I do not have Punkbuster installed.