PDA

View Full Version : USN-553-1: Mono vulnerability



rss-bot
December 5th, 2007, 01:50 AM
Referenced CVEs:
CVE-2007-5197


Description:
================================================== ========= Ubuntu Security Notice USN-553-1 December 04, 2007 mono vulnerability CVE-2007-5197 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 6.10 Ubuntu 7.04 Ubuntu 7.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: mono-classlib-1.0 1.1.13.6-0ubuntu3.3 mono-classlib-2.0 1.1.13.6-0ubuntu3.3 Ubuntu 6.10: libmono-corlib1.0-cil 1.1.17.1-1ubuntu7.2 libmono-corlib2.0-cil 1.1.17.1-1ubuntu7.2 libmono-security1.0-cil 1.1.17.1-1ubuntu7.2 libmono-security2.0-cil 1.1.17.1-1ubuntu7.2 Ubuntu 7.04: libmono-corlib1.0-cil 1.2.3.1-1ubuntu1.1 libmono-corlib2.0-cil 1.2.3.1-1ubuntu1.1 libmono-security1.0-cil 1.2.3.1-1ubuntu1.1 libmono-security2.0-cil 1.2.3.1-1ubuntu1.1 Ubuntu 7.10: libmono-corlib1.0-cil 1.2.4-6ubuntu6.1 libmono-corlib2.0-cil 1.2.4-6ubuntu6.1 libmono-security1.0-cil 1.2.4-6ubuntu6.1 libmono-security2.0-cil 1.2.4-6ubuntu6.1 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: It was discovered that Mono did not correctly bounds check certain BigInteger actions. Remote attackers could exploit this to crash a Mono application or possibly execute arbitrary code with user privileges.





More... (http://www.ubuntu.com/usn/usn-553-1)