View Full Version : Problem with scons: " No SConstruct file found"

November 14th, 2007, 11:28 AM
I tried to compile the unreleased version of lprof (GUI for argyllcms, to calibrate my display with a hardwaredevice). The last step a developer mailed me, is this one:

4) after that, you can try to build lprof. You will need to know where you have QT installed on your system (QTDIR)
scons PREFIX=/usr/local qt_directory=QTDIR
scons install

But there are some things i don't know:
- what is exactly my QTdir? There are several folders named /QT4
- do i have to run this command in the /src directory of lprof?
- every time i run the first command i get the error
scons: *** No SConstruct file found.
File "/usr/lib/scons/SCons/Script/Main.py", line 1128, in _main

March 31st, 2008, 05:08 AM
Argh! I'm trying to compile ardour, and I get the exact same error you are having... Tried to reinstall scons three times, but the error perssits..

June 15th, 2008, 01:07 PM
I fixed this problem by getting into the right directory scons is just like make, it will only work if your IN the directory with the sconstruct file

different line

File /usr/lib/scons/SCons/Script/Main.py, line 825, in _main

for me but same problem