View Full Version : [SOLVED] vim gone nuts

November 11th, 2007, 02:28 AM
OK, what the?! I just rebooted and everything's fine.

Nuts, man!

Vim has gone nuts on me!

I just installed vim-full, decided I didn't really like gvim, and reverted to just ordinary vim (ie. sudo apt-get install vim).

The problem is, vim doesn't behave the way it used to before (I didn't make any configuration changes using gvim).

The most telling is that in insert mode, my arrow keys, backspace and delete keys, no longer work. I have to get back into command mode to do all edits. Before this anomaly, those keys behaved as they normally do in a GUI text editor (ie. arrow keys moved the cursor, backspace and delete keys erased characters, etc).

A lesser problem is that when I ":set nu", the line numbers are indented around 8 spaces into the buffer. Before, the line numbers used to appear roughly where the ~ symbols are on the far left-hand side of the buffer.

I have tried purging and reinstalling vim, even going as far as to remove all files related to vim off the drive, but vim is still not working the way it used to.

Does anyone know what's gone wrong?