View Full Version : Sybase ASE Express edition

November 7th, 2007, 09:43 PM

Just wondering if anyone has managed to install the free edition of Sybase ASE 15.0.2 for linux?

I've followed the instructions from here:

but got stuck on the stage where the installer builds the master database. no matter what I try it always segfaults. setting the LD_POINTER_GUARD enviroment variable to 0 or 1 as suggested by some ppl did help either.

any help would be appreciated!

January 14th, 2008, 10:13 AM
Bad news: It will not work. Because of the libc.

It seems it will not work on fresh distro's of Suse and Fedora too.

So better forget about it.

Use Postgress instead.

January 14th, 2008, 10:26 AM
you can still download the 11.9.2 versoin (http://www.sybase.com/detail?id=1011127) and have a try on it.

April 3rd, 2008, 06:00 PM
the error is caused because aswell as libaio you will also need libaio_devel installed

I know as i used to work for Sybase :)

However ASE 15 was compiled on an older version of glibc so your mileage may vary

I have had it running on 6.10 and 7.04



May 4th, 2008, 01:21 PM

does it mean that Sybase will probably NOT work on Ubuntu Hardy Heron ?

Thanks for your answers.

June 27th, 2008, 09:21 AM
This should work fine now:



April 16th, 2009, 04:21 PM
www.happy-hacking.com has the solution for you:


September 19th, 2009, 07:10 PM
To fix the problem is a very simple matter.
ASE requires at least 64 MB of shared memory. To increase, for example, 256 MB, you must add the line:

kernel.shmmax = 268435456 to /etc/sysctl.conf
Then load the setup command:

/sbin/sysctl -p That's all.
Regards, Bogdan cw19.

December 2nd, 2009, 12:44 PM
Hi all,

just to let you know that I am using 9.10 (Karmic Koala).
(I am VERY new to Ubuntu - but been around UNIX for a long time.)

I was able to make the current release of Sybase ASE (free) which is 15.0.3 ESD#1 work out of the box.

It requires the package libaio1 to be installed and shmmax to be set (as described above).

The the installer will run without problems.

Have fun with it,
- jon.

December 12th, 2009, 03:49 AM
Hi folks,
I'm new to Ubuntu but familiar with UNIX.
I'm in the process of installing the developers edition of ASE 15.0.3 on Karmic Koala (9.10) and have a few questions.

kernel.shmmax = 268435456
sudo apt-get install build-essential libaio1 # Fix libaio issue

1) I've created a 'sybase' user via the menus but I'm unable to run xterm under it. On my main ubuntu account xterm works (DISPLAY=:0.0) fine. What should be the display variable for the new SYBASE user?
sybase@ubuntu:~$ export DISPLAY=:0.0
sybase@ubuntu:~$ xterm
No protocol specified
xterm Xt error: Can't open display: :0.0

2) Is it OK to use sudo to run the ASE installation as /opt needs root write perms?
sudo ./setup # ASE installation program

December 12th, 2009, 02:08 PM
Here is the solution for the xterm issue:

Login as the ubuntu user created during system installation
At the shell prompt enter: xhost + so that clients can connect from any host

To carry on with the SYBASE installation:
1) su - sybase
2) sudo rm -rf /opt/sybase # Delete ASE installation done as root
3) sudo mkdir /opt/sybase
4) chown sybase /opt/sybase
5) chgrp sybase /opt/sybase
6) ./setup # Run ASE installation without sudo logged in as 'sybase'
7) . /opt/sybase/SYBASE.sh # set the env for ksh
8) export LANG=en_GB # reset LANG so that isql doesn't whinge

isql -U sa -S UBUNTU -P ""
1>select db_name()

ASE 15.0.3 on Karmic Koala (9.10) now sorted!

December 12th, 2009, 03:42 PM
Duplicate post and hence, deleted

April 22nd, 2010, 01:39 PM
To carry on with the SYBASE installation:
1) su - sybase
2) sudo rm -rf /opt/sybase # Delete ASE installation done as root
3) sudo mkdir /opt/sybase
4) chown sybase /opt/sybase
5) chgrp sybase /opt/sybase
6) ./setup # Run ASE installation without sudo logged in as 'sybase'

Hi, as a long-time-with-sybase-dealing guy let me comment these steps:
- you don't need to have an extra user/group ("sybase") for running ASE
- if ase was already installed, leave it on disk; just take steps 4 and 5. They also can be done in one command: chown -R sybase:sybase /opt/sybase

chown -R \ # for recursion on subdirectories
<yourUser>:<yourGroup> \ # telling user AND group to the command

Good luck

December 19th, 2010, 09:01 AM
See here:


October 28th, 2011, 11:34 AM
I managed to install sybase on Ubuntu server 11.10... maybe it helps. Install ubuntu server (no extra packages selected).

Setting up ASE 15.7 on Ubuntu Server 11.10 (64it)

Preparing the Linux System

sudo su
#adjust shared mem space (as documented in install requirements)
echo "kernel.shmmax=1073741824" >> /etc/sysctl.conf
sysctl -w kernel.shmmax=1073741824
apt-get install libxp-dev
apt-get install libxt-dev
apt-get install libxtst-dev
apt-get install libxmu-dev
apt-get install libxext-dev
apt-get install libsm-dev
apt-get install libice-dev
apt-get install libx11-dev
apt-get install libaio-dev
apt-get install dkms build-essential alien
apt-get install openjdk-6-jdk
apt-get install ia32-libs
#pull openmotif RPM http://www.openmotif.org/files/public_downloads/openmotif/2.3/2.3.0/openmotif-2.3.0-1.rhel4.x86_64.rpm
alien -d openmotif-2.1.30-1.rhel4.x86_64.rpm
#this generates openmotif_2.3.0-2_amd64.deb on my system... now install with dpkg -i
dpkg -i openmotif_2.3.0-2_amd64.deb
#create sybase install user + directories
mkdir /opt/sybase
mkdir /opt/sybasesetup
useradd -s /bin/bash -M -d /opt/sybase sybase
chown sybase.sybase /opt/sybase*

su sybase
cd /opt/sybasesetup
#pull http://download.sybase.com/eval/157/ase157_linuxx86-64.tgz and copy to sybasesetup
tar xzf ase157_linuxx86-64.tgz

November 4th, 2011, 04:36 PM
I struggled to get ASE and PAM auth running on Ubuntu. In hope this might help other users:

1) Prepare PAM. Create a the file /etc/pam.d/ase with the following contents

auth required pam_unix.so
2) Assuming your sybase process user is called sybase, you must add this user to the shadow group in order to get PAM going. Do so by issuing

root@sybase# usermod -a -G shadow sybase
3) Enable PAM authentication in sybase. I assume sybase is installed in /opt/sybase

sybase@sybase:~$ cd /opt/sybase
sybase@sybase:/opt/sybase$ . SYBASE.sh
sybase@sybase:/opt/sybase$ isql -U sa
1> sp_configure "enable pam user auth",2
2> go
1> quit
This should get PAM up and running... now we can test it.
1) create a system user

sybase@sybase:~# useradd -MN sybtest
sybase@sybase:~# passwd sybtest
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
2) create a sybase login (login as sybase user)

sybase@sybase:~$ cd /opt/sybase
sybase@sybase:/opt/sybase$ . SYBASE.sh
sybase@sybase:/opt/sybase$ isql -U sa
1>create login sybtest with password anypass
3) tryout the new login (login as sybase user) use the unix password for the isql login!

sybase@sybase:~$ cd /opt/sybase
sybase@sybase:/opt/sybase$ . SYBASE.sh
sybase@sybase:/opt/sybase$ isql -U sybtest
AAAAAAAAAAAAaaaaand we are done! have fun!