PDA

View Full Version : [SOLVED] Mythbackend



besmith2@hotmail.com
October 19th, 2007, 12:39 AM
Ok I installed this thing about 10 times with no luck yet. I have a backend setup with a PVR-150 and a PVR-350 on a Sony Viao RS 2.4Ghz hyperthreaded with no problems with the hardware so far.

What steps must I complete manually to connect a mythbuntu front end to my backend?
:confused:
I installed the backend only and enabled the MySql service.

MythWeb works fine which is kewl as I already scheduled stuff to record. :D

I am a linux newbie with multiple years experience trying to convert over to the rite-side (Dark-side/Lite-side)(windows/mac) and everytime I get frustrated and stop.

Thanks in advance.

besmith2@hotmail.com
October 19th, 2007, 12:49 AM
I am referring extra steps on the back end, I can't even connect to the database remotely yet.

besmith2@hotmail.com
October 20th, 2007, 10:50 PM
Anyone??

tgm4883
October 21st, 2007, 12:57 AM
is the Backend and Frontend on the same machine?

You need to set the frontend to connect via the actual ip address, not 127.0.0.1

besmith2@hotmail.com
October 21st, 2007, 05:33 PM
The backend is on a different machine. I tried that. I can't even connect to the database on the backend server. I get:

Access denied for user 'mythtv'@144.10.10.143'(using password: NO) I did not set a password to try and make things as simple as possible.

superm1
October 21st, 2007, 05:45 PM
There was a bug in the RC installation that the mysql service may not have been activated in a few instances.

Can you open up mythbuntu control centre on it, and make sure the mysql service is activated there?

besmith2@hotmail.com
October 21st, 2007, 06:18 PM
It was not activated however I activated it and rebooted with no luck.

superm1
October 21st, 2007, 06:25 PM
It was not activated however I activated it and rebooted with no luck.
After doing this, did you make sure that your ip addresses were all set to the non 127.0.0.1 ip?

besmith2@hotmail.com
October 21st, 2007, 06:54 PM
On the backend I ran the Myth backend setup again and changed the two spots where it said 127.0.0.1 to 144.10.10.10 <-- backend ip

BTW
Thanks for the help.

besmith2@hotmail.com
October 21st, 2007, 06:55 PM
Just an FYI I can connect through VNC.

superm1
October 21st, 2007, 07:01 PM
From your other machine (the FE machine), can you open up MCC and see if the connection test on the "MythTV configuration" tab works?

besmith2@hotmail.com
October 21st, 2007, 07:08 PM
It fails <Red> Failure.
MYSQL MythTV User: mythtv
MYSQL MythTV Passowrd: empty
MYSQL MythTV Database: mythconverg
MYSQL Server: 144.10.10.10

I'm sorry I didn't clarify this more.

superm1
October 21st, 2007, 07:12 PM
Unless you completely got rid of your mysql password, you need to be filling in that box. Get this information from /etc/mythtv/mysql.txt on your backend machine.

besmith2@hotmail.com
October 21st, 2007, 07:14 PM
I never created one on install.

superm1
October 21st, 2007, 07:16 PM
I never created one on install.
Right. One was created for you on the backend. It's in that file.

besmith2@hotmail.com
October 21st, 2007, 07:18 PM
oh geesh, thanks I will look there

Sorry for the noob mistake.

besmith2@hotmail.com
October 22nd, 2007, 01:10 PM
That was it, I guess I missed that in the install docs.