View Full Version : [SOLVED] cant open M-C-C

October 17th, 2007, 12:52 AM
I cant use launcher in menu and this is what I get from the Terminal. I dont know what I did????

andy@andy-dvr:~$ mythbuntu-control-centr
bash: mythbuntu-control-centr: command not found
andy@andy-dvr:~$ mythbuntu-control-centre
Reading package lists... Done
Building dependency tree
Reading state information... Done
File "/usr/share/mythbuntu-control-centre/bin/mythbuntu-control-centre", line 46, in <module>
script = ControlCentre()
File "/usr/lib/python2.5/site-packages/MythbuntuControlCentre/core.py", line 166, in __init__
File "/usr/lib/python2.5/site-packages/MythbuntuControlCentre/core.py", line 942, in revert_gui
File "/usr/lib/python2.5/site-packages/MythbuntuControlCentre/core.py", line 610, in query_system_state
if self.query_installed("ubuntu-desktop"):
File "/usr/lib/python2.5/site-packages/MythbuntuControlCentre/core.py", line 544, in query_installed
return self.cache[package].CurrentVer
KeyError: 'ubuntu-desktop'

October 17th, 2007, 04:23 AM
Can you try to apt-get update and run it again?

October 18th, 2007, 05:45 AM
I am having the same problem with RC.

October 18th, 2007, 05:47 AM
The solution for govee as mentioned in another thread, was the apt-get update.

October 18th, 2007, 06:04 AM
I have done that but it still does not work. I have rebooted several times but still no luck.

October 18th, 2007, 06:13 AM
...sigh... well that's not a good sign.

Give this a shot:

It works around that error that you were getting. Unfortunately the archives are closed, so it won't be in the ubuntu archives for release. It will however be on the final mythbuntu disk. Will try to shoot for gutsy-updates too.

October 19th, 2007, 12:37 AM
Ok, thanks! That worked.