PDA

View Full Version : HOWTO: Latest NVIDIA drivers



Pages : [1] 2

tseliot
August 16th, 2005, 01:36 PM
If you want to install Nvidia driver with the nvidia installer (I've tried v.7667) and you use a kernel from Ubuntu Hoary or you compiled it from Hoary sources (or kernel.org sources), then just try this HOWTO.
If you have a kernel from Ubuntu Breezy then try this HOWTO:
http://www.ubuntuforums.org/showthread.php?t=52924 OR just look at point 2 of the problems section of THIS guide.

Make sure you graphic card is not among the ones which are NOT SUPPORTED by looking at the list you will find in the NOTES SECTION *

You need 7676 version only if you have Geforce 7800, otherwise is useless (and it has some bugs). If you haven't got this graphic card PLEASE try 7667, it's more stable.

Download the installer from this page according to your architecture (32bit or 64bit)
http://www.nvidia.com/object/unix.html

Before you start you have to make sure the following things are installed (see points "a","b","c"). If not, you can install them following these steps:

Open either Terminal or Konsole and type:

uname -r (this will tell you the name and version of the kernel you are using)

Open either Synaptic or Kynaptic

a) press the "Search" button and put "header" in the search field

you will see a list of files, find "linux-headers-the name you got from uname -r"

for example if your kernel is "2.6.10-5-386", the headers will be "linux-headers-2.6.10-5-386"

click on the files and select "Mark for installation"

b) press the "Search" button and put "linux-source" in the search field

you will see a list of files, find "linux-source-the name you got from uname -r"

click on the file and select "Mark for installation"

c) press the "Search" button and put "build-essential" in the search field

click on the file and select "Mark for installation"


d) Press the "Apply" button.

You can close Synaptic (or Kynaptic) after it has finished installing the headers.


Ok, now let's begin:

1) uninstall nvidia-glx (if you don't have it just go to step 2)

2) remove the file manually:
sudo rm /etc/init.d/nvidia-glx

3) sudo apt-get install gcc (just in case)

ctl-alt-f1 (so as to get to the command line, not a windowed terminal, but out of the graphical interface GUI)

login with your username and password (if required)

sudo /etc/init.d/gdm stop (or "kdm stop" if you use KDE)

cd “directory where you have the nvidia installer”

If you have Ubuntu 64bit type: **
sudo sh NVIDIA-Linux-x86_64-1.0-7667-pkg2.run

Otherwise if you have Ubuntu 32 bit type:
sudo sh NVIDIA-Linux-x86-1.0-7667-pkg2.run

If you have Ubuntu 64bit you can't install OpenGL32bit compatibility libraries, so when the installer asks whether to install it just answer no OR you may want to try a workaround which Draugen found but which I haven't tried myself (look at the PROBLEMS SECTION at the end of the guide: point 5).

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

sudo nano /etc/X11/xorg.conf
scroll the file down until you find the line with “Modules” and comment out (by putting a "#" before the line) the 2 lines I put in blue and add Load "glx". It should look like the example below:


Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
#Load "dri"
#Load “GLcore”
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"

Then find the section Device and make sure the word I put in red is “nvidia”:

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"


CTRL+O to save (yes, use the same name and overwrite the file)
CTRL+X to exit

sudo /etc/init.d/gdm start (or "kdm start" if you use KDE)

Now you have installed the new nvidia driver.

If you want a "control panel" which shows the settings of your card you might want to install "Nvidia-settings" (this part of the guide has been taken from the Unofficial Ubuntu Starter Guide) although they driver works fine also without it (the choice it's up to you).

Open Terminal or Konsole and type

sudo apt-get install nvidia-settings

sudo gedit /usr/share/applications/NVIDIA-Settings.desktop (you can use "kate" instead of "gedit" in KDE)

Insert the following lines into the new file:

[Desktop Entry]
Name=NVIDIA Settings
Comment=NVIDIA Settings
Exec=nvidia-settings
Icon=
Terminal=false
Type=Application
Categories=Application;System;


Save the file and exit.

Restart your computer

You will be able to see "Nvidia settings" in the menu (the one from which you launch all the applications)

Enjoy!
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
NOTES SECTION

* Below are the legacy GPUs that are no longer supported in the unified driver.
These GPUs will continue to be maintained through the special legacy NVIDIA
GPU driver releases.

NVIDIA chip name Device PCI ID
------------------------------- -------------------------------
RIVA TNT 0x0020
RIVA TNT2/TNT2 Pro 0x0028
RIVA TNT2 Ultra 0x0029
Vanta/Vanta LT 0x002C
RIVA TNT2 Model 64/Model 64 Pro 0x002D
Aladdin TNT2 0x00A0
GeForce 256 0x0100
GeForce DDR 0x0101
Quadro 0x0103
GeForce2 GTS/GeForce2 Pro 0x0150
GeForce2 Ti 0x0151
GeForce2 Ultra 0x0152
Quadro2 Pro 0x0153
----------------------------------------------------------------


** the name of the installer may vary:
e.g. it could be NVIDIA-Linux-x86_64-1.0-7667-pkg1.run.

So just put the name of the installer you've downloaded from Nvidia website.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

PROBLEMS SECTION

1) If the installer reports that the “Framebuffer” kernel module conflicts with the drivers you will have to recompile your kernel and disable this function
Here's a HOWTO for kernel compilation for newbies
http://www.ubuntuforums.org/showthread.php?t=56835&page=1&pp=10

2) If the installer complains in this way (this is an example of part of the error):
...
nvidia: version magic '2.6.10-5-386 preempt 386 gcc-3.4' should be
'2.6.10-5-386 preempt 386 gcc-3.3'
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details.
...

This means the installer tries to use gcc-3.4 instead of gcc-3.3(the right one).Type this before launching NVIDIA installer:

CC=gcc-3.3
export CC

The number of the version of gcc has to be the same as the 2nd one reported in the error by nvidia installer (i.e. the word I put in red instead of the one I put in blue)

then run nvidia installer again.

3) If the installer complains in this way:
...
ERROR: Unable to find the development tool `cc` in your path; please make sure
that you have the package 'gcc' installed. If gcc is installed on your
system, then please check that `cc` is in your PATH.

The user Reid has suggested this solution:

To find out where 'gcc' is located I did:
Code:

which gcc


which returned:
Code:

/usr/bin/gcc


then I made a symbolic link to gcc called cc so programs trying to use 'cc' would get gcc, with this code:
Code:

sudo ln -s /usr/bin/gcc /usr/bin/cc

Then try the installer again.

4) If you have an AGP graphic card and your system freezes but you can still move the mouse pointer you will have to do this:
sudo nano /etc/X11/xorg.conf
Add the lines in red at this section of the file:

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NvAGP" "0"
Option "RenderAccel" "Off"
Option "IgnoreDisplayDevices" "DFP,TV"
Option "NoRenderExtension" "Off"
Option "Accel" "Off"
Option "AllowGLXWithComposite" “Off”

EndSection


This will either disable 3d acceleration or make it slower (sorry but I haven't got an AGP card so I haven't tried them myself)

If this doesn't work for you try asking at this Forum and you might be talking to some of the developers of the NVIDIA drivers (there's a Linux section) (it's very useful)
http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

5) If you have Ubuntu 64bit you will have some problems when trying to install OpenGL32bit compatibility libraries, so yuomay want to try a workaround suggested by Draugen but which I haven't tried myself

type:

sudo mkdir /emul
sudo mkdir /emul/ia32-linux
sudo mkdir /emul/ia32-linux/usr

sudo ln -s /usr/lib32 /emul/ia32-linux/usr/lib


if /usr/lib32 does not exist, you need to do this

Type:

sudo apt-get install ia32-libs lib32gcc1 lib32stdc++6

without which the opengl compat libs probably won't be much use anyway

there are more 32bit libs as well. check synaptic.


Alberto

cutOff
August 16th, 2005, 01:47 PM
Option "RenderAccel" "On"
It's not sure. At least for me.

Anyway thanks for the howto.

tseliot
August 16th, 2005, 01:49 PM
You're right, thanks it was a mistake. Fixed.

Kyral
August 17th, 2005, 01:29 AM
What if I'm in Breezy but I'm using the Hoary kernel?

earobinson
August 17th, 2005, 08:06 AM
dident work for me got a kernel error :(

tseliot
August 17th, 2005, 08:46 AM
What if I'm in Breezy but I'm using the Hoary kernel?

Before running NVIDIA installer, type:

CC=gcc-3.4 (here you have to put the number of the gcc you used to compile your kernel, which is 3.4 in my case*)

export CC


When I wanted to compile the modules for a Breezy kernel in Hoary I had to use gcc 3.4. If you want to compile them for a Hoary kernel in Breezy you should use the gcc with which Hoary kernel are usually compiled.

I'm not sure if it is gcc 3.3 (try with this one first).

If this gcc doesn't work you should try different versions of gcc until you find the right one (and the module will compile).

Have a look at this:

This works great. Getting the corect version of gcc is the key. When you run the Nvidia installer, if it fails because of your version of gcc, it will tell you what version of gcc you need based on what your kernel is compiled with. Make sure to get gcc-X.X and not just gcc-X.X- base.

This was in my other thread about installing NVIDIA drivers with a Breezy kernel. That's how things work.

tseliot
August 17th, 2005, 08:48 AM
dident work for me got a kernel error :(

1) Have you installed the kernel headers of your current kernel?

2) Are you using Ubuntu Hoary or Breezy?

3) What's the output of the error (what does the installer say?)?

izmaelis
August 17th, 2005, 12:25 PM
What are big improvements in this new nVidia driver if there are any? If there are no, why should any user bother installing/upgrading them?

tseliot
August 17th, 2005, 01:28 PM
What are big improvements in this new nVidia driver if there are any? If there are no, why should any user bother installing/upgrading them?

Well, the main reason is COMPATIBILITY. Without driver 7664-7667 I could never have 3d acceleration or a screen without any corruption with my Geforce 6200 PCI-E. Latest Nvidia graphic cards might not work with Ubuntu's nvidia drivers. I don't play games under Linux (I have an Xbox for that) but: in my case "nv" drivers= screen corruption, nvidia drivers (the ones you can install following Ubuntu Starter Guide) =black screen, no Xorg. If you want to know about the changes in the latest release (7676 I think) you shoul go to nvidia forum, Linux section.

izmaelis
August 17th, 2005, 01:49 PM
I think that I won't bother installing new nVidia drivers cause my video card is quite old (FX5600XT), I'm not a gamer person and it works just fine now.
Anyway, I'll remember this thread for possible future needs. Thanks.

earobinson
August 17th, 2005, 08:06 PM
1) Have you installed the kernel headers of your current kernel?

2) Are you using Ubuntu Hoary or Breezy?

3) What's the output of the error (what does the installer say?)?
1) Have you installed the kernel headers of your current kernel?

no how do i do this?

tseliot
August 17th, 2005, 09:12 PM
Well, I didn't explain how to install the headers, I'll fix this in the HOWTO. All you've got to do is:

Open either Terminal or Konsole and type:

uname -r (this will tell you the name and version of the kernel you are using)


Open either Synaptic or Kynaptic

press the "Search" button and put "header" in the search field

you will see a list of files, find "linux-headers-the name you got from uname -r"

for example if your kernel is "2.6.10-5-386", the headers will be "linux-headers-2.6.10-5-386"

click on the files and select "Mark for installation"

Press the "Apply" button.

After it has installed the headers try to follow my HOWTO again.

earobinson
August 17th, 2005, 10:38 PM
Well, I didn't explain how to install the headers, I'll fix this in the HOWTO. All you've got to do is:

Open either Terminal or Konsole and type:

uname -r (this will tell you the name and version of the kernel you are using)


Open either Synaptic or Kynaptic

press the "Search" button and put "header" in the search field

you will see a list of files, find "linux-headers-the name you got from uname -r"

for example if your kernel is "2.6.10-5-386", the headers will be "linux-headers-2.6.10-5-386"

click on the files and select "Mark for installation"

Press the "Apply" button.

After it has installed the headers try to follow my HOWTO again.
Still no luck

here is the nvidia-install.log



nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Aug 17 17:29:41 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
ERROR: An NVIDIA kernel module 'nvidia' appears to already be loaded in your
kernel. This may be because it is in use (for example, by the X
server), but may also happen if your kernel was configured without
support for module unloading. Please be sure you have exited X before
attempting to upgrade your driver. If you have exited X, know that your
kernel supports module unloading, and still receive this message, then
an error may have occured that has corrupted the NVIDIA kernel module's
usage count; the simplest remedy is to reboot your computer.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

tseliot
August 17th, 2005, 10:50 PM
Sorry pal, I've got to go to bed now (it's midnight in Italy and I' very tired). Tomorrow I'll find a solution.

good night

kangpeh
August 17th, 2005, 11:54 PM
Just a wild guess, as I will in fact not do any additional research above and beyong merely scanning the error message posted in your forum posting above, but basically, it means that the module is in fact still loaded (as the statement claims).

To begin, try looking in your processes list for any and all applications/software that may in fact be using the said drivers (i.e., "X", "gdm", etc. may be good grep keywords) [ps aux |grep <keyword>]. Also, if in fact you do not find any said applications in your processes list, then go ahead and type "lsmod |grep nv". What the previous command will do is 'list' the 'modules' loaded in your kernel and 'grep' the results for 'nv' and only return said lines which contain such keyword 'nv'. If in fact there is any module still loaded into the kernel, once you find out the name (it will probably be like 'nvidia' or something) type 'sudo rmmod nvidia' or whatever applicable command.

Good luck in your endeavours.

pz and blessings.

tseliot
August 18th, 2005, 09:00 AM
I agree with kangpeh. Try his/her method and install the drivers again.

However if this doesn't solve the problem try installing kernel image and headers 2.6.11. Here's how to do it:

Open Synaptic (or Kynaptic) and put "linux" in the search engine.
You will find something like linux-image-2.6.11 and linux-headers-2.6.11, install them.
Restart your computer.

Follow my HOWTO again.
Make sure you follow EVERY step in my guide, don't skip any.

Let me know if it works.

earobinson
August 18th, 2005, 02:38 PM
I agree with kangpeh. Try his/her method and install the drivers again.

However if this doesn't solve the problem try installing kernel image and headers 2.6.11. Here's how to do it:

Open Synaptic (or Kynaptic) and put "linux" in the search engine.
You will find something like linux-image-2.6.11 and linux-headers-2.6.11, install them.
Restart your computer.

Follow my HOWTO again.
Make sure you follow EVERY step in my guide, don't skip any.

Let me know if it works.
Will do as soon as i get home thanks for all the help guys, ill let you know if it works.

blackant
August 18th, 2005, 04:28 PM
Newbie here... can we have a update through apt-get?

tseliot
August 18th, 2005, 04:38 PM
Newbie here... can we have a update through apt-get?
Unfortunately the only driver available for Ubuntu (using apt-get) is 7174 version.

It's not hard. Follow the instructions, they are described step by step. If you think something is not clear or you have any doubt do not hesitate to ask me. I'm here to help newbies like you.

You just have to follow the steps, and you will also learn something.

strawberry
August 18th, 2005, 08:11 PM
Unfortunately the only driver available for Ubuntu (using apt-get) is 7174 version.
...

i think the 7174 is not so bad for a newbie and very easy to install...
then you can play the latest driver version...

tseliot
August 18th, 2005, 08:26 PM
i think the 7174 is not so bad for a newbie and very easy to install...
then you can play the latest driver version...
You're right but if he/she has the same graphic card as mine s/he will only have a black screen. The biggest problem is compatibility.

Marshalus
August 18th, 2005, 08:32 PM
Just used your guide, and it worked great. No problems at all.

tseliot
August 18th, 2005, 08:38 PM
Just used your guide, and it worked great. No problems at all.
I'm happy it helped you.

tseliot
August 18th, 2005, 08:49 PM
i think the 7174 is not so bad for a newbie and very easy to install...
then you can play the latest driver version...
Oh, and by the way s/he wanted to update her/his driver.

DancingSun
August 18th, 2005, 10:59 PM
(...)
If this doesn't work for you try asking at the official Nvidia Forum (there's a Linux section) (it's very useful)
http://www.nvnews.net/vbulletin/forumdisplay.php?f=14


Alberto

Alberto, nvnews.net is a fan/nVidia news site, not an "official" representation of nVidia. Just thought I'd point that out. Although it is said that there are 2 nVidia employees on the Unix team that frequently hangs out in that forum.

tseliot
August 18th, 2005, 11:02 PM
Alberto, nvnews.net is a fan/nVidia news site, not an "official" representation of nVidia. Just thought I'd point that out. Although it is said that there are 2 nVidia employees on the Unix team that frequently hangs out in that forum.

Thanks for the information. I talked to a developer of the drivers in there so I think it's quite a useful place to ask questions and to find solutions.

tseliot
August 18th, 2005, 11:12 PM
Dancingsun, I've corrected the thread.

earobinson
August 19th, 2005, 12:42 AM
Dancingsun, I've corrected the thread.
thanks all i got it working instead of ctrl - alt - f1 i did a reboot.

jodef
August 19th, 2005, 01:40 AM
Tried the HOWTo but ran into problems early on with installer not finding gcc, I tried the suggestion early on :

CC=gcc-3.3
export CC
But this doesn't have any effect I post the error log here I would appreciate any suggestions that might help:

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

ERROR: Unable to find the development tool `cc` in your path; please make sure
that you have the package 'gcc' installed. If gcc is installed on your
system, then please check that `cc` is in your PATH.

reid
August 19th, 2005, 06:11 AM
Tried the HOWTo but ran into problems early on with installer not finding gcc, I tried the suggestion early on :

CC=gcc-3.3
export CC
But this doesn't have any effect I post the error log here I would appreciate any suggestions that might help:


<snipped>

ERROR: Unable to find the development tool `cc` in your path; please make sure
that you have the package 'gcc' installed. If gcc is installed on your
system, then please check that `cc` is in your PATH.
I did something a little different. To find out where 'gcc' is located I did:


$ which gcc

which returned:


/usr/bin/gcc

then I made a symbolic link to gcc called cc so programs trying to use 'cc' would get gcc, with this code:


$ sudo ln -s /usr/bin/gcc /usr/bin/cc


HTH,

Reid

tseliot
August 19th, 2005, 07:50 AM
I think the problem is easy to solve

Please jodef, open Synaptic or Kynaptic and make sure you have gcc-3.3 installed (not only the base package)*, if not install it. Then try the command (the one which failed before) again.


*If you don't know how to install them, follow this steps:
Press the Search button and put "gcc" in the search field. I this way you will see a list of all gcc(s) available. There will be 2 items named "gcc-3.3" (the 2nd one is "gcc-3.3-base" or something like this). select them with your mouse, then select "Mark for installaton" and press the "Apply" button. The packages will be installed.

reid
August 19th, 2005, 09:48 AM
I think the problem is easy to solve

Please jodef, open Synaptic or Kynaptic and make sure you have gcc-3.3 installed (not only the base package)*, if not install it. Then try the command (the one which failed before) again.


*If you don't know how to install them, follow this steps:
Press the Search button and put "gcc" in the search field. I this way you will see a list of all gcc(s) available. There will be 2 items named "gcc-3.3" (the 2nd one is "gcc-3.3-base" or something like this). select them with your mouse, then select "Mark for installaton" and press the "Apply" button. The packages will be installed.
tseliot - when I encountered the 'no cc' problem, that is the first thing I did - and gcc 3.3 and gcc 3,3-base were both already installed. I then told synaptic to reisntall them in hopes that would fix the problem. Nope. That is when I tapped into my limited linux knowledge and pulled a 'ln -s' out of my hat. Are there other gcc 3.3 packages that need to be installed as well?

It worked for me, and hopefully it helps someone else also.

Thanks for the great HOWTO - I just needed to add a little to it to get it to work locally.


reid

tseliot
August 19th, 2005, 10:03 AM
tseliot - when I encountered the 'no cc' problem, that is the first thing I did - and gcc 3.3 and gcc 3,3-base were both already installed. I then told synaptic to reisntall them in hopes that would fix the problem. Nope. That is when I tapped into my limited linux knowledge and pulled a 'ln -s' out of my hat. Are there other gcc 3.3 packages that need to be installed as well?

It worked for me, and hopefully it helps someone else also.

Thanks for the great HOWTO - I just needed to add a little to it to get it to work locally.


reid
Thanks for your contribution reid. I didn't mean to say your suggestion is wrong. I remember that when I had the same problem I hadn't installed the right version of gcc yet.

In a nutshell, I wanted to say that jodef should make sure the right gcc is installed (otherwise it won't work), then if it doesn't solve the problem, he can try your method.

reid I really appreciate your help.

tseliot
August 19th, 2005, 10:10 AM
Reid, I've added your method to the guide (giving you the credits for this)

jodef
August 19th, 2005, 11:34 AM
Thanks reid and tseliot haven't tried it yet but will later. tseliot the necessary gcc packages are installed and it is the correct version. I hope the symlink works.

strawberry
August 19th, 2005, 05:16 PM
You're right but if he/she has the same graphic card as mine s/he will only have a black screen. The biggest problem is compatibility.
I see.
It was not mentioned so far but we also should consider that the new drivers - from version 1.0-7664 - do not support the following /old/ cards:



Below are the legacy GPUs that are no longer supported in the unified driver.
These GPUs will continue to be maintained through the special legacy NVIDIA
GPU driver releases.


NVIDIA chip name Device PCI ID
------------------------------- -------------------------------
RIVA TNT 0x0020
RIVA TNT2/TNT2 Pro 0x0028
RIVA TNT2 Ultra 0x0029
Vanta/Vanta LT 0x002C
RIVA TNT2 Model 64/Model 64 Pro 0x002D
Aladdin TNT2 0x00A0
GeForce 256 0x0100
GeForce DDR 0x0101
Quadro 0x0103
GeForce2 GTS/GeForce2 Pro 0x0150
GeForce2 Ti 0x0151
GeForce2 Ultra 0x0152
Quadro2 Pro 0x0153

tseliot
August 19th, 2005, 05:25 PM
I see.
It was not mentioned so far but we also should consider that the new drivers - from version 1.0-7664 - do not support the following /old/ cards:
I see, that's a good point. I'll add the information to the HOWTO. Thanks, strawberry.

Cyberkef
August 19th, 2005, 09:17 PM
Yet again a great HOWTO :)

I just had one problem, but because i came here from your great "Kernel Rebuild for Newbies" I found the solution myself :)

I'll post it in this thread so anyone with the same problem would be helped :)

The Warning:

-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
I have build my own custom kernel, so i selected No (dunno if it would have worked if I did Yes)

I have a GeForce MX 400 (which is not in the 'Old' list), and I got this error:


-> Kernel source path: '/lib/modules/2.6.10-cyberia/source'
-> Performing CC test with CC="cc".
-> Performing rivafb check.
ERROR: Your kernel was configured to include rivafb support!

The rivafb driver conflicts with the NVIDIA driver, please
reconfigure your kernel and *disable* rivafb support, then
try installing the NVIDIA kernel module again.
I had to rebuild my Kernel with the following option DISABLED (not enabled, not as module) :

Device Drivers > Graphics Support > nVidia Riva Support (disable it by pressing N)

Then rebuild your kernel :)

Worked like a charm to me ^_^

blastus
August 20th, 2005, 01:28 AM
In setting up the drivers for my nVidia card I used the instructions posted at
http://ubuntuguide.org/ and they worked fine. However, everytime I boot up I need to open the NVIDIA Settings program or enter in "nvidia-settings --load-config-only" to get the settings to load.

My question is how do I get the "nvidia-settings --load-config-only" command to run everytime I boot up? How do I get something like this to run everytime I boot up with X.Org in Ubuntu or with XFree86 in Mepis??? :?

linuxa
August 20th, 2005, 05:10 AM
I followed the instructions as best as I could in the parent post. Except for the following change:

After I type CTRL-ALT-F1 and tried to shut kde down with "kdm stop", trying to install the NVIDIA drivers still come up with "it detected X server running"...

So I ended up deleting /etc/rc2.d/S21kdm (safe to do, since was a symbolic link to /etc/init.d/kdm). After rebooting, it forced Ubuntu into a terminal window, from which I was able to successfully install the drivers.

Unfortunately, after installation, my screen size has been reduced to 800x600 (that being the biggest size in control centre). I had a peak into /etc/X11/xorg.conf and it seems that all modes were still at 1021x768, just as I had left them.

Does any one know how I could get back my larger screen size please?

p.s. FYI, with S21kdm gone, Ubuntu will always boot to terminal, to undo what you did and restore booting to KDE type "ln -s /etc/init.d/kdm /etc/rc2.d/S21kdm" in a terminal

Content of xorg.conf:

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection
Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV17 [GeForce4 420 Go]"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-72
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV17 [GeForce4 420 Go]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

tseliot
August 20th, 2005, 11:20 AM
In setting up the drivers for my nVidia card I used the instructions posted at
http://ubuntuguide.org/ and they worked fine. However, everytime I boot up I need to open the NVIDIA Settings program or enter in "nvidia-settings --load-config-only" to get the settings to load.

My question is how do I get the "nvidia-settings --load-config-only" command to run everytime I boot up? How do I get something like this to run everytime I boot up with X.Org in Ubuntu or with XFree86 in Mepis??? :?
Sorry pal, I've no idea of how to do it. Try asking the nvidia forums (the link is at the bottom of the page of the guide)

tseliot
August 20th, 2005, 11:25 AM
I followed the instructions as best as I could in the parent post. Except for the following change:

After I type CTRL-ALT-F1 and tried to shut kde down with "kdm stop", trying to install the NVIDIA drivers still come up with "it detected X server running"...

So I ended up deleting /etc/rc2.d/S21kdm (safe to do, since was a symbolic link to /etc/init.d/kdm). After rebooting, it forced Ubuntu into a terminal window, from which I was able to successfully install the drivers.

Unfortunately, after installation, my screen size has been reduced to 800x600 (that being the biggest size in control centre). I had a peak into /etc/X11/xorg.conf and it seems that all modes were still at 1021x768, just as I had left them.

Does any one know how I could get back my larger screen size please?

p.s. FYI, with S21kdm gone, Ubuntu will always boot to terminal, to undo what you did and restore booting to KDE type "ln -s /etc/init.d/kdm /etc/rc2.d/S21kdm" in a terminal

Content of xorg.conf:

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection
Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV17 [GeForce4 420 Go]"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-72
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV17 [GeForce4 420 Go]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Ok try this command (let's make another symlink):

sudo ln -s /etc/init.d/kdm /etc/rc2.d/S21kdm

Then restart your computer.

Tell me if it works

linuxa
August 20th, 2005, 12:04 PM
OK, I finally got this solved. :grin:

Effectively for my Toshiba Laptop with the Gefore4 420GO, the nv drivers that came with Ubuntu worked fine except for 3d acceleration (and it was somewhat laggy). But neither the nvidia-glx nor the nvidia drivers from nvidia.com wanted to display the 1024x768 resolution native to my laptop. Both opting to go with 800x600 each and every time.

After examining the the xorg log /var/log/Xorg.0.log line by line, I found that the EDID reported by the laptop was identifying the screen width as 969 (it was auto-correcting the horizontal & vertical refresh rates I entered as well), basically telling the driver that width of 1024 wouldn't fit.

It all worked out after I put the line:

Option "IgnoreEDID" "true"

in the Device section in xorg.conf. Basically telling X to trust the figures in xorg.conf instead what EDID comes back with.

Beware that the above option could be dangerous if you haven't set your xorg.conf correctly, it could potentially mess up your X when you start (read: black or warped display). So please careful if you intend to use this option.

Also the above option will only work for the nvidia driver. nvidia-glx doesn't have this option as far as I'm aware (someone correct me if I'm wrong).

And for anyone wanting to upgrade their drivers. It soooo pays to back up your xorg.conf before you start.

I've had many situations where I've uninstalled either of the nvidia drivers and X refused to boot to X using the default nv driver (even know the driver file was still where it's suppose to be). In those situations I've had to restore the xorg.conf to its original state and reboot to revert back to my pre-change status.

All in all, a very lengthy exercise. But well worth the fact that I can now play tuxracer with no lag ;-)

A big thank you goes out to the thread originator - tseliot)

p.s. for those wishing to install nvidia-glx instructions could be found at www.ubuntuguide.org

kwid21
August 20th, 2005, 06:06 PM
I don't understand.....
I did all the steps in the how-to, but the installation still fails. It gives an error message about my source files are not the ones used to compile my original kernel. I have used Synaptic to install the right ones for my kernel, but they don't work. Why does this have to be so hard?

cutOff
August 20th, 2005, 06:43 PM
I don't understand.....
I did all the steps in the how-to, but the installation still fails. It gives an error message about my source files are not the ones used to compile my original kernel. I have used Synaptic to install the right ones for my kernel, but they don't work. Why does this have to be so hard?
First, make sure you don't have installed nvidia-glx from repos and remove /etc/init.d/nvidia-glx.

Second, you have to install kernel-headers according to your kernel. Type

sudo aptitude install linux-headers-$(uname -r)

kwid21
August 20th, 2005, 07:15 PM
Same error. The error is cannot locate kernel module 'nvidia.ko'

Here's the terminal dialouge for getting the headers:

root@ubuntu:~ # sudo aptitude install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading extended state information
Initializing package states... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading extended state information
Initializing package states... Done
root@ubuntu:~ #

tseliot
August 20th, 2005, 07:21 PM
Same error. The error is cannot locate kernel module 'nvidia.ko'

Here's the terminal dialouge for getting the headers:

root@ubuntu:~ # sudo aptitude install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading extended state information
Initializing package states... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading extended state information
Initializing package states... Done
root@ubuntu:~ #

could you give me a more complete output of the error ( "The error is cannot locate kernel module 'nvidia.ko'" is not enough for me) you can find it in "/var/log/" it should be a file called "Nvidia log" or something (I don't recall its name). Please post it.

kwid21
August 20th, 2005, 07:45 PM
Had to format and reinstall because I could not get back to the desktop. I guess I start from scratch AGAIN (this is like my 6th install of Ubuntu in 2 days trying to just update my video drivers) and I have been trying to update my video drivers for 2 weeks trying 6 different distros in the process.

kwid21
August 20th, 2005, 08:12 PM
I think I got it now. It said that the driver install was successful, then I edited my xorg.conf and restarted X. The Nvidia logo splash screen went up, and brought me to the desktop. Is there a way to test if it is installed correctly?

cutOff
August 20th, 2005, 08:23 PM
I think I got it now. It said that the driver install was successful, then I edited my xorg.conf and restarted X. The Nvidia logo splash screen went up, and brought me to the desktop. Is there a way to test if it is installed correctly?
Type ' glxinfo | grep rendering'. If yes, all ok.

btw what do you say 'glxgears'?

tseliot
August 20th, 2005, 08:29 PM
I think I got it now. It said that the driver install was successful, then I edited my xorg.conf and restarted X. The Nvidia logo splash screen went up, and brought me to the desktop. Is there a way to test if it is installed correctly?
I completely understand you. I've tried many distros. And, well after the 20th reinstallation I've lost the count... :-P

kwid21
August 20th, 2005, 08:31 PM
robby@ubuntu:~$ glxgears
44947 frames in 5.0 seconds = 8989.400 FPS
50780 frames in 5.0 seconds = 10156.000 FPS
50633 frames in 5.0 seconds = 10126.600 FPS
50533 frames in 5.0 seconds = 10106.600 FPS
65570 frames in 5.0 seconds = 13114.000 FPS
70335 frames in 5.0 seconds = 14067.000 FPS
69883 frames in 5.0 seconds = 13976.600 FPS
59932 frames in 5.0 seconds = 11986.400 FPS
59815 frames in 5.0 seconds = 11963.000 FPS
65689 frames in 5.0 seconds = 13137.800 FPS
69870 frames in 5.0 seconds = 13974.000 FPS
69982 frames in 5.0 seconds = 13996.400 FPS
70386 frames in 5.0 seconds = 14077.200 FPS
62468 frames in 5.0 seconds = 12493.600 FPS
X connection to :0.0 broken (explicit kill or server shutdown).
robby@ubuntu:~$


BTW Thanks for helping guys! I been wrestling with this for 2 weeks, and thanks to you guys I FINALLY got it working! \\:D/

tseliot
August 20th, 2005, 08:47 PM
I'm very happy for you! :)

linuxa
August 21st, 2005, 01:33 AM
Had to format and reinstall because I could not get back to the desktop. I guess I start from scratch AGAIN (this is like my 6th install of Ubuntu in 2 days trying to just update my video drivers) and I have been trying to update my video drivers for 2 weeks trying 6 different distros in the process.


When the driver install failed, did it boot to Terminal (i.e. text mode)? ?

Because that would've given you a chance to recover the original xorg.conf which in theory should take you back to the way it was before you attempted the driver install.

Assuming that you backed up xorg.conf to begin with and that the default ubuntu installation did get you to X...

Edit: Glad it all worked out for you in the end Kwid21

arnieboy
August 21st, 2005, 03:31 AM
sudo nano /etc/X11/xorg.conf
scroll the file down until you find the line with “Modules” and either remove the first 2 lines in red and add Load "glx" or just make it look like this:


Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
#Load "dri"
#Load “GLcore”
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
Its very important that u comment out the "Load "dri"" lineby placing a "#" before it. if u dont do that, xserver will crash when u try to restart it.
Thanks for the HOWTO though.

tseliot
August 21st, 2005, 11:49 AM
Its very important that u comment out the "Load "dri"" lineby placing a "#" before it. if u dont do that, xserver will crash when u try to restart it.
Thanks for the HOWTO though.
Thanks for the correction, I'll fix it.

tseliot
August 21st, 2005, 12:01 PM
I had made a mess with the colours (which I forgot to use in that case) but now it's fixed. Sorry for the mess, guys.

tseliot
August 21st, 2005, 01:36 PM
Hi guys, I've just noticed my HOWTO has only 1 vote and it's a bad rating.

This guide has worked for a few people so could I know the reason for such a LOW rate?

I would like an answer, some constructive criticism will be accepted. And in conclusion if you are having a problems using my guide, please tell me. We can make it better together!

And if you like it as it is, PLEASE VOTE.

izmaelis
August 22nd, 2005, 06:02 PM
I upgraded my kernel to 2.6.10-5-686 and can't install these nvidia drivers.


sudo sh NVIDIA-Linux-x86-1.0-7676-pkg1.run

says that there are no kernel sources although i aot-geted linux-headers-2.6.10-5-686 and linux-headers-2.6.10-5.
Thanks for your help.

tseliot
August 22nd, 2005, 06:19 PM
I upgraded my kernel to 2.6.10-5-686 and can't install these nvidia drivers.


sudo sh NVIDIA-Linux-x86-1.0-7676-pkg1.run

says that there are no kernel sources although i aot-geted linux-headers-2.6.10-5-686 and linux-headers-2.6.10-5.
Thanks for your help.

Does it also complain about GCC and kernel modules?

EDIT: can you post the output of the error (look at /ver/log you will find a nvidia log file)

izmaelis
August 22nd, 2005, 07:40 PM
Here is my /var/log/nvidia-installer.log


nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Mon Aug 22 21:34:25 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel source path: '/lib/modules/2.6.10-5-686/build'
-> Performing CC test with CC="cc".
-> Performing rivafb check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
agp.o os-interface.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.10-5-686/bu
ild SYSOUT=/lib/modules/2.6.10-5-686/build'...

NVIDIA: calling KBUILD...
make CC=cc KBUILD_VERBOSE=1 -C /lib/modules/2.6.10-5-686/build SUBDIRS=/tmp
/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv modules
mkdir -p /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.tmp_vers
ions
make -f scripts/Makefile.build obj=/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676
-pkg1/usr/src/nv
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /tmp/selfgz9511/NVI
DIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/nv_compiler.h
cc -Wp,-MD,/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.nv.o
.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -Wstrict-pro
totypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame
-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i686 -Iincl
ude/asm-i386/mach-default -I/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/
usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscript
s -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD
-Wsign-compare -Wno-c
ast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -D_G
NU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1
-DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7676 -UDEBUG -U_DEBUG -DNDEBUG -DNV_SI
GNAL_STRUCT_RLIM -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT
-DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_PCI_GET_CLASS_PRESENT -DNV_VMAP_4_PRESE
NT -DMODULE -DKBUILD_BASENAME=nv -DKBUILD_MODNAME=nvidia -c -o /tmp/selfgz9
511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.tmp_nv.o /tmp/selfgz9511/NVID
IA-Linux-x86-1.0-7676-pkg1/usr/src/nv/nv.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:18,
from include/linux/module.h:10,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:46,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arith
metic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:837,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:69,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv.c:14:
include/asm/io.h: In function `check_signature':
include/asm/io.h:242: warning: wrong type argument to increment
cc -Wp,-MD,/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.nv-v
m.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -Wstrict-
prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-fr
ame-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i686 -Ii
nclude/asm-i386/mach-default -I/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pk
g1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscr
ipts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -
O -fno-common -MD -Wsign-compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL
_NAMES -D__KERNEL__ -DMODULE -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D_
_KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVE
L=7676 -UDEBUG -U_DEBUG -DNDEBUG -DNV_SIGNAL_STRUCT_RLIM -DNV_REMAP_PFN_RAN
GE_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DN
V_PCI_GET_CLASS_PRESENT -DNV_VMAP_4_PRESENT -DMODULE -DKBUILD_BASENAME=nv_v
m -DKBUILD_MODNAME=nvidia -c -o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pk
g1/usr/src/nv/.tmp_nv-vm.o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/us
r/src/nv/nv-vm.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:18,
from include/linux/module.h:10,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:46,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-vm.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arith
metic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:837,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:69,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-vm.c:14:
include/asm/io.h: In function `check_signature':
include/asm/io.h:242: warning: wrong type argument to increment
cc -Wp,-MD,/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.os-a
gp.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -Wstrict
-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-f
rame-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i686 -I
include/asm-i386/mach-default -I/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-p
kg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subsc
ripts
-Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD
-Wsign-compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__
-DMODULE -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE
-DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7676 -UDEBUG -U_D
EBUG -DNDEBUG -DNV_SIGNAL_STRUCT_RLIM -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHAN
GE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_PCI_GET_CLASS_PRES
ENT -DNV_VMAP_4_PRESENT -DMODULE -DKBUILD_BASENAME=os_agp -DKBUILD_MODNAME=
nvidia -c -o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.tmp_
os-agp.o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/os-agp.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:18,
from include/linux/module.h:10,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:46,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/os-agp.c:24:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arith
metic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:837,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:69,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/os-agp.c:24:
include/asm/io.h: In function `check_signature':
include/asm/io.h:242: warning: wrong type argument to increment
cc -Wp,-MD,/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.os-i
nterface.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -W
strict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -f
omit-frame-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i
686 -Iinclude/asm-i386/mach-default -I/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-
7676-pkg1/usr/src/n
v -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparen
theses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD -Wsign-
compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODUL
E -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MA
JOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7676 -UDEBUG -U_DEBUG -D
NDEBUG -DNV_SIGNAL_STRUCT_RLIM -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHANGE_PAGE
_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_PCI_GET_CLASS_PRESENT -DN
V_VMAP_4_PRESENT -DMODULE -DKBUILD_BASENAME=os_interface -DKBUILD_MODNAME=n
vidia -c -o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.tmp_o
s-interface.o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/os-i
nterface.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:18,
from include/linux/module.h:10,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:46,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/os-interface.c:26:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arith
metic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:837,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:69,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/os-interface.c:26:
include/asm/io.h: In function `check_signature':
include/asm/io.h:242: warning: wrong type argument to increment
cc -Wp,-MD,/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.os-r
egistry.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -Ws
trict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fo
mit-frame-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march
=i686 -Iinclude/asm-i386/mach-default -I/tmp/selfgz9511/NVIDIA-Linux-x86-1.
0-7676-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wch
ar-subscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno
-common -MD -Wsign-compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES
-D__KERNEL__ -DMODULE -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL
__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7676
-UDEBUG -U_DEBUG -DNDEBUG -DNV_SIGNAL_STRUCT_RLIM -DNV_REMAP_PFN_RANGE_PRESE
NT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_PCI_GE
T_CLASS_PRESENT -DNV_VMAP_4_PRESENT -DMODULE -DKBUILD_BASENAME=os_registry
-DKBUILD_MODNAME=nvidia -c -o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1
/usr/src/nv/.tmp_os-registry.o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg
1/usr/src/nv/os-registry.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:18,
from include/linux/module.h:10,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:46,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/os-registry.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arith
metic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:837,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/nv-linux.h:69,
from /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src
/nv/os-registry.c:14:
include/asm/io.h: In function `check_signature':
include/asm/io.h:242: warning: wrong type argument to increment
ld -m elf_i386 -r -o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/s
rc/nv/nvidia.o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/nv-
kernel.o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/nv.o /tmp
/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/nv-vm.o /tmp/selfgz951
1/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/os-agp.o /tmp/selfgz9511/NVIDIA-
Linux-x86-1.0-7676-pkg1/usr/src/nv/os-interface.o /tmp/selfgz9511/NVIDIA-Lin
ux-x86-1.0-7676-pkg1/usr/src/nv/os-registry.o
Building modules, stage 2.
make -rR -f /usr/src/linux-headers-2.6.10-5-686/scripts/Makefile.modpost
scripts/mod/modpost -m -a -i /usr/src/linux-headers-2.6.10-5-686/Module.sy
mvers /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/nvidia.o
Warning: could not find /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/s
rc/nv/.nv-kernel.o.cmd for /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/us
r/src/nv/nv-kernel.o
cc -Wp,-MD,/tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/.nvid
ia.mod.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -Wst
rict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fom
it-frame-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i68
6 -
Iinclude/asm-i386/mach-default -DKBUILD_BASENAME=nvidia -DKBUILD_MODNAME
=nvidia -DMODULE -c -o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/sr
c/nv/nvidia.mod.o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/
nvidia.mod.c
ld -m elf_i386 -r -o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/sr
c/nv/nvidia.ko /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/nvi
dia.o /tmp/selfgz9511/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/nvidia.mod.o
NVIDIA: left KBUILD.
-> done.
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'. This is most likely
because the kernel module was built using the wrong kernel source files.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
-1 File exists
-> Kernel messages:
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:02:00.0 into 8x mode
NET: Registered protocol family 10
Disabled Privacy Extensions on device c0313ce0(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:02:00.0 into 8x mode
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:02:00.0 into 8x mode
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:02:00.0 into 8x mode
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

Hope it helps.

tseliot
August 22nd, 2005, 08:01 PM
I'll try to solve your problem tomorrow. By the way have you tried driver 7667? Does it work?

Version 7676 just adds the following feature to 7667 and it seems (I'm not sure yet though) to have several bugs (have a look at the forum):

Improved GeForce 7800 GTX performance

So unless you have this card you should use 7667. I'll try to solve your problem although I can't try the drivers myself as I haven't got my computer any more.

izmaelis
August 22nd, 2005, 09:41 PM
Ok. I had to do


#sudo rmmod nvidia

and than new driver was compiled perfectly. Now I have another problem. Here is a part from my /var/log/Xorg.0.org:


(II) Loading extension NV-CONTROL
(EE) NVIDIA(0): Failed to load GLX
(==) RandR enabled

So, another question is why glx fails to load?

tseliot
August 22nd, 2005, 09:43 PM
Your log file says the nvidia module can't be loaded because it (or another module) exists.

1) Did you uninstall your previous drivers (do it ONLY if you had installed the drivers recommended by the Unofficial Starter guide)

If you did or you just didn't use them then try this:

sudo rm ./usr/src/nv/nvidia.ko

Then try the installer again.

Let me know if it works.

tseliot
August 22nd, 2005, 09:47 PM
Ok. I had to do


#sudo rmmod nvidia

and than new driver was compiled perfectly. Now I have another problem. Here is a part from my /var/log/Xorg.0.org:


(II) Loading extension NV-CONTROL
(EE) NVIDIA(0): Failed to load GLX
(==) RandR enabled

So, another question is why glx fails to load?

Try asking here, this questions are out of range for me (since when my motherboard decided to die):
http://www.nvnews.net/vbulletin/showthread.php?t=54863

senectus
August 23rd, 2005, 08:04 AM
How come every time I reboot that PC I have to re-install the new drivers or 3D will not work (segfault) ?

arnieboy
August 23rd, 2005, 08:06 AM
How come every time I reboot that PC I have to re-install the new drivers or 3D will not work (segfault) ?
try commenting "load dri" under "Module" by adding a "#" before that in /ect/X11/xorg.conf.

senectus
August 23rd, 2005, 08:17 AM
try commenting "load dri" under "Module" by adding a "#" before that in /ect/X11/xorg.conf.

load "dri" isn't in my xorg.conf at all, so it's not that :-P

arnieboy
August 23rd, 2005, 08:24 AM
load "dri" isn't in my xorg.conf at all, so it's not that :-P
dude.. READ ur xorg.conf. LOOK FOR THE SECTION CALLED "MODULE"
u will find "load dri"

senectus
August 23rd, 2005, 08:27 AM
dude.. READ ur xorg.conf. LOOK FOR THE SECTION CALLED "MODULE"
u will find "load dri"

Would you like me to post my xorg.conf.. ?
LOAD "dri" _is not_ in my xorg.conf.

It's not under the Module section or anywhere else in that document either (I did a search just to make sure I wasn't going blind).

arnieboy
August 23rd, 2005, 08:31 AM
Would you like me to post my xorg.conf.. ?
LOAD "dri" _is not_ in my xorg.conf.

It's not under the Module section or anywhere else in that document either (I did a search just to make sure I wasn't going blind).
shucks am sorry.. been attending to a few zillion posts on DRI and 3d acceleration all evening and its really late here. my apologies.

tseliot
August 23rd, 2005, 08:38 AM
Would you like me to post my xorg.conf.. ?
LOAD "dri" _is not_ in my xorg.conf.

It's not under the Module section or anywhere else in that document either (I did a search just to make sure I wasn't going blind).
make sure you have the lines I put in blue in the example


Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
#Load "dri"
#Load “GLcore”
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"

Fyrzen
August 23rd, 2005, 01:21 PM
I installed the drivers using your guide(great guide btw).

And I've run into my first problem, maybe you can help? When i check screensavers, none of the OpenGL ones work. I just get a black screen, the small preview says "No Preview Available". Something tells me i'm not going to be able to run neverwinter nights once i install it... The screensavers worked before.

Maybe not worth mentioning is, that in my xorg.conf file there was no Load "GLcore" line and Load "glx" was already present.

tseliot
August 23rd, 2005, 01:42 PM
I installed the drivers using your guide(great guide btw).

And I've run into my first problem, maybe you can help? When i check screensavers, none of the OpenGL ones work. I just get a black screen, the small preview says "No Preview Available". Something tells me i'm not going to be able to run neverwinter nights once i install it... The screensavers worked before.

Maybe not worth mentioning is, that in my xorg.conf file there was no Load "GLcore" line and Load "glx" was already present.
It's weird, I've never had such a problem. I don't use games in Ubuntu but OpenGL screensavers woked well on my computer.

I can try to run the installer again and to say yes when it asks you about OpenGL32bit compatibility libraries (expecially if you have Ubuntu 32)

Tell me if it works

izmaelis
August 23rd, 2005, 04:23 PM
After messing arround with new nvidia drivers for about three hours I finaly got them working... but I'm not so happy, cause performance isn't as it should be. I get:


izmaelis@boxzilla:~$ glxgears
6761 frames in 5.0 seconds = 1352.200 FPS
7931 frames in 5.0 seconds = 1586.200 FPS
7942 frames in 5.0 seconds = 1588.400 FPS
7866 frames in 5.0 seconds = 1573.200 FPS
7801 frames in 5.0 seconds = 1560.200 FPS
7688 frames in 5.0 seconds = 1537.600 FPS
7827 frames in 5.0 seconds = 1565.400 FPS
7716 frames in 5.0 seconds = 1543.200 FPS
X connection to :0.0 broken (explicit kill or server shutdown).

And I had to disable Composite extention in xorg.conf.
Now, how can I rollback to standart nvidia driver from ubuntu repos? I remember them working better than 7676 driver that I have now.

EDIT: I have GeForce FX5600XT 128Mb

tseliot
August 23rd, 2005, 05:13 PM
After messing arround with new nvidia drivers for about three hours I finaly got them working... but I'm not so happy, cause performance isn't as it should be. I get:


izmaelis@boxzilla:~$ glxgears
6761 frames in 5.0 seconds = 1352.200 FPS
7931 frames in 5.0 seconds = 1586.200 FPS
7942 frames in 5.0 seconds = 1588.400 FPS
7866 frames in 5.0 seconds = 1573.200 FPS
7801 frames in 5.0 seconds = 1560.200 FPS
7688 frames in 5.0 seconds = 1537.600 FPS
7827 frames in 5.0 seconds = 1565.400 FPS
7716 frames in 5.0 seconds = 1543.200 FPS
X connection to :0.0 broken (explicit kill or server shutdown).

And I had to disable Composite extention in xorg.conf.
Now, how can I rollback to standart nvidia driver from ubuntu repos? I remember them working better than 7676 driver that I have now.

EDIT: I have GeForce FX5600XT 128Mb
Set xorg.conf to either "vesa" or "nv"
then follow the method in the guide to launch the installer but this time you will have to launch it in this way:

sudo sh NVIDIA-Linux-x86_64-1.0-7676-pkg2.run --uninstall

Of course use the name of the file you downloaded (this is an example of my installer)

Then you can follow Ubuntu guide and install the driver you like most.

Fyrzen
August 23rd, 2005, 05:36 PM
I haven't tried reinstalling the driver yet, yes i am running ubuntu 32 but i didn't get a prompt for libraries. I thought it wasn't worth mentioning that i did not add the line Device "Nvidia", since i saw it was "nv" I figured "what's the difference right?"

Meanwhile i ran NWN from the terminal and it didn't start, it repeated the error "GLX missing on display 0:0" "Failed to initialize graphics". So i reinstalled the GLX packages from Synaptic. To no avail... If there's a difference between nv and Nvidia i might as well remove glx again and reinstall the drivers and be done with it, so is this the root of my problem?

arnieboy
August 23rd, 2005, 05:43 PM
I haven't tried reinstalling the driver yet, yes i am running ubuntu 32 but i didn't get a prompt for libraries. I thought it wasn't worth mentioning that i did not add the line Device "Nvidia", since i saw it was "nv" I figured "what's the difference right?"

Meanwhile i ran NWN from the terminal and it didn't start, it repeated the error "GLX missing on display 0:0" "Failed to initialize graphics". So i reinstalled the GLX packages from Synaptic. To no avail... If there's a difference between nv and Nvidia i might as well remove glx again and reinstall the drivers and be done with it, so is this the root of my problem?
nv is the nvidia driver that Ubuntu has packaged. Its old and ineffective. the whole point of this HowTo is to replace that. u need to change the driver name to "nvidia" if u want to use the most current Nvidia drivers that u have installed.

tseliot
August 23rd, 2005, 05:46 PM
I haven't tried reinstalling the driver yet, yes i am running ubuntu 32 but i didn't get a prompt for libraries. I thought it wasn't worth mentioning that i did not add the line Device "Nvidia", since i saw it was "nv" I figured "what's the difference right?"

Meanwhile i ran NWN from the terminal and it didn't start, it repeated the error "GLX missing on display 0:0" "Failed to initialize graphics". So i reinstalled the GLX packages from Synaptic. To no avail... If there's a difference between nv and Nvidia i might as well remove glx again and reinstall the drivers and be done with it, so is this the root of my problem?
It's important to follow EVERY step in my guide. Remove nvidia-glx in Synaptic and follow my guide again.

I hope it works now

Fyrzen
August 23rd, 2005, 06:01 PM
Fix't.

Thanks for your help, t'was my mistake.
Screensavers actualy work with a decent fps now, thanks again for this guide! :smile:

tseliot
August 23rd, 2005, 06:11 PM
Fix't.

Thanks for your help, t'was my mistake.
Screensavers actualy work with a decent fps now, thanks again for this guide! :smile:
I'm happy for you :)

onlyOknows
August 23rd, 2005, 07:56 PM
my experience after appling this howto; (I think I need some help too)

I tried this upgrade expecting to be able to make my philips 107B monitor run with 100Hz refresh rate. But I'm still can't reach this refresh rate. It's still working with 85 Hz at 1024x768. But I know this monitor and my FX5200 card support 100hz. (Actually it runs at 100Hz under windows.) How can I succed in that issue?

I could easily completed installing new nvidia drivers by following simply this howto.
Thanks to tseliot.

But I'm not sure if I really succedded upgrading my drivers. How can I check it. When I restarted the gdm after installation it seems nothing changed!!! But at least I could be able to return my X again :-)

And an other thing, I have previously installed Celestia. It was working well before the installation. After this upgrade it started to not to work!.

The error I got when I tried to start celestia is below;

onlyOknows@ubuntu:~$ celestia
kbuildsycoca running...
Unable to resolve Xmu symbols - please check your Xmu library installation.
DCOP aborting call from 'anonymous-10336' to 'celestia'
celestia: ERROR: Communication problem with celestia, it probably crashed.
onlyOknows@ubuntu:~$

Thanks in advance.

P.S.
These how to really makes sense for newbies like me. I'm learning many more things besides the main aim of the howto by just appling these howto's, even I can't succed. Thanks again.

tseliot
August 23rd, 2005, 08:14 PM
my experience after appling this howto; (I think I need some help too)

I tried this upgrade expecting to be able to make my philips 107B monitor run with 100Hz refresh rate. But I'm still can't reach this refresh rate. It's still working with 85 Hz at 1024x768. But I know this monitor and my FX5200 card support 100hz. (Actually it runs at 100Hz under windows.) How can I succed in that issue?

I could easily completed installing new nvidia drivers by following simply this howto.
Thanks to tseliot.

But I'm not sure if I really succedded upgrading my drivers. How can I check it. When I restarted the gdm after installation it seems nothing changed!!! But at least I could be able to return my X again :-)

And an other thing, I have previously installed Celestia. It was working well before the installation. After this upgrade it started to not to work!.

The error I got when I tried to start celestia is below;

onlyOknows@ubuntu:~$ celestia
kbuildsycoca running...
Unable to resolve Xmu symbols - please check your Xmu library installation.
DCOP aborting call from 'anonymous-10336' to 'celestia'
celestia: ERROR: Communication problem with celestia, it probably crashed.
onlyOknows@ubuntu:~$

Thanks in advance.

P.S.
These how to really makes sense for newbies like me. I'm learning many more things besides the main aim of the howto by just appling these howto's, even I can't succed. Thanks again.

1) can you post your /etc/xorg.conf, please?

2) I don't know Celestia but I think you should try to reinstall it

3) If you want to know which driver version you are using try this (it's from Ubuntu Starter guide):
Open Terminal or Konsole and type

sudo apt-get install nvidia-settings

sudo gedit /usr/share/applications/NVIDIA-Settings.desktop (you can use "kate" instead of "gedit" in KDE)

Insert the following lines into the new file

[Desktop Entry]
Name=NVIDIA Settings
Comment=NVIDIA Settings
Exec=nvidia-settings
Icon=
Terminal=false
Type=Application
Categories=Application;System;

Save the file and exit.

Restart your computer

You will be able to see "Nvidia settings" in the menu (I don't remember the exact name of the menu in GNOME which is the one with all the applications, and which is called kmenu in KDE)

Use it and you will be able to check and set a few things.

I'm going to add this in the guide

Let me know if it works.

mega
August 23rd, 2005, 08:15 PM
Is there a howto to ensure everything is working?

glxgears peaks my cpu at 100 %, and seems pretty slow, trying to play warcraft is not fun

card is a fx5200

mega@mainpc:/etc/X11$ glxgears
5103 frames in 5.0 seconds = 1020.600 FPS
6049 frames in 5.0 seconds = 1209.800 FPS


mega@mainpc:/etc/X11$ cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 8x
Fast Writes: Enabled
SBA: Enabled

I can run xpdyinfo but ONLY if it's the first thing I do, if I run it after glxgears I crash out to the shell, and gdm restarts

mega@mainpc:~$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3

tseliot
August 23rd, 2005, 08:22 PM
Is there a howto to ensure everything is working?

glxgears peaks my cpu at 100 %, and seems pretty slow, trying to play warcraft is not fun

card is a fx5200

mega@mainpc:/etc/X11$ glxgears
5103 frames in 5.0 seconds = 1020.600 FPS
6049 frames in 5.0 seconds = 1209.800 FPS


mega@mainpc:/etc/X11$ cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 8x
Fast Writes: Enabled
SBA: Enabled

I can run xpdyinfo but ONLY if it's the first thing I do, if I run it after glxgears I crash out to the shell, and gdm restarts

mega@mainpc:~$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3

Which driver version do you use?

mega
August 23rd, 2005, 08:27 PM
mega@mainpc:~$ glxgears -info
GL_MAX_VIEWPORT_DIMS=4096/4096
GL_RENDERER = GeForce FX 5200/AGP/SSE2/3DNOW!
GL_VERSION = 2.0.0 NVIDIA 76.76
GL_VENDOR = NVIDIA Corporation


76.76 I think, installed it last night

I coulda swore I was getting 3000fps last night, today after a few reboots everything is slow again, been trying to get my microphone working properly (it is now)

tseliot
August 23rd, 2005, 08:30 PM
mega@mainpc:~$ glxgears -info
GL_MAX_VIEWPORT_DIMS=4096/4096
GL_RENDERER = GeForce FX 5200/AGP/SSE2/3DNOW!
GL_VERSION = 2.0.0 NVIDIA 76.76
GL_VENDOR = NVIDIA Corporation


76.76 I think, installed it last night

I coulda swore I was getting 3000fps last night, today after a few reboots everything is slow again, been trying to get my microphone working properly (it is now)
Please use 7667, they are more stable. Try to install them and see if they solve the problem. You need 7676 only if you have Geforce 7800, otherwise is useless.

mega
August 23rd, 2005, 08:32 PM
installign it now

I did learn something interesting

glxinfo only crashes if I run it right after glxgears

but if I do glxinfo > test.txt it wont crash

it must be writing something from the registers onto the screen that crashes the driver?!?

onlyOknows
August 23rd, 2005, 08:36 PM
1) can you post your /etc/xorg.conf, please?

2) I don't know Celestia but I think you should try to reinstall it

3) If you want to know which driver version you are using try this (it's from Ubuntu Starter guide):
Open Terminal or Konsole and type

sudo apt-get install nvidia-settings

sudo gedit /usr/share/applications/NVIDIA-Settings.desktop (you can use "kate" instead of "gedit" in KDE)

Insert the following lines into the new file

[Desktop Entry]
Name=NVIDIA Settings
Comment=NVIDIA Settings
Exec=nvidia-settings
Icon=
Terminal=false
Type=Application
Categories=Application;System;

Save the file and exit.

Restart your computer

You will be able to see "Nvidia settings" in the menu (I don't remember the exact name of the menu in GNOME which is the one with all the applications, and which is called kmenu in KDE)

Use it and you will be able to check and set a few things.

I'm going to add this in the guide

Let me know if it works.

Celestia is a real-time visual simulation of space program.

I installed nvidia-settings as you said. But after installation I couldn't find the file NVIDIA-Settings.desktop in the location you said. (even I did "locate")

my xorg.conf file; (just the working lines)
------------------------------------------------------------------------------------------------------
Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "tr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
BusID "PCI:3:0:0"
EndSection

Section "Monitor"
Identifier "PHILIPS 107B"
Option "DPMS"
HorizSync 30-86
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
Monitor "PHILIPS 107B"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

-----------------------end of my xorg.conf--------------------------------------------------------------

Thanks.

mega
August 23rd, 2005, 08:37 PM
No improvement with 7667

mega@mainpc:~$ glxgears -info
GL_MAX_VIEWPORT_DIMS=4096/4096
GL_RENDERER = GeForce FX 5200/AGP/SSE2/3DNOW!
GL_VERSION = 2.0.0 NVIDIA 76.67
GL_VENDOR = NVIDIA Corporation

4957 frames in 5.0 seconds = 991.400 FPS
5257 frames in 5.0 seconds = 1051.400 FPS
5223 frames in 5.0 seconds = 1044.600 FPS


cpu is peaked at 100 %, should glxgears hit the cpu like that?

tseliot
August 23rd, 2005, 08:54 PM
... But after installation I couldn't find the file NVIDIA-Settings.desktop in the location you said. (even I did "locate")

Please, follow my instructions. Of course the file doesn't exists but you have to create it by using the commands I told you to use.


Section "Monitor"
Identifier "PHILIPS 107B"
Option "DPMS"
HorizSync 30-86
VertRefresh 50-160
EndSection


Find the specs of your monitor (you can use Google) and find the Horizontal and the Vertical refresh of your monitor then put them instead of the default values

HorizSync 30-86
VertRefresh 50-160


Then save the file.

If you do this using the graphic interface log out and then login (it should restart Xorg)

onlyOknows
August 23rd, 2005, 09:03 PM
ohh. sorry sorry sorry! I have missed the words "the new file". I'm a newbie but not as new as that :-)
now I'm restarting the machine.

tseliot
August 23rd, 2005, 09:12 PM
No improvement with 7667

mega@mainpc:~$ glxgears -info
GL_MAX_VIEWPORT_DIMS=4096/4096
GL_RENDERER = GeForce FX 5200/AGP/SSE2/3DNOW!
GL_VERSION = 2.0.0 NVIDIA 76.67
GL_VENDOR = NVIDIA Corporation

4957 frames in 5.0 seconds = 991.400 FPS
5257 frames in 5.0 seconds = 1051.400 FPS
5223 frames in 5.0 seconds = 1044.600 FPS


cpu is peaked at 100 %, should glxgears hit the cpu like that?
Try to add the lines I've put in blue to your xorg.conf:

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "RenderAccel" "OFF"
Option "AllowGLXWithComposite" "OFF"

Restart X by (logout and then login) and try glxgears again. If this does the trick but you have low FPS THEN (and ONLY THEN) erase "Option "RenderAccel" "OFF"" and try glxgears again.

Tell me what happens in both cases.

DancingSun
August 23rd, 2005, 09:32 PM
(...)
Find the specs of your monitor (you can use Google) and find the Horizontal and the Vertical refresh of your monitor then put them instead of the default values

HorizSync 30-86
VertRefresh 50-160


Then save the file.

If you do this using the graphic interface log out and then login (it should restart Xorg)
Or you could try commenting out those two lines by putting a "#" in front of the lines. I did this and all my refresh rate@resolution combinations are detected automatically. If this doesn't work for you, just uncomment the lines and you should be back on track.

onlyOknows
August 23rd, 2005, 09:56 PM
Please, follow my instructions. Of course the file doesn't exists but you have to create it by using the commands I told you to use.



Find the specs of your monitor (you can use Google) and find the Horizontal and the Vertical refresh of your monitor then put them instead of the default values

HorizSync 30-86
VertRefresh 50-160


Then save the file.

If you do this using the graphic interface log out and then login (it should restart Xorg)

Following your guide to nvidia-settings installation is worked. Thanks.

I entered the values as what is given in the Philisps data sheet. In the data sheet these values are also given as ranges, but not as a single value!
The results is, I'm still couldn't reach the 100 Hz refresh rate. I also tried the way explained in the following howto;
http://www.ubuntuforums.org/showpost.php?p=129379&postcount=21

It also didn't worked :-(

In the linux kernel or in the driver who decides to use which refresh rate? In the "Screen Resolution preference tool" of ubuntu the maximum listed rate is 85Hz. How these lists are generated? And when I changed the value in this list which file is being affected exactly? So maybe I can change this file by myself.

tseliot
August 23rd, 2005, 10:15 PM
Following your guide to nvidia-settings installation is worked. Thanks.

I entered the values as what is given in the Philisps data sheet. In the data sheet these values are also given as ranges, but not as a single value!
The results is, I'm still couldn't reach the 100 Hz refresh rate. I also tried the way explained in the following howto;
http://www.ubuntuforums.org/showpost.php?p=129379&postcount=21

It also didn't worked :-(

In the linux kernel or in the driver who decides to use which refresh rate? In the "Screen Resolution preference tool" of ubuntu the maximum listed rate is 85Hz. How these lists are generated? And when I changed the value in this list which file is being affected exactly? So maybe I can change this file by myself.
The file you are looking for is xorg.conf.

Have you tried this (in the command line)? :

sudo dpkg-reconfigure xserver-xorg

And follow the instructions (it will also ask you the refresh rate (Vertical and Horizontal) of your monitor

REBELinBLUE
August 24th, 2005, 09:45 AM
If you haven't got this solved now (and even if you had so other people will know) I have to make a symlink from linux-headers-2.6.10-5 (think thats the name, you'll see the folder in /usr/src) to linux, i.e.


sudo ln -s /usr/src/linux-headers-2.6.10-5/ /usr/src/linux/

then it worked

tseliot
August 24th, 2005, 09:54 AM
If you haven't got this solved now (and even if you had so other people will know) I have to make a symlink from linux-headers-2.6.10-5 (think thats the name, you'll see the folder in /usr/src) to linux, i.e.


sudo ln -s /usr/src/linux-headers-2.6.10-5/ /usr/src/linux/

then it worked
I'm happy it works in this way. I might add this method to my guide later. Thanks

mega
August 24th, 2005, 01:43 PM
Option "RenderAccel" "OFF"
Option "AllowGLXWithComposite" "OFF"


if I put this in, I can no longer start xorg, it tries 3-4 times, then locks up the computer

I had to boot in recovery mode to fix it, both have to be set to true, or xorg crashes

glxgears fps seems bad, but I was playing warcraft last night and I was getting 15-30fps, not too bad for a old card like this

tseliot
August 24th, 2005, 01:53 PM
if I put this in, I can no longer start xorg, it tries 3-4 times, then locks up the computer

I had to boot in recovery mode to fix it, both have to be set to true, or xorg crashes
Try the other suggestions (in red) at the end of the guide.

Then if they don't work you will have to ask in Nvidia Forum (at the Linux section) as your problem can be related to some bug of the driver. You can ask the developers and some users in there.

http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

mega
August 24th, 2005, 02:00 PM
I'm just going to leave it as is, glxgears fps sucks, but warcraft was ok, drop shadows works fine, overall desktop performance seems fine too

everything says direct rendering is working properly, not sure why glxgears performance is half what others get with this card

tseliot
August 24th, 2005, 02:05 PM
I'm just going to leave it as is, glxgears fps sucks, but warcraft was ok, drop shadows works fine, overall desktop performance seems fine too

everything says direct rendering is working properly, not sure why glxgears performance is half what others get with this card
By the way I've read somewhere that glxgears fps aren't very important (I don't remember the exact reason though).

arnoct
August 24th, 2005, 04:10 PM
Is there any way to enable hardware rendering without potentially randomly killing the x session? This was one of the reasons I went back to windows last time, because what use is emulating games like Warcraft 3 if they're unplayable?

tseliot
August 24th, 2005, 04:51 PM
Is there any way to enable hardware rendering without potentially randomly killing the x session? This was one of the reasons I went back to windows last time, because what use is emulating games like Warcraft 3 if they're unplayable?
As mega said he/she had no problems with Warcraft. I don't use Linux for games.

1) Have you tried this guide? (following EVERY step)
2) If you tried it, which is your problem (when does it occur,etc.)?

onlyOknows
August 24th, 2005, 05:37 PM
The file you are looking for is xorg.conf.

Have you tried this (in the command line)? :

sudo dpkg-reconfigure xserver-xorg

And follow the instructions (it will also ask you the refresh rate (Vertical and Horizontal) of your monitor

As soon as I returned from the job started to apply your suggestions.

Yess! That worked. But the only difference in my xorg.conf file is that the 1600x1200 is added. my monitor supports that mode but since I don't want to use it I didn't thought to add it. But while reconfiguration when it asked me for the supported modes I also chose 1600x1200. After reconfiguration completed I started "Screen Resolution preference tool" and seen that for 1024x768 now 100hz is available \\:D/
Just chose it and it worked. :grin:

here is the diff of my previous and after reconfiguration xorg.conf files.
onlyOknows@ubuntu:~$ diff -u /etc/X11/xorg.conf.200508241920 /etc/X11/xorg.conf --- /etc/X11/xorg.conf.200508241920 2005-08-24 19:20:19.528869888 +0300
+++ /etc/X11/xorg.conf 2005-08-24 19:20:19.664849216 +0300
@@ -37,7 +37,7 @@
Load "bitmap"
Load "dbe"
Load "ddc"
-# Load "dri"
+ Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
@@ -77,10 +77,6 @@
Option "DPMS"
HorizSync 30-92
VertRefresh 50-160

#it was just a trial. I had also tried without the following 3 lines.
-
- # 1024x768 @ 100.00 Hz (GTF) hsync: 81.40 kHz; pclk: 113.31 MHz
- Modeline "1024x768_100.00" 113.31 1024 1096 1208 1392 768 769 772 814 -HSync +Vsync
-
EndSection

#see difference in modes. Only 1600x1200 is added!
Section "Screen"
@@ -90,27 +86,27 @@
DefaultDepth 24
SubSection "Display"
Depth 1
- Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
+ Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
- Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
+ Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
- Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
+ Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
- Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
+ Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
- Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
+ Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
- Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
+ Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

onlyOknows@ubuntu:~$


Thanks for your help. Now I have a really flicker free monitor. :smile:
And by solving the problems I'm really getting far away to use MS Windows from day to day.

tseliot
August 24th, 2005, 05:48 PM
Thanks for your help. Now I have a really flicker free monitor. :smile:
And by solving the problems I'm really getting far away to use MS Windows from day to day.
I hope one day you can completely switch to Ubuntu as I did.
I'm happy the monitor works for you now :)

onlyOknows
August 24th, 2005, 08:10 PM
As soon as I returned from the job started to apply your suggestions.

Yess! That worked. But the only difference in my xorg.conf file is that the 1600x1200 is added. my monitor supports that mode but since I don't want to use it I didn't thought to add it. But while reconfiguration when it asked me for the supported modes I also chose 1600x1200. After reconfiguration completed I started "Screen Resolution preference tool" and seen that for 1024x768 now 100hz is available \\:D/
Just chose it and it worked. :grin:




Ohh No!!! When I reboot the machine lost 100hz again :-x
And beside that my login window is started to open at 1600x1200@65Hz (it was 1024x768@75Hz). And the main window is again 1024x768@85Hz as before.

What am I missing???

One more thing tseliot, you modified the "how to", and at the beggining you are saying that; "You need 7676 version only if you have Geforce 7800, otherwise is useless (and it has some bugs). If you haven't got this graphic card PLEASE try 7667, it's more stable."
So, since my graphic card is an Fx5200 T128 I think I need to downgrade the nvdia driver. How can I do that?

tseliot
August 24th, 2005, 08:18 PM
Ohh No!!! When I reboot the machine lost 100hz again :-x
And beside that my login window is started to open at 1600x1200@65Hz (it was 1024x768@75Hz). And the main window is again 1024x768@85Hz as before.

What am I missing???

One more thing tseliot, you modified the "how to", and at the beggining you are saying that; "You need 7676 version only if you have Geforce 7800, otherwise is useless (and it has some bugs). If you haven't got this graphic card PLEASE try 7667, it's more stable."
So, since my graphic card is an Fx5200 T128 I think I need to downgrade the nvdia driver. How can I do that?
1) You can do this again:

sudo dpkg-reconfigure xserver-xorg
You can try to select the resolution you use as the only supported mode (1024x768 )

2) If you want to install 7667 follow the guide again and use nvidia installer 7667. It will ask you if you want to overwrite the previous installation, answer yes and there you go.

arnoct
August 25th, 2005, 04:54 AM
As mega said he/she had no problems with Warcraft. I don't use Linux for games.

1) Have you tried this guide? (following EVERY step)
2) If you tried it, which is your problem (when does it occur,etc.)?

I'm having the "random freezeups when RenderAccel is turned on" bug. yes I followed the guide, but since it was really bad I rolled back my drivers to an old version (I only have a 32mb GeForce2) and the problem still persisted, albeit slightly less.

onlyOknows
August 25th, 2005, 05:56 AM
1) You can do this again:

sudo dpkg-reconfigure xserver-xorg
You can try to select the resolution you use as the only supported mode (1024x768 )

2) If you want to install 7667 follow the guide again and use nvidia installer 7667. It will ask you if you want to overwrite the previous installation, answer yes and there you go.


1- it didn!t worked :-(

2- I successfully downgraded to 7667. here is the link where to download the installer for 7667 driver; http://www.nvidia.com/object/linux_display_ia32_1.0-7667.html

tseliot
August 25th, 2005, 08:28 AM
I'm having the "random freezeups when RenderAccel is turned on" bug. yes I followed the guide, but since it was really bad I rolled back my drivers to an old version (I only have a 32mb GeForce2) and the problem still persisted, albeit slightly less.
Old graphic cards are not supported any more by this driver
Here's a list
RIVA TNT 0x0020
RIVA TNT2/TNT2 Pro 0x0028
RIVA TNT2 Ultra 0x0029
Vanta/Vanta LT 0x002C
RIVA TNT2 Model 64/Model 64 Pro 0x002D
Aladdin TNT2 0x00A0
GeForce 256 0x0100
GeForce DDR 0x0101
Quadro 0x0103
GeForce2 GTS/GeForce2 Pro 0x0150
GeForce2 Ti 0x0151
GeForce2 Ultra 0x0152
Quadro2 Pro 0x0153

tseliot
August 25th, 2005, 08:32 AM
1- it didn!t worked :-(
2- I successfully downgraded to 7667. here is the link where to download the installer for 7667 driver; http://www.nvidia.com/object/linux_display_ia32_1.0-7667.html
I didn't understand if 7667 work for you.
I really don't know how to help you with the refresh rate.

1) Can you see the refresh in nvidia-settings?
2) Otherwise you can start another thread and ask for help. I'm sure there are more experienced user who can help you.

onlyOknows
August 25th, 2005, 08:46 AM
I didn't understand if 7667 work for you.
I really don't know how to help you with the refresh rate.

1) Can you see the refresh in nvidia-settings?
2) Otherwise you can start another thread and ask for help. I'm sure there are more experienced user who can help you.

you suggested; "sudo dpkg-reconfigure xserver-xorg
You can try to select the resolution you use as the only supported mode (1024x768 )"

I mean that suggestion didn't worked.

But installing 7667 is OK.

Thanks anyway. Although I'm still working with 85Hz refresh rate, I learned many things. :-)

liquidfire
August 25th, 2005, 08:00 PM
I didn't understand if 7667 work for you.
I really don't know how to help you with the refresh rate.

1) Can you see the refresh in nvidia-settings?
2) Otherwise you can start another thread and ask for help. I'm sure there are more experienced user who can help you.

Great guide :)
But i'm having some compile errors.
It stops with the error
No kernelsources found blabla nvidia.ro.
I downloaded the right source (I hope) but i get that error above
Here's my log



nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Aug 25 20:47:28 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : /emul/ia32-linux
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel source path: '/lib/modules/2.6.12-6-amd64-generic/build'
-> Performing CC test with CC="gcc-3.3".
-> Performing rivafb check.
-> Performing change_page_attr() check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
agp.o os-interface.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.12-6-amd64-
generic/build SYSOUT=/lib/modules/2.6.12-6-amd64-generic/build'...

NVIDIA: calling KBUILD...
make CC=gcc-3.3 KBUILD_VERBOSE=1 -C /lib/modules/2.6.12-6-amd64-generic/bui
ld SUBDIRS=/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv modu
les
mkdir -p /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/.tmp_v
ersions
make -f scripts/Makefile.build obj=/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7
676-pkg2/usr/src/nv
echo \#define NV_COMPILER \"`gcc-3.3 -v 2>&1 | tail -n 1`\" > /tmp/selfgz538
6/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/nv_compiler.h
gcc-3.3 -Wp,-MD,/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/
nv/.nv.o.d -nostdinc -isystem /usr/lib/gcc-lib/x86_64-linux-gnu/3.3.6/inclu
de -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigraphs -fno-str
ict-aliasing -fno-common -ffreestanding -Os -fomit-frame-pointer -mno-r
ed-zone -mcmodel=kernel -pipe -fno-reorder-blocks -Wno-sign-compare -fno-as
ynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -I/tmp/se
lfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv -Wall -Wimpli
cit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointe
r-arith -Wno-multichar -Werror -O -fno-common -mno-red-zone -minline-all-s
tringops -MD -Wsign-compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAME
S -D__KERNEL__ -DMODULE -mcmodel=kernel -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNE
L_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DN
V_PATCHLEVEL=7676 -UDEBUG -U_DEBUG -DNDEBUG -DNV_SIGNAL_STRUCT_RLIM -DNV_MU
LTIPLE_BRIDGE_AGPGART_PRESENT -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHANGE_PAGE_
ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_PCI_GET_CLASS_PRESENT -DNV
_VMAP_4_PRESENT -DMODULE -DKBUILD_BASENAME=nv -DKBUILD_MODNAME=nvidia -c -o
/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/.tmp_nv.o /tmp/
selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/nv.c
In file included from include/linux/sched.h:15,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv.c:14:
include/linux/cpumask.h: In function `__first_cpu':
include/linux/cpumask.h:215: let op: signed and unsigned type in conditional
expression
include/linux/cpumask.h: In function `__next_cpu':
include/linux/cpumask.h:221: let op: signed and unsigned type in conditional
expression
In file included from include/linux/sched.h:17,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv.c:14:
include/linux/nodemask.h: In function `__first_node':
include/linux/nodemask.h:226: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__next_node':
include/linux/nodemask.h:232: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__first_unset_node':
include/linux/nodemask.h:250: let op: signed and unsigned type in conditiona
l expression
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:42,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: let op: pointer van type `void *' gebruikt in r
ekensom
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:864,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv.c:14:
include/asm/io.h: In function `check_signature':
include/asm/io.h:308: let op: argument van verkeerd type voor incrementeren
In file included from include/asm/pci.h:94,
from include/linux/pci.h:904,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv.c:14:
include/asm-generic/pci-dma-compat.h: In function `pci_map_page':
include/asm-generic/pci-dma-compat.h:49: let op: pointer van type `void *' g
ebruikt in rekensom
gcc-3.3 -Wp,-MD,/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/
nv/.nv-vm.o.d -nostdinc -isystem /usr/lib/gcc-lib/x86_64-linux-gnu/3.3.6/in
clude -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigraphs -fno-
strict-aliasing -fno-common -ffreestanding -Os -fomit-frame-pointer -mn
o-red-zone -mcmodel=kernel -pipe -fno-reorder-blocks -Wno-sign-compare -fno
-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -I/tmp
/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv -Wall -Wimplicit -W
return-type -Wswitch -Wformat
-Wchar-subscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O
-fno-common -mno-red-zone -minline-all-stringops -MD -Wsign-compare -Wno-c
ast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -mcmodel=ke
rnel -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_
MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7676 -UDEBUG -U_DEBUG
-DNDEBUG -DNV_SIGNAL_STRUCT_RLIM -DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT -DNV_R
EMAP_PFN_RANGE_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE
_PRESENT -DNV_PCI_GET_CLASS_PRESENT -DNV_VMAP_4_PRESENT -DMODULE -DKBUILD_B
ASENAME=nv_vm -DKBUILD_MODNAME=nvidia -c -o /tmp/selfgz5386/NVIDIA-Linux-x86
_64-1.0-7676-pkg2/usr/src/nv/.tmp_nv-vm.o /tmp/selfgz5386/NVIDIA-Linux-x86_6
4-1.0-7676-pkg2/usr/src/nv/nv-vm.c
In file included from include/linux/sched.h:15,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-vm.c:14:
include/linux/cpumask.h: In function `__first_cpu':
include/linux/cpumask.h:215: let op: signed and unsigned type in conditional
expression
include/linux/cpumask.h: In function `__next_cpu':
include/linux/cpumask.h:221: let op: signed and unsigned type in conditional
expression
In file included from include/linux/sched.h:17,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-vm.c:14:
include/linux/nodemask.h: In function `__first_node':
include/linux/nodemask.h:226: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__next_node':
include/linux/nodemask.h:232: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__first_unset_node':
include/linux/nodemask.h:250: let op: signed and unsigned type in conditiona
l expression
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:42,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-vm.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: let op: pointer van type `void *' gebruikt in r
ekensom
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:864,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-vm.c:14:
include/asm/io.h: In function `check_signature':
include/asm/io.h:308: let op: argument van verkeerd type voor incrementeren
In file included from include/asm/pci.h:94,
from include/linux/pci.h:904,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-vm.c:14:
include/asm-generic/pci-dma-compat.h: In function `pci_map_page':
include/asm-generic/pci-dma-compat.h:49: let op: pointer van type `void *' g
ebruikt in rekensom
gcc-3.3 -Wp,-MD,/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/
nv/.os-agp.o.d -nostdinc -isystem /usr/lib/gcc-lib/x86_64-linux-gnu/3.3.6/i
nclude -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigraphs -fno
-strict-aliasing -fno-common -ffreestanding -Os -fomit-frame-pointer -m
no-red-zone -mcmodel=kernel -pipe -fno-reorder-blocks -Wno-sign-compare -fn
o-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -I/tm
p/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv -Wall -Wimplicit -
Wreturn-type -Wswitch -Wformat -Wchar-subs
cripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common
-mno-red-zone -minline-all-stringops -MD -Wsign-compare -Wno-cast-qual -Wn
o-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -mcmodel=kernel -DNTRM
-D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSIO
N=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7676 -UDEBUG -U_DEBUG -DNDEBUG -DN
V_SIGNAL_STRUCT_RLIM -DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT -DNV_REMAP_PFN_RAN
GE_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DN
V_PCI_GET_CLASS_PRESENT -DNV_VMAP_4_PRESENT -DMODULE -DKBUILD_BASENAME=os_a
gp -DKBUILD_MODNAME=nvidia -c -o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-767
6-pkg2/usr/src/nv/.tmp_os-agp.o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676
-pkg2/usr/src/nv/os-agp.c
In file included from include/linux/sched.h:15,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-agp.c:24:
include/linux/cpumask.h: In function `__first_cpu':
include/linux/cpumask.h:215: let op: signed and unsigned type in conditional
expression
include/linux/cpumask.h: In function `__next_cpu':
include/linux/cpumask.h:221: let op: signed and unsigned type in conditional
expression
In file included from include/linux/sched.h:17,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-agp.c:24:
include/linux/nodemask.h: In function `__first_node':
include/linux/nodemask.h:226: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__next_node':
include/linux/nodemask.h:232: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__first_unset_node':
include/linux/nodemask.h:250: let op: signed and unsigned type in conditiona
l expression
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:42,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-agp.c:24:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: let op: pointer van type `void *' gebruikt in r
ekensom
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:864,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-agp.c:24:
include/asm/io.h: In function `check_signature':
include/asm/io.h:308: let op: argument van verkeerd type voor incrementeren
In file included from include/asm/pci.h:94,
from include/linux/pci.h:904,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-agp.c:24:
include/asm-generic/pci-dma-compat.h: In function `pci_map_page':
include/asm-generic/pci-dma-compat.h:49: let op: pointer van type `void *' g
ebruikt in rekensom
gcc-3.3 -Wp,-MD,/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/
nv/.os-interface.o.d -nostdinc -isystem /usr/lib/gcc-lib/x86_64-linux-gnu/3
.3.6/include -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigraph
s -fno-strict-aliasing -fno-common -ffreestanding -Os -fomit-frame-point
er -mno-red-zone -mcmodel=kernel -pipe -fno-reorder-blocks -Wno-sign-compa
re -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow
-I/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv -Wall -Wimpli
cit -Wreturn-type -Wswitch -Wformat -Wchar-s
ubscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-com
mon -mno-red-zone -minline-all-stringops -MD -Wsign-compare -Wno-cast-qual
-Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -mcmodel=kernel -DNT
RM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VER
SION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7676 -UDEBUG -U_DEBUG -DNDEBUG
-DNV_SIGNAL_STRUCT_RLIM -DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT -DNV_REMAP_PFN_
RANGE_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT
-DNV_PCI_GET_CLASS_PRESENT -DNV_VMAP_4_PRESENT -DMODULE -DKBUILD_BASENAME=o
s_interface -DKBUILD_MODNAME=nvidia -c -o /tmp/selfgz5386/NVIDIA-Linux-x86_6
4-1.0-7676-pkg2/usr/src/nv/.tmp_os-interface.o /tmp/selfgz5386/NVIDIA-Linux-
x86_64-1.0-7676-pkg2/usr/src/nv/os-interface.c
In file included from include/linux/sched.h:15,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-interface.c:26:
include/linux/cpumask.h: In function `__first_cpu':
include/linux/cpumask.h:215: let op: signed and unsigned type in conditional
expression
include/linux/cpumask.h: In function `__next_cpu':
include/linux/cpumask.h:221: let op: signed and unsigned type in conditional
expression
In file included from include/linux/sched.h:17,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-interface.c:26:
include/linux/nodemask.h: In function `__first_node':
include/linux/nodemask.h:226: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__next_node':
include/linux/nodemask.h:232: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__first_unset_node':
include/linux/nodemask.h:250: let op: signed and unsigned type in conditiona
l expression
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:42,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-interface.c:26:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: let op: pointer van type `void *' gebruikt in r
ekensom
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:864,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-interface.c:26:
include/asm/io.h: In function `check_signature':
include/asm/io.h:308: let op: argument van verkeerd type voor incrementeren
In file included from include/asm/pci.h:94,
from include/linux/pci.h:904,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-interface.c:26:
include/asm-generic/pci-dma-compat.h: In function `pci_map_page':
include/asm-generic/pci-dma-compat.h:49: let op: pointer van type `void *' g
ebruikt in rekensom
gcc-3.3 -Wp,-MD,/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/
nv/.os-registry.o.d -nostdinc -isystem /usr/lib/gcc-lib/x86_64-linux-gnu/3.
3.6/include -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigraphs
-fno-strict-aliasing -fno-common -ffreestanding -Os -fomit-frame-pointer
-mno-red-zone -mcmodel=kernel -pipe -fno-reorder-blocks -Wno-sign-compare
-fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -I
/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv -Wall -
Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -W
pointer-arith -Wno-multichar -Werror -O -fno-common -mno-red-zone -minline
-all-stringops -MD -Wsign-compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNE
L_NAMES -D__KERNEL__ -DMODULE -mcmodel=kernel -DNTRM -D_GNU_SOURCE -D_LOOSE
_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION
=0 -DNV_PATCHLEVEL=7676 -UDEBUG -U_DEBUG -DNDEBUG -DNV_SIGNAL_STRUCT_RLIM -
DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHANGE
_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_PCI_GET_CLASS_PRESEN
T -DNV_VMAP_4_PRESENT -DMODULE -DKBUILD_BASENAME=os_registry -DKBUILD_MODNA
ME=nvidia -c -o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv
/.tmp_os-registry.o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/sr
c/nv/os-registry.c
In file included from include/linux/sched.h:15,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-registry.c:14:
include/linux/cpumask.h: In function `__first_cpu':
include/linux/cpumask.h:215: let op: signed and unsigned type in conditional
expression
include/linux/cpumask.h: In function `__next_cpu':
include/linux/cpumask.h:221: let op: signed and unsigned type in conditional
expression
In file included from include/linux/sched.h:17,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-registry.c:14:
include/linux/nodemask.h: In function `__first_node':
include/linux/nodemask.h:226: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__next_node':
include/linux/nodemask.h:232: let op: signed and unsigned type in conditiona
l expression
include/linux/nodemask.h: In function `__first_unset_node':
include/linux/nodemask.h:250: let op: signed and unsigned type in conditiona
l expression
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:42,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:46,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-registry.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: let op: pointer van type `void *' gebruikt in r
ekensom
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:864,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-registry.c:14:
include/asm/io.h: In function `check_signature':
include/asm/io.h:308: let op: argument van verkeerd type voor incrementeren
In file included from include/asm/pci.h:94,
from include/linux/pci.h:904,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/nv-linux.h:69,
from /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/
src/nv/os-registry.c:14:
include/asm-generic/pci-dma-compat.h: In function `pci_map_page':
include/asm-generic/pci-dma-compat.h:49: let op: pointer van type `void *' g
ebruikt in rekensom
ld -m elf_x86_64 -r -o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/
usr/src/nv/nvidia.o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/sr
c/nv/nv-kernel.o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/n
v/nv.o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/nv-vm.o
/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/os-agp.o /tmp/s
elfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/os-interface.o /tmp/s
elfgz5386/NVIDIA-Linux-x86_6
4-1.0-7676-pkg2/usr/src/nv/os-registry.o
Building modules, stage 2.
make -rR -f /usr/src/linux-headers-2.6.12-6-amd64-generic/scripts/Makefile.m
odpost
scripts/mod/modpost -m -a -i /usr/src/linux-headers-2.6.12-6-amd64-generic
/Module.symvers /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv
/nvidia.o
Warning: could not find /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/us
r/src/nv/.nv-kernel.o.cmd for /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-p
kg2/usr/src/nv/nv-kernel.o
gcc-3.3 -Wp,-MD,/tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/
nv/.nvidia.mod.o.d -nostdinc -isystem /usr/lib/gcc-lib/x86_64-linux-gnu/3.3
.6/include -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigraphs
-fno-strict-aliasing -fno-common -ffreestanding -Os -fomit-frame-pointer
-mno-red-zone -mcmodel=kernel -pipe -fno-reorder-blocks -Wno-sign-compare
-fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow
-DKBUILD_BASENAME=nvidia -DKBUILD_MODNAME=nvidia -DMODULE -c -o /tmp/sel
fgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/nvidia.mod.o /tmp/selfg
z5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/nvidia.mod.c
ld -m elf_x86_64 -r -o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/u
sr/src/nv/nvidia.ko /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/sr
c/nv/nvidia.o /tmp/selfgz5386/NVIDIA-Linux-x86_64-1.0-7676-pkg2/usr/src/nv/n
vidia.mod.o
NVIDIA: left KBUILD.
-> done.
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'. This is most likely
because the kernel module was built using the wrong kernel source files.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
-1 Invalid module format
-> Kernel messages:
[ 360.828049] cpu_init done, current fid 0xe, vid 0x6
[ 397.796974] Bluetooth: Core ver 2.7
[ 397.796979] NET: Registered protocol family 31
[ 397.796981] Bluetooth: HCI device and connection manager initialized
[ 397.796989] Bluetooth: HCI socket layer initialized
[ 397.810820] Bluetooth: L2CAP ver 2.7
[ 397.810823] Bluetooth: L2CAP socket layer initialized
[ 397.817729] Bluetooth: RFCOMM ver 1.5
[ 397.817735] Bluetooth: RFCOMM socket layer initialized
[ 397.817744] Bluetooth: RFCOMM TTY layer initialized
[ 831.262068] ibm_acpi: ec object not found
[ 1308.306748] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 1309.386012] ISO 9660 Extensions: RRIP_1991A
[ 1371.851331] nvidia: version magic '2.6.12-6-amd64-generic gcc-3.3' should
be '2.6.12-6-amd64-generic gcc-3.4'
[ 1724.604132] nvidia: version magic '2.6.12-6-amd64-generic gcc-3.3' should
be '2.6.12-6-amd64-generic gcc-3.4'
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

bagatonovic
August 25th, 2005, 08:09 PM
1- it didn!t worked :-(

2- I successfully downgraded to 7667. here is the link where to download the installer for 7667 driver; http://www.nvidia.com/object/linux_display_ia32_1.0-7667.html


I got a higher refresh rate using any Nvidia driver by commenting out the following lines in my xorg.conf

HorizSync
VertRefresh

So just add "#" in front of those 2 lines. This will force X to probe the monitor and will automatically pick best refresh

tseliot
August 25th, 2005, 08:11 PM
Great guide :)
But i'm having some compile errors.
It stops with the error
No kernelsources found blabla nvidia.ro.
I downloaded the right source (I hope) but i get that error above
Here's my log
It's easy to solve. I've dealt with it in point 2 of the "Problem Section" of my guide. Have a look at it.

By the way this is the solution for you:

It means the installer tries to use gcc-3.3 instead of gcc-3.4(the right one).Type this before launching NVIDIA installer:

CC=gcc-3.4
export CC

then run nvidia installer again.

P.S. Let me guess: you are using a Breezy kernel, aren't you?

liquidfire
August 25th, 2005, 08:27 PM
It's easy to solve. I've dealt with it in point 2 of the "Problem Section" of my guide. Have a look at it.

By the way this is the solution for you:

It means the installer tries to use gcc-3.3 instead of gcc-3.4(the right one).Type this before launching NVIDIA installer:

CC=gcc-3.4
export CC

then run nvidia installer again.

P.S. Let me guess: you are using a Breezy kernel, aren't you?
Sorry, how stupid of me ;) I did exactly what I read, setting CC=gcc3.3 but i type 3 instead of four :)

tseliot
August 25th, 2005, 08:43 PM
Sorry, how stupid of me ;) I did exactly what I read, setting CC=gcc3.3 but i type 3 instead of four :)
No problem, have fun with your new driver :)

liquidfire
August 25th, 2005, 09:18 PM
No problem, have fun with your new driver :)
Hmm, its conflicting with the 7667 driver which is installed by default
Any idea how to avoid it? I removed everything except the common thingy.
Should I remove it, if so it will remove some image files too and I don't know if that would be harmfull.

onlyOknows
August 25th, 2005, 09:29 PM
I got a higher refresh rate using any Nvidia driver by commenting out the following lines in my xorg.conf

HorizSync
VertRefresh

So just add "#" in front of those 2 lines. This will force X to probe the monitor and will automatically pick best refresh

I have already tried it, but it didn't change anything. I thing xorg.conf is a useless file. I have tried billions of configurations that are all suggested by some people on the forums. But no one worked!!! :-x :-x :-x ](*,) ](*,) ](*,)

tseliot
August 25th, 2005, 09:35 PM
Hmm, its conflicting with the 7667 driver which is installed by default
Any idea how to avoid it? I removed everything except the common thingy.
Should I remove it, if so it will remove some image files too and I don't know if that would be harmfull.
I don't understand (perhaps because it's 10.35PM and I'm still studying and I'm tired) .

1) Which driver are you trying to install?

2) Which driver was previously installed? And what do you mean when saying "installed by default"

3) What do you want to remove?

Thanks

liquidfire
August 26th, 2005, 03:16 PM
I don't understand (perhaps because it's 10.35PM and I'm still studying and I'm tired) .

1) Which driver are you trying to install?

2) Which driver was previously installed? And what do you mean when saying "installed by default"

3) What do you want to remove?

Thanks

1) I try to install the 7676 drivers because I have a 7800GTX
2)I had none driver installed, but by default the 7667 is installed.
3) I want to remove nvidia-kernel-common because it says the 7667 is in it, but i'm unsure if I can boot if I remove that.

bagatonovic
August 26th, 2005, 03:54 PM
1) I try to install the 7676 drivers because I have a 7800GTX
2)I had none driver installed, but by default the 7667 is installed.
3) I want to remove nvidia-kernel-common because it says the 7667 is in it, but i'm unsure if I can boot if I remove that.

I am sorry the refresh rate fix didn't work for you. It worked for me. I feel bad for ya because I know what this is like. I remember trying to get my GeForce2 to work on Mandrake 6.x a long time ago, and it was hell.

Tseliot's guide is totally awesome, and it worked for me. Could you humor me and just try the following.
DONT remove any packages with synaptic or Apt-get.
DO the following command: sudo rm /etc/init.d/nvidia-glx
DO install the latest driver downloaded form Nvidia.
Make sure your xorg.conf is setup just like tseliot's guide tells you to with the exception of the refresh rate fix I posted earlier.

I would be interested to see if this works for you.

BTW - I think it's funny when you say xorg.conf is useless because it controls the X settings. Could you please verify the exact location and name of the file you are editing? I am not poking fun, and would sincerely like to help. :)

DancingSun
August 26th, 2005, 04:11 PM
1) I try to install the 7676 drivers because I have a 7800GTX
2)I had none driver installed, but by default the 7667 is installed.
3) I want to remove nvidia-kernel-common because it says the 7667 is in it, but i'm unsure if I can boot if I remove that.
Hmm ... I didn't know 7667 was installed by default. I had to use Synaptic to install my nVidia drivers and those were only 7174. By default, I believe X was using theb built-in nv drivers.

tseliot
August 26th, 2005, 04:51 PM
1) I try to install the 7676 drivers because I have a 7800GTX
2)I had none driver installed, but by default the 7667 is installed.
3) I want to remove nvidia-kernel-common because it says the 7667 is in it, but i'm unsure if I can boot if I remove that.
Neither 7667 nor 7174 is the default driver in Ubuntu Hoary although you can get 7174 in Synaptic. ("nv" is the default open source driver in Ubuntu)

Are you using Breezy?

liquidfire
August 26th, 2005, 04:58 PM
Neither 7667 nor 7174 is the default driver in Ubuntu Hoary although you can get 7174 in Synaptic. ("nv" is the default open source driver in Ubuntu)

Are you using Breezy?
Yes, i am using breezy.
nvidia-kernell-common states that its driver version 7667 :neutral:

tseliot
August 26th, 2005, 05:06 PM
Yes, i am using breezy.
nvidia-kernell-common states that its driver version 7667 :neutral:
Ok, set "vesa" instead of nvidia in your xorg.conf.
Log out and log in
Open Synaptic/Kynaptic and remove anything that has to do with nvidia (you can keep "nvidia-settings" if you installed it before).

Then follow this guide which is for Breezy (and which also works in Hoary with Breezy kernels) (as I recommended to do in this HOWTO)

http://www.ubuntuforums.org/showthread.php?t=52924

and use gcc 3.4 (as it's explained in the guide)

liquidfire
August 26th, 2005, 08:16 PM
Ok, set "vesa" instead of nvidia in your xorg.conf.
Log out and log in
Open Synaptic/Kynaptic and remove anything that has to do with nvidia (you can keep "nvidia-settings" if you installed it before).

Then follow this guide which is for Breezy (and which also works in Hoary with Breezy kernels) (as I recommended to do in this HOWTO)

http://www.ubuntuforums.org/showthread.php?t=52924

and use gcc 3.4 (as it's explained in the guide)
I'm getting new errors now.


nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Aug 26 21:06:02 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : /emul/ia32-linux
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel source path: '/lib/modules/2.6.12-6-amd64-generic/build'
ERROR: You do not appear to have libc header files installed on your system.
Please install your distribution's libc development package.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

tseliot
August 26th, 2005, 09:21 PM
I'm getting new errors now.
Did you install the kernel headers for your kernel version?

If you didn't, you can install it in Synaptic and then try the installer again

liquidfire
August 26th, 2005, 09:44 PM
Did you install the kernel headers for your kernel version?

If you didn't, you can install it in Synaptic and then try the installer again
I did but nevermind i'll wait till we get a more stable version for breezy :)

arnoct
August 26th, 2005, 10:28 PM
Old graphic cards are not supported any more by this driver
Here's a list
RIVA TNT 0x0020
RIVA TNT2/TNT2 Pro 0x0028
RIVA TNT2 Ultra 0x0029
Vanta/Vanta LT 0x002C
RIVA TNT2 Model 64/Model 64 Pro 0x002D
Aladdin TNT2 0x00A0
GeForce 256 0x0100
GeForce DDR 0x0101
Quadro 0x0103
GeForce2 GTS/GeForce2 Pro 0x0150
GeForce2 Ti 0x0151
GeForce2 Ultra 0x0152
Quadro2 Pro 0x0153

My card is not in that list. It's a GeForce2 MX 100/200, which is supported. However, it doesn't matter, since every version I've used in the last six months has had this bug. I can't enable hardware rendering (RenderAccel) because if I do, Xorg freezes. I just want to know if there's a fix/workaround for it yet, or if nvidia is just sitting on their hands with the problem.

DancingSun
August 26th, 2005, 10:39 PM
My card is not in that list. It's a GeForce2 MX 100/200, which is supported. However, it doesn't matter, since every version I've used in the last six months has had this bug. I can't enable hardware rendering (RenderAccel) because if I do, Xorg freezes. I just want to know if there's a fix/workaround for it yet, or if nvidia is just sitting on their hands with the problem.
Please consult the last paragraph of this page (http://www.nvidia.com/object/linux_display_ia64_1.0-5336).

liquidfire
August 27th, 2005, 07:08 PM
Oke breezy just attracted me again.
I'm having new errors :/

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Aug 27 20:05:51 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : /emul/ia32-linux
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
ERROR: Unable to find the development tool `make` in your path; please make
sure that you have the package 'make' installed. If make is installed
on your system, then please check that `make` is in your PATH.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

liquidfire
August 27th, 2005, 07:32 PM
Oke breezy just attracted me again.
I'm having new errors :/

Something is wrong with the forums

PsychoTrauma
August 31st, 2005, 08:46 AM
How would you go about updating the drivers for a new kernel? Would it be as simple as using the nvidia installer with the --uninstall command, then logging in with the new kernel and following the above steps?

tseliot
August 31st, 2005, 10:08 AM
How would you go about updating the drivers for a new kernel? Would it be as simple as using the nvidia installer with the --uninstall command, then logging in with the new kernel and following the above steps?
Just follow the instructions from the beginning. As I wrote you have to set the driver to vesa or nv (if it worked for you) in xorg.

Then you boot in the new kernel and repeat the installation process with the nvidia installer (which will ask you to overwrite the previous installation).

tseliot
August 31st, 2005, 10:12 AM
Oke breezy just attracted me again.
I'm having new errors :/
Open synaptic or kynaptic and make sure you have installed "make" and "makedev" packages.

Then try again.

PsychoTrauma
August 31st, 2005, 06:46 PM
Thank you, I took your advice as well as trying the way I described above and they both worked. I left the settings as "nvidia" though and just did the removal and reinstall after X couldn't start.

AntiKris
September 2nd, 2005, 04:22 PM
Howdy. First off, I'm a complete linux noob, so apologies for asking what would appear to be dumb, basic questions. I've reviewed this and similar posts, and have tried some of the various offered solutions, but nothing seems to work yet. I apologize if the answer I need has already been posted, but so far, I'm still out in the NVIDIA cold, so to speak.

Here's what I'm running: thanks to Tseliot's very helpful HOWTO, I compiled a brand spanking new emt64 smp kernel from 2.6.13 (it was the new release that inspired me to get around to checking out linux). I've got a pentium 830d on a p5wd2 (which is a problematic board, so far, if anyone's thinking of getting one), with a crappy-ass Asus en6200 TC. I compiled my kernel from the 'vanilla' 2.6.13.

So far, trying to install NVIDIA's latest two drivers (7667 and 7676, doesn't matter, same effect), in a word, fails. I'm postulating that this might be because of smp, or the 2.6.13 (instead of .11 or .12), but my rather uneducated guesswork is worth the paper this is printed on. (nobody print this reply out)

I can successfully compile the module, using either NVIDIA's run package, or doing it manually in terminal, but the results are the same: X-server fails to load the graphical environment.

Before anyone asks, I've done all the cancelling out of "Load DRI" and added "nvidia" and the other steps in NVIDIA's readme. That is apparently successful in telling the system to load a driver which, alas, isn't. I'm not expecting wonderful things from my crapply little video card (that's what November is for), but I'd like to load the NVIDIA driver just to prevent the inevitable screen corruption yielded by the default nv driver. Having said that, who wouldn't want Opengl working? I've managed to get my girlfriend hooked on Baldur's Gate (I think that deserves a standing ovation, actually), so when BG2 time comes around, I'd like to have her play that in Ubuntu, rather than Winblows.

Any and all help appreciated. You can even be nasty and derogatory while helping me, as long as you're funny, too. ](*,)

brainspank
September 2nd, 2005, 11:41 PM
was reading the topic and saw the references to gcc 3.3 -> 3.4 and thought I'd add a tip:

when updating symlinks, a simpler command is to use "ln -sf" instead of just "ln -s".

eg.

"ln -sf gcc-3.4 gcc"

instead of

"rm gcc"
"ln -s gcc-3.4 gcc"

it just avoids an "rm" and "f"orces the new symlink, and you don't have to worry if it already exists.

tseliot
September 3rd, 2005, 08:26 PM
Howdy. First off, I'm a complete linux noob, so apologies for asking what would appear to be dumb, basic questions. I've reviewed this and similar posts, and have tried some of the various offered solutions, but nothing seems to work yet. I apologize if the answer I need has already been posted, but so far, I'm still out in the NVIDIA cold, so to speak.

Here's what I'm running: thanks to Tseliot's very helpful HOWTO, I compiled a brand spanking new emt64 smp kernel from 2.6.13 (it was the new release that inspired me to get around to checking out linux). I've got a pentium 830d on a p5wd2 (which is a problematic board, so far, if anyone's thinking of getting one), with a crappy-ass Asus en6200 TC. I compiled my kernel from the 'vanilla' 2.6.13.

So far, trying to install NVIDIA's latest two drivers (7667 and 7676, doesn't matter, same effect), in a word, fails. I'm postulating that this might be because of smp, or the 2.6.13 (instead of .11 or .12), but my rather uneducated guesswork is worth the paper this is printed on. (nobody print this reply out)

I can successfully compile the module, using either NVIDIA's run package, or doing it manually in terminal, but the results are the same: X-server fails to load the graphical environment.

Before anyone asks, I've done all the cancelling out of "Load DRI" and added "nvidia" and the other steps in NVIDIA's readme. That is apparently successful in telling the system to load a driver which, alas, isn't. I'm not expecting wonderful things from my crapply little video card (that's what November is for), but I'd like to load the NVIDIA driver just to prevent the inevitable screen corruption yielded by the default nv driver. Having said that, who wouldn't want Opengl working? I've managed to get my girlfriend hooked on Baldur's Gate (I think that deserves a standing ovation, actually), so when BG2 time comes around, I'd like to have her play that in Ubuntu, rather than Winblows.

Any and all help appreciated. You can even be nasty and derogatory while helping me, as long as you're funny, too. ](*,)
Open either Terminal or Konsole and type:
sudo gedit /etc/X11/xorg.conf (if you use GNOME)

or

sudo kate /etc/X11/xorg.conf (if you use KDE)

and post the file, please.

I have my last exam in 2 days (5 september) and I'm studying really hard. I'll have much more time to help you after the exam (if I pass it).

TakisX
September 3rd, 2005, 09:49 PM
My problem is i have a Sony tft monitor with dvi conection.I can not select resolution bigger of 1024 768 my conf file is
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
# sudo dpkg-reconfigure xserver-xorg

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV20 [GeForce3]"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-72
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV20 [GeForce3]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

the 1280x1024 was put by me ( aforum in Greece says so )

TakisX
September 3rd, 2005, 09:55 PM
My problem is i have a Sony tft monitor with dvi conection.I can not select resolution bigger of 1024 768 my conf file is
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
# sudo dpkg-reconfigure xserver-xorg

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV20 [GeForce3]"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-72
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV20 [GeForce3]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

the 1280x1024 was put by me ( aforum in Greece says so )

tseliot
September 3rd, 2005, 10:18 PM
Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
#Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

First of all look at the red line and set it as in the example

And about the resolution issue:

Find the supported refresh rates (Horizontal and Vertical refresh) in the manual of your monitor. Or find it in google.

and put the rates in these lines in red



Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-72
EndSection


Then log out and log in.

Try to select the resolution you want

DancingSun
September 3rd, 2005, 11:28 PM
It's also possible to have X automatically detect your monitor's supported refresh rates, although this doesn't always work. Just comment out the two refresh rate lines above (put a "#" in front of the lines), and restart the computer (just to be sure). If this doesn't work, you can try entering the refresh rate values manually.

Also, according to the xorg.conf you posted, it seems like you have to have 24-bit color enabled to be able to get 1280x1024. And that resolution is the highest it can go.

TakisX
September 4th, 2005, 10:33 AM
Thanks it worked the trick with # in xorg.conf but the disaster came.
I tried ti install the new drivers and
1 unistalled nvidia-glx
2 clt-alt -f1
3 stoped gdm
4 gave sudo sh nvidia-linux-x86-1.0-7667-pkg1.run and gave an error message about some module in kernel
5 gave /etc/init.d/gdm start and Failed Gnome does not start
reboot xserver does not load
gave sudo xorgconfig followed the steps the same failed
Disaster
Please help
gave sudo apt-get install nvidia-glx to install the old drivers but i cant get Gnome

tseliot
September 4th, 2005, 11:59 AM
Thanks it worked the trick with # in xorg.conf but the disaster came.
I tried ti install the new drivers and
1 unistalled nvidia-glx
2 clt-alt -f1
3 stoped gdm
4 gave sudo sh nvidia-linux-x86-1.0-7667-pkg1.run and gave an error message about some module in kernel
5 gave /etc/init.d/gdm start and Failed Gnome does not start
reboot xserver does not load
gave sudo xorgconfig followed the steps the same failed
Disaster
Please help
gave sudo apt-get install nvidia-glx to install the old drivers but i cant get Gnome
It will boot in the command line.

sudo nano /etc/X11/xorg.conf

and set "nvidia" back to either "nv" or "vesa"

save and exit. Reboot.

If this works (it should) please post the nvidia log file (you can find it under /var/log)

TakisX
September 4th, 2005, 02:43 PM
Nothing worked . I installed Ubuntu again .
What can i do with that error message for kernel ? Recompile the kernel ?

tseliot
September 4th, 2005, 10:34 PM
Nothing worked . I installed Ubuntu again .
What can i do with that error message for kernel ? Recompile the kernel ?
1) which kernel are you using?
if you don't know: open Terminal or Konsole and type "uname -r"

2) try to run the nvidia installer WITHOUT following ANY OTHER thing in my guide:
i.e. Just follow (ONLY) the instructions below


QUOTE:
---------------------------------------------------------------------------------------------------------------------------------
uname -r (this will tell you the name and version of the kernel you are using)

Open either Synaptic or Kynaptic

press the "Search" button and put "header" in the search field

you will see a list of files, find "linux-headers-the name you got from uname -r"

for example if your kernel is "2.6.10-5-386", the headers will be "linux-headers-2.6.10-5-386"

click on the files and select "Mark for installation"

Press the "Apply" button.

You can close Synaptic (or Kynaptic) after it has finished installing the headers.


1) uninstall nvidia-glx (if you don't have it just go to step 2)

2) remove the file manually:
sudo rm /etc/init.d/nvidia-glx

3) sudo apt-get install gcc (just in case)

ctl-alt-f1 (so as to get to the command line)

login with your username and password (if required)

sudo /etc/init.d/gdm stop (or "kdm stop" if you use KDE)

cd “directory where you have the nvidia installer”

If you have Ubuntu 64bit type: **
sudo sh NVIDIA-Linux-x86_64-1.0-7667-pkg2.run

Otherwise if you have Ubuntu 32 bit type:
sudo sh NVIDIA-Linux-x86-1.0-7667-pkg2.run


sudo /etc/init.d/gdm start
--------------------------------------------------------------------------------------------------------------------------------

3) get to /var/log/ and look for "nvidia-installer.log" and post the content of the file.

In this way I will see the complete error output.

DariusTriplet
September 5th, 2005, 05:44 AM
Hey,

I'm running Hoary, and tried to install the newest drivers. I was able to install without a problem, but upon startup, X crashes. I checked the X log, and it stated that it couldn't load the Nvidia kernel modules. The strange part is, according to dmesg, the modules -did- load.

I cannot post dmesg, X log, or the install log at the moment, as I'm posting this via Links. If it's possible to copy/paste the text into here, though, I'll see what I can do about posting those.

Thanks in advance!

tseliot
September 5th, 2005, 09:52 PM
Hey,

I'm running Hoary, and tried to install the newest drivers. I was able to install without a problem, but upon startup, X crashes. I checked the X log, and it stated that it couldn't load the Nvidia kernel modules. The strange part is, according to dmesg, the modules -did- load.

I cannot post dmesg, X log, or the install log at the moment, as I'm posting this via Links. If it's possible to copy/paste the text into here, though, I'll see what I can do about posting those.

Thanks in advance!
1) What's the model of your graphic card?
2) Can you post your /etc/X11/xorg.conf?

DariusTriplet
September 6th, 2005, 12:26 AM
1) What's the model of your graphic card?
2) Can you post your /etc/X11/xorg.conf?

1) Fx5600

2) (All irrelevant information, such as InputDevice, have been removed for this post)

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV31 [GeForce FX 5600]"
Driver "nvidia"
BusID "PCI:2:0:0"
EndSection

muzzie
September 6th, 2005, 06:47 AM
OK... I've got a problem.

I followed your guide (which is excellent, btw), tseliot,and got my nvidia drivers installed and running fine (or so I thought).
I have been using them for the last week or so with no trouble, but I hadn't done any 3d stuff yet.

Today I installed the game Enemy Territory, and it would load, but was very slow. I went ingame and it would play at 15-30fps and all the textures/graphics were very low quality. My machine is a 3000+ Athlon 64 paired with a GeForce 6800 GT, so obviously something was wrong with my software.

I then noticed that my OpenGL screensavers were just black in preview, and would not start when I tried to test them. Finnaly, I ran glxgears and the results are pitiful, 14fps. Yes, 14fps glxgears, on a brand spankin' new system that plays Half Life 2 at 100+ FPS under Winblows.

So, I am thinking something is wrong with my OpenGL drivers. I am very new to Linux, only a week or so, but I'm enjoying it despite all the little problems I've come across.
Normally I'd spend hours crawling around on Google to figure this out, but I see you are a helpful guy who knows this stuff pretty well, so I thought I'd ask...
What the heck is going on? :D

tseliot
September 6th, 2005, 08:58 AM
1) Fx5600

2) (All irrelevant information, such as InputDevice, have been removed for this post)

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV31 [GeForce FX 5600]"
Driver "nvidia"
BusID "PCI:2:0:0"
EndSection
Try point 4 in the problem section of my guide

tseliot
September 6th, 2005, 09:00 AM
OK... I've got a problem.

I followed your guide (which is excellent, btw), tseliot,and got my nvidia drivers installed and running fine (or so I thought).
I have been using them for the last week or so with no trouble, but I hadn't done any 3d stuff yet.

Today I installed the game Enemy Territory, and it would load, but was very slow. I went ingame and it would play at 15-30fps and all the textures/graphics were very low quality. My machine is a 3000+ Athlon 64 paired with a GeForce 6800 GT, so obviously something was wrong with my software.

I then noticed that my OpenGL screensavers were just black in preview, and would not start when I tried to test them. Finnaly, I ran glxgears and the results are pitiful, 14fps. Yes, 14fps glxgears, on a brand spankin' new system that plays Half Life 2 at 100+ FPS under Winblows.

So, I am thinking something is wrong with my OpenGL drivers. I am very new to Linux, only a week or so, but I'm enjoying it despite all the little problems I've come across.
Normally I'd spend hours crawling around on Google to figure this out, but I see you are a helpful guy who knows this stuff pretty well, so I thought I'd ask...
What the heck is going on? :D

Can you post your /etc/X11/xorg.conf?

muzzie
September 6th, 2005, 09:36 AM
Sure, here ya go, attached to this post.

tseliot
September 6th, 2005, 11:23 AM
Sure, here ya go, attached to this post.
Which driver version did you install? (7667, 7676,etc.)

muzzie
September 6th, 2005, 04:41 PM
I installed 7676. I know now that you recommend that folks use 7667 unless they have a 7800, but somehow I didn't remember that when getting the drivers.

Still though, could the 7676 drivers really be causing all the trouble I'm having? If you think that's the case, I could do a driver reinstall I suppose.

tseliot
September 6th, 2005, 08:36 PM
I installed 7676. I know now that you recommend that folks use 7667 unless they have a 7800, but somehow I didn't remember that when getting the drivers.

Still though, could the 7676 drivers really be causing all the trouble I'm having? If you think that's the case, I could do a driver reinstall I suppose.
I think it's worth a try (use 7667).

TakisX
September 6th, 2005, 10:54 PM
Disaster help.
I installed the kernel 2.6.11 with synaptic ,everything ok . Reboot and when goew to Desktop freezes.Reboot the same.Reboot with the old kernel everything ok.

I follow your how to to install nvidia drivers.When i give sudo sh Nvidia ..... it says somethind about a mising modules and compiles it .Everything ok it says.I give sudo /etc/init.d/gdm start and canot load xserver .Black screen.
Reboot in command line. I type sudo gedit /etc/X11/xorg.conf to see what it says
and get

GK-warning ** : cannot open display
every log file i try open the same
Disaster (not install ubuntu again) i cnt get grafical gui .
p.s. how it is posible to install kernrl form synaptic and not working ?

tseliot
September 6th, 2005, 11:02 PM
Disaster help.
I installed the kernel 2.6.11 with synaptic ,everything ok . Reboot and when goew to Desktop freezes.Reboot the same.Reboot with the old kernel everything ok.

I follow your how to to install nvidia drivers.When i give sudo sh Nvidia ..... it says somethind about a mising modules and compiles it .Everything ok it says.I give sudo /etc/init.d/gdm start and canot load xserver .Black screen.
Reboot in command line. I type sudo gedit /etc/X11/xorg.conf to see what it says
and get

GK-warning ** : cannot open display
every log file i try open the same
Disaster (not install ubuntu again) i cnt get grafical gui .
p.s. how it is posible to install kernrl form synaptic and not working ?
It's not a disaster: of course gedit doesn't work when the gui is not running.

Type this instead:

sudo nano /etc/X11/xorg.conf

and set "nvidia" back to "nv" or "vesa"

CTRL+O to overwrite the file
CTRL+X to exit

Then:

sudo /etc/init.d/gdm start

TakisX
September 7th, 2005, 12:24 AM
I did that and xserver started.
I installed with synaptic the nvidia driver and made vesa nvidia to xorg.conf
reboot
and the xserver does not begin
it says module already started


It makes crazy something so simple in win driver instalation to be so dificult
In the nvidia - linux forum so many with the same problem

Why the kernel instalation with synaptic does not work is crazy ?

TakisX
September 7th, 2005, 12:28 AM
I install ubuntu one more time.If ican not setup this OS to work properly good bye Linux .I like the linux idea but is years behind windows in usability ,so sory about it.

Nvidia so big company and no drivers for Linux ,Shame

tseliot
September 7th, 2005, 08:10 AM
I install ubuntu one more time.If ican not setup this OS to work properly good bye Linux .I like the linux idea but is years behind windows in usability ,so sory about it.

Nvidia so big company and no drivers for Linux ,Shame
Calm down. Repeat the step from the command line and set "nvidia" back to "nv".

The driver you can install in synaptic didn't work for me. I use the installer.

Which is you graphic card model?

TakisX
September 7th, 2005, 01:40 PM
But if i change nvidia to nv the resolution is only 1024 768 and refresh rate is 0 ???
My card is Geforce3 (agp) my display Sony tft with dvi

Finally when you install a nvidia driver what is right at xorg.conf ? nvidia vesa nv ?

tseliot
September 7th, 2005, 03:23 PM
But if i change nvidia to nv the resolution is only 1024 768 and refresh rate is 0 ???
My card is Geforce3 (agp) my display Sony tft with dvi

Finally when you install a nvidia driver what is right at xorg.conf ? nvidia vesa nv ?
CTRL+ALT+F1

sudo /etc/init.d/gdm stop

sudo dpkg-reconfigure xserver-xorg

it will ask you several things(if you don't know the answer just press Enter):

Tell it to autodetect the card and then select "nv".

It will ask you (I don't remember when) you desired resolutions:

select the one you need and press the spacebar to enable it (press Enter when you've finished)

When it comes to the refresh rate question select "advanced" and put the values of your monitor (horizontal and vertical refresh)

sudo /etc/init.d/gdm start

I hope it works now

Owdy
September 8th, 2005, 12:08 AM
Trying to update. There arent installer in latest package, just makefile. Make install gives Makefile:17: *** missing separator. Stop.


Other thing, my corg.conf says
Section "Device"
Identifier "NVIDIA Corporation NV15DDR [GeForce2 Ti]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NoLogo"

I have GF 5200 now. That is my old card. Does it matter?

tseliot
September 8th, 2005, 08:09 AM
Trying to update. There arent installer in latest package, just makefile. Make install gives Makefile:17: *** missing separator. Stop.


Other thing, my corg.conf says
Section "Device"
Identifier "NVIDIA Corporation NV15DDR [GeForce2 Ti]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NoLogo"

I have GF 5200 now. That is my old card. Does it matter?
Trying to update from what? From the installer or from synaptic?

Owdy
September 8th, 2005, 08:30 AM
I try to update my driver. I downloaded package from there http://www.nvidia.com/object/unix.html , but those packages dont have installers in it.

And, my corg.conf is outdated. I have differend card now. I have no idea what to put in that.


Section "Device"
Identifier "NVIDIA Corporation NV15DDR [GeForce2 Ti]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NoLogo"

tseliot
September 8th, 2005, 08:56 AM
I try to update my driver. I downloaded package from there http://www.nvidia.com/object/unix.html , but those packages dont have installers in it.

And, my corg.conf is outdated. I have differend card now. I have no idea what to put in that.


Section "Device"
Identifier "NVIDIA Corporation NV15DDR [GeForce2 Ti]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NoLogo"
for example "NVIDIA-Linux-x86-1.0-7676-pkg1.run" IS an installer.

If you want to update the name of your card:
CTRL+ALT+F1

sudo /etc/init.d/gdm stop

sudo dpkg-reconfigure xserver-xorg

it will ask you several things(if you don't know the answer just press Enter):

Tell it to autodetect the card and then select "nvidia".

And so on.

sudo /etc/init.d/gdm start

Owdy
September 8th, 2005, 09:14 AM
There arent any .pkg1.run file in that package: http://download.nvidia.com/freebsd/1.0-7676/NVIDIA-FreeBSD-x86-1.0-7676.tar.gz

tseliot
September 8th, 2005, 09:29 AM
There arent any .pkg1.run file in that package: http://download.nvidia.com/freebsd/1.0-7676/NVIDIA-FreeBSD-x86-1.0-7676.tar.gz
Why are you trying to install the drivers for BSD???
Remember that this is an Ubuntu forum

BSD is not Linux

tseliot
September 8th, 2005, 09:30 AM
select "Linux IA32" in this page http://www.nvidia.com/object/unix.html

Owdy
September 8th, 2005, 09:35 AM
LOL. I shoyuld learn how to read. Sorry. Ill try with that :D

tseliot
September 8th, 2005, 09:47 AM
LOL. I shoyuld learn how to read. Sorry. Ill try with that :D
No problem :)

Owdy
September 8th, 2005, 10:48 AM
Yes, worked.

Now i have this:

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "UseFBDev" "true"
Option "NoLogo"

That driver part was 'nv' after reinstall, changed that to 'nvidia'. What is that UseFBDev part, it wasnt there before?

tseliot
September 8th, 2005, 11:25 AM
Yes, worked.

Now i have this:

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "UseFBDev" "true"
Option "NoLogo"

That driver part was 'nv' after reinstall, changed that to 'nvidia'. What is that UseFBDev part, it wasnt there before?
I have no idea, I had never noticed it (and I can't check it on my computer because I don't have it now).

However if it works properly don't you worry... :)

vayu
September 8th, 2005, 06:43 PM
After a bit of struggling I finally got the driver to compile and install succesfully. Yay!

But now whenever I try to run anything OpenGL I get a segmentation error. Even glxinfo gives me the error. I have an eVGA GeForce 6200 (AGP). I have my xorg.conf set the way you describe. I used the 7667 driver. I unistalled nvidia-glx first. I don't know where to go from here.

tseliot
September 8th, 2005, 06:56 PM
After a bit of struggling I finally got the driver to compile and install succesfully. Yay!

But now whenever I try to run anything OpenGL I get a segmentation error. Even glxinfo gives me the error. I have an eVGA GeForce 6200 (AGP). I have my xorg.conf set the way you describe. I used the 7667 driver. I unistalled nvidia-glx first. I don't know where to go from here.
Look at point 4 in the Problems section of my guide

Cinjun
September 9th, 2005, 12:33 AM
Super HOWTO tseliot, no problems whatsoever, Worked like a charm. Thanks again. :)

wmaddler
September 9th, 2005, 02:39 AM
Very useful.
It worked (breezy C4 on AMD64). Everything went fine, but I had to (discover ](*,) and) remove /usr/X11R6/lib/modules/extensions/libglx.a which prevented glx extension to properly work.

The file is provided by xerver-core, so it will have to be removed every time you update dat package.

Best regards...

vayu
September 9th, 2005, 03:42 AM
Where can I look up the "Option" values in xorg.conf (under device)?

tseliot
September 9th, 2005, 09:22 AM
Where can I look up the "Option" values in xorg.conf (under device)?
If you want to add them follow the example:

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NvAGP" "0"
Option "RenderAccel" "Off"
Option "IgnoreDisplayDevices" "DFP,TV"
Option "NoRenderExtension" "Off"
Option "Accel" "Off"
Option "AllowGLXWithComposite" “Off”

Usually there are no options set by default

tseliot
September 9th, 2005, 09:24 AM
Very useful.
It worked (breezy C4 on AMD64). Everything went fine, but I had to (discover ](*,) and) remove /usr/X11R6/lib/modules/extensions/libglx.a which prevented glx extension to properly work.

The file is provided by xerver-core, so it will have to be removed every time you update dat package.

Best regards...
thanks for the tip

TakisX
September 9th, 2005, 08:36 PM
I compiled the new driver. HERE is a part of my log file .A lot of warnings. Do you see something wrong ?

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Sep 9 22:20:09 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
7667). As part of installing this driver (version: 1.0-7667), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel source path: '/lib/modules/2.6.13-maria/source'
-> Performing CC test with CC="cc".
-> Performing rivafb check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
agp.o os-interface.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.13-maria/so
urce SYSOUT=/lib/modules/2.6.13-maria/build'...

NVIDIA: calling KBUILD...
make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.13-maria/build KBUILD_VERBOSE=1 -C
/lib/modules/2.6.13-maria/source SUBDIRS=/tmp/selfgz7853/NVIDIA-Linux-x86-1.
0-7667-pkg1/usr/src/nv modules
make -C /lib/modules/2.6.13-maria/build \


-> done.
-> Kernel module compilation complete.
-> Installing both new and classic TLS OpenGL libraries.
-> Parsing log file:
-> done.
-> Validating previous installation:
-> Unable to access previously installed file
'/usr/X11R6/lib/modules/drivers/nvidia_drv.o' (No such file or directory).
-> Unable to access previously installed file '/usr/X11R6/lib/libXvMCNVIDIA.a'
(No such file or directory).
-> Unable to access previously installed file '/usr/bin/nvidia-settings' (No
such file or directory).
-> Unable to access previously installed file '/usr/bin/nvidia-bug-report.sh'
(No such file or directory).
-> Unable to access previously installed file
'/lib/modules/2.6.10-5-386/kernel/drivers/video/nvidia.ko' (No such file or
directory).
-> Unable to access previously installed file '/usr/lib/libGL.la' (No such file
or directory).
-> Unable to access previously installed symlink
'/usr/X11R6/lib/modules/extensions/libglx.so' (No such file or directory).
-> done.
WARNING: Your driver installation has been altered since it was initially
installed; this may happen, for example, if you have since installed
the NVIDIA driver through a mechanism other than the nvidia-installer
(such as rpm or with the NVIDIA tarballs). The nvidia-installer will
attempt to uninstall as best it can. Please see the file
'/var/log/nvidia-installer.log' for details.
-> Uninstalling NVIDIA Accelerated Graphics Driver for Linux-x86 (1.0-7667):
-> Unable to restore symbolic link /usr/X11R6/lib/nvidia/libGL.so.1.xlibmesa ->
libGL.so.1.2 (No such file or directory).
ERROR: Unable to create '/usr/X11R6/lib/nvidia/libGL.so.1.2.xlibmesa' for
copying (No such file or directory)
WARNING: Unable to restore file '/usr/X11R6/lib/nvidia/libGL.so.1.2.xlibmesa'.
ERROR: Unable to create '/usr/X11R6/lib/nvidia/libGLcore.a.xlibmesa' for
copying (No such file or directory)
WARNING: Unable to restore file '/usr/X11R6/lib/nvidia/libGLcore.a.xlibmesa'.
ERROR: Unable to create '/usr/X11R6/lib/nvidia/libglx.a.xlibmesa' for copying
(No such file or directory)
WARNING: Unable to restore file '/usr/X11R6/lib/nvidia/libglx.a.xlibmesa'.
-> Unable to restore symbolic link /usr/lib/nvidia/libGL.so.1.xlibmesa ->
libGL.so.1.2 (No such file or directory).
-> Unable to restore symbolic link /usr/lib/nvidia/libGL.so.1.2.xlibmesa ->
../X11R6/lib/libGL.so.1.2 (No such file or directory).
ERROR: Unable to create '/usr/lib/nvidia/libnvidia-tls.so.1.0.7174' for copying
(No such file or directory)
WARNING: Unable to restore file '/usr/lib/nvidia/libnvidia-tls.so.1.0.7174'.
-> done.
-> Uninstallation of existing driver: NVIDIA Accelerated Graphics Driver for
Linux-x86 (1.0-7667) is complete.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-7667):
executing: '/sbin/ldconfig'...
executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Post-install sanity check passed.
-> Shared memory test passed.
-> Running runtime sanity check:
-> done.
-> Runtime sanity check passed.
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 1.0-7667) is now complete. Please update your XF86Config or
xorg.conf file as appropriate; see the file
/usr/share/doc/NVIDIA_GLX-1.0/README.txt for details.

tseliot
September 9th, 2005, 09:20 PM
Does the driver work?

By the way try to type this in the command line:

sudo ln -s /usr/X11R6/lib/nvidia/libGL.so.1.xlibmesa libGL.so.1.2

vayu
September 10th, 2005, 06:40 AM
If you want to add them follow the example:

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NvAGP" "0"
Option "RenderAccel" "Off"
Option "IgnoreDisplayDevices" "DFP,TV"
Option "NoRenderExtension" "Off"
Option "Accel" "Off"
Option "AllowGLXWithComposite" “Off”

Usually there are no options set by default
I mean where do you find out about those options? Which ones are available, what they do, etc....

Resin
September 10th, 2005, 06:53 AM
Thanks buddy, this thread is wicked. Its the first one I've found that actually worked! :grin:

tseliot
September 10th, 2005, 08:44 AM
I mean where do you find out about those options? Which ones are available, what they do, etc....
As I said before there are no options set by default.

The options are useful if you have any problems with the driver.

Some of them disable 3d acceleration.

However if you want to know something more about them you can ask at this forum (maybe the developers themselves will answer you)

http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

P.S. if you don't have any problems, please don't mess with them

tseliot
September 10th, 2005, 08:46 AM
Thanks buddy, this thread is wicked. Its the first one I've found that actually worked! :grin:
Thanks, I'm happy for you :)

TakisX
September 10th, 2005, 03:44 PM
This driver is mystery to me.
I downloaded installed with your how to.If i put nvidia and not nv in xorg.conf the system dont reboot .If iput nv ok .I recompiled the original kernel , the new kernel 2.6.13 , i tried everything.

I read this forum the nvidia forum nothing works .
Why ?

tseliot
September 10th, 2005, 06:15 PM
This driver is mystery to me.
I downloaded installed with your how to.If i put nvidia and not nv in xorg.conf the system dont reboot .If iput nv ok .I recompiled the original kernel , the new kernel 2.6.13 , i tried everything.

I read this forum the nvidia forum nothing works .
Why ?
Try to add the red lines to your xorg.conf:

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NvAGP" "0"
Option "RenderAccel" "Off"
Option "IgnoreDisplayDevices" "DFP,TV"
Option "NoRenderExtension" "Off"
Option "AllowGLXWithComposite" “Off”

Log oout and login

busboy.ca
September 10th, 2005, 06:37 PM
Thanks Alberto. Molto bene bello. :)

tseliot
September 10th, 2005, 06:39 PM
Thanks Alberto. Molto bene bello. :)
Grazie a te :)

TakisX
September 10th, 2005, 11:00 PM
If i put the lines you say freezes even i put nv in xorg.conf
At the other forum a lot of people ungry with nvidia because the drivers dont work
The last driver they say is 6629 that worked ok

Why a big firm like nvidia does not fix it ?

tseliot
September 10th, 2005, 11:41 PM
If i put the lines you say freezes even i put nv in xorg.conf
At the other forum a lot of people ungry with nvidia because the drivers dont work
The last driver they say is 6629 that worked ok

Why a big firm like nvidia does not fix it ?
Because they focus more on Windows drivers than on Linux ones. And Games are developed for Windows.

By the way you could give Breezy (stable) a shot (13th october) as it has 7667 nvidia driver modules available in the repositories. Please try to be patient until then (I understand your frustration though).

TheTK421
September 11th, 2005, 01:15 AM
Well add me to the list of failures when trying to install these drivers. Right after I installed them I rebooted X, got the Nvidia screen, then it dumped me out to command line. I was able to uninstall the "glx" package, then restore from a copy of xorg.conf I kept for situations like this. It will only boot into GDM if I am root, and even then it I have about a 1-in-a-hundred chance of it working, or it will just boot to the gray screen with the "x" for the mouse pointer until I restart the computer. Recently I have been getting a blue screen with an error box asking me if I wish to look at the Xorg.0.log file to see if I can fix the problem, but it looks fine. I haven't had the courage to reboot my system for a few days now and I don't plan on ever rebooting it.
Is there anyway to fix this? I finally went through the horrible process of getting KDE installed, just so I could never use it. I can post a copy of my xorg.conf and the backup I have used if it would help.

I have searched the nVidia forums to no avail. I would love to keep using Ubuntu, but I never had these problems with SuSE or any other distro I have used.

tseliot
September 11th, 2005, 09:47 AM
I can post a copy of my xorg.conf and the backup I have used if it would help.
Please post them.

And did the driver compile?

muzzie
September 11th, 2005, 08:52 PM
Hey Tseilot,

You might remember a couple pages back I was having trouble with OpenGL. glxgears was getting 14fps and my games weren't rendering properly at all.
You suggested I downgrade from 7676 to 7667 and I have just now finnaly got around to doing that, and, voila! It works great now. Glxgears is giving 12,000+ and I am getting a solid 90fps (locked there) in Enemy Territory with all details at max @ 1024x768.

I thought the process was going to be a pain, but I simply just downloaded the 7667 drivers, stopped X and did a sh "NVIDA-blablablaDrivers" and the whole process was automated. Uninstalled 7676 and put 7667 in. I don't know if that's the safest way to go about it, but no problems so far!

Thanks!

tseliot
September 11th, 2005, 08:57 PM
Hey Tseilot,

You might remember a couple pages back I was having trouble with OpenGL. glxgears was getting 14fps and my games weren't rendering properly at all.
You suggested I downgrade from 7676 to 7667 and I have just now finnaly got around to doing that, and, voila! It works great now. Glxgears is giving 12,000+ and I am getting a solid 90fps (locked there) in Enemy Territory with all details at max @ 1024x768.

I thought the process was going to be a pain, but I simply just downloaded the 7667 drivers, stopped X and did a sh "NVIDA-blablablaDrivers" and the whole process was automated. Uninstalled 7676 and put 7667 in. I don't know if that's the safest way to go about it, but no problems so far!

Thanks!
Of course I remember of you ;-) . Well, let's say there's a reason if I discourage users from installing 7676. The way you installed the new driver is right (so don't you worry).

I'm very happy for you! :)

Zillion
September 11th, 2005, 10:34 PM
.. in my case "nv" drivers= screen corruption, nvidia drivers (the ones you can install following Ubuntu Starter Guide) =black screen, no Xorg...

could you plz explain me (=noob) how to get the display driver working after installing Ubuntu (Hoary). At the moment Xserver should start I get black screen, though I can get in the shell with ctrl alt f1.
I have MSI Neo4 Nforce4 Platinum board with Nvidia 6800gt vga

tx

edit -> forget it, I changed in xorg.conf driver from NV to Vesa, and now I have visuals :)

23meg
September 13th, 2005, 05:28 PM
i've just got a new computer with a nvidia geforce go6200 chip. i've done everything exactly as specified in this thread, yet i'm still getting the dreaded blackout. and with ubuntu's "nv" driver x does start, but gnome hangs on startup (it plays the startup sound after login, the mouse pointer works, but no splash, no desktop, nothing, just a brown screen).

in short i just can't run ubuntu any more! the device and module sections of my xorg.conf are exactly the same as those on tseliot's first post. i'm trying with the 7667 driver + stock hoary kernel, and there were no errors in the driver installation.

any help appreciated.

](*,) ](*,) ](*,)

tseliot
September 13th, 2005, 06:30 PM
i've just got a new computer with a nvidia geforce go6200 chip. i've done everything exactly as specified in this thread, yet i'm still getting the dreaded blackout. and with ubuntu's "nv" driver x does start, but gnome hangs on startup (it plays the startup sound after login, the mouse pointer works, but no splash, no desktop, nothing, just a brown screen).

in short i just can't run ubuntu any more! the device and module sections of my xorg.conf are exactly the same as those on tseliot's first post. i'm trying with the 7667 driver + stock hoary kernel, and there were no errors in the driver installation.

any help appreciated.

](*,) ](*,) ](*,)
I'm afraid I can't help you with that card. However I can recommend you to make a search in the nvidia forum (you can follow the link at the end of the 1st page of my guide) or start a new thread in there and ask for help. The (nvidia) developers of the drivers can help you in there.

TheTK421
September 14th, 2005, 01:53 AM
Sorry it took me so long to get back to you with the file (working on my C++)

Here is the backup and current xorg.conf file I am using.

If there is anything else you need please ask, I would love to have 3d support.

linkunderscore
September 14th, 2005, 06:34 AM
I used this guide to help me install my nvidia drivers about 3 weeks ago. Worked great.

After this last Ubuntu Update, my system wouldn't start X. I would get the nvidia splash then it would crash into commandline. After some digging I found that the update required me to manually change "Keyboard" to "kbd" and "nvidia" to "nv" in order to startX.

I was wondering...If i re-install these drivers again(following the same instructions), would it b0rk on start up again?

I'd leave it "nv" except I can't play UT2004 or any game for that matter.

tseliot
September 14th, 2005, 08:16 AM
I used this guide to help me install my nvidia drivers about 3 weeks ago. Worked great.

After this last Ubuntu Update, my system wouldn't start X. I would get the nvidia splash then it would crash into commandline. After some digging I found that the update required me to manually change "Keyboard" to "kbd" and "nvidia" to "nv" in order to startX.

I was wondering...If i re-install these drivers again(following the same instructions), would it b0rk on start up again?

I'd leave it "nv" except I can't play UT2004 or any game for that matter.
Follow my guide again and reinstall the drivers, it will work (probably the update upgraded your kernel)

tseliot
September 14th, 2005, 08:24 AM
Sorry it took me so long to get back to you with the file (working on my C++)

Here is the backup and current xorg.conf file I am using.

If there is anything else you need please ask, I would love to have 3d support.
Follow my guide again and add the lines in red to your xorg.conf (see the example below)

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NvAGP" "0"
Option "RenderAccel" "Off"

If this doesn't work you can try to add the other lines as shown in point 4 of the problems section of my guide.

Tell me if it works

draugen
September 14th, 2005, 09:00 AM
just a quick note on the 32bit compatibility libraries for x86_64: you can install them with this hack:



sudo mkdir /emul/ia32-linux/usr/
sudo ln -s /usr/lib32 /emul/ia32-linux/usr/lib


if /usr/lib32 does not exist, you need to do this


sudo apt-get install ia32-libs lib32gcc1 lib32stdc++6

without which the opengl compat libs probably won't be much use anyway :)

there are more 32bit libs as well. check synaptic :)


--martin

edited for clarity :)

tseliot
September 14th, 2005, 09:04 AM
just a quick note on the 32bit compatibility libraries for x86_64: you can install them with this hack:



sudo mkdir /emul/ia32-linux/usr/
sudo ln -s /usr/lib32 /emul/ia32-linux/usr/lib


if /usr/lib32 does not exist, you need to do this


sudo apt-get install ia32-libs lib32gcc1 lib32stdc++6

without which the opengl compat libs probably won't be much use anyway :)

there are more 32bit libs as well. check synaptic :)


--martin

edited for clarity :)

I can't try it (I'm running Ubuntu 32bit in this period) but I can add it to my guide later (I'm studying for an exam).

Thanks for the tip!

draugen
September 14th, 2005, 09:39 AM
I can't try it (I'm running Ubuntu 32bit in this period) but I can add it to my guide later (I'm studying for an exam).

Thanks for the tip!
happy to help!

oh... one thing. you probably need to break up the mkdir command:


sudo mkdir /emul
sudo mkdir /emul/ia32-linux
sudo mkdir /emul/ia32-linux/usr

23meg
September 14th, 2005, 01:27 PM
i've tried again, this time with the 2.6.11 kernel, and i can now get the driver running only with the "Accel" "Off" option, but window moving and resizing are horribly, unusably slow.

after months of low 2d performance from an ATI card, i specially looked for a laptop with a NVIDIA chip and bought one, and now look what i got in my hands...

anyone having these issues with the 2.6.12 kernel? i can't properly set it up now since ubuntu doesn't recognize my new ethernet adapter either and i can't connect to the net with my laptop...

](*,) ](*,) ](*,)

tseliot
September 14th, 2005, 01:43 PM
i've tried again, this time with the 2.6.11 kernel, and i can now get the driver running only with the "Accel" "Off" option, but window moving and resizing are horribly, unusably slow.

after months of low 2d performance from an ATI card, i specially looked for a laptop with a NVIDIA chip and bought one, and now look what i got in my hands...

anyone having these issues with the 2.6.12 kernel? i can't properly set it up now since ubuntu doesn't recognize my new ethernet adapter either and i can't connect to the net with my laptop...

](*,) ](*,) ](*,)
Use kernel 2.6.11 and try this:

1) Delete the "Accel" "Off" option

2) add the lines in red to your xorg.conf

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NvAGP" "0"
Option "RenderAccel" "Off"
Option "IgnoreDisplayDevices" "DFP,TV"
Option "NoRenderExtension" "Off"
Option "AllowGLXWithComposite" “Off”

In this way the acceleration should work.

Tell me if it works

tseliot
September 14th, 2005, 01:52 PM
Of course everytime you change your kernel you have to reinstall the nvidia drivers

23meg
September 14th, 2005, 02:29 PM
i've tried that, it doesn't work. the only way to get past the splash screen is to use "Accel" "Off" or use the vesa driver. in both cases i get 16bit color depth, and low 2d performance, plus my laptop's native resolution of 1400x1050 is unavailable in vesa. in short, all is bad.

i also tried the latest 7676 driver, and it just totally crashes x.

i'm now downloading the breezy preview at an internet cafe to see if the 2.6.12 kernel plays well with my go6200 chip... i'm that desperate.



](*,) ](*,) ](*,)

tseliot
September 14th, 2005, 03:10 PM
i've tried that, it doesn't work. the only way to get past the splash screen is to use "Accel" "Off" or use the vesa driver. in both cases i get 16bit color depth, and low 2d performance, plus my laptop's native resolution of 1400x1050 is unavailable in vesa. in short, all is bad.

i also tried the latest 7676 driver, and it just totally crashes x.

i'm now downloading the breezy preview at an internet cafe to see if the 2.6.12 kernel plays well with my go6200 chip... i'm that desperate.



](*,) ](*,) ](*,)
I don't think Breezy can solve your problem. It's a matter of hardware compatibility. Please ask for help (register there and start a new thread) at the nvidia forum (at the Linux section). Only the developers can help you and you might also find other users who have the same problem (they might have solved the problem).

I can't help you as there are some problems with Geforce Go in Linux (and I don't have such a graphic card)

23meg
September 14th, 2005, 04:40 PM
my only reason for trying breezy is the 2.6.12 kernel, since i have no way of installing it on top of hoary right now. the driver is very "kernel sensitive" so it may "play better" with the newer kernel. plus almost half of all hardware on my Tecra M4 isn't detected by hoary, so i'm hoping the newer kernel will provide better hardware support as well.

if all fails i may have to abandon ubuntu altogether (i can't believe i'm saying this! :-# )... or replace my laptop (i don't want to do that either)...

btw, i've posted on the nvnews forum as well. i hope the folks there come up with something.

](*,)

tseliot
September 14th, 2005, 05:43 PM
my only reason for trying breezy is the 2.6.12 kernel, since i have no way of installing it on top of hoary right now. the driver is very "kernel sensitive" so it may "play better" with the newer kernel. plus almost half of all hardware on my Tecra M4 isn't detected by hoary, so i'm hoping the newer kernel will provide better hardware support as well.

if all fails i may have to abandon ubuntu altogether (i can't believe i'm saying this! :-# )... or replace my laptop (i don't want to do that either)...

btw, i've posted on the nvnews forum as well. i hope the folks there come up with something.

](*,)
If you add Breezy repositories you can install kernel image header and source (2.6.12-8) in Synaptic.

Then restart your computer and try again. (remember to delete the new repos after the process)

23meg
September 14th, 2005, 07:38 PM
If you add Breezy repositories you can install kernel image header and source (2.6.12-8) in Synaptic.

Then restart your computer and try again. (remember to delete the new repos after the process)

i know, but i can't do that, since Hoary doesn't recognize my new laptop's Marvell/Yukon ethernet adapter and i can't connect to the net using Ubuntu, and grabbing the 2.6.12 kernel + headers from packages.ubuntu.com with all their dependencies one by one is a royal pain.

i'm now installing Breezy on the laptop. i'll post back and report how things went.

TakisX
September 14th, 2005, 10:27 PM
The nvidia driver is just a broken thing .
Another try ( 1000000 times )
here what i get
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Sep 15 00:20:50 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
7667). As part of installing this driver (version: 1.0-6629), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel source path: '/lib/modules/2.6.13.1-dyo/source'
-> Performing CC test with CC="cc".
-> Performing rivafb check.
-> Performing rivafb module check.
WARNING: Your kernel was configured to include rivafb support as
a loadable kernel module.

The rivafb driver conflicts with the NVIDIA driver; the
NVIDIA kernel module will still be built and installed,
but be aware that the NVIDIA driver will not be able to
function properly if the rivafb module is loaded!
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
agp.o os-interface.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.13.1-dyo/so
urce SYSOUT=/lib/modules/2.6.13.1-dyo/build'...
Your kernel was configured to include rivafb support as
a loadable kernel module.

The rivafb driver conflicts with the NVIDIA driver; the
NVIDIA kernel module will still be built and installed,
but be aware that the NVIDIA driver will not be able to
function properly if the rivafb module is loaded!

*** Failed rivafb module sanity check, but continuing! ***


NVIDIA: calling KBUILD...
make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.13.1-dyo/build KBUILD_VERBOSE=1 -C
/lib/modules/2.6.13.1-dyo/source SUBDIRS=/tmp/selfgz12491/NVIDIA-Linux-x86-1
.0-6629-pkg1/usr/src/nv modules
make -C /lib/modules/2.6.13.1-dyo/build \
KBUILD_SRC=/usr/src/linux-2.6.13.1 KBUILD_VERBOSE=1 \
KBUILD_CHECK= KBUILD_EXTMOD="/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1
/usr/src/nv" \
-f /usr/src/linux-2.6.13.1/Makefile modules
mkdir -p /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.tmp_ver
sions
make -f /usr/src/linux-2.6.13.1/scripts/Makefile.build obj=/tmp/selfgz12491/
NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /tmp/selfgz12491/NV
IDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv_compiler.h
cc -Wp,-MD,/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.nv.
o.d -nostdinc -isystem /usr/lib/gcc-lib/i486-linux/3.3.5/include -D__KERNEL
__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.13.1/include -I/tmp/selfgz1249
1/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wstrict-prototypes -Wno-t
rigraphs -fno-strict-aliasing -fno-common -ffreestanding -Os -fomit-frame-po
inter -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i686 -I/usr/src
/linux-2.6.13.1/include/asm-i386/mach-default -Iinclude/asm-i386/mach-defaul
t -I/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wimpl
icit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpoint
er-arith -Wno-multichar -Werror -O -fno-common -MD -Wno-cast-qual -Wno-error
-D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -D_GNU_SOURCE -D_LOOSE_KE
RNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MI
NOR_VERSION=0 -DNV_PATCHLEVEL=6629 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCP
U_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHANGE_PAG
E_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_PCI_GET_CLASS_PRESENT -D
MODULE -DKBUILD_BASENAME=nv -DKBUILD_MODNAME=nvidia -c -o /tmp/selfgz12491/N
VIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.tmp_nv.o /tmp/selfgz12491/NVIDIA-L
inux-x86-1.0-6629-pkg1/usr/src/nv/nv.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-linux.h:52,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arith
metic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:870,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-linux.h:75,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv.c:14:
include/asm/io.h: In function `check_signature':
include/asm/io.h:253: warning: wrong type argument to increment
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c: In function
`nvidia_init_module':
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:930: warning
: `pm_register' is deprecated (declared at include/linux/pm.h:107)
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c: In function
`nvidia_exit_module':
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:1051: warnin
g: `pm_unregister' is deprecated (declared at include/linux/pm.h:112)
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c: In function
`_get_phys_address':
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:2509: warnin
g: passing arg 1 of `pmd_offset' from incompatible pointer type
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c: In function
`nv_agp_init':
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:2991: warnin
g: implicit declaration of function `inter_module_get'
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:2992: warnin
g: `inter_module_put' is deprecated (declared at include/linux/module.h:573)
cc -Wp,-MD,/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.nv-
vm.o.d -nostdinc -isystem /usr/lib/gcc-lib/i486-linux/3.3.5/include -D__KER
NEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.13.1/include -I/tmp/selfgz1
2491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wstrict-prototypes -Wn
o-trigraphs -fno-strict-aliasing -fno-common -ffreestanding -Os -fomit-frame
-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i686 -I/usr/
src/linux-2.6.13.1/include/asm-i386/mach-default -Iinclude/asm-i386/mach-def
ault -I/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/
src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -W
parentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD -Wno-c
ast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -D_GN
U_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -D
NV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6629 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -
DNVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHANG
E_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_PCI_GET_CLASS_PRESE
NT -DMODULE -DKBUILD_BASENAME=nv_vm -DKBUILD_MODNAME=nvidia -c -o /tmp/selfg
z12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.tmp_nv-vm.o /tmp/selfgz124
91/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv-vm.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-linux.h:52,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-vm.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arith
metic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:870,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-linux.h:75,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-vm.c:14:
include/asm/io.h: In function `check_signature':
include/asm/io.h:253: warning: wrong type argument to increment
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv-vm.c: At top l
evel:
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv-vm.c:59: warni
ng: `cache_flush' defined but not used
cc -Wp,-MD,/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.os-
agp.o.d -nostdinc -isystem /usr/lib/gcc-lib/i486-linux/3.3.5/include -D__KE
RNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.13.1/include -I/tmp/selfgz
12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wstrict-prototypes -W
no-trigraphs -fno-strict-aliasing -fno-common -ffreestanding -Os -fomit-fram
e-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i686 -I/usr
/src/linux-2.6.13.1/include/asm-i386/mach-default -Iinclude/asm-i386/mach-de
fault -I/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -W
implicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wp
ointer-arith -Wno-multichar -Werror -O -fno-common -MD -Wno-cast-qual -Wno-e
rror -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -D_GNU_SOURCE -D_LOO
SE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSIO
N=0 -DNV_PATCHLEVEL=6629 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -UDE
BUG -U_DEBUG -DNDEBUG -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHANGE_PAGE_ATTR_PRE
SENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_PCI_GET_CLASS_PRESENT -DMODULE -DK
BUILD_BASENAME=os_agp -DKBUILD_M
ODNAME=nvidia -c -o /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/
nv/.tmp_os-agp.o /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/
os-agp.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-linux.h:52,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/os-agp.c:24:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arith
metic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:870,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-linux.h:75,
from /tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/os-agp.c:24:
include/asm/io.h: In function `check_signature':
include/asm/io.h:253: warning: wrong type argument to increment
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c: At top
level:
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:48: erro
r: syntax error before '*' token
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:48: warn
ing: type defaults to `int' in declaration of `drm_agp_p'
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:48: warn
ing: data definition has no type or storage class
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c: In func
tion `KernInitAGP':
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:76: warn
ing: assignment discards qualifiers from pointer target type
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:85: erro
r: request for member `acquire' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:88: warn
ing: `inter_module_put' is deprecated (declared at include/linux/module.h:57
3)
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:113: err
or: request for member `copy_info' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:173: err
or: request for member `enable' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:185: err
or: request for member `release' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:186: war
ning: `inter_module_put' is deprecated (declared at include/linux/module.h:5
73)
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c: In func
tion `KernTeardownAGP':
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:216: err
or: request for member `release' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:218: war
ning: `inter_module_put' is deprecated (declared at include/linux/module.h:5
73)
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c: In func
tion `KernAllocAGPPages':
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:265: err
or: request for member `allocate_memory' in something not a structure or uni
on
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:273: err
or: request for member `bind_memory' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:290: err
or: request for member `unbind_memory' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:305: err
or: request for member `free_memory' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c: In func
tion `KernMapAGPPages':
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:345: err
or: request for member `unbind_memory' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c: In func
tion `KernFreeAGPPages':
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:444: err
or: request for member `unbind_memory' in something not a structure or union
/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c:445: err
or: request for member `free_memory' in something not a structure or union
make[4]: *** [/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-
agp.o] Error 1
make[3]: *** [_module_/tmp/selfgz12491/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv] Error 2
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

23meg
September 14th, 2005, 10:43 PM
hell, i tried with a fresh install of Breezy, and it W O R K S !

everyone having trouble with 2.6.1x kernels: if all fails, try Breezy, or get the 2.6.12-8 kernel and follow tseliot's other guide for setting the drivers for use with the Breezy kernel.

2d performance is remarkably better than the vesa driver, and when it comes to 3d all i can say is that glxgears shows 4000-something fps. can you suggest a more reliable way to make sure 3d acceleration is working?

tseliot
September 14th, 2005, 11:20 PM
hell, i tried with a fresh install of Breezy, and it W O R K S !

everyone having trouble with 2.6.1x kernels: if all fails, try Breezy, or get the 2.6.12-8 kernel and follow tseliot's other guide for setting the drivers for use with the Breezy kernel.

2d performance is remarkably better than the vesa driver, and when it comes to 3d all i can say is that glxgears shows 4000-something fps. can you suggest a more reliable way to make sure 3d acceleration is working?
I'm happy for you and I really don't know why it works. I'm happy to be wrong though ;-)

tseliot
September 14th, 2005, 11:26 PM
for TakisX:

It's not a problem related to the driver this time. What kernel is yours? Did you compile it?

The kernel has the nvidia Framebuffer module enabled and this won't make the driver work. You have to compile a new one (with that module disabled) OR You can try a Breezy kernel if you need kernel 2.6.12. It should work (install kernel image, source and headers) and Look at the problems section as the installer will complain about GCC.

linkunderscore
September 15th, 2005, 02:57 AM
Follow my guide again and reinstall the drivers, it will work (probably the update upgraded your kernel)

It did. I love you :heart:

TakisX
September 15th, 2005, 12:35 PM
It drives me crazy. I installed Ubuntu 5.10 .In synartic i see i have installed 7667 driver but it does not work .Why ?its so crazy. If i put nvidia or nv in xorg file it crushes.

What to do ? I want to have 1280x1024 and i have only 1024x768

If i put glxgears

takisx@nisaki:~$ glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
takisx@nisaki:~$
what is the problem ? the kernel is the original

Please help

TakisX
September 15th, 2005, 12:38 PM
Here is my xorg.conf file

Section "Module"
Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV20 [GeForce3]"
Driver "vesa"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-64
VertRefresh 60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV20 [GeForce3]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "2048x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "2048x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

tseliot
September 15th, 2005, 01:31 PM
It drives me crazy. I installed Ubuntu 5.10 .In synartic i see i have installed 7667 driver but it does not work .Why ?its so crazy. If i put nvidia or nv in xorg file it crushes.

What to do ? I want to have 1280x1024 and i have only 1024x768

If i put glxgears

takisx@nisaki:~$ glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
takisx@nisaki:~$
what is the problem ? the kernel is the original

Please help
I understand your frustration. Uninstall nvidia drivers from synaptic and follow my guide again (every step).
Then if the installer complains about gcc, please see the problem section of my guide. If the installer doesn't work, please post the nvidia log file under /var/log/

TakisX
September 15th, 2005, 09:44 PM
I updated drivers with synaptic and reboot and crashes .I cant get xserver start even if i put vesa or nv or nvidia in xorg file.
Format and new of instalation of 5.04
So bad expirience with linux .i cant even my desktop look ok , and i have so typical ,comon hardware .

tseliot
September 15th, 2005, 10:09 PM
I updated drivers with synaptic and reboot and crashes .I cant get xserver start even if i put vesa or nv or nvidia in xorg file.
Format and new of instalation of 5.04
So bad expirience with linux .i cant even my desktop look ok , and i have so typical ,comon hardware .
Maybe I asked you before but I don't remember (I'm studying too hard and my brain is not ok) what is your graphic card model.

merlyn
September 16th, 2005, 05:21 AM
Could someone explain what the following line from the device section, actually does.

Option NvAGP "1"

I always have mine set at 1, as this value was suggested in another howto.

Having read through this forum, some posts made reccomendations to set this at 0 to resolve particular problems.

Recently in another forum I noticed that this was set to 3 in another persons conf file.

Does, this affect the AGP rate, my card is an 8?

Also is there any value in setting this to a higher value.

Cheers.

tseliot
September 16th, 2005, 08:22 AM
Could someone explain what the following line from the device section, actually does.

Option NvAGP "1"

I always have mine set at 1, as this value was suggested in another howto.

Having read through this forum, some posts made reccomendations to set this at 0 to resolve particular problems.

Recently in another forum I noticed that this was set to 3 in another persons conf file.

Does, this affect the AGP rate, my card is an 8?

Also is there any value in setting this to a higher value.

Cheers.
No, don't you worry it doesn't have anything to do with the AGP rate. It only tells xorg which module it has to load (nvAGP). You have to change it only if nvidia drivers don't work for you.

I think AGP rate can be changed in the bios.

TakisX
September 16th, 2005, 10:08 AM
Tseliot thanks for trying to help this Greek

I have Geforce3 and Sony tft with dvi

I instaled Ubuntu 5.04 and in synaptic i see that nvidia drivers not installed.
I just upgraded the packets with synartic.
I changed nv to vesa and put # dri in xorg.conf
What to do ? Install drivers with synartic or do your how to ?
The kernel is the original .( in the previous instalation i had compiled kernels easily ,only the drivers is my problem

Thanks

tseliot
September 16th, 2005, 10:17 AM
Tseliot thanks for trying to help this Greek

I have Geforce3 and Sony tft with dvi

I instaled Ubuntu 5.04 and in synaptic i see that nvidia drivers not installed.
I just upgraded the packets with synartic.
I changed nv to vesa and put # dri in xorg.conf
What to do ? Install drivers with synartic or do your how to ?
The kernel is the original .( in the previous instalation i had compiled kernels easily ,only the drivers is my problem

Thanks
Perhaps Geforce 3 is not supported very well in driver 7667.
You should use the Ubuntu Starter's guide and follow its instructions about installing the nvidia drivers (the ones in synaptic).

If it doesn't work you have to switch back to "vesa".

TheTK421
September 16th, 2005, 10:12 PM
Thanks for all your help! Is there anyway to install the nVidia drivers and enable 3d support during the inital install?

Thanks in advance!
TheTK421

Owdy
September 16th, 2005, 10:18 PM
http://digital-conquest.ath.cx/wiki/index.php/Ubuntu#Enabling_Nvidia_3D_driver

I tryed optimise my card with that tutorila, still my settings are
Fast Writes: Disabled
SBA: Disabled

Motherboard support those. Ideas to fix that?

tseliot
September 17th, 2005, 07:59 AM
Thanks for all your help! Is there anyway to install the nVidia drivers and enable 3d support during the inital install?

Thanks in advance!
TheTK421
There's no way to do it in Ubuntu during the installation. But if you use the Ubuntu starter's guide it's just a matter of copy and paste.

http://ubuntuguide.org/

or

http://www.frankandjacq.com/ubuntuguide/5.04/index.html

tseliot
September 17th, 2005, 08:11 AM
http://digital-conquest.ath.cx/wiki/index.php/Ubuntu#Enabling_Nvidia_3D_driver

I tryed optimise my card with that tutorila, still my settings are
Fast Writes: Disabled
SBA: Disabled

Motherboard support those. Ideas to fix that?
I've never tried such things because I've had a PCI-E card. I bought a new computer last week and it has an agp card but I haven't tried the trick. I don't use the card for games.

I'm sorry, I can't help you with that.

zBoost
September 18th, 2005, 12:06 PM
Thanks for this How-to, it's great.
So I've done everything, and installed the 7667 driver without problems and it is working on my GF 6600GT AGP. On glxgears I get about 7800 fps but I noticed that the GL screensavers doesn't show up. I remember before on my x86_64 Kubuntu when I installed the GL driver from Kynaptic, they worked.
Do u have any idea why, it seems it isn't something serious while glxgears is runing fine and it says Direct Rendering yes, and shows OpenGL versions etc.

tseliot
September 18th, 2005, 02:39 PM
Thanks for this How-to, it's great.
So I've done everything, and installed the 7667 driver without problems and it is working on my GF 6600GT AGP. On glxgears I get about 7800 fps but I noticed that the GL screensavers doesn't show up. I remember before on my x86_64 Kubuntu when I installed the GL driver from Kynaptic, they worked.
Do u have any idea why, it seems it isn't something serious while glxgears is runing fine and it says Direct Rendering yes, and shows OpenGL versions etc.
I don't know. It worked for me in 64bit too. I haven't tried in 32bit though

zBoost
September 18th, 2005, 05:25 PM
Hmm I just tested the Doom 3 demo and on high, 1024x768 with 4x AA is over 60 fps, I think it's perfect :D

tseliot
September 19th, 2005, 09:12 AM
zBoost, I think you won't miss opengl screensavers as Doom is better ;-)

rjwood
September 21st, 2005, 03:47 PM
I went to nvidia's site and the 7667 drivers are not listed only the 7676 drivers are there. I have amd athalon 2800+ and I just installed a "e-GeForce FX 5500" card. The box says DDR-128MB and AGP 8X/4X.
I installed this card after I did a new install of Breezy and had problems with rebooting (couldn't) so I did a clean reinstall of horay and seems to be ok. I just installed the k7 kernel and now want to make sure I have the proper drivers. This is what my device manager says:

/home/rob/Screenshot.png
Can you advise me what to do.

I am not a gamer I just want faster more clean graphics all around and was compelled to upgrade card because I tried the "composit and transset thing. Shadowing and fading was nice but locked up my system.

Thanks

tseliot
September 21st, 2005, 04:10 PM
I went to nvidia's site and the 7667 drivers are not listed only the 7676 drivers are there. I have amd athalon 2800+ and I just installed a "e-GeForce FX 5500" card. The box says DDR-128MB and AGP 8X/4X.
I installed this card after I did a new install of Breezy and had problems with rebooting (couldn't) so I did a clean reinstall of horay and seems to be ok. I just installed the k7 kernel and now want to make sure I have the proper drivers. This is what my device manager says:

/home/rob/Screenshot.png
Can you advise me what to do.

I am not a gamer I just want faster more clean graphics all around and was compelled to upgrade card because I tried the "composit and transset thing. Shadowing and fading was nice but locked up my system.

Thanks
1) I can't see the image but you can use the link below:

http://www.nvidia.com/object/unix.html

2) click on the word "Archive" below your desired architecture:

This is an example

Graphics Drivers

Linux IA32
Latest Version: 1.0-7676
Archive

Linux IA64
Latest Version: 1.0-5336
Archive

Linux AMD64/EM64T
Latest Version: 1.0-7676
Archive

3) Then you will see a list of all the versions of nvidia drivers and you can click 7667.

P.S. your architecture is IA32 (as AMD64 is for 64bit systems ONLY)

persis
September 21st, 2005, 05:15 PM
Hi there -

Been running Hoary for quite awhile now with no problems. Just upgraded displays from a Dell CRT to an Apple Cinema 20" lcd display. I installed a FX 5200 card so that I would have the DVI interface - and now I'm trying to get the drivers , lcd, etc.. working properly. I don't know if there have been many people to setup a 20" cinema on a PC running Hoary, but I thought I'd give it a shot.

I ran through your manual, but still am not able to loadup the gui. Attached is a view of my xorg.conf.

Hope all is well - and thanks in advance for any support. Would love to get this baby working and maybe it would serve as a good doc for anyone else doing the same.

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
# sudo dpkg-reconfigure xserver-xorg

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 5200]" (I put this in manually)
Driver "nvidia"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "DELL P992"
Option "DPMS"
HorizSync 30-107
VertRefresh 85
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
Monitor "DELL P992"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

tseliot
September 21st, 2005, 05:26 PM
Hi there -

Been running Hoary for quite awhile now with no problems. Just upgraded displays from a Dell CRT to an Apple Cinema 20" lcd display. I installed a FX 5200 card so that I would have the DVI interface - and now I'm trying to get the drivers , lcd, etc.. working properly. I don't know if there have been many people to setup a 20" cinema on a PC running Hoary, but I thought I'd give it a shot.

I ran through your manual, but still am not able to loadup the gui. Attached is a view of my xorg.conf.

Hope all is well - and thanks in advance for any support. Would love to get this baby working and maybe it would serve as a good doc for anyone else doing the same.

Have a look at this link, I hope it helps you.

http://www.ubuntuforums.org/showthread.php?t=60030&highlight=DVI

tseliot
September 21st, 2005, 05:32 PM
If you can see something (at least the command line) when booting using the new monitor you can use this command:

sudo dpkg-reconfigure xserver-xorg

Select the "advanced" when it asks you about the refresh rate (make sure you know the horizontal and vertical refresh rate supported by your monitor

persis
September 21st, 2005, 06:02 PM
Have a look at this link, I hope it helps you.

http://www.ubuntuforums.org/showthread.php?t=60030&highlight=DVI



Yup - got the cinema going now. Thing is, I don't have an option under "Screen Resolution" for it's native resolution of 1680 X 1050.

Any thoughts on how to go about getting the resolution there?

Thanks

tseliot
September 21st, 2005, 06:11 PM
Yup - got the cinema going now. Thing is, I don't have an option under "Screen Resolution" for it's native resolution of 1680 X 1050.

Any thoughts on how to go about getting the resolution there?

Thanks
Open Terminal or Konsole and type:

sudo dpkg-reconfigure xserver-xorg

Select the "advanced" when it asks you about the refresh rate (make sure you know the horizontal and vertical refresh rate supported by your monitor.

It will ask you your desired resolutions, select the ones you need.

After it ends you can go to "Screen Resolution" and select your resolution.

Tell me if it works

rjwood
September 21st, 2005, 06:13 PM
thanks for the how to tseliot. your a great help. I am thinking about trying breezy upgrade. Nothing to lose really--I can just re-install. Do you think breezy will try to change my kernel or settings for my driver?? thanks again

tseliot
September 21st, 2005, 06:21 PM
thanks for the how to tseliot. your a great help. I am thinking about trying breezy upgrade. Nothing to lose really--I can just re-install. Do you think breezy will try to change my kernel or settings for my driver?? thanks again
It could upgrade your kernel to 2.6.12-8 version and you would have to modify your xorg.conf (and set "nvidia" to "nv" or "vesa") (because it's likely that the graphical interface doesn't start) and to reinstall the nvidia drivers. There might be dependency problems and other bugs, but if you have nothing to lose...

persis
September 21st, 2005, 09:13 PM
Still nothing -

attempted to follow various examples from :
http://micke.hallendal.net/archives/2004/09/apple_cinema_di_1.html

but still nothing.