PDA

View Full Version : Tk-804.027, Device-SerialPort-1.002 and ubuntu



duuchung
October 3rd, 2007, 06:53 PM
Dear pals,
I was installing Perl/Tk-804.027 just now. I had an error: /usr/include/X11/Xlib.h:52:23: error: sys/types.h: No such file or directory.

I had been installing Device-SerialPort-1.002.tar.gz, a CPAN module of PERL, onto my ubuntu machine.
I got an error message that " C compiler cannot create executables".


Could anyone enlighten me by telling me what has gone wrong and how to get the modules running?
regards

geraldm
October 10th, 2007, 05:33 AM
Your compiler setup was not complete, or is since corrupted.
Try to correct it


sudo apt-get install build-essential


NOTE: also when you post a subject, please keep followup posts within
the same thread. You might have just posted "bump" in this thread
rather than start http://ubuntuforums.org/showthread.php?t=571041

Gerald

duuchung
October 16th, 2007, 03:30 AM
Thank you for your advice.

Finally I solved the puzzle of installing Tk onto Ubuntu. I tried everything I could think of; download from CPAN, download from Perl/tk
and......

Finally I used apt-get TK. These were the magic words one must use.
Duuchung