PDA

View Full Version : USN-516-1: xfsdump vulnerability



rss-bot
September 21st, 2007, 04:50 AM
Referenced CVEs:
CVE-2007-2654


Description:
================================================== ========= Ubuntu Security Notice USN-516-1 September 20, 2007 xfsdump vulnerability CVE-2007-2654 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 6.10 Ubuntu 7.04 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: xfsdump 2.2.30-1ubuntu0.1 Ubuntu 6.10: xfsdump 2.2.38-1ubuntu0.6.10.1 Ubuntu 7.04: xfsdump 2.2.38-1ubuntu0.7.04.1 In general, a standard system upgrade is sufficient to affect the necessary changes. Details follow: Paul Martin discovered that xfs_fsr creates a temporary directory with insecure permissions. This allows a local attacker to exploit a race condition in xfs_fsr to read or overwrite arbitrary files on xfs filesystems.





More... (http://www.ubuntu.com/usn/usn-516-1)