PDA

View Full Version : USN-505-1: vim vulnerability



rss-bot
August 28th, 2007, 11:50 PM
Referenced CVEs:
CVE-2007-2953


Description:
================================================== ========= Ubuntu Security Notice USN-505-1 August 28, 2007 vim vulnerability CVE-2007-2953 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 6.10 Ubuntu 7.04 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: vim 1:6.4-006+2ubuntu6.1 Ubuntu 6.10: vim 1:7.0-035+1ubuntu5.2 Ubuntu 7.04: vim 1:7.0-164+1ubuntu7.2 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Ulf Harnhammar discovered that vim does not properly sanitise the "helptags_one()" function when running the "helptags" command. By tricking a user into running a crafted help file, a remote attacker could execute arbitrary code with the user's privileges.





More... (http://www.ubuntu.com/usn/usn-505-1)