PDA

View Full Version : Weatherlink 54



dublinfireman
August 17th, 2007, 02:59 AM
I run a weather station, the Davis VantagePro. I can't seem to get weatherlink to run properly, I have everything connected, however once I pull up the main screen, it freezes up everytime. Anyone out there have any insight?

abrianb
August 17th, 2007, 11:30 PM
Bump

abrianb
August 19th, 2007, 02:58 PM
Try this link www.wviewweather.com (http://ubuntuforums.org/www.wviewweather.com) I believe you can run ths software without wine. Hope it solves your problem.

abrianb
August 19th, 2007, 03:20 PM
These folks use a Davis with Ubuntu. www.npuphysics.org/weather/helwig/index.shtml

dublinfireman
August 23rd, 2007, 02:06 AM
I tried to install the wview but keep getting an error:

configure: error: C compiler cannot create executables

I attempted to e-mail someones e-mail that I found in the config.log error screen, but no response yet, anyone wanna take a crack at the problem?

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by wview configure 3.3.0, which was
generated by GNU Autoconf 2.61. Invocation command line was

$ ./configure --enable-station-vpro

## --------- ##
## Platform. ##
## --------- ##

hostname = jimmy-desktop
uname -m = i686
uname -r = 2.6.20-16-generic
uname -s = Linux
uname -v = #2 SMP Thu Jun 7 20:19:32 UTC 2007

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = i686
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/X11R6/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1812: checking for a BSD-compatible install
configure:1868: result: /usr/bin/install -c
configure:1879: checking whether build environment is sane
configure:1922: result: yes
configure:1987: checking for gawk
configure:2017: result: no
configure:1987: checking for mawk
configure:2003: found /usr/bin/mawk
configure:2014: result: mawk
configure:2025: checking whether make sets $(MAKE)
configure:2046: result: yes
configure:2360: checking for style of include used by make
configure:2388: result: GNU
configure:2461: checking for gcc
configure:2477: found /usr/bin/gcc
configure:2488: result: gcc
configure:2726: checking for C compiler version
configure:2733: gcc --version >&5
gcc (GCC) 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2736: $? = 0
configure:2743: gcc -v >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
configure:2746: $? = 0
configure:2753: gcc -V >&5
gcc: '-V' option must have argument
configure:2756: $? = 1
configure:2779: checking for C compiler default output file name
configure:2806: gcc conftest.c >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
configure:2809: $? = 1
configure:2847: result:
configure: failed program was:
| /* confdefs.h. */
| #define PACKAGE_NAME "wview"
| #define PACKAGE_TARNAME "wview"
| #define PACKAGE_VERSION "3.3.0"
| #define PACKAGE_STRING "wview 3.3.0"
| #define PACKAGE_BUGREPORT "mteel@users.sourceforge.net"
| #define PACKAGE "wview"
| #define VERSION "3.3.0"
| /* end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:2854: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_CCC_set=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXFLAGS_set=
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_HOST_IS_BIGENDIAN_set=
ac_cv_env_HOST_IS_BIGENDIAN_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_install='/usr/bin/install -c'
ac_cv_prog_AWK=mawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/jimmy/wview-3.3.0/missing --run aclocal-1.9'
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR='${SHELL} /home/jimmy/wview-3.3.0/missing --run tar'
AUTOCONF='${SHELL} /home/jimmy/wview-3.3.0/missing --run autoconf'
AUTOHEADER='${SHELL} /home/jimmy/wview-3.3.0/missing --run autoheader'
AUTOMAKE='${SHELL} /home/jimmy/wview-3.3.0/missing --run automake-1.9'
AWK='mawk'
CC='gcc'
CCDEPMODE=''
CFLAGS=''
CPP=''
CPPFLAGS=''
CXX=''
CXXDEPMODE=''
CXXFLAGS=''
CYGPATH_W='echo'
DB_MYSQL_FALSE=''
DB_MYSQL_TRUE='#'
DB_PGRESQL_FALSE=''
DB_PGRESQL_TRUE='#'
DEFS=''
DEPDIR='.deps'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
GREP=''
HOST_IS_BIGENDIAN=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
IS_BIGENDIAN_FALSE=''
IS_BIGENDIAN_TRUE=''
LDFLAGS=''
LIBOBJS=''
LIBS=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /home/jimmy/wview-3.3.0/missing --run makeinfo'
OBJEXT=''
PACKAGE='wview'
PACKAGE_BUGREPORT='mteel@users.sourceforge.net'
PACKAGE_NAME='wview'
PACKAGE_STRING='wview 3.3.0'
PACKAGE_TARNAME='wview'
PACKAGE_VERSION='3.3.0'
PATH_SEPARATOR=':'
SET_MAKE=''
SHELL='/bin/bash'
STATION_SIM_FALSE=''
STATION_SIM_TRUE='#'
STATION_VPRO_FALSE='#'
STATION_VPRO_TRUE=''
STATION_WXT510_FALSE=''
STATION_WXT510_TRUE='#'
STRIP=''
VERSION='3.3.0'
WUNDERGROUND_FALSE=''
WUNDERGROUND_TRUE=''
ac_ct_CC='gcc'
ac_ct_CXX=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE=''
am__fastdepCXX_TRUE=''
am__include='include'
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build_alias=''
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host_alias=''
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='/home/jimmy/wview-3.3.0/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
mkdir_p='mkdir -p --'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='NONE'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "wview"
#define PACKAGE_TARNAME "wview"
#define PACKAGE_VERSION "3.3.0"
#define PACKAGE_STRING "wview 3.3.0"
#define PACKAGE_BUGREPORT "mteel@users.sourceforge.net"
#define PACKAGE "wview"
#define VERSION "3.3.0"

configure: exit 77

]Nbx*cmD[
November 5th, 2007, 12:08 PM
Hey, configure worked for me, but not make.

If you found a solution please tell, i also need to configure a vantage pro 2 on a ubuntu server!

I'll also let you know my achievements ;)

Thanks!

jdr2710
November 13th, 2007, 03:22 PM
To fix the "can't create executable" error you need to su and run:

apt-get install build-essential

Once I did this the configure worked fine, but I was not able to compile. I downloaded the various packages that wview calls for (radlib, libgd, and libcurl see http://www.wviewweather.com/release-notes/wview-Quick-Start.html )

but I couldn't get the libgd to compile, it complains of a linker error which I haven't tracked down yet.

umechanism
January 22nd, 2010, 11:16 PM
It's been a while since this thread was updated but I'm trying to help my dad get his Vantage Pro 2 weather station configured with wview. He's a Linux noob and I live in a different state than he does. Just wondering if you ever got yours running. If so, where is the wview html page located that shows the station's readings? I'm looking for a file path to the html page...any help is appreciated.

Mike

StephenWoods69
January 23rd, 2010, 03:10 PM
I don't use the software myself but I found some links that may or may not help
http://www.wviewweather.com/
On the user manual page they state the following

Local server access:
Enter the URL: http://localhost/wviewmgmt/login.php
The default password is "wview" (you should change this).

Remote server access: Enter the URL: http://[remote_host_or_IP]/wviewmgmt/login.php

This is a direct link to the manual page
http://www.wviewweather.com/release-notes/wview-User-Manual.html

I'm sorry I can't help any-more than this but like I say I don't actually use the software