PDA

View Full Version : [SOLVED] soldat wine prob



don durito
July 31st, 2007, 07:19 PM
Hi,

I have installed Soldat 1.4.1 (http://www.soldat.pl) via wine (v. 0.9.42).
The installation and configuration went great. But i can't play the game. i can start it but when i start it get this error: control is not unicode;
but i don't know what this means.

after this i get the soldat login screen and then soldat freezes and i have to kill x.

don't know whats wrong cause according to the wine app data base soldat 1.4.x has got platinum status.

now i have tried to run soldat in a virtual desktop. in a virtual desktop i can run soldat and even start a game. but i'll get this error message every 3 seconds so that the game is unplayable.

here's ther error message: Acces violation at adress 00401CEA in module 'Soldat.exe'. Write of adress 5046202D

please help me cause this game is just pure fun :-)

yours
don

don durito
August 2nd, 2007, 04:17 PM
Solved

to solve this prob just look at the faq at the soldat forums (http://www.soldatforums.com/index.php?topic=13.0) and tweak your soldat config a little bit.

BlahMan_of.Doom
August 3rd, 2007, 12:59 AM
That's really weird. It should work out of the box with wine.

don durito
August 3rd, 2007, 02:05 AM
I know

but i belive thist is not a wine prob. the Access Denied error seems to be common on windows setups and those tweaks just worked as well under wine.

yowshi
November 10th, 2007, 08:18 AM
it doesnt alwaysd work though. i keep getting an exce[ption eror on most servers i can join and in the conmsole windows i tells me

err:d3d_draw:blt_to_drawable Blitting surfaces from sysmem not supported yet


at this point all one can do is Ctrl+c to kill the game