PDA

View Full Version : Pidgin 2.1.0 Released!



Kosimo
July 30th, 2007, 08:52 PM
Hi guys.
Good news.
Pidgin reaches the 2.1.0 version with more than 120 bugfixes.
Enjoy it!


Pidgin Website (http://pidgin.im/pidgin/home/)

Kosimo
July 30th, 2007, 09:00 PM
By the way if someone doesn't know how to install from the source code:

Download the source
Extract pidgin folder
open the terminal and go inside that folder

then



./configure
make
sudo make install

jcrnan
July 30th, 2007, 09:26 PM
I managed to install it, but when I try to add my msn account it complains about needing SSL support. What do I do?

~LoKe
July 30th, 2007, 09:30 PM
loke@x04d:~/pidgin-2.1.0$ pidgin
pidgin: symbol lookup error: pidgin: undefined symbol: purple_core_ensure_single_instance
Great start.

Kosimo
July 30th, 2007, 09:53 PM
Here is working with no issues.

How did you install it?

ubuntu27
July 30th, 2007, 10:14 PM
I managed to install it, but when I try to add my msn account it complains about needing SSL support. What do I do?

You need to install the following packages from the repositories (or compile from the offical tcl website to get the latest version)

openssl
tcltls
tk8.4
tcl8.4


sudo aptitude install openssl tk8.4 tcltls tcl8.4

Optional:

libsnack2


sudo aptitude install libsnack2

Dimitriid
July 30th, 2007, 10:36 PM
I usually try to install source things with checkinstall so they are easy to find in synaptic, will synaptic take care of those libraries for me if I do it that way or do I still need to install em separately?

plun
July 30th, 2007, 10:44 PM
Great start.

Got the same on Gutsy.....noticed this during configure

Pidgin will be installed in /usr/local/bin.
Warning: You have an old copy of Pidgin at /usr/bin/pidgin.

sudo apt-get remove pidgin

sudo make install again...:)

EDIT
Also got a little gstreamer error so maybe its better to discuss this i Gutsys forum.

jcrnan
July 30th, 2007, 11:17 PM
Ubuntu27: I installed those packages and I still get the error when I try to enable the msn account.

walkerk
July 30th, 2007, 11:21 PM
thanks for the heads up.. just compiled it :)

aeon
July 30th, 2007, 11:28 PM
@jcrnan

install those and possibly also libgnutls and try to compile again, the errors should be gone now

Cyfr
July 31st, 2007, 01:32 AM
Why am I getting

bash: ./configure: No such file or directory

When I try and ./configure?

Im rather tired. Am I missing something? :p

cookieofdoom
July 31st, 2007, 01:34 AM
libxss-dev is needed to support the "Report idle time based on keyboard or mouse use" option. libnss-dev libnspr-dev are (I believe) needed for supporting the protocols requiring SSL.

You can do
sudo apt-get install libxss-dev libnss-dev libnspr-dev to get those packages installed.

@ Cyfr, are you in the right directory?

Cyfr
July 31st, 2007, 01:39 AM
@ Cyfr, are you in the right directory?

I tried the directory that the extract gives and I tried the "pidgin"
directory within that

migla
July 31st, 2007, 01:40 AM
dpkg: error processing [...] trying to overwrite `/usr/bin/ld', which is also in package binutils

:(

Cyfr
July 31st, 2007, 01:40 AM
Nevermind it didn't extract the files correctly for some reason. Fixed now :)

nrs
July 31st, 2007, 01:49 AM
omgz you should be installing in /usr/local !

./configure --prefix=/usr/local

migla
July 31st, 2007, 02:42 AM
My problem was caused by me using "sudo checkinstall -D" instead of "sudo make install". Found a solution in the comments on some blog: (http://jhcore.com/2007/06/04/install-pidgin-in-ubuntu/) "sudo checkinstall --exclude=/etc/gconf,/usr/bin,/usr/lib" (whatever that means, it worked for me) :)

WastingBody
July 31st, 2007, 03:29 AM
Everything went well for me except there is no sound when someone sends a message. The console beeps and thats it.

Montsegur87
July 31st, 2007, 03:34 AM
config.status: error: cannot find input file: doc/Makefile.in

stmiller
July 31st, 2007, 03:34 AM
Just do this to install all dependencies needed to compile:


sudo apt-get build-dep gaim


And no need to set the prefix. It defaults to /usr/local as you can see in the configure help.

apc15x
July 31st, 2007, 04:35 AM
Well I downloaded pidgin 2.1.0 but I get an error:
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking target system type... i686-pc-linux-gnulibc1
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for sed... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.
Can anybody help.
Thank in advance :(

syxbit
July 31st, 2007, 04:57 AM
where's the changelog?

Quillz
July 31st, 2007, 05:00 AM
Cool, thanks for the news.

il-luzhin
July 31st, 2007, 06:46 AM
E: Couldn't find package sibxss-dev

AlexC_
July 31st, 2007, 10:56 AM
I compiled Pidgin 2.1.0 first time and it works ... however I have no sound, all I get is a console beep - I've played with the settings but no luck - what could be going on?

Kosimo
July 31st, 2007, 11:08 AM
How can I install the spelling plugin?

bubi
July 31st, 2007, 11:48 AM
How can I install the spelling plugin?

You have to install the -dev package:

sudo apt-get install libgtkspell-dev

Kosimo
July 31st, 2007, 12:12 PM
You have to install the -dev package:

sudo apt-get install libgtkspell-dev

Done.
But I'm still not getting the spelling corrector when typing in the chat window.
Do I maybe have to reinstall Pidgin from the source having this lib installed?

happy-and-lost
July 31st, 2007, 01:07 PM
Will this release make it into the final release of Gutsy?

Kosimo
July 31st, 2007, 01:27 PM
Will this release make it into the final release of Gutsy?


Gutsy will may have the 2.1.2 or 2.2.0 as you can see in pidgin's roadmap (here (http://developer.pidgin.im/roadmap))

Acutally, in two weeks a new version 2.1.1 should be ready.
Then 2.1.2 in one month
and finally 2.2.0 will be ready in two months... Maybe not in time for Gutsy.

liamwithers
July 31st, 2007, 01:33 PM
Heya, I've done configure and am on make but it's taking forever!

Kosimo
July 31st, 2007, 01:39 PM
Heya, I've done configure and am on make but it's taking forever!

Wait... It takes long time (about 10 to 20 minutes) don't cancel it!

graabein
July 31st, 2007, 01:44 PM
Looks pretty good based on the screenshot.

http://img503.imageshack.us/img503/5148/contactwindowlq6.png

ThrobbingBrain66
July 31st, 2007, 02:02 PM
If you guys can wait a little while, getdeb.net will have 2.1 posted in a few days and you won't have to worry about compile errors and the like.

www.getdeb.net

cookieofdoom
July 31st, 2007, 02:24 PM
Sorry, my bad on the typo. It's:

sudo apt-get libxss-dev

I'll edit my post above, too.

Kosimo
July 31st, 2007, 02:56 PM
If you guys can wait a little while, getdeb.net will have 2.1 posted in a few days and you won't have to worry about compile errors and the like.

www.get-deb.net


http://www.getdeb.net ;)

ThrobbingBrain66
July 31st, 2007, 03:06 PM
http://www.getdeb.net ;)

Thanks, corrected. :)

AaronMT
July 31st, 2007, 03:06 PM
configure: error:

You must have the GTK+ 2.0 development headers installed to compile Pidgin.
If you only want to build Finch then specify --disable-gtkui when running configure.

How can I fix this so I can compile?

Solved.

Old Pink
July 31st, 2007, 04:29 PM
There's nothing new anyway. 120 previously unnoticeable bugs have been fixed. Big deal.

Might look into it when on getdeb, but studied the roadmap, etc for ages, and not only is it almost a month late, there's not a single new feature worth getting excited about.

Poor show.

DC@DR
July 31st, 2007, 04:40 PM
Right, nothing new and astonishing :-(

Kosimo
July 31st, 2007, 05:26 PM
Right, nothing new and astonishing :-(

Well guys... I see some important differences, specially in the new chat window.

And about the new versions... People is always complaining.. We're having every new version a most stable bugfree pidgin guys.
At the moment Pidgin is ok for me (I would like to have P2P transfers between MSN users anyway). But, for now, I don't need any new feature. I want a solid/rock Program. If you have a look to pidgin developer roadmap (see above) you'll notice about the many bugs with a ticket assigned already and still waiting to be fixed. I prefer to have all this bugs fixed than add some new feature that give us more and more bugs.

Kosimo
July 31st, 2007, 05:28 PM
By the way...
If you want a super fashioning with much more features and videoconference program. Use aMSN.

Old Pink
July 31st, 2007, 05:31 PM
aMSN is ugly as sin. And has no support for AIM, ICQ, Jabber/XMPP Yahoo!, Bonjour, Gadu-Gadu, IRC, Novell GroupWise Messenger, QQ, Lotus Sametime, SILC, SIMPLE, or Zephyr.

jcrnan
July 31st, 2007, 11:11 PM
I find it hard to get a IM to be like I want it to. I wish I could have all the features and customizability of aMsn and the looks and stability of pidgin :)

Old Pink
August 1st, 2007, 12:51 AM
Review, Roundup, What's New: http://www.mbhoy.com/01-08-2007/pidgin-210

Working well for me, quite nice, nothing to get excited about though.

syxbit
August 1st, 2007, 12:58 AM
considering sean egan works for google, you'd think he could get all the googleTalk features working (voice etc..)

fyllekajan
August 1st, 2007, 01:13 AM
Yawn.. any audio/video conferencing capabilities this year!? it's their own fault starting the hype years ago.. talking a lot of... on the other hand they are doing a good job on this program.. for what it is.

theonlyalterego
August 1st, 2007, 01:47 AM
I get this


You must have libxml2 >= 2.6.0 development headers installed to build.


I can't seem to find a ubuntu package with 2.6.0 or greater, has anyone made one?

Jerr973
August 1st, 2007, 12:06 PM
Ok I have tried everything managed compile and it's installed, not will not start, so giving up but how do I remove it now?

ike
August 1st, 2007, 12:26 PM
Well I downloaded pidgin 2.1.0 but I get an error:
...
configure: error: C compiler cannot create executables
See `config.log' for more details.
Can anybody help.
Thank in advance :(

Start with these:
http://forums.gentoo.org/viewtopic.php?t=27486
http://www.binrev.com/forums/index.php?showtopic=18678
http://www.linuxquestions.org/questions/showthread.php?threadid=386790

and if unlucky, try:
http://www.google.com/search?hl=sv&q=%22C+compiler+cannot+create+executables%22+ubunt u&btnG=S%C3%B6k&lr=


edit: Also check your config.log

oliverb4ss
August 1st, 2007, 05:43 PM
I just got the following error after issuing the command "./configure" :

The msgfmt command is required to build libpurple. If it is installed
on your system, ensure that it is in your path. If it is not, install
GNU gettext to continue.

What can I do about that?

fakie_flip
August 1st, 2007, 10:14 PM
I have Pidgin 2.0.2-1 compiled. How can I get off the record plugin to work for it?

crhylove
August 2nd, 2007, 01:17 AM
getdeb.net is down. Any other place where I can get a 2.1.0 .deb?

Kosimo
August 2nd, 2007, 01:29 AM
getdeb.net is down. Any other place where I can get a 2.1.0 .deb?

Is on again...

(But Pidgin 2.1.0 is not available yet) Why don't you just try to compile by yourself? Is really easy.

foureight84
August 2nd, 2007, 04:36 AM
is it just me or is 2.10 missing the tray icon?

Kosimo
August 2nd, 2007, 11:58 AM
is it just me or is 2.10 missing the tray icon?

No issues here.

How did u install it?

happy-and-lost
August 2nd, 2007, 12:26 PM
How come it's in the Debian Sid repos but not the Ubuntu Gutsy ones?

PartisanEntity
August 2nd, 2007, 02:07 PM
Cool thanks for the heads up, just installed it and am happy to see that it loads much faster than version 2.0.0

BW~Merlin
August 2nd, 2007, 04:50 PM
I have been trying to compile this for the last several hours and know matter what I try I keep getting these errors and I don't know how to fix them.

In file included from /usr/include/gtk-2.0/gtk/gtkwidget.h:32,
from /usr/include/gtk-2.0/gtk/gtkcontainer.h:33,
from /usr/include/gtk-2.0/gtk/gtkbin.h:32,
from /usr/include/gtk-2.0/gtk/gtkwindow.h:33,
from /usr/include/gtk-2.0/gtk/gtkdialog.h:32,
from /usr/include/gtk-2.0/gtk/gtkaboutdialog.h:28,
from /usr/include/gtk-2.0/gtk/gtk.h:32,
from ../../../pidgin/pidgin.h:33,
from gestures.c:22:
/usr/include/gtk-2.0/gtk/gtkobject.h:85: error: expected specifier-qualifier-list before 'GInitiallyUnowned'
/usr/include/gtk-2.0/gtk/gtkobject.h:97: error: expected specifier-qualifier-list before 'GInitiallyUnownedClass'

Can someone please help me.

Kosimo
August 2nd, 2007, 05:01 PM
I have been trying to compile this for the last several hours and know matter what I try I keep getting these errors and I don't know how to fix them.

In file included from /usr/include/gtk-2.0/gtk/gtkwidget.h:32,
from /usr/include/gtk-2.0/gtk/gtkcontainer.h:33,
from /usr/include/gtk-2.0/gtk/gtkbin.h:32,
from /usr/include/gtk-2.0/gtk/gtkwindow.h:33,
from /usr/include/gtk-2.0/gtk/gtkdialog.h:32,
from /usr/include/gtk-2.0/gtk/gtkaboutdialog.h:28,
from /usr/include/gtk-2.0/gtk/gtk.h:32,
from ../../../pidgin/pidgin.h:33,
from gestures.c:22:
/usr/include/gtk-2.0/gtk/gtkobject.h:85: error: expected specifier-qualifier-list before 'GInitiallyUnowned'
/usr/include/gtk-2.0/gtk/gtkobject.h:97: error: expected specifier-qualifier-list before 'GInitiallyUnownedClass'

Can someone please help me.


I'm not really sure about it...
But could be a problem with some GTK library. You can install it by synaptic if I'm not mistaken. Search for GTK engines

BW~Merlin
August 2nd, 2007, 05:13 PM
As far as I am aware I have all the gtk engines installed. Is there some sort of check for error's and missing componets that might help narrow down what is wrong?

bokibre
August 2nd, 2007, 09:26 PM
here it is .deb package!!

http://www.debuntu.org/pidgin-2.1.0-for-ubuntu-feisty

J-Wreck
August 2nd, 2007, 10:02 PM
I don't like the way it gets rid of several of the icons in the IM window. It was better when their were individual buttons for things like bold, etc.

ThrobbingBrain66
August 2nd, 2007, 10:47 PM
I don't like the way it gets rid of several of the icons in the IM window. It was better when their were individual buttons for things like bold, etc.
Quoted for truth.

The package just got pushed through on Gutsy Testing and the chat window is hideous now. Making the chat window a normal size gives tons of empty space on the formatting toolbar.

Kosimo
August 2nd, 2007, 11:49 PM
Getdeb is also offering pidgin 2.1.0

http://www.getdeb.net/

vishzilla
August 3rd, 2007, 06:31 AM
You can include SSL support by including the following lines


./configure --enable-gnutls=yes
make
sudo make install

matteusz
August 12th, 2007, 03:01 PM
is it just me or is 2.10 missing the tray icon?

Try this:
Tools->Preferences->Show system tray icon->Always

cdecarlo
August 17th, 2007, 05:55 AM
You can include SSL support by including the following lines


./configure --enable-gnutls=yes
make
sudo make install

Thank you!