View Full Version : [SOLVED] anyone know how to fix a DCOP communications error?

July 27th, 2007, 09:17 PM
recently I started receiving DCOP communication errors, whenever I try to launch a KDE program in GNOME. This error screenshot is for kalzium, but is not limited to it.

I get the error, and the the program seems to run fine. It is rather annoying.

here is the massage in text form:

DCOP communications error (kalzium)

could not read network connection list.

Please check that the "dcopserver" is running!

July 27th, 2007, 10:07 PM
just delete that file that it references

July 27th, 2007, 10:19 PM
DCOP communications erro

I've had that error before. To fix it you just need to delete the files DCOP files. In your home directory there will be files that start with ".DCOP" that you need to delete. There might also be ".ICE" files, too:

$ cd ~
$ rm .DCOPserver*
$ rm .ICEauthority*

After deleting them, logout or reboot. It's safe to delete those files because KDE recreates them on login.

July 27th, 2007, 11:56 PM
unfortunately none of your suggestions help. I looked. there is no file named .DCOP or anything close to that name. (and, yes I did look at the hidden files)

my .DCOPserver file is missing.

August 2nd, 2007, 09:13 AM
I'm also having the same error when i try to start up Amarok. Its looking for that DCOP server. I looked all over for the DCOP files but I also do not have them...

August 2nd, 2007, 09:38 AM
I just figured it out for my machine. I hope it works for you. What i found happening was that it was trying to create files in my /home/user/.kde folder but since i was running it under a normal user it couldn't get permissions to create files in that directory. So what i did was just changed the owner to the normal user by using the "chown user:group /home/user/.kde" command and all the folders within it and now my Amarok works.

August 2nd, 2007, 07:22 PM
huh. well, i guess zir0n was right.

I tried what he said worked for him.

for me it was "sudo chown andrew:andrew /home/andrew/.kde"

Cool. it works fine now!

September 22nd, 2007, 06:51 PM
i have a similar problem

what should i do?

I attached a little picture of it

September 24th, 2007, 02:38 AM
umm... for me it was "sudo chown andrew:andrew /home/andrew/.kde"

Your problem could be different, but maybe not.

so, try opening a terminal... (>Applications >Accessories >Terminal)

then write this out and press enter:

sudo chown sabrina:sabria /home/sabrina/.kde

(assuming your username and home directory are "sabrina")


November 9th, 2007, 05:52 PM
Neither of the above solutions work for me and I have the exact same error message. I removed the ICE file and that didn't work. I also used the chown command and that didn't work. Any other ideas?

November 10th, 2007, 05:43 PM
A good general rule for things that give errors is to use Synaptic to re-install them. It has worked in the past for other errors from other programs.

If any other people have this problem, and the above solutions do not work for you, then start your own thread! I am very sure more people will help you that way. I would hate for someone not to be able to solve a problem, because they are asking for help on a solved thread.

best of luck!

December 14th, 2007, 02:38 PM
Thanks. It solved my problem so nicely.

April 7th, 2008, 06:36 AM
just restart your computer. it works for me. (I find this trick in ubuntu chinese community.)

May 5th, 2008, 12:40 AM
Deleting .kde did the job for me!



August 4th, 2008, 02:25 PM
I had to add the recursive option (-R) to the chown command to get it to work, but: it works! Thanks :)

October 23rd, 2008, 10:34 AM
Thank you all, I also fixed it by removing the .kde folder from the home folder. I was having this problem on asus eee 4g (Xandros).

January 18th, 2009, 09:54 PM
Removing the .kde folder from my home folder seemed to do the trick.

(I had used the chown command suggested without luck before trying this)

Do other programs use this directory to store information? Basically I'm asking if this fix could potentially break other stuff.


- wonder

July 29th, 2009, 07:54 PM
Hey guys. This is my first time on the forum, and working w/ Linux - please bare with me :)

I'm trying to sync up an iPod nano (5th gen) to an Asus Eee PC running Ubuntu. I've been checking the forums and am not able to find out how to get the command line to appear so I can try some of the ideas below.

The error says:
There was an error setting up inter-process communications for KDE. The message returned by the system was:
Could not read network connection list.
Please check that the "dcopserver" program is running!

I am not able to find those files to try and delete them.

What can I do? Thanks for your help everyone!

August 15th, 2009, 06:48 PM
I ran around in circles looking for what was wrong - turned out I had no space left on my /home partition

Check you have enough disk space if you don't have any luck with the suggested solutions.

November 4th, 2009, 04:38 PM
As far as getting k3b to run on karmic. I had to start nautilus from root using sudo then change the permissions of all the folders, subfolders and files in the .kde file located at /home/<username>/.kde
After I did that k3b ran perfectly from the icon, where as before I had to open a console and run it as root.

November 24th, 2009, 08:09 AM
Whenever you have a problem like the DCOP or your mouse or anything, shut down your computer and remove the battery. This is a reset that fixes everything instantly without having to alter your files. I had the mouse problem once, the mouse just was non responsive, so I removed the battery and that cleared that up. Then when the DCOP server error happened to my wireless....I did the same thing, and all the other former wireless connections that filled the wireless box were gone except mine and it connected instantly.

Try it before you do anything extreme....remove the battery and wait for 10 sec. and put it back...turn it all on. DONE!

Let me know if this helps anyone.

March 23rd, 2011, 10:03 AM
same problem try them all but nothing

Sadiq Huq
November 25th, 2012, 10:05 PM
I ran into 'DCOP communications error' when I tried to compress many folders with ark and it carshed..

I solved it by removing the temporary files created by ark in this location ~/.kde/tmp-computerName. You might also see konqueror-crash-blabla.log.
konqueror runs fine now.

November 25th, 2012, 10:21 PM
Thanks for sharing and please do not post in threads that have not had activity for a year or longer, since this is an old thread it has been closed.