View Full Version : USN-488-1: mod_perl vulnerability

July 18th, 2007, 03:20 AM
Referenced CVEs:

================================================== ========= Ubuntu Security Notice USN-488-1 July 17, 2007 libapache2-mod-perl2 vulnerability CVE-2007-1349 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 6.10 Ubuntu 7.04 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: libapache2-mod-perl2 2.0.2-2ubuntu1.6.06.1 Ubuntu 6.10: libapache2-mod-perl2 2.0.2-2ubuntu1.6.10.1 Ubuntu 7.04: libapache2-mod-perl2 2.0.2-2.3ubuntu1 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Alex Solovey discovered that mod_perl did not correctly validate certain regular expression matches. A remote attacker could send a specially crafted request to a web application using mod_perl, causing the web server to monopolize CPU resources. This could lead to a remote denial of service.

More... (http://www.ubuntu.com/usn/usn-488-1)