View Full Version : HELP: Problem Installing MTGO with Cedega or Wine (Magic the Gathering Online)

July 11th, 2007, 07:08 PM
Hi Guys, I've intalled Linux now and i'm a Newbie user, but some questions i got on net , but this one its making me crazy ^^
I installed Cedega on my linux and tryed to install Magic The gathering Online but when i do i allways get this error, even on Wine

Anyone knows how i can get this error off?
Or where i got to isntall the windows fonts ??

plz help me!!
i dont wanna go back to windows ^^

July 11th, 2007, 07:12 PM
Start by installing the msttcorefonts package. Run this in a terminal:

sudo apt-get install msttcorefonts
However, according to the Wine AppDB, the game has had problems with fonts in the past, but it doesn't have any test data beyond Win 0.9.17:
Even with the MS fonts installed, you may still have problems.

July 11th, 2007, 07:22 PM
I intalled the sudo apt-get install msttcorefonts but still getting the same error on Cedega.
i know the font erros but the initial font error i know that its not a problem cause on Cedega GameDB MTGO its there with Screen SHoots

July 11th, 2007, 07:31 PM
There is a post on that AppDB page that seems to address this:

I tried to install mtgo and I got this error "Failed to create font resource sserife.fot fontname sserife.fon". I went to my .wine folder and noticed that the fonts folder (windows fonts) was empty, so I made a copy of a ttf file (ms sans serif.ttf) from a computer with windows xp installed. I placed 2 copies into my fonts folder (wine folder) and renamed each one with the name of the files that appeared in the error message (including the extension fot and fon).
It seems that will at least get you past the error. If you don't have access to a Windows XP machine to copy the font files from, you may be able to find them online.

July 11th, 2007, 07:36 PM
i dont know where the folders is ^^ and i find one with Fonts but allways says that i dont have permition to put file there ^^

July 11th, 2007, 07:43 PM
You want to put it in Wine's font folder: /home/username/.wine/drive_c/windows/fonts

The ".wine" directory is a hidden directory in your home folder. Open the file browser and press CTRL-H to display hidden files.

July 11th, 2007, 08:04 PM
I will try cause my cedega and wine dont want to open the progrmas anymore
i will try to get out WINE and CEDEGA and reinstall

July 11th, 2007, 08:40 PM
i have put the fonts there but has 2 diferents area Dosdevices and drive_c what should i put on?

July 11th, 2007, 09:59 PM
Put it in .wine/drive_c/windows/fonts

October 7th, 2007, 07:36 PM
1) Had the same error as above, right as the MTGO installer finishes unzipping its resources, it crashes with: "Failed to create font resource sserife.fot fontname sserife.fon!!!"

2) Tried placing copies of my windows font files in ".../.wine/drive_c/windows/fonts/" as suggested above.
(I found "sserife.fon" in my "C:\windows\fonts" directory, I just made a copy and renamed it to "sserife.fot" for the second file.)
There was no change in behavior.

3) Then realized it's talking about resources pre-installation. Noted where the installer thought it was unzipping everything to, the "C:\windows\temp" directory. Poking around in there, I found a lot of magic files in the "data" subdirectory. Tried placing my "sserife.fon" and fake "sserife.fot" files in the data directory, ".../.wine/drive_c/windows/temp/data"

This eliminated the error for me.

However, a new error came up asking for vgasys.fon and vgasys.fot.

I will try the process again with these, and let you know of my progress.

(minutes later... )

Step 2:
I copied over vgasys.fon, which I found in the same C:\Windows\fonts\ directory. I also noticed a "magic.fot" file while there, so I copied that as well.

This time, out of curiosity, I didn't make an extra .fot file, and even renamed my sserife.fot file to sserife.bak. So I have 3 extra files in that temp/data directory: "sserife.fon" "vgasys.fon" and "magic.fot"

After just those three files in the data directory, the setup program began just fine.

(*It might be that either magic.fot or vgasys.fon on their own would have been sufficient, I can't say.)

Best of luck.

October 7th, 2007, 08:31 PM
After my last post, I was able to complete the installation of MTGO and play a match online against someone else.

Aside from the incredible slowness of the game, everything seemed to work fine.

October 8th, 2007, 04:06 AM
WOW! Thanks this thread worked perfect for me, thanks for everyones input it solve the same problem you all had for me too.

October 17th, 2007, 03:12 AM
Though I would add my two cents here after trying this process for myself. I would have never thought that in my first post I would be GIVING help. =D

To save yourself some headache, if you have an XP CD, you can extract the fonts from there with cabextract (http://packages.ubuntu.com/feisty/utils/cabextract). (I found that under Feisty it was already installed)

Commands for the lazy (or learning, like me :) ) :

mkdir ~/.wine/drive_c/windows/temp/data
cd /cdrom/I386
cp sserife.fo_ vgasys.fo_ ~/.wine/drive_c/windows/temp/data
cd ~/.wine/drive_c/windows/temp/data
cabextract sserife.fo_ vgasys.fo_

Then download the installer, and install install with WINE (it takes forever, just like in Windows!)

Though now that I have it installed, it seems to just die when it tries to bring up the intro video. =(

October 26th, 2007, 09:36 PM
Thanks TheMightyBorys! Your instructions revived my three year old account. I just played a match, a tad sluggish but totally playable, and won. Right now Magic is up and running, I'm sitting in the lobby right now, on my Desk2 Screen.

The only instructions I had to modify was changing:
cd /cdrom/I386
cd /cdrom/i386

Other than that, worked great!

November 6th, 2007, 01:17 AM
I don't have access to a windows disk and cant find the fonts online. would anyone mind posting them for me?

November 26th, 2007, 08:00 AM
i also would like these fonts...anyone have them? thanks!

December 13th, 2007, 01:26 AM
again, will someone please post these? I'm trying to avoid pirating something for once in my life...

December 13th, 2007, 05:06 PM
You're asking us to post Microsoft-owned fonts that are not legally available for free, but only come with Windows and are attached to the Windows license, but you don't want to pirate something...

You do see the irony here, right?

December 14th, 2007, 05:48 PM
You don't need them. If you have tahoma.ttf from msttcorefonts (or windows, or any of the free font websites) you can copy that to sserife.fon/fot and vgasys.fon/fot and it will work. In fact, I just did it.

February 18th, 2008, 04:20 AM
If you are like me, and had your downloader crap out at about 97% (internet connection timed out on blah blah blah):

1) open System Monitor with the installer running.
2) find the "setup.exe" process, under the process tab.
3) right click and choose "Change Priority"
4) move the priority slider to the left, increasing it's priority.

I think this is "common knowledge," but it took me a while to find it online, so i posted it here. also, make sure you close any unneccesary programs while running the downloader, and you might still have to click on the boxes that occasionally pop up.

March 6th, 2008, 07:36 PM
Ive gotten past all the fonts issues, thanks to the above posts! But I've hit another snag:

"Could not get host by name. Try again?"

If I say no, don't try again, the installer quits.
If I do try again, the status bar says:

"Checking file: tos.txt"

then pops up the same error again.

I couldn't find tos.txt anywhere, but did find tos.bin in the data directory.

any ideas?

March 6th, 2008, 07:54 PM
I found this thread:


the initial post seemed to deal with my problem. being from 2003, I had hoped that it would be fixed in the current release of wine, so I updated mine from


but it still doesnt work!

March 6th, 2008, 10:50 PM
OK i fixed it. I had changed my hostname by editing /etc/hostname, but hadn't updated /etc/hosts, which broke gethostbyname_r.