View Full Version : World of Warcraft Mouse problem.

July 6th, 2007, 12:57 AM
I recently reinstalled Ubuntu, gotten everything I need setup and configured correctly, except World of Warcraft.

I have installed it and I can login, but the cursor while I am in the window is the Ubuntu Human cursor overlaping the Warcraft cursor.

I have followed the instructions in WoWwiki's Wine guide, and I am still having this problem.
This has worked before I formatted my system. My config.wtf file was not using either OpenGL or d3d, so its not a problem with that. Now I know that WoW uses DirectX, so should I install a version of DirectX?

How do I fix this?

July 6th, 2007, 01:22 AM
If you followed the guide you would know to use OpenGL under linux to run WoW.
Also with the latest version of WINE the cursor issue does not exist in d3d mode,
but this is not really useful unless OpenGL mode which y(ou should be using) does not
work for some reason.

And lastly you can't install DirectX under linux, there is no need to do so, if you manage to install it anyway you will not accomplish anything as WINE uses it's own d3d libraries.

July 6th, 2007, 01:29 AM
Sorry, I made a major mistake. When I installed Wine, I installed it right after I installed Ubuntu. So I was an older version. I just added another source for wine to my repositories and it works perfectly.

As for OpenGL on my WoW, it freezes while I load. I added d3d but unfortunately, the graphics suck.

But anyway, I got the game working on whatever its running on right now :S (Its not on OpenGL or d3d).

Thanks anyways for the talking too.

July 6th, 2007, 01:35 AM
Sorry if I was blunt, lack of sleep. >.<

Glad it works, but I have to say it's one or the other, WoW defaults to d3d. It can't be neither mode, it's not possible. But it works is the important thing.

July 6th, 2007, 01:52 AM

July 6th, 2007, 07:28 AM
D3D is all that will work with my intel graphics chip so no open gl for me, as ideal as it is i guess...

July 6th, 2007, 05:03 PM
In my experience d3d is a little better at running when there are issues, while opengl either works or it doesn't.

July 14th, 2007, 03:00 PM
I recently installed a new version of wine and now my Warcraft is crashing.
I'll be able to login and be able to enter the world, but when my character model is loading it crashes.
Attached is the output from start to finish.
I don't know how to fix this. Please help.

July 14th, 2007, 03:59 PM
It's called a regression. As some things in development get better some other things break. It happens because the Wine packages aren't tested before they are released. They are simply snapshots of the current development, that are made at a fixed two weeks interval.

Go here for the older packages: http://wine.budgetdedicated.com/archive/index.html

December 25th, 2007, 01:02 AM
To anyone else who's having the same trouble, I fixed this problem by changing my "Enable hardware cursor" setting (I also changed the "Smooth Cursor" setting, but I don't think that was the issue.

I don't know if this is something that would have helped you, or just that I ran into a different problem with the same symptom, I'm quite new. Hopefully that helps someone tho'. ^^