View Full Version : Command & Conquer 3 - Tiberium Wars

April 9th, 2007, 09:44 PM
Anybody got C&C3 working in Ubuntu yet?

I've been playing the series since the very first Command & Conquer. Just bought C&C3 and would like to avoid booting into windows to play it.

The game is great. It's pretty much the same game as it always has been (standard RTS fare). Good looking, well balanced and fun to play.

April 9th, 2007, 10:07 PM
I haven't tried playing on ubuntu yet but i have played it on my windows:) great game worth booting to windows for:)

April 9th, 2007, 11:59 PM
Haven't tried it yet myself. Go to http://appdb.winehq.org/appview.php?iAppId=4671 and check out how other people are getting it to work. Would be useful for me - I don't dual-boot windows anymore, thank god.

April 12th, 2007, 10:59 AM
i tried yesterday with the new release of cedega 6.0.
First i come in to some problems with the with the windows installer. It said, cant find F:\INSTMSIA.EXE

I solved this by downloading InstMsia.exe from microsoft.com, installed this into cedega. Then i put in my C&C Tiberium Wars, Kane edition dvd, installed with setup.exe.

When installing the game, you have to use the same install name as you chose when installing the windows installer.

The setup.exe now can take use of the installed windows installer. Now the Tiberium Wars start to install.

The problem occurs when you have read the license agreement. You sign for 'agree', and continue the process. It now got a error that halts the program. Permission denied for the file: Command and Conquer 3_code.exe

So this is how far i have come until now..

April 12th, 2007, 11:11 AM
Kill the hanging process, which just shows as a white screen, and the installer will complete. Not managed to get it to run though :(

April 12th, 2007, 12:50 PM
Interresting.. I never get this white screen you are talking about. In my case, it just exits when it get this permission denied error.

I will try more this afternoon. :)

April 18th, 2007, 02:48 PM
I'm locking up at the copying files stage. I tried following the install directions with wine and crossover and still no-go thought it is listed as a working product if you install with crossover.

justin whitaker
April 18th, 2007, 03:08 PM
I'm locking up at the copying files stage. I tried following the install directions with wine and crossover and still no-go thought it is listed as a working product if you install with crossover.

Try dumping the files on the discs into a folder, and install from there. That usually works with the file copy errors.

April 18th, 2007, 06:46 PM
I get an error launching the installer even with CrossOver.. Does it have to be 6.01?

May 4th, 2007, 11:01 AM
I tried copying all files over from my windows install along with any references to it anywhere else on the HDD including the reg. But still didn't work.

Ah well, I gladly boot into windows for it. I feel dirty...but man its worth it

December 20th, 2007, 02:59 AM
runs perfectly fine in with Wine. There is one very annoying problem though. When I try playing with a friend of mine on a Lan, that won't work. I am currently trying to go about it with the friendly help of Hamachi, but that ain't workin either, so far anyway. I cannot change the Online IP address in the settings, which I would need to change to the one set by hamachi. But the dropdown is disabled. So I am stomped here. I tried changing the Options.ini but that did not wok, so if anyone has ANY idea on how I can link up to a windows machine, that would be wonderful!


December 20th, 2007, 09:37 PM
I had it running fine on cedega, can't remember what the hell I did but I also got it running in wine (Seems to have suffered a regression as it won't even install now.) but in Wine most of the snazzy grpahics need to be turned off.

Pretty certain I had to use a nocd crack to get it working.

It ran perfectly on cedega at close to native speeds.

You could try playonlinux


it has support for C&C:TW

December 21st, 2007, 08:09 PM
well that did help, since I can now play with High graphics, so that is nice. But I still have the same networking problem. He sees me, and the games I create but he cannot join them....and I do not see him on my end at all. Any ideas anyone?