PDA

View Full Version : Need JRE



1337sithlord
May 19th, 2005, 03:22 AM
Okay Sun Java isnt working on here, and I need some Java runtime environment for Ubuntu, Does anyone, have one, or know where to get one? Im surprised it isnt here cause ubunut comes with some pretty 1337 software already.

pdk001
May 19th, 2005, 03:37 AM
did u try this way (source is here http://www.ubuntuguide.org/#jre)

wget -c http://frankandjacq.com/ubuntuguide/jre-1_5_0_03-linux-i586.bin
sh jre-1_5_0_03-linux-i586.bin
sudo mkdir /usr/java
sudo mv jre1.5.0_03/ /usr/java/
sudo chown -R root:root /usr/java/jre1.5.0_03/
sudo ln -fs /usr/java/jre1.5.0_03/bin/java /usr/bin/java
sudo ln -fs /usr/java/jre1.5.0_03/bin/java_vm /usr/bin/java_vm
sudo ln -fs /usr/java/jre1.5.0_03/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins/
sudo ln -fs /usr/java/jre1.5.0_03/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla-firefox/plugins/
java -version

WildTangent
May 19th, 2005, 03:46 AM
ya, me and my friend here have tried that one, the link seems to be broken

-Wild

bored2k
May 19th, 2005, 04:02 AM
Download http://www.java.com/en/download/manual.jsp
Linux (self-extracting file)(.bin)

sudo apt-get install java-common fakeroot java-package build-essential
fakeroot make-jpkg jre-1_5_0_02-linux-i586.bin
sudo dpkg -i sun-j2re1.5_1.5.0+update02_i386.deb

poofyhairguy
May 19th, 2005, 10:53 AM
? Im surprised it isnt here cause ubunut comes with some pretty 1337 software already.

Thats is because JAVA is tied up by legalities (many restrictions on distrobution).

jdong
May 19th, 2005, 11:03 PM
Add the Ubuntu Backports repositories to your sources.list:


deb http://ftp2.caliu.info/backports hoary-backports main universe multiverse restricted
deb http://ftp2.caliu.info/backports hoary-extras main universe multiverse restricted


then, run apt-get update && apt-get install sun-j2re1.5

that'll automatically install Java for you, including Firefox plugins.

WildTangent
May 20th, 2005, 12:10 AM
w00t! it works!

edit: i should add it was the ubuntuguide method that worked. if i had seen your method jdong about 20 minutes earlier, i woulda tried it, but me and my friend both got it working now :)

-Wild

1337sithlord
May 20th, 2005, 03:45 AM
Yay I got it working too. I was getting so mad, when wild tangent told me that i had to put it in one line at a time lol. Apparently the word wrap combines some lines so they dont go through, and thats why it kept not working. Aaaahh.. well, I'm an idiot. Lol ty