View Full Version : Cannot rename registry keys in WINE regedit

January 31st, 2007, 08:41 PM
Hello, I am new to the Ubuntu community so I will try to explain everything with as much detail as possible. After completing the setup of my last Ubuntu Edgy install, I set out to install games, the first chosen being World of Warcraft and Counter-Strike Source. After full installation of WoW the Wine AppDB website requires that you must disable extensions in regedit by adding a new key and string value. (http://appdb.winehq.org/appview.php?iVersionId=5606). The very first time I accessed this manager I was able to complete the task and rename "New Key #1" to opengl as informed, but for every attempt after this, and even after a complete hard drive wipe and reinstall of Ubuntu Edgy, I still cannot rename the registry keys to add the required extensions to my WINE regedit. Any help will be happily welcomed, as I am getting quite frustrated with this predicament.
Thank You,

January 31st, 2007, 10:19 PM
Sorry to get you excited with a reply to your post.
Just wanted to say that the same exact thing is happening to me and I feel your pain. I recently updated wine and I think this is a symptom of that upgrade. I'll head over to their bug forums and post our problem.

edit: The wine crew is on it. http://bugs.winehq.org/show_bug.cgi?id=7280

January 31st, 2007, 10:57 PM
This may not help, but if you have upgraded wine or have issues with your wine directories, run:


From a terminal. This shouldn't affect any of your settings it will just clean up a few things to make sure everything is setup as it should be.

February 1st, 2007, 03:10 AM
Well thanks a lot cdevil, but does this mean that we will simply have to wait until the next version of WINE? Or is it something odd with our coding...because it seems as though not very many people are having this problem.

February 1st, 2007, 04:18 AM
No no, read the responses. If you expand the field horizontinally until the scroll bar disappears you can rename the key. I just did it. Good luck.

February 1st, 2007, 09:08 PM
Excellent! That fix works perfectly. Thank you very much to both of you. Hopefully this will lead to fixes for everyone else having this problem.

February 1st, 2007, 10:09 PM
I also had this problem. Only I kept on tinkering with regedit, trying to edit other keys, then suddenly it worked after a few minutes. I must have expanded the hierarchical field without noticing :D

Seems like a very small and precise bug. There shouldn't be much code in Wine that can be suspected to be the culprid of this bug.

October 24th, 2008, 09:49 PM
This problem is still not resolved