PDA

View Full Version : Packages now GPG-signed



jdong
May 5th, 2005, 11:27 PM
After reading up on debsign, I've added GPG signatures to all my packages (yep -- all 409!).

This is still uploading, and will take a bit of time to upload!

To take advantage of this, run:



wget http://backports.ubuntuforums.org/backports/pubkey.gpg -O- | sudo apt-key add -

XDevHald
May 5th, 2005, 11:42 PM
After reading up on debsign, I've added GPG signatures to all my packages (yep -- all 409!).

This is still uploading, and will take a bit of time to upload!

To take advantage of this, run:



wget http://backports.ubuntuforums.org/backports/pubkey.gpg -O- | sudo apt-key add -

As well needed indeed! thanks jdong, all 1,422 signed, that's a lot to me, but you guys might have more ;)

Good stuff jdong :D

jdong
May 5th, 2005, 11:49 PM
Ugh, doesn't seem to be working... :(

XDevHald
May 5th, 2005, 11:51 PM
Ugh, doesn't seem to be working... :(
what error you getting?

jdong
May 5th, 2005, 11:57 PM
Still getting "The Following Packages are not Authenticated"

XDevHald
May 6th, 2005, 12:01 AM
Still getting "The Following Packages are not Authenticated"

Very interesting, I'm not getting that error like I did before I added the GPG signatures to the packages :-k

jdong
May 6th, 2005, 12:02 AM
Can you elaborate on how you did it?

Maybe I'm doing something wrong :)

RastaMahata
May 6th, 2005, 01:09 AM
Can you elaborate on how you did it?

Maybe I'm doing something wrong :)
Yeah, I'm still getting "The Following Packages are not Authenticated" :(

jdong
May 6th, 2005, 02:13 AM
It's not Synaptic's/APT's fault -- I'm just being retarded at learning how to sign debs :)

I'll keep on trying in the meantime. However, I don't want to shift too much focus off backporting to sign debs :)

XDevHald
May 6th, 2005, 02:15 AM
It's not Synaptic's/APT's fault -- I'm just being retarded at learning how to sign debs :)

I'll keep on trying in the meantime. However, I don't want to shift too much focus off backporting to sign debs :)

Ok, I take that back I am still getting the error, such as samba from the backports.

I contacted Michael Vogt who is the developer of Synaptic with regards of the error we're getting and also a way to find out on how to get this resolved if not turned off.

I'll keep you updated jdong through PM

jdong
May 6th, 2005, 01:09 PM
Ok, debsigs is DEFINITELY the wrong way -- dpkg spews weird errors about packages being in invalid format.

I'm rolling all packages back to pre-signed status.

slava
May 11th, 2005, 08:01 AM
Hello
I am also having authentication problems...
i called
wget http://backports.ubuntuforums.org/backports/pubkey.gpg -O- | sudo apt-key add -
and it printed out
OK
but the packages from backports are still not authenticated
i checked sudo gpg --list-keys and it seems not have the new key.

Firetech
May 11th, 2005, 08:35 AM
Hello
I am also having authentication problems...
i called
wget http://backports.ubuntuforums.org/backports/pubkey.gpg -O- | sudo apt-key add -
and it printed out
OK
but the packages from backports are still not authenticated
i checked sudo gpg --list-keys and it seems not have the new key.
1. Read the whole thread, jdong couldn't work out how to sign them the right way
2. the correct way to list the keys used by apt is "apt-key list".