PDA

View Full Version : This is odd.



dirtydan
April 28th, 2005, 05:25 AM
If I try to go directly to a sub forum ie Security Announcements I'm not logged in. If I go through the parent forum ie Offical Ubuntu Announcements then Security Announcements I stay logged in. I'm using Netscape 7.2 browser and Windows 98 (it's my wife's computer). Is this a bug or a feature?

AgenT
May 16th, 2005, 05:27 PM
If I try to go directly to a sub forum ie Security Announcements I'm not logged in. If I go through the parent forum ie Offical Ubuntu Announcements then Security Announcements I stay logged in. I'm using Netscape 7.2 browser and Windows 98 (it's my wife's computer). Is this a bug or a feature?

This is because, for whatever strange reason, some links point to the domain with www and others without. And for another strange reason, the cookies are www specific. That is to say, some links are like http://www.ubuntuforums.org and others http://ubuntuforums.org. These two issues combined create the strange situation that if one logs in to the www part, the cookie set is www specific so that any website that does not have the www will not initiate the cookie. Hence you will not be logged in.

Quick Solution: Login to both http://www.ubuntuforums.org and http://ubuntuforums.org.

ubuntu-geek
May 16th, 2005, 05:57 PM
hello, I just fixed this I would suggest deleting your cookie and then re-logging into the forums so it will store the correct cookie information for *.ubuntuforum.org :)

AgenT
May 16th, 2005, 06:19 PM
hello, I just fixed this I would suggest deleting your cookie and then re-logging into the forums so it will store the correct cookie information for *.ubuntuforum.org :)

Wow, talk about a quick response :razz:

dirtydan
May 20th, 2005, 06:03 PM
That's better. Thanks.