View Full Version : "make" or "gmake" not in path!?

September 27th, 2006, 08:22 PM
Hey, Im trying to compile qT and im told:

You don't seem to have 'make' or 'gmake' in your PATH.
Cannot proceed.

Here is my current PATH:

bash: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin: No such file or directory

That last piece of the PATH looks a little wack to me, but I only know enough about the PATH variable to hurt myself. Can someone tell me what needs to be there. and Where make and/or gmake are? When I 'Whereis' them i just get 'make:' What?

September 27th, 2006, 08:31 PM
Did you install build-essential

September 27th, 2006, 08:33 PM
Hadn't, Did now. Thanks.

November 21st, 2006, 11:41 PM
I have the same problem when trying to install postgresql...

and I've installed build-essentials and also the latest make 3.81 through source

but I don't know how to edit my path...

November 21st, 2006, 11:45 PM
You shouldn't really need to... but it's as simple as:

In your case, it would be:
"export PATH=$PATH:addition"

This keeps the old path intact at the same time, using the old variable as part of the new ($PATH). Variables are accessed by using a $ sign. So, to print the path, run "echo $PATH".

To have any command, such as the above, run at every terminal session, edit ~/.bashrc and add your command in somewhere, say, at the bottom. ;)

December 12th, 2006, 04:42 PM
initial errors were gmake not found, and gnumake not found.

apparently still no effect

even did sudo aptitude install build-essential

still no effect

ln -s make /usr/bin/gmake

not effect

ln -s make /usr/bin/gnumake


new output
./COMPILE: 8: gnumake: not found
gnumake: *** No targets specified and no makefile found. Stop.
gmake: *** No targets specified and no makefile found. Stop.
make: *** No targets specified and no makefile found. Stop.

I am trying to install uisp for tinyos (www.tinyos.net) anyone got a method let me know...

December 12th, 2006, 04:45 PM
what i am trying to do is to run the ./COMPILE command as stated in its install readme file as follows:

Installation for TinyOS-specific uisp:

(you can run the commands it contains directly if you prefer)

make install
(you must be root on Linux to perform this step)

WARNING: if you don't use the COMPILE script, you may get compilation
errors (depending on whether you've installed autoconf/etc, and what
versions you have)

December 12th, 2006, 04:46 PM
this is what the ./COMPILE script looks like
if [ ! -f .dates-set ]; then
. ./set-dates
touch .dates-set

gnumake || gmake || make

December 12th, 2006, 04:59 PM
i looked ahead and tried to run ./configure without ./COMPILE, i got the following error

loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal-1.4... missing
checking for working autoconf... found
checking for working automake-1.4... missing
checking for working autoheader... found
checking for working makeinfo... missing
checking for gcc... gcc-4.0
checking whether the C compiler (gcc-4.0 ) works... yes
checking whether the C compiler (gcc-4.0 ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc-4.0 accepts -g... yes
checking for c++... g++-4.0
checking whether the C++ compiler (g++-4.0 ) works... no
configure: error: installation or configuration problem: C++ compiler cannot create executables.

how do figure this... this is really upsetting me

December 12th, 2006, 06:18 PM
ok i thought i would try installing something else in meanwhile for tinyos and i tried to install mspggc

i need to do this as root,,,

but if i do sudo INSTALL_DIR=/opt/msp430 ./build-mspgcc install

i get error INSTALL_DIR is not a command......

how do i run ./build-mspgcc install with an setting INSTALL_DIR=/opt/msp430 in sudo mode????

December 12th, 2006, 06:50 PM
i entered that setting in normal mode INSTALL_DIR=/opt/msp430 and then sudo ./build-mspgcc

and for some reason it worked...it installed a lot of things as well and fetched some programs from ftp sites etc etc

when i came back to ./configure for uisp it was working and it installed when i prompted make install after configuration command.....according to this method,, i didn't use ./COMPILE and didn't require gnumake or gmake thus... strange huh... i think so..

March 12th, 2007, 06:23 PM
yup, that'll work and the reason is because the "sudo" command is expecting the next thing on the line to be either some option/switch or the command/program to run as super-user. A more accurate way to do it all on one line would be like this:

INSTALL_DIR=/opt/msp430 ; sudo ./build-mspgcc

it sets that INSTALL_DIR environment variable first and then runs the ./build-mspgcc as super-user using your normal login environment, including INSTALL_DIR. Ofcourse, doing it on separate lines also works.

FYI, did you know that you can also install Eclipse and the C/C++ dev kit( Eclipse CDT ) in Ubuntu to develop and debug apps for the TI MSP430 chips?

The 'tricks' are as follows:

1) create a normal managed C/C++ make project
2) in the project Properties -> Tool Settings
2a) change the compiler/linker/assembler to use msp430-xxx and add " -mmcu=msp430xXXXX" on these lines too.
3) in the project Properties -> Build Settings
3a) insert "elf" to the Artifact extension
4) in the Run -> Debug... dialog Create a new Debug project
5) in the Main tab:
5a )set the C/C++ Application to Debug/XXXX.elf ( XXXX is your app name )
6) in the Debugger tab:
6a) set Debugger to "gdb Debugger"
6b) still in the Debugger tab but in its "Debugger Options" section:
6b1) enter the "GDB Debugger:" command, msp430-gdb
6b2) enter the "GDB command file:" as gdbinit (note: I just removed the "." )
7) create a "gdbinit" file at your project level and add one line:
load Debug/XXXX.elf
(note: XXXX is your application name. Also, you can not put this command in )
( the Eclipse Run->Debug...->(x)Arguments->Program arguments section )
8) outside of eclipse, create the file ~/.gdbinit with the following lines:
set remoteaddresssize 64
set remotetimeout 999999
target remote localhost:2000
monitor erase all

You should now be able to compile, build, and debug TI MSP430 applications in Eclipse.