PDA

View Full Version : HOW TO: Configure wireless cards with Broadcom chipsets



Pages : [1] 2 3

jonny
April 11th, 2005, 01:00 AM
Edit: bodhi.zazen - Please note, this thread is from 2005 and although it turns up on a google search the information is out of date.

Please see the Ubuntu wiki broadcom page (https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx)



6 July 2006 Update
I haven't had a Broadcom card for many months, but I've been told this how-to doesn't work properly under Dapper. Here are a couple of links that have been passed to me - but I can't vouch for their quality.

http://www.beginningubuntu.com/dapper_tips.html#Using_Ndiswrapper_to_get_wifi_wor king
http://ubuntuforums.org/showthread.php?t=201902

Good luck. I'm very happy that this how-to has helped so many people in the past year or so.

Broadcom wireless cards are tricky to set up in ubuntu, and the forums are full of frustrated users seeking advice. Broadcom provide no Linux support (feel free to complain to your hardware vendor or choose a different card if you haven't yet shelled out your cash), but they can be made to work - and you're in the right place if you want to know how.

First, you need to find out if this How To is for you. Broadcom wireless cards come under many brand names and, in particular, are used in many Dell and Acer laptops. Look for the drivers supplied with your card (Dell usually store a copy in C:/DRIVERS/NETWORK/ADDON); if you have a file called bcmwl5.inf or bcmwl5a.inf then keep on reading. You won't succeed without following these instructions!

0. Before you start, clear out any mess from existing failed attempts to use ndiswrapper. Note that you shouldn't use a root terminal to execute the code in this how-to; use a normal terminal session instead.
sudo modprobe -r bcmwl5
sudo rmmod ndiswrapper
sudo apt-get remove ndiswrapper-utils
sudo rm -r /etc/ndiswrapper/
sudo rm -r /etc/modprobe.d/ndiswrapperSome of these steps may report errors; just ignore them.

1. Copy the bcmwl5.inf and bcmwl5.sys files to your desktop

2. Follow the advice given here under How to add extra repositories (http://ubuntuguide.org/#extrarepositories)

3. Open a terminal session and enter this code. Note that you need an active network connection for this to work; I've assumed that if you have access to a wireless LAN, you also have access to a wired network as a fallback.
sudo apt-get install ndiswrapper-utils
sudo ndiswrapper -i ~/Desktop/bcmwl5.inf
sudo ndiswrapper -m
for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
done4. Reboot your PC. On restarting, the light on your wireless card should come on. If not, try entering
sudo modprobe ndiswrapper5. Your card is now working. Open the networking configuration tool System --> Administration --> Networking

6. Select your wireless network card (probably wlan0) and hit the properties button.

7. Tick the 'This device is configured' box, and enter your network name and connection settings. Ask your office network administrator for support if you don't know what this question means, or copy your settings from Windows.

8. BE CAREFUL entering your WEP key, if you're using one. You're expected to enter this in hexadecimal form; if you don't speak hex, prefix your key with s:

9. Click OK. The screen should close fairly quickly; if it hangs, you probably aren't connected properly.

10. Back in the Network Settings screen, select your wireless device as the default gateway device.

11. Click OK. Again, the screen should close fairly quickly.

12. Enjoy wireless nirvana. If everything works, you can delete the file from your desktop.

13. You might notice that the signal strength applet doesn't work properly. This is a known bug with these cards.

If you have trouble, try booting into Windows - if you dual boot - and checking that the card is enabled. Some laptops allow the wireless card to be switched off, usually with a special key combination, and I've not found a reliable way to make this work in Linux.

(Note: This how-to has been updated to reflect all comments from the thread up to 19 April)

poofyhairguy
April 11th, 2005, 03:02 AM
great Howto. I need this next weekend. What a lifesaver...

Chromance
April 11th, 2005, 05:31 AM
what version of Ndiswrapper is included in the ubuntu 5.04? should be 1.1?

Remix_88
April 12th, 2005, 02:48 PM
You don't have to edit all the .conf files by hand. Replace steps 'sudo gedit' and Step 4 with the following...


$ sed -e 's/RadioState|1/RadioState|0/' /etc/ndiswrapper/bcmwl5/*.conf

kuleali
April 12th, 2005, 04:18 PM
it worked, thank you

jonny
April 12th, 2005, 07:16 PM
You don't have to edit all the .conf files by hand. Replace steps 'sudo gedit' and Step 4 with the following...


$ sed -e 's/RadioState|1/RadioState|0/' /etc/ndiswrapper/bcmwl5/*.confThanks; I've updated the how-to. I knew you could use sed instead of gedit, but couldn't get the syntax quite right. You're obviously smarter then me!

By the way, if you get here from a search engine, I imagine this would work for any other Debian based distros. Steps 5 onward need Gnome, but KDE has equivalent tools.

Musiknonstop
April 13th, 2005, 11:51 PM
Hi,

When I use the sed command the output just oes to the terminal window. The files do not get changed. Does anyone know what I'm doing wrong here?

Thanks

jonny
April 14th, 2005, 01:46 AM
I'll have to test this tomorrow. In the meantime, you need to replace the sed command with these steps:

- sudo gedit
- This will open a text editor. Open every file in the directory /etc/ndiswrapper/bcmwl5/ and replace every instance of RadioState|1 with RadioState|0
- continue with step 4

Sorry for the confusion.

Antman
April 14th, 2005, 04:20 AM
Thank you, thank you, thank you. I knew all the steps but the "sed" step.

I'm going to boot into Ubuntu now and try it. :smile:

Ant

Antman
April 14th, 2005, 05:05 AM
I'll have to test this tomorrow. In the meantime, you need to replace the sed command with these steps:

- sudo gedit
- This will open a text editor. Open every file in the directory /etc/ndiswrapper/bcmwl5/ and replace every instance of RadioState|1 with RadioState|0
- continue with step 4

Sorry for the confusion.

Johnny,

Thanks for posting this. After I edited the .conf files my card started working after doing modprobe. Writing post via my new wireless Ubuntu laptop.... \\:D/

Ant

jonny
April 14th, 2005, 09:19 AM
I've updated the code to correct the error reported by Antman. If you get any trouble, drop the 3 lines beginning with "for confile in..." and follow the temorary instructions that I gave to him (her?).

Could the first person to use this please report whether it succeeded. It's hard for me to test it properly, as my wireless lan's already working!

jdodson
April 14th, 2005, 07:03 PM
what version of Ndiswrapper is included in the ubuntu 5.04? should be 1.1?

its something like 1.0rc2 if memory serves. it works really well from what i have seen. occasionally there are some hiccups, but it is pretty stable.

kb00heda
April 15th, 2005, 05:07 PM
Thanks jonny!

It worked perfect on my Acer Ferrari 3000 laptop. Had to "sudo modprobe ndiswrapper" after login, for wlan0 to show up as a selectable option in Gnome (i.e. under the network settings), but afterwards it was all OK.

Is there a way to do the configure the network settings outside Gnome, e.g., in XFCE, which I'm currently using? I suppose there must be but I don't know how. Does anyone else know better?

P.S. This message was also written/posted using WLAN. D.S. :)

jonny
April 15th, 2005, 05:21 PM
Is there a way to do the configure the network settings outside Gnome, e.g., in XFCE, which I'm currently using? I suppose there must be but I don't know how. Does anyone else know better?

It's fairly simple to define network settings from the command line. Without creating an enormous tutorial, this is what you do:

- Create some entries in /etc/network/interfaces. The man pages for this file are pretty good, so you shouldn't have too much difficulty. It's particularly powerful if you use the pre up, post up, pre down and post down functionality - for example to load / unload ndiswrapper or to mount / unmount network drives.

- To start, simply type sudo ifup. Again, the man pages are good.

- sudo ifdown will disconnect you.

Bear in mind that the gnome networking tool overwrites this file. Keep a backup if you ever plan to use that tool, or your hard work might be destroyed.

fazer
April 15th, 2005, 09:06 PM
Hello,

I have a MN 720 Wifi card ( made from Microsoft) and I heard that it uses the Broadcom chipset. I was wondeirng that if I could use this how-to:
http://tuxspot.blogspot.com/2005/02/microsoft-mn-720-driver-update.html

will I have the same results? That how-to was done on Suse 9.2. Will I get the same results in Ubuntu?

Thanks.

vaughnet
April 17th, 2005, 05:43 AM
I've updated the code to correct the error reported by Antman. If you get any trouble, drop the 3 lines beginning with "for confile in..." and follow the temorary instructions that I gave to him (her?).

Could the first person to use this please report whether it succeeded. It's hard for me to test it properly, as my wireless lan's already working!
Hello,
I am brand new to linux and chose Ubuntu for the great community that seems to surround it. I am trying to get a Dell TrueMobile 1300 up and running with this "how to". I didn't have any trouble until I rebooted with no luck.

Upon entering "sudo modprobe ndiswrapper" I get the following message:

FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted

Any help would be greatly appreciated.

sparke67
April 17th, 2005, 05:22 PM
Hello,
I am brand new to linux and chose Ubuntu for the great community that seems to surround it. I am trying to get a Dell TrueMobile 1300 up and running with this "how to". I didn't have any trouble until I rebooted with no luck.

Upon entering "sudo modprobe ndiswrapper" I get the following message:

FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted

Any help would be greatly appreciated.
thanks for great write up I was directed here by fellow user with great patience --- I too an new and geting this :

sparke67@shawnlinux:~ $ sudo ndiswrapper -m
Adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper
sparke67@shawnlinux:~ $ for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
> sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
> done
bash: /etc/ndiswrapper/bcmwl5/14E4:4301.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4307.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4321.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324.conf: Permission denied
sparke67@shawnlinux:~ $

sparke67
April 17th, 2005, 05:36 PM
re ran as root and now like the other guy:
sparke67@shawnlinux:~ $ sudo modprobe ndiswrapper
Password:
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.8.1-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Invalid module format
sparke67@shawnlinux:~ $

jonny
April 17th, 2005, 09:38 PM
re ran as root and now like the other guy:
sparke67@shawnlinux:~ $ sudo modprobe ndiswrapper
Password:
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.8.1-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Invalid module format
sparke67@shawnlinux:~ $Hmmm, that's two of you with an almost identical error message that I've never heard reported before. I don't know what the issue is, but I suggest a few routes for exploring possible solutions:

1. Start again from the beginning. Use
sudo modprobe -r bcmwl5
sudo rmmod ndiswrapper
sudo rm -r /etc/ndiswrapper/bcmwl5 to undo the effects of what you've done to date.
2. There are two drivers associated with thes cards, bcmwl5 and bcmwl5a. Most cards can accept either (mine certainly can), but some can only accept one or the other. If you have the 5a driver available, try repeating the how-to but repeat every instance of "bcmwl5" with "bcmwl5a".
3. Try downloading the latest version of the XP drivers from Dell's website (http://support.dell.com/support/downloads/index.aspx?c=us&cs=19&l=en&s=dhs) and starting again. Try using both bcmwl5 and bcmwl5a
4. Just in case my script isn't working properly in all cases, try this: replace the three lines beginning with "for conffile...", "sudo cat..." and "done" with "sudo gedit". This will open a text editor; use it to open every file in the directory /etc/ndiswrapper/bcmwl5/ and replace every instance of RadioState|1 with RadioState|0
5. (Yuk) Try grabbing the latest version of ndiswrapper and compiling it yourself. You'll find several sets of instructions between the forums and the wiki.

Please post your results for the benefit of the rest of the community.

sparke67
April 17th, 2005, 11:25 PM
Some results of trying the first part :

sparke67@shawnlinux:~ $ sudo ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present, hardware present
sparke67@shawnlinux:~ $ sudo ndiswrapper -e bcmwl5
sparke67@shawnlinux:~ $ sudo ndiswrapper -l
No drivers installed


sparke67@shawnlinux:~ $ sudo rmmod ndiswrapper
ERROR: Module ndiswrapper does not exist in /proc/modules

sparke67@shawnlinux:~ $ sudo rm -r /etc/ndiswrapper/bcmwl5
rm: cannot remove `/etc/ndiswrapper/bcmwl5': No such file or directory
sparke67@shawnlinux:~ $

Seth
April 18th, 2005, 12:11 AM
What does dmesg say after you try to modprobe it and it's invalid? I'll bet you have a compiler mismatch.

vaughnet
April 18th, 2005, 12:23 AM
Hmmm, that's two of you with an almost identical error message that I've never heard reported before. I don't know what the issue is, but I suggest a few routes for exploring possible solutions:

1. Start again from the beginning. Use
sudo modprobe -r bcmwl5
sudo rmmod ndiswrapper
sudo rm -r /etc/ndiswrapper/bcmwl5 to undo the effects of what you've done to date.
2. There are two drivers associated with thes cards, bcmwl5 and bcmwl5a. Most cards can accept either (mine certainly can), but some can only accept one or the other. If you have the 5a driver available, try repeating the how-to but repeat every instance of "bcmwl5" with "bcmwl5a".
3. Try downloading the latest version of the XP drivers from Dell's website (http://support.dell.com/support/downloads/index.aspx?c=us&cs=19&l=en&s=dhs) and starting again. Try using both bcmwl5 and bcmwl5a
4. Just in case my script isn't working properly in all cases, try this: replace the three lines beginning with "for conffile...", "sudo cat..." and "done" with "sudo gedit". This will open a text editor; use it to open every file in the directory /etc/ndiswrapper/bcmwl5/ and replace every instance of RadioState|1 with RadioState|0
5. (Yuk) Try grabbing the latest version of ndiswrapper and compiling it yourself. You'll find several sets of instructions between the forums and the wiki.

Please post your results for the benefit of the rest of the community.
1. I started again from the beginning.
2. I tried both drivers (starting from the beginning each time with the most recent version of each).
3. Double-checked with downloaded drivers from Dell.
4. Manually changed the RadioState for each .conf file
5. Researched and compiled the latest ndiswrapper (1.1)

Finally got this result:


root@laptop:/home/vaughnet # modprobe ndiswrapper
root@laptop:/home/vaughnet #

Then went to System>Administration>Networking only to find no available wireless interface. Numerous restarts and plugging the card in and out has seemed to work. I truly believe I have exhausted every conceivable option. Any ideas...?

sparke67
April 18th, 2005, 04:16 AM
What does dmesg say after you try to modprobe it and it's invalid? I'll bet you have a compiler mismatch.

is this what I am looking for ?

sparke67@shawnlinux:~ $ dmesg
Linux version 2.6.8.1-5-386 (buildd@rothera) (gcc version 3.3.4 (Debian 1:3.3.4-9ubuntu5)) #1 Thu Apr 7 08:47:11 UTC 2005

or maybe this ?

ndiswrapper version 0.10 loaded (preempt=yes,smp=no)
ndiswrapper (wrapper_init:2286): loadndiswrapper failed (1536);check utils version mismatch
ndiswrapper version 0.10 loaded (preempt=yes,smp=no)
ndiswrapper (wrapper_init:2286): loadndiswrapper failed (1536);check utils version mismatch
sparke67@shawnlinux:~ $

](*,)

darthsabbath
April 18th, 2005, 07:04 AM
Something interesting... my wireless was working fine until I did a clean installation of Hoary. I'd originally started with the Release Candidate, and once I changed the RadioState, everything was gravy.

However, I formatted and reinstalled to the "official" release, and now I'm getting the same "Error inserting ndiswrapper" issue that you guys are getting. Were there any changes between the Release Candidates and the Official release that could've caused this?

Gonna play with it some tomorrow and see what I can figure out...

Serves me right for doing a format and reinstall. :-P

Phil

jonny
April 18th, 2005, 09:55 AM
Something interesting... my wireless was working fine until I did a clean installation of Hoary. I'd originally started with the Release Candidate, and once I changed the RadioState, everything was gravy.Phil, you might be on to something here. My how-to was based on the release candidate too.

Good luck!

sparke67
April 18th, 2005, 12:24 PM
Phil, you might be on to something here. My how-to was based on the release candidate too.

Good luck!
could that be the reason for this ?

ndiswrapper version 0.10 loaded (preempt=yes,smp=no)
ndiswrapper (wrapper_init:2286): loadndiswrapper failed (1536);check utils version mismatch
ndiswrapper version 0.10 loaded (preempt=yes,smp=no)
ndiswrapper (wrapper_init:2286): loadndiswrapper failed (1536);check utils version mismatch
sparke67@shawnlinux:~ $

allen
April 18th, 2005, 02:01 PM
hopefully you work something out phil,

i'm having the exact same problems as the others.

mine is a BT Voyager 1040 pci card and following the instructions gives the same errors as you described.

Seth
April 18th, 2005, 02:32 PM
Phil, the version of utils in the repo's is something like .12. Looks like you're trying to use .10 of ndiswrapper. Grab ndiswrapper-source and ndiswrapper-utils out of the repo's and build your own set?

allen
April 18th, 2005, 02:34 PM
heres a log of my problems


root@allens:/home/allen # modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted
root@allens:/home/allen # ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present, hardware present
root@allens:/home/allen # dmesg

[*snip*]

ndiswrapper version 1.0rc2 loaded (preempt=yes,smp=no)
ndiswrapper (wrapper_init:1494): loadndiswrapper failed (1792); check system log for messages from 'loadndisdriver'


where would i find the system log ?

darthsabbath
April 18th, 2005, 04:46 PM
Can't try any of this now, as I'm at work, but wanted to add that the ndiswrapper-utils I installed off the Hoary CD are version 0.11. When I get home, I'll hook it up to my LAN and download the latest versions of both the kernel and ndiswrapper.

Phil

sparke67
April 18th, 2005, 07:24 PM
Oh God !!! The nightmare is over.

All I did was remove NDISWRAPPER via synaptic.
Reboot and re add it again !!
I re ran modprobe and BOOM the lights show up at 100 % signal strength !!
All is re ran dmesg and it shows there also.

I did notice that after re installing ndiswrapper via synaotic I got different prompt about the the drivers not being supported by Ubuntu !!!

Thanks everyone who got me thinking along the right path -- \\:D/
WARNING:
This tool allows you to use a driver written for the Windows operating
system on Ubuntu. Please note that the use of such drivers is entirely
unsupportable by the Ubuntu team, and not recommended, even if it is
theoretically possible with this tool.

bcmwl5 is already installed. Use -e to remove it

sparke67@shawnlinux:~ $ sudo modprobe ndiswrapper

sparke67@shawnlinux:~ $ dmesg
Linux version 2.6.8.1-5-386 (buildd@rothera) (gcc version 3.3.4 (Debian 1:3.3.4-9ubuntu5)) #1 Thu Apr 7 08:47:11 UTC 2005

CPU: AMD Mobile AMD Athlon(tm) XP 2400+ stepping 00
Enabling fast FPU save and restore... done.

blah blah blah .......

wlan0: ndiswrapper ethernet device 00:90:96:70:d3:68 using driver bcmwl5.sys
ndiswrapper device wlan0 supports WPA with AES/CCMP and TKIP ciphers
ndiswrapper: driver bcmwl5.sys (Broadcom,06/13/2003, 3.20.23.0) added
sparke67@shawnlinux:~ $

jonny
April 18th, 2005, 09:07 PM
If I understand events properly, I should update the how-to to add the following steps right at the start:

- remove any previous attempts at using ndiswrapper (remove the .inf file, remove the module and remove any residual files lurking around
- remove any existing versions of ndiswrapper
- remove the CD from the sources list

...and then continue as previously documented. Does that sound right, sparke67? Does it work for everyone else? If so, I'll put it into noob friendly language and update accordingly.

sparke67
April 18th, 2005, 09:27 PM
yes that is what I did. I try to complile myself because I did not even know what synaptic was when I downloaded NDISWrapper the first time and tried to compile it.

I deleted all references to it I had downloaded. Removed and re added via Synaptic. Rebooted and was good to go --- unfortunatly I am next to unsecured wireless connection and can not use the network tool to add it - or maybe I can but don't know who to enter the info here but neverless I have rebooted 4 times and it works each time ..

I hope this will help someone else //// :)


****** one thing I forgot, at each reboot I do have to run ---sudo modprobe ndiswrapper --- for the card to activate but this is small and I am sure I could play with it to go at start but for now I am happy --- :wink: ;-)

darthsabbath
April 19th, 2005, 06:37 AM
Hrm. When I got home, I tried the above steps (removing Ndiswrapper and all associated files), then reinstalled from the repo... same problem. :/ One question: when you removed Ndiswrapper, what else did you take out?

I removed:
ndiswrapper-utils
/etc/ndiswrapper/
/etc/modprobe.d/ndiswrapper

Anything else?

I also tried installing the latest 686 kernel, same problem.

I guess I can always go back to the release candidate and just upgrade, but damnit, I wanna know the problem. ;-)

Phil

jonny
April 19th, 2005, 01:25 PM
I don't know if this has affected you, but have you copied the file bcmwl5.sys to your desktop along with bcmwl5.inf. I've just realised that I missed this out of the how-to (it's about to be corrected).

If my faulty instructions are to blame, then I'm terribly sorry to have caused you so much hassle...

dcraven
April 19th, 2005, 03:08 PM
Just in case anyone needs/wants to compile the newerver ndiswrapper v1.1, there are instructions on the wiki here (http://www.ubuntulinux.org/wiki/SetupNdiswrapperHowto).

HTH,
~djc

darthsabbath
April 20th, 2005, 04:01 AM
Interestingly enough, I did a clean install of the Hoary Preview Release, and I experienced the same problem, so I remembered something from when I first installed Hoary... I'd turned off my wireless card, and it took me forever to figure out why it wasn't finding my wireless access point.

So I turned off my wireless, installed ndiswrapper, ran modprobe... BOOM! Turned on wireless, it works!

Amazing the little quirks of Linux, eh? ;-) Still, I'm happy I got it working! Thanks ot all!

Phil

jonny
April 20th, 2005, 09:54 AM
Interestingly enough, I did a clean install of the Hoary Preview Release, and I experienced the same problem, so I remembered something from when I first installed Hoary... I'd turned off my wireless card, and it took me forever to figure out why it wasn't finding my wireless access point.

So I turned off my wireless, installed ndiswrapper, ran modprobe... BOOM! Turned on wireless, it works!

Amazing the little quirks of Linux, eh? ;-) Still, I'm happy I got it working! Thanks ot all!

PhilThat's something else that I found out the hard way. My laptop has an unmarked Fn+F2 key combination that toggles wireless activity. In Linux, it only switches the wireless off, and the only way that I've found to re-enable power is to boot into Windows and press Fn+F2 again.

I've added a note to the How-to to this effect.

slipp3dstr3am
April 20th, 2005, 10:05 PM
yes I have done it.... it only took me 2 weeks of reading and trying to figure out what i was doing wrong but i did it and now i'm wire free....

thanks to every one that has posted in here ... you have no idea how much this n00b feels right now ... \\:D/ \\:D/ \\:D/ \\:D/ \\:D/ \\:D/ \\:D/ \\:D/

slipp3dstr3am
April 25th, 2005, 06:35 PM
Broadcom wireless cards are tricky to set up in ubuntu, and the forums are full of frustrated users seeking advice. Broadcom provide no Linux support (feel free to complain to your hardware vendor or choose a different card if you haven't yet shelled out your cash), but they can be made to work - and you're in the right place if you want to know how.

First, you need to find out if this How To is for you. Broadcom wireless cards come under many brand names and, in particular, are used in many Dell and Acer laptops. Look for the drivers supplied with your card (Dell usually store a copy in C:/DRIVERS/NETWORK/ADDON); if you have a file called bcmwl5.inf or bcmwl5a.inf then keep on reading. You won't succeed without following these instructions!

0. Before you start, clear out any mess from existing failed attempts to use ndiswrapper.
sudo modprobe -r bcmwl5
sudo rmmod ndiswrapper
sudo apt-get remove ndiswrapper-utils
sudo rm -r /etc/ndiswrapper/
sudo rm -r /etc/modprobe.d/ndiswrapperSome of these steps may report errors; just ignore them.

1. Copy the bcmwl5.inf and bcmwl5.sys files to your desktop

2. Follow the advice given here under How to add extra repositories (http://ubuntuguide.org/#extrarepositories)

3. Open a terminal session and enter this code. Note that you need an active network connection for this to work; I've assumed that if you have access to a wireless LAN, you also have access to a wired network as a fallback.
sudo apt-get install ndiswrapper-utils
sudo ndiswrapper -i ~/Desktop/bcmwl5.inf
sudo ndiswrapper -m
for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
done4. Reboot your PC. On restarting, the light on your wireless card should come on. If not, try entering
sudo modprobe ndiswrapper5. Your card is now working. Open the networking configuration tool System --> Administration --> Networking

6. Select your wireless network card (probably wlan0) and hit the properties button.

7. Tick the 'This device is configured' box, and enter your network name and connection settings. Ask your office network administrator for support if you don't know what this question means, or copy your settings from Windows.

8. BE CAREFUL entering your WEP key, if you're using one. You're expected to enter this in hexadecimal form; if you don't speak hex, prefix your key with s:

9. Click OK. The screen should close fairly quickly; if it hangs, you probably aren't connected properly.

10. Back in the Network Settings screen, select your wireless device as the default gateway device.

11. Click OK. Again, the screen should close fairly quickly.

12. Enjoy wireless nirvana. If everything works, you can delete the file from your desktop.

13. You might notice that the signal strength applet doesn't work properly. This is a known bug with these cards.

If you have trouble, try booting into Windows - if you dual boot - and checking that the card is enabled. Some laptops allow the wireless card to be switched off, usually with a special key combination, and I've not found a reliable way to make this work in Linux.

(Note: This how-to has been updated to reflect all comments from the thread up to 19 April)





is there any way to get this pinned?
i would hate for some one to miss this

jardasarp
April 27th, 2005, 09:04 AM
jonny, you are a god among men :smile:

I tried installing this on a Kubuntu 5.04 stable release and it worked fine with a Linksys WPC54G.

It should be noted that any supplementary wifi apps should be installed BEFORE doing this, as programs like wpa_supplicant seem to *** up the settings on the card (could scan before installing other wifi apps, but not afterward).

Staesys
April 28th, 2005, 12:39 PM
I've followed your steps closely for my Motorola WN825G PCMCIA wireless card and I can now get the power light to come on, but there is no communication through it at all. Here's some info:

root@ubuntu:/home/paul # iwconfig wlan0
wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:C0AD-9DDC-5AFD-BC8B-AA46-CAE5-98 Security mode:restricted
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:9253 Missed beacon:0

root@ubuntu:/home/paul # dhclient wlan0
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/wlan0/00:0c:e5:52:a9:89
Sending on LPF/wlan0/00:0c:e5:52:a9:89
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

It can however scan for access points:

root@ubuntu:/home/paul # iwlist wlan0 scanning
wlan0 Scan completed :
Cell 01 - Address: 00:06:25:51:D2:2A
ESSID:"@home"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:0/100 Signal level:-70 dBm Noise level:-256 dBm
Encryption key:on
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 02 - Address: 00:11:50:0F:0F:EB
ESSID:"barry"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:0/100 Signal level:-88 dBm Noise level:-256 dBm
Encryption key:on
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:54 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:12 Mb/s
Bit Rate:48 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 03 - Address: 00:09:5B:4E:D9:DA
ESSID:"NETGEAR"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-86 dBm Noise level:-256 dBm
Encryption key:off
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:12 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:48 Mb/s
Bit Rate:54 Mb/s
Extra:bcn_int=100
Extra:atim=0

Any ideas?

-Paul

kmyram
April 28th, 2005, 12:49 PM
ESSID:"@home"
ESSID:"barry"
ESSID:"NETGEAR"

So, these are the AP's you can see - which is yours? If it's "@home" then try:

$ iwconfig wlan0 essid @home
$ iwconfig wlan0 key C0AD-9DDC-5AFD-BC8B-AA46-CAE5-98
$ dhclient wlan0

Should work (if the key is right too :))

Staesys
April 28th, 2005, 01:14 PM
root@ubuntu:/home/paul # iwconfig wlan0 essid @home
root@ubuntu:/home/paul # iwconfig wlan0 key C0AD9DDC5AFDBC8BAA46CAE598
root@ubuntu:/home/paul # dhclient wlan0
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/wlan0/00:0c:e5:52:a9:89
Sending on LPF/wlan0/00:0c:e5:52:a9:89
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Yeah, @home's mine...

I also tried it with the "-"'s in the key and it didn't make any difference.

I'm guessing it's either not transmitting or not recieving...perhaps both... I know this card works, and I know the AP works, it's just getting this card working in Linux that's the rub...

Thanks, btw, I appreciate the help!

-Paul

jonny
April 28th, 2005, 05:16 PM
Personally, I failed to configure my card using iwconfig, ifconfig, and dhclient - that's why I recommended using the Gnome tools - so I'm not the best person to advise you. Your card is certainly receiving signals, but it's unclear to me why your DHCP request isn't being honoured.

You could try first removing WEP from the network. That would eliminate a potential failure point.

Another approach that you might want to try is to use the Debian command line tools for networking. That involves putting some entries into /etc/network and using ifup and ifdown to start and stop the network. This works perfectly for me.

man interfaces and man ifup will give you the information you need.

Staesys
April 29th, 2005, 09:48 AM
Know what?

I removed WEP and the card connected, in fact, I'm using it right now. I don't like to running an open WAP though, any ideas on how I can get WEP to work?

-Paul

jonny
April 29th, 2005, 12:59 PM
Presumably you've tried the gnome tool described in the how-to? And, if you entered your WEP key as a 5 or 13 character string, you put s: in front of it? And you're sure the '@' symbol in your network name's not causing trouble?

If so, try editing /etc/network/interfaces directly. Replace the existing stanza (if any) that refers to your card with this:
iface wlan0 inet dhcp
wireless-essid @home
wireless-key s:paulzSet the WEP key on your router to 'paulz', and try
sudo ifup wlan0

Staesys
May 1st, 2005, 12:43 PM
No go. Everytime I try to enable WEP the card and the wap stop talking. I'm really not sure what to do at this point.

My notebook has an internal card (802.11b), but it sucks and the one I'm using now supports 802.11g. Thing is, I had the same trouble with that one too. Currently, it's disabled and turned off so the only card I'm using is the Broadcom based (Motorola) card.

I tried it at two seperate coffe shops today and was able to connect to their wap's, although they were not running WEP.

I'm beginning to think there's something screwy in my setup or something...

-Paul :-?

spd106
May 1st, 2005, 09:18 PM
Hi, you could try setting the key mode to open instead of the default restricted, maybe also specify the channel your AP is using. Though that shouldn't be necessary.


iwconfig wlan0 key open XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX

Staesys
May 2nd, 2005, 06:01 AM
Thanks everyone for their help. I finally fixed it... I went out and got a Belkin F5D7230-4 Wireless-G router to replace my Linksys WAP11. I set it up with 128 bit WEP encryption and entered the WEP key into System -> Administration -> Networking.

Guess what...?

The damn thing works now.

I guess my WAP11 wasn't allowing my card to connect with 128 bit WEP set up. Funny thing, it's the same card that connected just fine when I had Windows XP on this laptop. Oh well, I've got a better Router/AP now anyway.

:-)

-Paul

chroland
May 2nd, 2005, 06:59 PM
root@ubuntu:/home/paul # iwconfig wlan0 essid @home
root@ubuntu:/home/paul # iwconfig wlan0 key C0AD9DDC5AFDBC8BAA46CAE598
root@ubuntu:/home/paul # dhclient wlan0
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/wlan0/00:0c:e5:52:a9:89
Sending on LPF/wlan0/00:0c:e5:52:a9:89
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Yeah, @home's mine...

I also tried it with the "-"'s in the key and it didn't make any difference.

I'm guessing it's either not transmitting or not recieving...perhaps both... I know this card works, and I know the AP works, it's just getting this card working in Linux that's the rub...

Thanks, btw, I appreciate the help!

-Paul
hi! i ve excatly the same problem with an hp compaq nx9105 laptop with an integrated broadcom wirelless card.
I can now get the power light to come on, but there is no communication through it at all. when i switch to windows there is no problem an ican connect to the internet with my usrobotics wireless router

can you help me

Staesys
May 2nd, 2005, 07:35 PM
Have you tried running your router and card without wep? That was the only way I could get it to work on my Linksys WAP11. I just changed to a Belkin wireless router and was able to get it to work with 128 bit WEP encryption right off the bat.

what does a:


iwconfig
show?

Also...


iwlist scanning
Will show if you can see the access points around you.


ifconfig
Will show the wireless access card(s) configuration info.

Get me this info so I can see what's going on...

-Paul

Kbel
May 3rd, 2005, 08:34 PM
i am also having a problem with an HP laptop broadcom wlan
it simply does not pick up any networks with iwlist

Hieronymus
May 3rd, 2005, 08:38 PM
i am also having a problem with an HP laptop broadcom wlan
it simply does not pick up any networks with iwlist

I have had the same problem with my HP laptop broadcom wlan, the solution was to uninstall ndiswrapper version 1.1 and to install ndiswrapper version 1.2. You can download this here http://sourceforge.net/project/showfiles.php?group_id=93482&package_id=125562&release_id=319772

just unpack, make and make install after you have removed the old version.

Good luck

Kbel
May 4th, 2005, 02:57 PM
I have had the same problem with my HP laptop broadcom wlan, the solution was to uninstall ndiswrapper version 1.1 and to install ndiswrapper version 1.2. You can download this here http://sourceforge.net/project/showfiles.php?group_id=93482&package_id=125562&release_id=319772

just unpack, make and make install after you have removed the old version.

Good luck

It worked thank you very much \\:D/

omegasoul
May 4th, 2005, 09:51 PM
I have had the same problem with my HP laptop broadcom wlan, the solution was to uninstall ndiswrapper version 1.1 and to install ndiswrapper version 1.2. You can download this here http://sourceforge.net/project/showfiles.php?group_id=93482&package_id=125562&release_id=319772

just unpack, make and make install after you have removed the old version.

Good luck
Can you please tell me how to uninstall the old ndiswrapper and install the new without screwing up. I seem to be a complete idiot? Thanks in advance.

Hieronymus
May 4th, 2005, 10:32 PM
Can you please tell me how to uninstall the old ndiswrapper and install the new without screwing up. I seem to be a complete idiot? Thanks in advance.

Well, as follows:



sudo modprobe -r bcmwl5
sudo rmmod ndiswrapper
sudo apt-get remove ndiswrapper-utils
sudo rm -r /etc/ndiswrapper/
sudo rm -r /etc/modprobe.d/ndiswrapper
sudo apt-get install linux-headers-2.6.10 (whatever version)
cd /usr/src/
sudo tar xvzf ndiswrapper-1.2-rc1
cd /usr/src/ndiswrapper-1.2-rc1/
sudo make
sudo make install
cd /the dir where your windows networkdrivers are/
sudo ndiswrapper -i bcmwl5 (or other driver name if you have another card)
sudo ndiswrapper -l (making sure the driver is installed)
sudo modprobe ndiswrapper
sudo dmesg (you sould see that the card is installed)
sudo iwlist wlan0 scan (to get a list of APs)
sudo ndiswrapper -m (ndiswrapper will now be loaded automatic at bootup)


now everything works you can goto network settings in administration. Here you can tell Ubuntu to get a dynamic ip (dhcp) and (if you need it) the wep encryption key. Then activate et voilą.

Good luck, Hieronymus

mike998
May 4th, 2005, 10:37 PM
Thank you Thank you Thank you.
This how-to FINALLY got my wireless up and running!

KrIaXPaTaLa
May 5th, 2005, 01:20 AM
I'm on an acer travelmate 4002 wlmi, followed this howto and wireless works now. Hoary final. Tnkz everyone.



for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
done


In my case, this wasn't necessary. Don't ask me why. In the .conf files I had, there was no "RadioState|1". Just "StateName|" and "RadioEnable|0x1". Didn't changed anything.

Further more, I used this xp driver:
ftp://ftp.support.acer-euro.com/notebook/TravelMate_4000_4500/driver/80211bg.zip

Best regards,

Kriax, Portugal

omegasoul
May 5th, 2005, 02:55 AM
Well, as follows:



sudo modprobe -r bcmwl5
sudo rmmod ndiswrapper
sudo apt-get remove ndiswrapper-utils
sudo rm -r /etc/ndiswrapper/
sudo rm -r /etc/modprobe.d/ndiswrapper
sudo apt-get install linux-headers-2.6.10 (whatever version)
cd /usr/src/
sudo tar xvzf ndiswrapper-1.2-rc1
cd /usr/src/ndiswrapper-1.2-rc1/
sudo make
sudo make install
cd /the dir where your windows networkdrivers are/
sudo ndiswrapper -i bcmwl5 (or other driver name if you have another card)
sudo ndiswrapper -l (making sure the driver is installed)
sudo modprobe ndiswrapper
sudo dmesg (you sould see that the card is installed)
sudo iwlist wlan0 scan (to get a list of APs)
sudo ndiswrapper -m (ndiswrapper will now be loaded automatic at bootup)


now everything works you can goto network settings in administration. Here you can tell Ubuntu to get a dynamic ip (dhcp) and (if you need it) the wep encryption key. Then activate et voilą.

Good luck, Hieronymus


Thanks for your help but I still am wirelessless. When I used the method described by the original poster my light would not even come on. So i followed the instructions here: http://www.ubuntulinux.org/wiki/SetupNdiswrapperHowto

I just replaced ndiswrapper1.1 with ndiswrapper1.2rc1. As a result the pretty little blue light came on but I can not ](*,) connect to the net. I have been working on this for 3 days. Thanks again but I think I have no choice but to go back to the "Darkside" aka Microsoft.

Hieronymus
May 5th, 2005, 09:15 AM
There are two things that I think could be wrong:


If you are using 64 bit Ubuntu you need 64 bit drivers, for my broadcom (the version that works with the bcmwl5 drivers) you can download it here:
http://ubuntuforums.org/attachment.php?attachmentid=186

If you are just using 32 bit ubuntu, are you sure dhcp is running for your wlan card?

dhcp: system >> administration >> networking

then click on the wireless connection, this should be there if de wlan driver is correctly installed, to check this check the output of the following commands:



ndiswrapper -l (shows if the driver is installed correctly)
dmesg (shows if the hardware is recognised correctly)
iwconfig (shows all NICs and tells if they have a wireless extention)


next click on properties and check the radiobutton of "this device is configured" next click on the scroll down menu and choose your essid (access point) then enter (if you have one) your WEP encryption key and click on the configuration scrolldown menu and choose DHCP. Click ok and then on Activate. To test type the following command in a terminal:



ping -c 3 ubuntuforums.org


If this doesn't work, or your stuck earlier in this "how to" please post the output of:



ndiswrapper -l
dmesg
iwconfig


Good luck!

omegasoul
May 5th, 2005, 02:58 PM
Here is the print out from from the commands you mentioned earlier. I hope there is something usefull in them. Also I have an AMD64 processor but I am using the 32 bit version of Ubuntu on a Compaq 3000 with internal wireless. Thanks again for helping me.

strong@omega:~$ ndiswrapper -l
Installed ndis drivers:
bcmwl5 in driver present, hardware present

This is only part of the output from dmesg.
NET: Registered protocol family 17
ndiswrapper version 1.2rc1 loaded (preempt=yes,smp=no)
ndiswrapper: driver bcmwl5 (Broadcom,10/20/2004, 3.70.22.0) loaded
ACPI: PCI Interrupt Link [LNK3] enabled at IRQ 17
ACPI: PCI interrupt 0000:02:02.0[A] -> GSI 17 (level, low) -> IRQ 17
ndiswrapper: using irq 17
wlan0: ndiswrapper ethernet device 00:90:4b:b7:e9:b1 using driver bcmwl5, configuration file 14E4:4320:103C:12F8.5.conf
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP
ACPI: AC Adapter [ACAD] (off-line)
ACPI: Battery Slot [BAT1] (battery present)
ACPI: Power Button (FF) [PWRF]
ACPI: Lid Switch [LID]
ibm_acpi: ec object not found
ACPI: Video Device [VGA] (multi-head: yes rom: no post: no)
apm: BIOS not found.
cs: IO port probe 0x0100-0x04ff: excluding 0x200-0x20f 0x4d0-0x4d7
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0a00-0x0aff: clean.
powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.00.09e)
powernow-k8: 0 : fid 0xa (1800 MHz), vid 0x2 (1500 mV)
powernow-k8: 1 : fid 0x8 (1600 MHz), vid 0x6 (1400 mV)
powernow-k8: 2 : fid 0x0 (800 MHz), vid 0x12 (1100 mV)
cpu_init done, current fid 0x8, vid 0x6
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02f0500(lo)
IPv6 over IPv4 tunneling driver
UDF-fs: No VRS found
ISO 9660 Extensions: Microsoft Joliet Level 3
ISOFS: changing to secondary root
wlan0: no IPv6 routers present
eth0: no IPv6 routers present
UDF-fs: No VRS found
ISO 9660 Extensions: Microsoft Joliet Level 3
ISOFS: changing to secondary root

strong@omega:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:2152800 Missed beacon:0

sit0 no wireless extensions.

Hieronymus
May 5th, 2005, 03:15 PM
Ok, next you have to find your accespoint.



sudo iwlist wlan0 scan


This gives all accesspoint surrounding you, at least there should be your own accesspoint. When you know the name of the accesspoint you want to use (of course you have given this name to the accesspoint yourself :) ) tell the Wlan adapter to connect to it:



sudo iwconfig wlan0 essid accesspoint_name


If you are using WEP encryption make sure that your Wlan adapter knows it:



sudo iwconfig wlan0 enc key


Now you should be connected, see if that is true:



sudo iwconfig


For your system the output should be something like:



strong@omega:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 IEEE 802.11g ESSID: the_name_of_your_AP
Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00 (for 00 read a number, this is the MAC adress of your AP)
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management: off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:2152800 Missed beacon:0


If this is correct you are connected to the AP, now let's connect to the internet:



sudo dhclient wlan0 (assigns a dynamic IP adress to the Wlan adapter)


and test the connection:



sudo ping -c 3 ubuntuforums.org (http://www.ubuntu-linux.nl/)


Et voilą, you are connected.

Tell me if it worked out, grz Hieronymus

eudemon
May 5th, 2005, 03:43 PM
:) Thanks, great howto! Worked perfectly.

omegasoul
May 5th, 2005, 03:55 PM
My AP was detected but here is my system output

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:2350866 Missed beacon:0

I know my AP was detected because I verified the MAC address on the router.
:-|
I copied and pasted the commands into my terminal so I dont think I put the wrong commands in. Do I need to add in the " " around the name of the AP or reset it?

Hieronymus
May 5th, 2005, 04:05 PM
Ok, here is the output I get when I do all the steps, maybe it helps.



root@home:/home/dusty # iwlist wlan0 scan
Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 Scan completed :
Cell 01 - Address: 00:90:96:CF:3B:60
ESSID:"Homenet"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.452 GHz (Channel 9)
Quality:0/100 Signal level:-54 dBm Noise level:-256 dBm
Encryption key:on
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Extra:bcn_int=100
Extra:atim=0

root@home:/home/dusty # iwconfig wlan0 essid Homenet
root@home:/home/dusty # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 IEEE 802.11b ESSID:"Homenet"
Mode:Managed Frequency:2.452 GHz Access Point: 00:90:96:CF:3B:60
Bit Rate=11 Mb/s Tx-Power:25 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:xxxx-xxxx-x Security mode:restricted
Power Management:off
Link Quality:100/100 Signal level:-51 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:6 Invalid misc:75 Missed beacon:0

sit0 no wireless extensions.

root@home:/home/dusty # iwconfig wlan0 enc xxxxxxxxxx (here was my key, but I would like to keep it private ;) )
root@home:/home/dusty # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 IEEE 802.11b ESSID:"Homenet"
Mode:Managed Frequency:2.452 GHz Access Point: 00:90:96:CF:3B:60
Bit Rate=11 Mb/s Tx-Power:25 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:xxxx-xxxx-x Security mode:restricted
Power Management:off
Link Quality:100/100 Signal level:-54 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:6 Invalid misc:75 Missed beacon:0

sit0 no wireless extensions.

root@home:/home/dusty # dhclient3 wlan0
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/wlan0/00:90:4b:57:c4:e4
Sending on LPF/wlan0/00:90:4b:57:c4:e4
Sending on Socket/fallback
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 10.0.0.138
bound to 10.0.0.171 -- renewal in 3284 seconds.

root@home:/home/dusty # ping -c 3 ubuntuforums.org
PING ubuntuforums.org (64.21.33.9) 56(84) bytes of data.
64 bytes from 64.21.33.9: icmp_seq=1 ttl=56 time=103 ms
64 bytes from 64.21.33.9: icmp_seq=2 ttl=56 time=103 ms
64 bytes from 64.21.33.9: icmp_seq=3 ttl=56 time=104 ms

--- ubuntuforums.org ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 103.036/103.432/104.107/0.546 ms


Does this output look like the output you get?

omegasoul
May 5th, 2005, 04:13 PM
This is my output so far.

wlan0 Scan completed :
Cell 01 - Address: 00:09:5B:71:AB:A6
ESSID:"Home"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-12 dBm Noise level:-256 dBm
Encryption key:off
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Extra:bcn_int=100
Extra:atim=0

root@omega:~# iwconfig wlan0 essid Home
root@omega:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B

Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:2750134 Missed beacon:0

sit0 no wireless extensions.

root@omega:~#

Hieronymus
May 5th, 2005, 04:23 PM
I think the problem is reception, look at your output:



wlan0 Scan completed :
Cell 01 - Address: 00:09:5B:71:AB:A6
ESSID:"Home"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-12 dBm Noise level:-256 dBm
Encryption key: off
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Extra:bcn_int=100
Extra:atim=0


can you get closer to the AP or something and try again?

omegasoul
May 5th, 2005, 04:27 PM
I am sitting next to it :)

Hieronymus
May 5th, 2005, 04:38 PM
I am sitting next to it :)

...:-) Well, thats strange.

But, we won't give up!

I notice that your AP is of version 802.11b which has a max bitrate of 11 Mbit/s. However, your Wlan adapter is of version 802.11g which has a max bitrate of 54 Mbit/s. I don't know if this can give problems, but we can at least try to change this.



iwconfig wlan0 rate 11M


or



iwconfig wlan0 rate auto


I see the frequencies match, but to be sure try this too



iwconfig wlan0 channel 11


You can get info on the options of iwconfig by doing


iwconfig --help


and very good info on iwconfig by doing


man iwconfig


I'm curious if any of this works!

btw I had deleted my WEP key in the command, but not in the iwconfig output.....](*,) :-P

omegasoul
May 5th, 2005, 04:41 PM
I looked at you output again and your quality was 0 until you changd the essid.
Then I looked at my output I saw that the quality was 100/100 after I tried to add the essid. I am getting a signal so it has to be something else ](*,) .

If your ready to give up on my crappy machine I will understand :-?

omegasoul
May 5th, 2005, 04:47 PM
I tried it and my system rejected it my friend, the output is still the same.

Hieronymus
May 5th, 2005, 04:50 PM
I looked at you output again and your quality was 0 until you changd the essid.
Then I looked at my output I saw that the quality was 100/100 after I tried to add the essid. I am getting a signal so it has to be something else ](*,) .

If your ready to give up on my crappy machine I will understand :-?

I'll keep on thinking on this one, I'm not a pro so maybe some things I think of won't be logical. Anyway, two minds can think of more than one (I guess).

Are you sure that your accesspoint is configured correctly? What I mean is if your AP allows every computer to connect or only computers with a certain name?

Try working with the graphical interface: goto System >> Administration >> Networking, choose your wlan adapter >> properties and see if you can chose your essid. Next chose dhcp for configuration, close and activate. Does this work?

omegasoul
May 5th, 2005, 04:50 PM
I forgot to mention that my none of my .conf files have the line RadioState|1 or RadioState|0 in them. I hope that is not important.

omegasoul
May 5th, 2005, 04:55 PM
I'll keep on thinking on this one, I'm not a pro so maybe some things I think of won't be logical. Anyway, two minds can think of more than one (I guess).

Are you sure that your accesspoint is configured correctly? What I mean is if your AP allows every computer to connect or only computers with a certain name?

Try working with the graphical interface: goto System >> Administration >> Networking, choose your wlan adapter >> properties and see if you can chose your essid. Next chose dhcp for configuration, close and activate. Does this work?


I have checked the network properties so many times I could draw you a picture of the layout. Do you think that I should start over using the original posters instructions. As I mentioned earlier I could not get them to work so I just used the HowToSetupNdiswrapper instructions.



Are you sure that your accesspoint is configured correctly? What I mean is if your AP allows every computer to connect or only computers with a certain name?

I am sure that my network is completely open and unsecure :-)

Hieronymus
May 5th, 2005, 05:00 PM
I forgot to mention that my none of my .conf files have the line RadioState|1 or RadioState|0 in them. I hope that is not important.

I have to say I don't know, I have seen that other people on this thread have remarked something about this. Try to follow their instructions before you reset anything.

Btw I have written a howto to install ndiswrapper so if you need it again it is easier to follow that all loose instructions http://ubuntuforums.org/showthread.php?t=31926

I will keep on thinking on this, but for now I'm out of options. If you got it working in the mean time please let me know.

Greetings

Hieronymus
May 5th, 2005, 05:13 PM
I just thought of something, probebly won't be the solution but you'll never know.

When I have both Wlan adapter and normal NIC adapter activated this gives problems with connecting to the net. It might also give other problems I haven't noticed. So if your also have your normal NIC activated try to deactivate and test again.

grz

omegasoul
May 5th, 2005, 05:15 PM
I had a break through. I double checked my properties in my router. Even though I turned off the MAC verification feature it would only let me on if I added the MAC for this computer. So now Here is my new out put:

root@omega:~# sudo iwlist wlan0 scan
Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 Scan completed :
Cell 01 - Address: 00:09:5B:71:AB:A6
ESSID:"Home"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-41 dBm Noise level:-256 dBm
Encryption key:off
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Extra:bcn_int=100
Extra:atim=0

root@omega:~# sudo iwconfig wlan0 essid Home
root@omega:~# sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 IEEE 802.11g ESSID:"Home"
Mode:Managed Frequency:2.462 GHz Access Point: 00:09:5B:71:AB:A6
Bit Rate:11 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-53 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:3971117 Missed beacon:0

sit0 no wireless extensions.

root@omega:~# sudo dhclient wlan0
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/wlan0/00:90:4b:b7:e9:b1
Sending on LPF/wlan0/00:90:4b:b7:e9:b1
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 1
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

I hope you can help me from here.

Hieronymus
May 5th, 2005, 05:26 PM
Well, at least you are connected. :-p



root@home:/ # dhclient3 wlan0
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/wlan0/00:90:4b:57:c4:e4
Sending on LPF/wlan0/00:90:4b:57:c4:e4
Sending on Socket/fallback
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 10.0.0.138
bound to 10.0.0.171 -- renewal in 3478 seconds.
root@home:/ #


Ok, I have tested something. This is because you have also a dhcp lease on eth0. the solution:



dhclient -r
dhclient wlan0


Worked?

omegasoul
May 5th, 2005, 05:36 PM
No, that is not working either. But it was a good idea.

Hieronymus
May 5th, 2005, 05:40 PM
No, that is not working either. But it was a good idea.
Oh, that's ashame. Did you already try to configure your wlan card with system >> administration >> networking? And did you try a reboot?

(I guess these are my noob solutions :-) )

Hieronymus
May 5th, 2005, 05:43 PM
Oh, that's ashame. Did you already try to configure your wlan card with system >> administration >> networking? And did you try a reboot?

(I guess these are my noob solutions :-) )
btw if you add a network monitor the the gnome panel and set the conection name to wlan0 you can see if the connection itself is up or down. could be usefull

omegasoul
May 5th, 2005, 05:44 PM
I am going to reboot to see if it helps. Yeah I know, I am grasping at straws.

omegasoul
May 5th, 2005, 05:56 PM
My friend i would go in to battle with you anytime. I am free.

Thank you for all of your help \\:D/

Hieronymus
May 5th, 2005, 06:24 PM
My friend i would go in to battle with you anytime. I am free.

Thank you for all of your help \\:D/
You're welcome, maybe you'll be able to help me out sometime :-)

dhanjel
May 6th, 2005, 07:05 AM
It would be nice if all of you that got the broadcom chipset working wrote down your wifi-card name in this thread so you get this thread as a search result when searching for cards that works in the forums.

Hieronymus
May 6th, 2005, 08:18 AM
It would be nice if all of you that got the broadcom chipset working wrote down your wifi-card name in this thread so you get this thread as a search result when searching for cards that works in the forums.

Well, you're right, but I guess my info doesn't do much good. I have a broadcom 802.11b Wlan adapter integrated into my HP Pavilion zv5133ea laptop. The drivers that get my wlan adapter to work in 32 bit linux are the bcmwl5.inf drivers and in 64 bit linux netbc564.inf.

Besides this info all Broadcom cards will work with Ndiswrapper, are you having trouble with yours?

Hieronymus

dhanjel
May 6th, 2005, 08:30 AM
Well, you're right, but I guess my info doesn't do much good. I have a broadcom 802.11b Wlan adapter integrated into my HP Pavilion zv5133ea laptop. The drivers that get my wlan adapter to work in 32 bit linux are the bcmwl5.inf drivers and in 64 bit linux netbc564.inf.

Besides this info all Broadcom cards will work with Ndiswrapper, are you having trouble with yours?

Hieronymus

Had a d-link g520+ and spent like 30 hours trying to get it to work before I figured out that it was broken, so I went to the store to get a new one, but they were all out on that card so I got a belkin card with broadcom chipset instead. Havn't had time to try it yet.

omegasoul
May 6th, 2005, 02:07 PM
You're welcome, maybe you'll be able to help me out sometime :-)

Just let me know when. If I dont have an answer I will help you find it. :mrgreen:

Hieronymus
May 6th, 2005, 03:01 PM
Just let me know when. If I dont have an answer I will help you find it. :mrgreen:

Now you mention it, this http://ubuntuforums.org/showthread.php?p=160846#post160846 is my problem at the moment, I'm trying to install the cvs version of Xorg, but run into a lot of errors, so far I have solved them all, but we'll see how far I get.

Hieronymus
May 6th, 2005, 04:12 PM
Ignore that last message, the problem is solved.

Thx anyway!

dhanjel
May 6th, 2005, 05:19 PM
Hi again guys, can't get this to work :/

Installed ndiswrapper and the drivers, activated the radio module in the conf file and everything, no error messages displayed in the message log but no networks are found when I scan and the leds on the network is not on.

Any suggestions?

The network card is a Belkin F5D7000yy.

Hieronymus
May 6th, 2005, 05:25 PM
Hi again guys, can't get this to work :/

Installed ndiswrapper and the drivers, activated the radio module in the conf file and everything, no error messages displayed in the message log but no networks are found when I scan and the leds on the network is not on.

Any suggestions?

The network card is a Belkin F5D7000yy.

Ok, that the LED is not on doen't have to mean anything, for my broadcom the LED only is on on data transfer.
But to get things working please post the output of:



iwconfig
dmesg
iwlist wlan0 scan


Are you sure there is a working network near you?
did you take all these (http://www.ubuntuforums.org/showthread.php?t=31926&highlight=howto%3A+wlan+ndiswrapper) steps?

Grz Hieronymus

dhanjel
May 6th, 2005, 05:41 PM
Yeah, followed that guide. Here is some output.

Iwconfig:


lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.437 GHz Access Point: 00:00:00:00:00:00
Bit Rate:54 Mb/s Tx-Power:16 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management:off


dmesg:


ndiswrapper: using irq 19
wlan0: ndiswrapper ethernet device 00:11:50:06:91:0d using driver bcmwl5, configuration file 14E4:4320:1799:7000.5.conf
wlan0: encryption modes supported: WEP
ACPI: Power Button (FF) [PWRF]
ACPI: Sleep Button (CM) [SLPB]
ibm_acpi: ec object not found
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
apm: overridden by ACPI.
drivers/usb/input/hid-input.c: event field not found
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02f0500(lo)
IPv6 over IPv4 tunneling driver
wlan0: no IPv6 routers present
UDF-fs: No VRS found
ISO 9660 Extensions: Microsoft Joliet Level 3
ISOFS: changing to secondary root
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
NET: Registered protocol family 17
eth0: no IPv6 routers present
wlan0: no IPv6 routers present
wlan0: no IPv6 routers present


iwlist scan:


iwlist wlan0 scan
Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 No scan results

Hieronymus
May 6th, 2005, 06:22 PM
Yeah, followed that guide. Here is some output.

Iwconfig:


dmesg:


iwlist scan:
The bcmwl5 driver is for Broadcom cards, so this could be the problem. What does



ndiswrapper -l


say?

dhanjel
May 6th, 2005, 11:52 PM
The bcmwl5 driver is for Broadcom cards, so this could be the problem. What does



ndiswrapper -l


say?

Driver loaded, hardware loaded.

The belkin card has the broadcom chipset. The drivers are from the cd that came with the card.

andyk
May 7th, 2005, 02:11 AM
well i've been away for awhile (trying my hand at slackware) it was fun, but nothing gets recognized from my system. spent more time configuring, than enjoying it. so i came back to ubuntu. and ndiswrapper install is a snap. for my compaq laptop with b'com 94306 chipset heres my easy install. (BTW: i'm using hoary R/C)

grab driver's (inf and sys) from wherever (XP cd, Compaq Website) and put them whereever.

pop in hoary cd and go to package mgr, search ndiswrapper-utils, install it.

open command line and cd to wherever you put drivers.

$ndiswrapper -i "your driver".inf

$ndiswrapper -l (if all went well it should tell you what drivers and hardware is present)

if it's all kosher type: $ ndiswrapper -m

then type: $ sudo modprobe ndiswrapper

next step key: $sudo gedit /etc/ndiswrapper/bcmwl5/"your conf".conf (for me it's 14E4:4320.conf) and change radio state to "0" and save.

next: $sudo gedit /etc/modules and add ndiswrapper to the list and save.

open networking and click on wireless then on right side click properties, new window click radio box "this device is configured" and enter your settings. click OK then at main window click activate. Turn other interfaces off (eth0 etc) and exit. reboot and you should be in business.

dhanjel
May 7th, 2005, 11:31 AM
andyk: tried that with no luck. It just can't find the AP for some reason. Don't know how to solve this :/

Chromance
May 11th, 2005, 01:07 AM
I did the steps above , isnt the Bcml5.inf supposed to be copied into the etc/ndiswrapper/bcml5 folder? I checked the folder and its not in there.
I even moved the drivers into the bcml5 folder and im still getting an
invalid driver! I know this is the right driver I had this wireless up and
running a few months ago . What am I doing wrong here

jonny
May 11th, 2005, 10:42 AM
I did the steps above , isnt the Bcml5.inf supposed to be copied into the etc/ndiswrapper/bcml5 folder? I checked the folder and its not in there.
I even moved the drivers into the bcml5 folder and im still getting an
invalid driver! I know this is the right driver I had this wireless up and
running a few months ago . What am I doing wrong hereThis step
sudo ndiswrapper -i ~/Desktop/bcmwl5.infshould copy the file.

I notice you refer to bcml5.inf. It's actually bcmwl5.inf - that's not the problem, is it?

NoTiG
May 11th, 2005, 04:50 PM
Hey . if anyone gets the error

"failure inserting ndiswrapper" when they try to modprobe ndiswrapper... I had this problem. but fixed it by

sudo cp /lib/modules/2.*/misc/ndiswrapper /lib/modules/2.*/extra/ndiswrapper

byen
May 13th, 2005, 08:53 PM
After months of trying to install Fedora and Mandrake...i finally came here and with your help am up and running. this walkthrough is perfect! thank you.... really! thank you! \\:D/ \\:D/

maspro
May 13th, 2005, 11:38 PM
Well to get my Wif-fi working on my Acer Ferrari 3200 I did the following and it worked perfectly :grin: :
Although I have a laptop with a 64-bit AMD processor, I used the Ubuntu 32-bit version for x86 systems, with the Ndiswrapper v1.1.

- First I plugged in the UTP cable to get internet access (since Wi-fi doesn't work yet ;-)) . If you have all of the below mentioned software, an off-line installation will also work.
- Download the ndiswrapper-source (NOT the .deb file) from http://ndiswrapper.sourceforge.net/
- You will also need an appropriate .inf driver for your Wi-fi, I used bcmwl5.inf.
- If you can't find a suitable driver then take a look here: http://ndiswrapper.sourceforge.net/phpwiki/index.php/List
- Then I downloaded build-essential, linux-headers and ndiswrapper utils through Synaptic. Although the ndiswrapper utils that are provided through Synaptic aren't really necessary I think because later on there are replaced by a newer version.

Then I typed the following commands in a terminal-window:

sudo su <your own password>
Copy the ndiswrappersource tar file to /usr/src
cd /usr/src
tar xvzf ndiswrapper*
cd ndiswrapper*
debian/rules binary
cd ..
dpkg -i ndiswrapper*.deb
Switch to your driver's directory with the cd command.
ndiswrapper -i bcmwl5.inf
ndiswrapper -l
modprobe ndiswrapper
iwconfig
iwconfig wlan0 essid <fill in your own essid>
iwlist wlan0 scan
iwconfig wlan0 mode Managed
iwconfig wlan0 key restricted <your own wep-key 10 hex digits for 40-bit encryption or 26 hex digits for 128-bit encryption>
iwconfig wlan0 essid <fill in your own essid>
ifconfig wlan0 up (or dhclient wlan0)

- I then disabled my eth0 (the port with the UTP cable) in the Gnome GUI network utility.
- Then use the Gnome GUI network utility to configure your wireless interface.
- Optionally you can download the KWifimanager through Synaptic and also make some configurations there, it also allows you to see if you have any signal strength and if you get an IP-address on your Wi-fi nic.

When all works well I typed the following last command:

ndiswrapper -m

And I added the following line to my /etc/modules: ndiswrapper

Maybe there is some redundant stuff that I did in the above list, but it's works perfectly for me.
So I guess that there are several ways to get your Wi-fi working in Ubuntu! :razz:

CloudNine
May 14th, 2005, 10:54 AM
Lo guys,

I'm currently working on a Linux driver for Broadcom chipsets. Currently I've got the bcm94306 chipset (the pci id is 14E4:4320) and it can read the MAC address of the card. However, it's really buggy atm, and not really that generic. Seeing as there's quite a few people struggling with ndiswrapper around here, it could be useful for the Linux commnity :) My personal motivation for this is to have a computer of completely free software :wink:

More details are at my website: http://c9online.l2p.net

Matt

KrIaXPaTaLa
May 14th, 2005, 03:42 PM
Great iniciative ;)

dhanjel
May 14th, 2005, 04:01 PM
Lo guys,

I'm currently working on a Linux driver for Broadcom chipsets. Currently I've got the bcm94306 chipset (the pci id is 14E4:4320) and it can read the MAC address of the card. However, it's really buggy atm, and not really that generic. Seeing as there's quite a few people struggling with ndiswrapper around here, it could be useful for the Linux commnity :) My personal motivation for this is to have a computer of completely free software :wink:

More details are at my website: http://c9online.l2p.net

Matt

Yeah! I'm waiting for your drivers! Can't use linux until then :/

maspro
May 15th, 2005, 12:13 AM
Hieronymus, maspro

You've probably seen the How To that I wrote for Broadcom cards (I managed to get the repository ndiswrapper to work), and I imagine it didn't work for you. I'd like to point my How To to yours so that users who have similar problems aren't left high and dry. You mention AMD64. Are you using AMD64 ubuntu? If so, I imagine that these are the users that need redirection.

The other thread has had around 7,000 hits so far, so Broadcom cards are obviously presenting huge problems. It would be good to be able to present a cast iron solution set between us.

One minor point that might trip up some unwary noobs: I think that, from a fresh ubuntu install, you'd also need to do apt-get install build-essential before compiling ndiswrapper.
The above quote is taken from the following thread: HOWTO: WLan via Ndiswrapper (http://www.ubuntuforums.org/showthread.php?t=31926)

Thx for your feedback jonny, I think that indeed it's handy to point to this how-to (http://www.ubuntuforums.org/showthread.php?t=31926) in your thread. The more ways to get a Wi-fi card working under Linux the better! :grin:

r0jaws
May 21st, 2005, 10:49 PM
Just wanted to say thanks!! :grin:
Probably one of the best walkthroughs I have found and used it to get sorted on my Avertec 3200. After about a week of frustration, this had me up and running in about 20 mins! TVM!!! \\:D/

aubreyisland
June 8th, 2005, 05:10 AM
alright i just thought id throw out how i got my broadcom (motorola ws810g) going...

first) installed ndiswrapper and the driver bcml...
second) edited /etc/ndis.../bcml.../14...conf to have radiostate = 0
third) used ubuntu GUI to configure netowrk

now its woriking! it reads my AP and all... BUT...

when i finally got it going i wasnt able to browse the internet,
i disabled ipv6 in firefox using about::config

so now internet browsing works, but as for all my other internet apps such as gaim, etc... they're not working. i even disabled ipv6 in /etc/...aliases and disabled the
ipv6 alias in modprobe.conf

any clue why i cant get internet to work on anything other than firefox?
why: need apt-get to update (wont work because of no internet access)
etc . ps my eth0 is down too...

mosfet
June 10th, 2005, 08:12 AM
hi

i tried everythin posted here...... i'm new using linux

when i type this

root@ubuntu:/home # ndiswrapper -i ~/home/mosfet/Desktop/bcmwl5.inf

i get this error

Installing bcmwl5
cp: cannot stat `/root/home/mosfet/Desktop/bcmwl5.inf': No such file or directory

any ideas?
can anyone help me?

jonny
June 10th, 2005, 09:31 AM
when i type this

root@ubuntu:/home # ndiswrapper -i ~/home/mosfet/Desktop/bcmwl5.infYou've typed the code incorrectly. The '~' symbol is interpreted by Linux as your own home directory, so you've effectively asked ndiswrapper tp install the file /home/mosfet/home/mosfet/Desktop/bcmwl5.inf.

Try this instead
ndiswrapper -i ~/Desktop/bcmwl5.inf

aubreyisland
June 10th, 2005, 03:11 PM
thats an easy fix i hope...

cd into the directory....

cd /home
cd <userid>
cd Desktop

ndiswrapper -i bcmlw5.inf

install the file FROM the directory so it can also copy the .sys files.

mosfet
June 10th, 2005, 08:44 PM
thanks guys it worked

topboi
June 12th, 2005, 06:33 PM
Please Help I am A Newbie and I follow your steps and made it to #5 and everything but the powerlight and my Motorola WN825G went just like you said but then there is a dim light on but not like it is when I plug it in to my other laptop that is running XP.
I am running Kubuntu

When I run iwconfig wlan0 here is my results

wlan0 Link encap:Ethernet HWaddr 00:0C:E5:47:53:56
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Memory:11000000-11001fff

and here is the results when I run ifconfig wlan0

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

when I run iwlist scan I get

root@ubuntu:~ # iwlist scanning
lo Interface doesn't support scanning.

sit0 Interface doesn't support scanning.

wlan0 No scan results
eth0 Interface doesn't support scanning.

Please Help

Newbbie Chris
:???:

aubreyisland
June 12th, 2005, 06:54 PM
try... (terminal)


ifconfig wlan0 down
ifconfig eth0 down

//then...

ifconfig wlan0 up

ifconfig <--- and see if you got an ap.

BTW. you arent getting any scans probably because you havent configured your conf files in ndiswrapper: RadioState|0 see my blog for a howto on doing that.

hope this helps you out...

ALSO: I would still like to note my previous post: that although I got my wireless working I still cannot get Gaim or Limewire to do anything.... I dont think its an ipv6 problem anymore as I removed the .ko file, but am pondering if its an ssh config or tpc config? I dont know anyone have any idea where to go?


CHANGES!
Okay limewire is now working? all i did was iwconfig wlan0 power all
but dont know if that is what fixed it?

topboi
June 14th, 2005, 08:47 PM
here is the results of your sugestion

root@ubuntu:~ # ifconfig wlan0 down
root@ubuntu:~ # ifconfig eth0 down
root@ubuntu:~ # ifconfig wlan0 up
root@ubuntu:~ # ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1510 errors:0 dropped:0 overruns:0 frame:0
TX packets:1510 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:138428 (135.1 KiB) TX bytes:138428 (135.1 KiB)

wlan0 Link encap:Ethernet HWaddr 00:0C:E5:47:53:56
inet6 addr: fe80::20c:e5ff:fe47:5356/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Memory:11000000-11001fff

root@ubuntu:~ #

and still no bright light on the pcmcia card ](*,)


BTW. you arent getting any scans probably because you havent configured your conf files in ndiswrapper: RadioState|0 see my blog for a howto on doing that

thank you ever so much
Newbbie

aubreyisland
June 14th, 2005, 10:42 PM
by the end of ur message i cant tell if things worked out?:D but, send me iwconfig if it didnt. (looking) i dont get a light either btw. it just doesnt turn on. dont know why!

vtechstu
June 15th, 2005, 03:14 AM
How would i complete steps 5 through the end in Kubuntu. I'm new to all this and can't get it working! It's driving me crazy.

jonny
June 16th, 2005, 06:55 PM
Sorry, don't know how to do this in kubuntu, as I've never used the KDE wireless network tools. If anyone else can answer this question, I'll update the how-to for the benefit of other users.

EndersGame
June 20th, 2005, 08:40 PM
Due to a long and painful adventure, I no longer have windows on my Dell Inspiron 5150. This means I don't have the drivers for the (broadcom) wireless card that I could just point ndiswrapper to. Therefore:
1.) Will ndiswrapper still work if I just downloaded someone else's bcmwl5 file(s)?
2.) If so, would someone be willing to either host the necessary file(s) or email them to me?
3.) If not, are there any other options available to me?

Thanks.

poofyhairguy
June 20th, 2005, 09:21 PM
1.) Will ndiswrapper still work if I just downloaded someone else's bcmwl5 file(s)?


Yep.

jonny
June 21st, 2005, 02:06 AM
With a little hunting, you can get the files from Dell's website or from the ndiswrapper site (preferred). Just remember to get all files starting with bcmwl5.

MetalMusicAddict
June 21st, 2005, 03:29 AM
I FRIGGIN' LOVE YOU MAN!!!!

I got a Dell Inspiron 2200 a month ago. Real base model. For thr day-to-day stuff. Wireless and the screen were the 2 things I couldnt get to work.

I ended up changing the "i810" video driver to "vesa" for now. I've read this is some kinda bug. So I got a screen workin. But not quite. Hopefully Brezzy will fix this.

Now this. So awesome. :) One thing Im wondering. In windows I think the connections load balance and switch back and fourth.

In Ubuntu if I "plug in" does the connection auto-switch to the faster "wired" one and then back if I unplug?

Also will this be fixed in Brezzy? This card workin' by default I mean.

EDIT:
Maybe I spoke too soon. 2 weird things.

1. I cant connect to my network. I dual boot with this machine and the info is the same on XP/Ubuntu.
2. Why do I have to "sudo modprobe ndiswrapper" everytime I wanna make the wireless work?

Sorry If this has been answered. I couldnt find it on the other pages.

filloy
June 21st, 2005, 06:19 AM
ha, i cant get my wireless card to be On, not Off, not even the Function+F2 is working, dont know why, cuz in windows it does.
I've just modified my BIOS, cus theres an option to keep the Wireless Card on, or Off, but it keeps off.
Any idea of how to ? im using a Gateway Laptop with a Broadcom Wireless Card.
I really need that to work, otherwise, i wont get wireless working.



when i do

sudo modprobe ndiswrapper i get:

root@marymoon:/home/filloy # sudo modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted

and if i do: ndiswrapper -l i get:


root@marymoon:/home/filloy # ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present, hardware present


So, i have the driver installed, the hardware present, but i cant start the frikin' card,any ideas

Thanx a lot !

MetalMusicAddict
June 21st, 2005, 09:38 PM
1. I cant connect to my network. I dual boot with this machine and the info is the same on XP/Ubuntu.
2. Why do I have to "sudo modprobe ndiswrapper" everytime I wanna make the wireless work?
I found out that my "/etc/network/interfaces" wasnt being saved properly.

I had to do this:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
mapping hotplug
script grep
map eth0 <-change to wlan0

# The primary network interface<- Move this down
iface eth0 inet static
address *.*.*.*
netmask *.*.*.*
gateway *.*.*.*


TO HERE!!
iface wlan0 inet static
address *.*.*.*
netmask *.*.*.*
gateway *.*.*.*
wireless-essid ******
wireless-key ****************

auto wlan0
The network works great now. Just like it was plugged in. ;)

Seer
June 21st, 2005, 11:00 PM
OK Here is a new one for yas... I thinK!!!!

Card is the (using latest winxp drivers) Belkin F5D8000 pre-n PCMIA in a PCI Bracket type card (thats a hotplug thing right???) Every thing appears to go swimmingly until the very last part....

A message from that bastard dmesg (he is always bringing me bad news!)


ndiswrapper version 1.2 loaded (preempt=yes,smp=no)
ndiswrapper: driver netani (Belkin Software, Inc.,08/11/2004, 1.2.0.68) loaded
PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
ACPI: PCI interrupt 0000:03:00.0[A] -> GSI 19 (level, low) -> IRQ 19
PCI: Unable to reserve mem region #1:fffea000@fa020000 for device 0000:03:00.0
ndiswrapper (ndiswrapper_add_pci_device:198): couldn't request PCI regions: fffffff0
ndiswrapper: probe of 0000:03:00.0 failed with error -16
PCI: Failed to allocate mem resource #1:80000@fa080000 for 0000:03:00.0
PCI: Failed to allocate mem resource #0:20000@fa020000 for 0000:03:00.0

For the love of god someone help me :) Its taken me days just to get this far!!! ] (*,)

Seer
June 21st, 2005, 11:44 PM
I may have found the source of my problem in a pretty obscure place - I am just not sure how to adapt the instructions to Ubuntu....

I found out this was the Rioch Rl5c475 PCI adapter from the Device Manager, and then I have read alll kinds of problems with other brands of cards using this too. Then I stumbled on this:


http://vprmatrixlinux.theeggbeater.net/

Networking
802.11b Wireless Networking
The internal chipset is Mini PCI Orinoco (Ricoh Rl5c475). After working with this I found the following site that shows you how to setup the Ricoh Rl5c475

It is supported via the orinoco driver in PCMCIA-CS. The trick is the chipset is connected via the pci bus to a PCMCIA slot.

Short Install Instructions:
1) compile and install 2.4.x without PCMCIA support but with Wireless LAN support (just Wireless LAN support, none of the drivers under that option)
2) compile and install latest pcmcia-cs (Gentoo: emerge pcmcia-cs)
3) compile and install latest wireless-tools (Gentoo: emerge wireless-tools)
4) edit your pcmcia options so that your socket driver is i82365 and your PCIC_OPTS="irq_mode=0" (use only PCI IRQs) in /etc/conf.d/pcmcia
5) reboot
6) the Ricoh Rl5c475 will be recognized as eth1


So far I have checked for latest version of pcmcia-cs and wireless tools via synaptic.
Problem is I cannot find 4) edit your pcmcia options so that your socket driver is i82365 and your PCIC_OPTS="irq_mode=0" (use only PCI IRQs) in /etc/conf.d/pcmcia

I know its a different NIC actually in the adapter but the problem is apparently due to the kernel trying to assign the same IRQ twice and is present in both 2.4 and 2.6??

Seer
June 22nd, 2005, 12:10 AM
Well - the closest I could find was /etc/default/pcmcia which has the exact same layout.... so I followed the instructions (bearing in mind they were for the 2.4 kernel) and produced a file like so:


# Defaults for pcmcia (sourced by /etc/init.d/pcmcia)
PCMCIA=yes
PCIC=i82365
PCIC_OPTS="irq_mode=0"
CORE_OPTS=
CARDMGR_OPTS=

Reboot and no joy ... so then I went and looked at /etc/init.d/pcmcia as referenced at the top of the file and found this little snippet...


# Treat i82365 specially, as many people with yenta_socket
# incorrectly has PCIC set to i82365 for historical reasons
if [ "$PCIC" = i82365 ]; then
if ! bridge_module_loaded ; then
# On 2.6 kernels, we must not load any other bridge
# modules than the right one
if cardbus_bridge_present ; then
[ "$VERBOSE" != no ] && log_warning_msg "Using yenta_socket instead of $PCIC"
load_module yenta_socket || failed_to_load yenta_socket

And bang went my hopes that this week old n00b had figured out something so detailed by himself lol!!!

Really I am going nuts now!!! Sorry for using this post like a journal of my actions but maybe some others with the same card but more knowledge can assist me !!

Seer
June 22nd, 2005, 12:59 AM
I promise my last post... (I'm about to pass out :) )

I have gone all round the houses reading the documentation and it seems whats needed is this.

You can exclude IRQ's that the Rioch gets assigned to using a file in the /etc/default/pcmcia directory - so in this case I excluded 19.

Then I found out that this only excludes irqs for the PCI bridge itself and not for the actual card inserted into it. (the problem seeming to be that the machine is attempting to assign the same IRQ to both the PCI Socket and the card inserted into it) For this I presume I would need to exclude the IRQ 19 not with PCMCIA but with the hotplug module with something within the /etc/hotplug directory but I'll be buggered if I can find a file where this is possible.

So if anyone knows a way to exclude an IRQ for the PCMCIA Card that is inserted into the bracket.... I might be on a winner lol

G'night!!

FesterHead
June 22nd, 2005, 08:36 AM
Thanks for the HOW-TO.
Works for me on an HP zd7168cl using the bcmwl5a.inf and bcmwl5.sys files from the latest HP SP.

Getting the wireless was the final straw for conversion to Ubuntu for me.
Rock on.

smedstadc
June 25th, 2005, 04:25 PM
I'm having a problem with this howto. I need to change those radiostates for my card to function properly, but when I used the command suggested (even as superuser) I just get permission denied for each of the files that would have been changed.

I can't open them up to edit manually either... Can anyone help?

jonny
June 25th, 2005, 11:23 PM
I imagine that they're locked by another process. Did you start the how-to from the beginning, removing ndiswrapper and the existing drivers? Other users (buried deep within this enormous thread) have reported various problems trying to fix an existing failed ndiswrapper installation, so I'd always recommend a clean restart.

smedstadc
June 27th, 2005, 03:31 AM
Thanks, I'll try that but, in case it doesn't do the trick... what would be the next best course of action?

gushy
June 27th, 2005, 04:16 PM
](*,) can't get my belkin f5d7010 working ... strange because I've had it working before ... with warty not hoary though.

lspci shows the card is present
ndiswrapper shows the driver loaded and the hardware present
the ndiswrapper module is loaded
iwconfig shows the card
all the config files have RadioState|1


yet the radio no the card will not come on, no green light. :(

Can anyone suggest what else I can look at?

jonny
June 27th, 2005, 07:59 PM
Radiostate should be 0, not 1. That's the central cause of the confusion with these cards.

This is the code that will fix it. Cut, paste and enjoy wireless networking.
for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
done

gushy
June 28th, 2005, 09:36 AM
oh ok, I see that now in the other posts, but I was absolutely positive that when I had problems with the radio state in the past I had to change it to 1. my bad.

now I feel like an idiot! :roll:

thanks.

flibble
June 30th, 2005, 09:24 AM
Woooo Hoooooo !

Found your guide and have wireless up with wpa-psk. Thank you!

Information for others: I'm using a T23 thinkpad, model 2468-ra1, a Linksys WPC54G v1.2 (broadcom chip) as client and a Linksys WRT54G router. The Linksys drivers didn't work for me at all. I tried them all, including the betas. What did work was the latest dell drivers (lost the link but i got them from dell's website). These drivers also work for me under XP (for what it's worth). In Ubuntu, I used ndiswrapper and this guide to wpa_supplicant.

Many thank. :)

sds
July 3rd, 2005, 03:44 PM
Hi all,
First of all, thanks to the author for writing this - I'm a recent convert to Linux / Ubuntu and there is a huge learning curve.
I've followed the instructions to the letter (i.e. all Radiostates|0) and my Belkin FD7010 network card now lights up (just the power light).
I know my card definitely works as I've been using it in Windows XP which is also on this laptop.
However, it can't see the access point (despite me opening it up completely and being a metre away from it). I've followed other bits of info I've seen and changed the channel so its the same (5) and tried setting the SSID. However, I think that could be the problem - even after typing

sudo iwconfig wlan0 essid shah

iwconfig wlan0 still gives:

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.432 GHz Access Point: 00:00:00:00:00:00
Bit Rate:54 Mb/s Tx-Power:16 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
I've set the WAP to broadcast its SSID but when I try "iwlist scan" I get:

root@LinuxLaptop:/home/sunil # iwlist scan
lo Interface doesn't support scanning.

wlan0 No scan results
eth0 Interface doesn't support scanning.

sit0 Interface doesn't support scanning.


Changing the AP's channel doesn't help.

I've also tried deactivating the eth0 interface completely and trying it but that doesn't seem to work either.

ndiswrapper -l gives:

Installed ndis drivers:
bcmwl5 driver present, hardware present

dmesg gives me:

0x1bf73fff
ACPI: FADT (v002 AMDK8 PTLTW 0x06040000 PTL_ 0x000f4240) @ 0x1bf79e77
ACPI: SSDT (v001 PTLTD POWERNOW 0x06040000 LTP 0x00000001) @ 0x1bf79efb
ACPI: MADT (v001 PTLTD APIC 0x06040000 LTP 0x00000000) @ 0x1bf79fb0ACPI: DSDT (v001 VIA PTL_ACPI 0x06040000 MSFT 0x0100000e) @ 0x00000000
ACPI: PM-Timer IO Port: 0x4008
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 15:8 APIC version 16
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 1, version 3, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 high edge)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Enabling APIC mode: Flat. Using 1 I/O APICs
Using ACPI (MADT) for SMP configuration information
Built 1 zonelists
Kernel command line: root=/dev/hda4 ro quiet splash
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 32768 bytes)
Detected 1601.235 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 446620k/458176k available (1436k kernel code, 10960k reserved, 754k data, 224k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 3170.30 BogoMIPS (lpj=1585152)
Security Framework v1.0.0 initialized
SELinux: Disabled at boot.
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: 078bfbff c1d3fbff 00000000 00000000 00000000 00000000
CPU: After vendor identify, caps: 078bfbff c1d3fbff 00000000 00000000 00000000 00000000
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After all inits, caps: 078bfbff c1d3fbff 00000000 00000010 00000000 00000000
CPU: AMD Mobile AMD Sempron(tm) Processor 2800+ stepping 02
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
ACPI: Looking for DSDT in initrd... not found!
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 pin1=2 pin2=-1
checking if image is initramfs...it isn't (bad gzip magic numbers); looks like an initrd
Freeing initrd memory: 4300k freed
NET: Registered protocol family 16
EISA bus registered
PCI: PCI BIOS revision 2.10 entry at 0xfd557, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20050211
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
PCI: Via IRQ fixup
PCI: Via IRQ fixup
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [ALKA] (IRQs 16 17 18 19 20 21 22 23) *10, disabled.
ACPI: PCI Interrupt Link [ALKB] (IRQs 16 17 18 19 20 21 22 23) *10, disabled.
ACPI: PCI Interrupt Link [ALKC] (IRQs 22) *11, disabled.
ACPI: PCI Interrupt Link [ALKD] (IRQs 21) *11, disabled.
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 9 12 14 15) *10
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 *10 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 9 10 *11 12 14 15)
ACPI: Embedded Controller [EC] (gpe 11)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 10 devices
PnPBIOS: Disabled by ACPI PNP
PCI: Using ACPI for IRQ routing
** PCI interrupts are no longer routed automatically. If this
** causes a device to stop working, it is probably because the
** driver failed to call pci_enable_device(). As a temporary
** workaround, the "pci=routeirq" argument restores the old
** behavior. If this argument makes the device work again,
** please email the output of "lspci" to bjorn.helgaas@hp.com
** so I can fix the driver.
pnp: 00:05: ioport range 0x600-0x60f has been reserved
pnp: 00:05: ioport range 0x1c0-0x1cf has been reserved
pnp: 00:05: ioport range 0x4d0-0x4d1 has been reserved
pnp: 00:05: ioport range 0xfe10-0xfe11 could not be reserved
audit: initializing netlink socket (disabled)
audit(1120402439.567:0): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Initializing Cryptographic API
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
i8042.c: Detected active multiplexing controller, rev 1.1.
serio: i8042 AUX0 port at 0x60,0x64 irq 12
serio: i8042 AUX1 port at 0x60,0x64 irq 12
serio: i8042 AUX2 port at 0x60,0x64 irq 12
serio: i8042 AUX3 port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 54 ports, IRQ sharing enabled
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
input: AT Translated Set 2 keyboard on isa0060/serio0
EISA: Probing bus 0 at eisa0
Cannot allocate resource for EISA slot 1
Cannot allocate resource for EISA slot 4
EISA: Detected 0 cards.
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
NET: Registered protocol family 8
NET: Registered protocol family 20
Restarting tasks...<6> Strange, kswapd0 not stopped
Strange, kseriod not stopped
done
ACPI wakeup devices:
PCI0 Z007 ILAN LID SLPB
ACPI: (supports S0 S3 S4 S5)
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 4300KiB [1 disk] into ram disk... done.
VFS: Mounted root (cramfs filesystem) readonly.
Freeing unused kernel memory: 224k freed
ACPI: Thermal Zone [THRS] (27 C)
ACPI: Thermal Zone [THRC] (42 C)
NET: Registered protocol family 1
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:11.1
ACPI: PCI interrupt 0000:00:11.1[A]: no GSI - using IRQ 0
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci0000:00:11.1
ide0: BM-DMA at 0x1c60-0x1c67, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0x1c68-0x1c6f, BIOS settings: hdc:DMA, hdd:pio
Probing IDE interface ide0...
hda: HTS424040M9AT00, ATA DISK drive
elevator: using anticipatory as default io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: max request size: 1024KiB
hda: 78140160 sectors (40007 MB) w/1739KiB Cache, CHS=16383/255/63, UDMA(100)
hda: cache flushes supported
/dev/ide/host0/bus0/target0/lun0: p1 p2 p3 < p5 p6 > p4
Probing IDE interface ide1...
hdc: UJDA760 DVD/CDRW, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
Probing IDE interface ide2...
Probing IDE interface ide3...
Probing IDE interface ide4...
Probing IDE interface ide5...
Stopping tasks: ==|
Freeing memory... done (458 pages freed)
Restarting tasks... done
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
Adding 457812k swap on /dev/hda6. Priority:-1 extents:1
EXT3 FS on hda4, internal journal
hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.20
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
lp0: using parport0 (interrupt-driven).
mice: PS/2 mouse device common for all mice
Synaptics Touchpad, model: 1
Firmware: 5.8
180 degree mounted touchpad
Sensor: 18
new absolute packet format
Touchpad has extended capability bits
-> 4 multi-buttons, i.e. besides standard buttons
-> multifinger detection
-> palm detection
input: SynPS/2 Synaptics TouchPad on isa0060/serio4
ieee1394: Initialized config rom entry `ip1394'
SCSI subsystem initialized
sbp2: $Rev: 1219 $ Ben Collins <bcollins@debian.org>
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ndiswrapper version 1.0rc2 loaded (preempt=yes,smp=no)
ts: Compaq touchscreen protocol output
ndiswrapper: driver bcmwl5 (Broadcom,06/13/2003, 3.20.23.0) added
Capability LSM initialized
device-mapper: 4.3.0-ioctl (2004-09-30) initialised: dm-devel@redhat.com
md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27
cdrom: open failed.
Real Time Clock Driver v1.12
input: PC Speaker
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected AGP bridge 0
agpgart: Maximum main memory to use for agp memory: 380M
agpgart: AGP aperture is 256M @ 0xe0000000
cpci_hotplug: CompactPCI Hot Plug Core version: 0.2
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
Evaluate _OSC Set fails. Status = 0x0005
pciehp: add_host_bridge: status 5
pciehp: Fails to gain control of native hot-plug
Linux Kernel Card Services
options: [pci] [cardbus] [pm]
ACPI: PCI interrupt 0000:00:0b.0[A] -> GSI 17 (level, low) -> IRQ 17
Yenta: CardBus bridge found at 0000:00:0b.0 [1025:006e]
Yenta: ISA IRQ mask 0x0c78, PCI irq 17
Socket status: 30000006
PCI: Enabling device 0000:00:0b.1 (0000 -> 0002)
ACPI: PCI interrupt 0000:00:0b.1[B] -> GSI 18 (level, low) -> IRQ 18
Yenta: CardBus bridge found at 0000:00:0b.1 [1025:006e]
Yenta: ISA IRQ mask 0x0c78, PCI irq 18
Socket status: 30000820
ohci1394: $Rev: 1223 $ Ben Collins <bcollins@debian.org>
ACPI: PCI interrupt 0000:00:0b.2[C] -> GSI 19 (level, low) -> IRQ 19
ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[19] MMIO=[d0005000-d00057ff] Max Packet=[2048]
PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
ACPI: PCI interrupt 0000:06:00.0[A] -> GSI 18 (level, low) -> IRQ 18
PCI: Setting latency timer of device 0000:06:00.0 to 64
ndiswrapper: using irq 18
USB Universal Host Controller Interface driver v2.2
wlan0: ndiswrapper ethernet device 00:11:50:10:97:b8 using driver bcmwl5
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP
ACPI: PCI interrupt 0000:00:10.0[A] -> GSI 21 (level, low) -> IRQ 21
uhci_hcd 0000:00:10.0: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
uhci_hcd 0000:00:10.0: irq 21, io base 0x1c00
uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:10.1[B] -> GSI 21 (level, low) -> IRQ 21
uhci_hcd 0000:00:10.1: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (#2)
uhci_hcd 0000:00:10.1: irq 21, io base 0x1c20
uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:10.2[C] -> GSI 21 (level, low) -> IRQ 21
uhci_hcd 0000:00:10.2: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (#3)
ieee1394: Host added: ID:BUS[0-00:1023] GUID[000ae40444100f4e]
uhci_hcd 0000:00:10.2: irq 21, io base 0x1c40
uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
usb 1-1: new full speed USB device using uhci_hcd and address 2
ACPI: PCI interrupt 0000:00:10.3[D] -> GSI 21 (level, low) -> IRQ 21
ehci_hcd 0000:00:10.3: VIA Technologies, Inc. USB 2.0
ehci_hcd 0000:00:10.3: irq 21, pci mem 0xd0005800
ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 4
ehci_hcd 0000:00:10.3: USB 2.0 initialized, EHCI 1.00, driver 26 Oct 2004
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 6 ports detected
Initializing USB Mass Storage driver...
irda_init()
NET: Registered protocol family 23
usb 1-1: string descriptor 0 read error: -71
usb 1-1: string descriptor 0 read error: -71
usb 1-1: string descriptor 0 read error: -71
scsi0 : SCSI emulation for USB Mass Storage devices
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb 1-1: USB disconnect, address 2
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usb 4-1: new high speed USB device using ehci_hcd and address 2
scsi1 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
via82xx: Assuming DXS channels with 48k fixed sample rate.
Please try dxs_support=1 or dxs_support=4 option
and report if it works on your machine.
ACPI: PCI interrupt 0000:00:11.5[C] -> GSI 22 (level, low) -> IRQ 22
PCI: Setting latency timer of device 0000:00:11.5 to 64
usb 1-2: new low speed USB device using uhci_hcd and address 4
usbcore: registered new driver hiddev
input: USB HID v1.00 Mouse [USB Wheel Mouse] on usb-0000:00:10.0-2
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
ACPI: PCI interrupt 0000:00:12.0[A] -> GSI 23 (level, low) -> IRQ 23
eth0: VIA Rhine II at 0x1800, 00:0a:e4:5e:1d:8d, IRQ 23.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 41e1.
NET: Registered protocol family 17
Vendor: Generic Model: USB Flash Disk Rev: 2.00
Type: Direct-Access ANSI SCSI revision: 02
usb-storage: device scan complete
SCSI device sda: 255488 512-byte hdwr sectors (131 MB)
sda: Write Protect is off
sda: Mode Sense: 03 00 00 00
sda: assuming drive cache: write through
SCSI device sda: 255488 512-byte hdwr sectors (131 MB)
sda: Write Protect is off
sda: Mode Sense: 03 00 00 00
sda: assuming drive cache: write through
/dev/scsi/host1/bus0/target0/lun0: unknown partition table
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
ACPI: AC Adapter [AC] (on-line)
ACPI: Battery Slot [BAT0] (battery present)
ACPI: Power Button (FF) [PWRF]
ACPI: Lid Switch [LID]
ACPI: Sleep Button (CM) [SLPB]
ibm_acpi: ec object not found
ACPI: Video Device [VGA] (multi-head: yes rom: no post: no)
apm: BIOS not found.
cs: IO port probe 0x0100-0x04ff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0a00-0x0aff: clean.
powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.00.09e)
powernow-k8: 0 : fid 0x8 (1600 MHz), vid 0x6 (1400 mV)
powernow-k8: 1 : fid 0x0 (800 MHz), vid 0x18 (950 mV)
cpu_init done, current fid 0x8, vid 0x4
powernow-k8: ph2 null fid transition 0x8
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02f0500(lo)
IPv6 over IPv4 tunneling driver
wlan0: no IPv6 routers present
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
eth0: no IPv6 routers present
ibm_acpi: ec object not found

Finally I followed the instructions given on another howto somewhere in this thread (where he made ndiswrapper from source) but that still didn't work.

Please help!

DW5
July 5th, 2005, 09:31 PM
It would be nice if all of you that got the broadcom chipset working wrote down your wifi-card name in this thread so you get this thread as a search result when searching for cards that works in the forums.

BCM 4301 802.11b built into a Compaq nx9010 laptop

I fiddled with this for a couple of hours, and after double checking the radio states manually (not all had changed using sed for some reason) and doing a couple of reboots, things worked.

I am having to do a #sudo modprobe ndiswrapper after each boot and having to turnoff eth0, and would ultimately like to know if someone knows how to fix that.

Thanks for the hard work everyone has put in on this howto.

DW

MetalMusicAddict
July 5th, 2005, 10:45 PM
BCM 4301 802.11b built into a Compaq nx9010 laptop

I fiddled with this for a couple of hours, and after double checking the radio states manually (not all had changed using sed for some reason) and doing a couple of reboots, things worked.

I am having to do a #sudo modprobe ndiswrapper after each boot and having to turnoff eth0, and would ultimately like to know if someone knows how to fix that.

Thanks for the hard work everyone has put in on this howto.

DW

Look at my posts on this page. #s 123&125. I had to turn off eth0 also.

Search is your friend. ;)

DW5
July 8th, 2005, 02:30 AM
Look at my posts on this page. #s 123&125. I had to turn off eth0 also.

Search is your friend. ;)

Indeed. I had read those but was not far enough along in the problem solving to recognize that changing the config file was the solution. I mapped both wlan0 and eth0 and both seem to be active and hot at boot up.

I have that crazy "SIOCGIFFLAGS error: No such device" on the network display applet on the panel now still and can't seem to get it gone (and search hasn't found the answer yet)--but at least I am networked both wired and wireless.


Thanks.

MetalMusicAddict
July 8th, 2005, 03:07 AM
...but at least I am networked both wired and wireless.

Are you connected to the same network both wired and wireless? I think I had to turn off my eth0 to connect wireless and vice-versa.

DW5
July 8th, 2005, 09:34 PM
Are you connected to the same network both wired and wireless? I think I had to turn off my eth0 to connect wireless and vice-versa.

It appears so. Both devices are active and the surfing is fine. I wish I had the network applet working so that I could get a sense of connection speed. My wired is 100btx and my wireless is 10bt. I would like to see if there is automatic switching when I plug in to the wired or if I need to turn off wireless to get the better speed.

Anyway, I think maybe the mapping both wlan0 and eth0 might have done that. I such a newbie though, that it's speculation on my part.

jonny
July 9th, 2005, 02:24 PM
If you're using Gnome - I really can't understand why anyone would want to use KDE :grin: (duck for cover) - and you configured your network settings using the gnome tools, you can tell which device is being used by looking in System --> Administration --> Networking. The device listed under default gateway is the one that connects you to the internet.

To get a networking applet, right -click on your panel and select Add to Panel. You neet to add the Network Monitor. When it appears in your panel, click on it and change the properties to select wlan0 or whatever your wireless device is called.

I should make two warning here, though. First, I find that the applet sometimes freezes my entire laptop when I change the device name. Second, the signal strength meter doesn't work with my Broadcom card - but you can tell when you're transmitting or receiving.

Error1312
July 10th, 2005, 03:48 PM
Thank you so much to all of you!

After reading 9 pages of this thread I finally managed to get my wireless up and running :grin: No more network cables for me.

luckyboylost
July 11th, 2005, 08:27 AM
Okay my first post, and im a big fresh off the boat noob to linux. These are the steps i took to make my wireless card work. I have a motorola WPCI810G card that uses the windows bcmwl5.inf file. Here is my step-by-step, noob-style, to get everything up and running on the wireless. I did it from a fresh install of ubuntu. So if you have ndiswrapper installed, you may want to unistall everything you have done with it before going through my steps. Oh and im using the 5.04 version of ubuntu

Step 1:
UPDATE UBUNTU! Some people in these posts were getting an error upon the final step of "sudo modprobe ndiswrapper" (the steps listed at the beginning of this thread). The error had something about not being able to find/use ndiswrapper.ko I had this problem when i tried to do my own steps to installing my wireless card and forgot to update ubuntu before I started. So make sure you are up to date. Go to: System->Administration->Ubuntu Update Manager

Step 2:
INSTALL NDISWRAPPER! I ultimatly ended up installing ndiswrapper-1.2 I used this page at wiki: https://wiki.ubuntu.com/SetupNdiswrapperHowto
there is one slight difference.. the howto at wiki is for version 1.1 just substitute 1.2 for 1.1 in all the instructions. I'm sure v1.1 would work fine though. To open a terminal window go to Applications->System Tools->Terminal

Step 3:
REBOOT! If you followed the instructions on the wiki page to the t, then you should see your wireless card in System->Administration->Networking before you reboot. But the reboot allows ubuntu to talk to the wireless card.

Step 4:
CONFIGURE YOUR NETWORK! Go to System->Administration->Networking. Click on your Ethernet connection and click on Deactivate. Then click on Wireless connection and click on Properties. check the "This device is configured" box and select your ESSID which should pop up in the drop-down box. Now one of the problems I originally had was that my network was set up with AES encryption. I had to change it to WEP. If you configured your WEP using a phrase, then when you enter the WEP key in the text-box you MUST preface it with s: Under connection settings set the Configuration to DHCP (assuming your router is using a DHCP server which most do out of the box). Click OK and you should be good to go.

One problem I still have at the time of this post is that upon reboot my eithernet is set to default. I think that is fixed in the /etc/network/interfaces file, where it says



# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
mapping hotplug
script grep
map eth0


I think the eth0 needs to be changed to wlan0. Ill guess ill find out when I reboot, but if someone knows im wrong, could they let me know?

I want to give a big thanks to jonny for the how-to write up. The community here, from what i have read thus far, is awsome. This is what will liberate me somewhat from m$ and expensive software \\:D/ . I only hope my little ultra noob write up helps some other ultra noob.

luckyboylost
July 12th, 2005, 11:42 AM
nope editing the /etc/network/interface file by changing that one word from my last post didnt work. I also moved the

iface eth0 inet dhcp

line down below the wireless stuff. After reboot I have to reactivate my wireless card to get a connection. Anyone have any thoughts as to how I can get the wireless to work upon boot up? ](*,)

flak9
July 13th, 2005, 08:44 AM
Ok. I have updated as it says above. I have an emachines m6805 with the broadcom wireless chip and I have done exactly what was posted in the guide and am coming up with this error when I am booting:


WARNING: /etc/modprobe.conf exists but does not include /etc/modprobe.d/

When I reboot and do a modprobe ndiswrapper, I can goto the Network and see my wireless device, but I think I only have an issue when it reboots. How can I restore modprobe.d?

I have removed the ndiswrapper source and utils through synaptic. I think that i might have possibly deleted something called modprobe.d, when I was fussing around earlier. Im not sure whats going on.

Can somebody who is using the broadcom driver post their modprobe.conf file?

What should I try next? :-x

jaymacwade
July 14th, 2005, 07:47 AM
I had read all 13 pages of this thread and spent about a day and a half trying every suggestion posted there without success. No matter what I tried, ndiswrapper from the synaptic repository would not work. ](*,)

I ended up compiling ndiswrapper v1.2 from source. Once that was done, everything suddenly fell into place. I am now surfing without the wires. Not bad considering that the Dell technician I talked to couldn't even help me get it working in M$Windows! :grin:

Now I just need to get the internal modem working. (--No PCtel drivers for 2.6 kernel ](*,) --)

Here are my specs:
Dell Latitude C640 laptop
Broadcom BCM4306 mini-pci wifi card (Dell TrueMobile 1300?)
Ndiswrapper v1.2 (compiled from source)
Windows XP driver (Dell download #R81433)

Hope this helps someone else,
~ j.Wade

pierre
July 18th, 2005, 07:41 PM
Hi all,

My laptop is an HP zd8147ea with broadcom b/g
Kernel is a Ubuntu, kernel 2.6.10-5-686-smp
I've applied the following instructions ( Hieronymus code ) and it works well after a reboot.



sudo modprobe -r bcmwl5
sudo rmmod ndiswrapper
sudo apt-get remove ndiswrapper-utils
sudo rm -r /etc/ndiswrapper/
sudo rm -r /etc/modprobe.d/ndiswrapper
sudo apt-get install linux-headers-2.6.10-5-686-smp
( Linux kernel headers 2.6.10 on PPro/Celeron/PII/PIII/PIV SMP )
cd /usr/src/
sudo tar xvzf ndiswrapper-1.2
(version ndiswrapper-1.2 (http://prdownloads.sourceforge.net/ndiswrapper/ndiswrapper-1.2.tar.gz?download) to be copied onto /usr/src/ )
cd /usr/src/ndiswrapper-1.2/
sudo make
sudo make install
cd /home/pierre/Desktop/
sudo ndiswrapper -i bcmwl5.inf
sudo ndiswrapper -l
sudo modprobe ndiswrapper ( blue led appears now )
sudo dmesg
sudo iwlist wlan0 scan
sudo ndiswrapper -m


I used Network Administration in order to manage Wlan Card ( DHCP, WEP Key ) and set wlan0 as default.
It works fine after reboot.

Hieronymus, Jonny , u all in this thread are really fantastic

Kind regards,

Pierre

Added : Just in case for zd8147ea users who cannot find drivers for this laptop.
They are on my own ftp.
bcmwl5.inf (http://www.lylyspace.com/nux/bcmwl5.inf)
bcmwl5.sys (http://www.lylyspace.com/nux/bcmwl5.sys)
and
ndiswrapper1.2 (http://www.lylyspace.com/nux/ndiswrapper-1.2.tar.gz)

umdzig
July 26th, 2005, 12:17 AM
I have installed ndiwswrapper. When i try to install the driver for my dell true mobile 1300, with the broadcom driver bcmwl5.inf all i get is this:

root@laptopmike:/home/zig # sudo ndiswrapper -i ~/Desktop/bcmwl5.inf
ls: /etc/ndiswrapper: No such file or directory
Installing bcmwl5
cp: cannot stat `/root/Desktop/bcmwl5.inf': No such file or directory


Any help is appreciated as this has been driving me crazy!

zer
July 27th, 2005, 01:37 PM
umdzig: You are already root, so the path is wrong ($HOME of root is another path as $HOME of the user)
Please open a gnome-terminal (pressing ALT+F2 and typing "gnome-terminal" followed by <Enter> will do it)
The follow the instructions.

Julius
July 28th, 2005, 01:10 PM
This howto got my card to work under Linux!
However, I was not able to change the value to 0 in all the .inf files by the command, I had to do it manually instead.

The problem is that now I get tons of messages at boot, one for each single inf file.
The message says something like "file 123981290.inf~ ignored"

(the file name I wrote is just random :P)

umdzig
July 29th, 2005, 02:16 PM
Julius: I had to do the same thing and im getting the same problem, however my wireless does work so im not too worried about it.

jonny
July 30th, 2005, 09:08 PM
This howto got my card to work under Linux!
However, I was not able to change the value to 0 in all the .inf files by the command, I had to do it manually instead.

The problem is that now I get tons of messages at boot, one for each single inf file.
The message says something like "file 123981290.inf~ ignored"

(the file name I wrote is just random :P)
You used gedit (Applications --> Accessories --> Text Editor) to do your amendments, right? By default, when gedit overwrites and existing file, it creates a backup file with the same name, but with a ~ character added to the end. These files can't be seen with Nautilus, even if you ask to see hidden files, but they're very real.

You can delete these files in a terminal session with the 'rm' command; that should make your problems go away. But it still doesn't explain why the how-to didn't work properly. Did you get any strange error messages when you tried the command to turn the zeroes into ones?

foxy123
August 2nd, 2005, 12:41 PM
hi jonny,thanks a lot for the great howto. It worked out very well for me, I only needed to make changes in conf files manually and here I am with Belkin wifi card enabled.

Stelmate
August 3rd, 2005, 02:41 PM
SOLUTION FOUND:
If you have
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted

Check your system logs, what happened to me is the update manager installed a new version of ndiswrapper when I wasn't looking, just reinstall the older version from the synaptic manager under packages>force version> hoary version
than install the older one and packages>lock version so it doesn't happen again.
Hope that helped some of you

Ubuntu-one
August 3rd, 2005, 03:06 PM
Ok, so i've read every post tried a lot...

boris@ubuntu-one:~$ sudo modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted

Keep getting this.

My version of ndsiwrapper is 0.12+1.0rc2-1, if I need another version please tell me which one and where i can get it. But all is configured according to this post.
Dunno what to do please help.

--------------------------------------------
Ok.

Got it...
I had compile ndiswrapper to get it work.
Work fine now thanx to the post by luckyboylost..

foxy123
August 3rd, 2005, 03:12 PM
Ok, so i've read every post tried a lot...

boris@ubuntu-one:~$ sudo modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted

Keep getting this.

My version of ndsiwrapper is 0.12+1.0rc2-1, if I need another version please tell me which one and where i can get it. But all is configured according to this post.
Dunno what to do please help.
I've got the same version and no problem...

BlueJack
August 4th, 2005, 01:41 AM
Thanks for this HOWTO, i am now able to connect to my wireless linksys router(WAG54G). However, i do have two small problems.

1. the local ip address of the machine with the wireless card keep increasing on every reboot (from 192.168.1.102 to 192.168.1.103 and so on) is this normal? if so, how can i use port forwarding to this machine?

2. while booting its takes an extra 30-60 secs to complete the Network Setup step, i can live with this, but would be nice to know of any way around it.

anyways, thanks again to everyone who has contributed to this HOW TO.


.

foxy123
August 4th, 2005, 09:03 AM
<snap>

2. while booting its takes an extra 30-60 secs to complete the Network Setup step, i can live with this, but would be nice to know of any way around it.
<snap>

Got the same thing. Though, it took some time to connect to a router even via ethernet cable...

jonny
August 4th, 2005, 11:51 AM
Thanks for this HOWTO, i am now able to connect to my wireless linksys router(WAG54G). However, i do have two small problems.

1. the local ip address of the machine with the wireless card keep increasing on every reboot (from 192.168.1.102 to 192.168.1.103 and so on) is this normal? if so, how can i use port forwarding to this machine?

2. while booting its takes an extra 30-60 secs to complete the Network Setup step, i can live with this, but would be nice to know of any way around it.

anyways, thanks again to everyone who has contributed to this HOW TO.


.
1. I've never seen this happen before, but, hey, it works. If you want to keep the same IP address each time, you shouldn't use DHCP. That only takes a small amount of fiddling in your router's settings and in your ubuntu network settings but presupposes a willingness to learn some networking basics.

2. The delay happens while your laptop is waiting for an IP address to be allocated by your router. If you don't plan to use the network in a particular session, or if you know that you're out of range of your wireless network, you can cut this step out by pressing ctrl-c. In my experience the delay is usually shorter if you use static IP addressing.

gardnerm
August 4th, 2005, 02:33 PM
I am having problems with a Dell Latitude D800 with the Dell Truemobile 1450. I have the wireless card working and can connect to access point fine as long as SSID is being broadcast and no encryption. When I try to disable SSID broadcast or use WEP I can not connect. Has anyone else had these problems?

BlueJack
August 4th, 2005, 03:09 PM
1. I've never seen this happen before, but, hey, it works. If you want to keep the same IP address each time, you shouldn't use DHCP. That only takes a small amount of fiddling in your router's settings and in your ubuntu network settings but presupposes a willingness to learn some networking basics.

2. The delay happens while your laptop is waiting for an IP address to be allocated by your router. If you don't plan to use the network in a particular session, or if you know that you're out of range of your wireless network, you can cut this step out by pressing ctrl-c. In my experience the delay is usually shorter if you use static IP addressing.

switching to staitc IP address fixed the first problem, i can live with the second.

thanks for your help jonny,

douglas_slac
August 11th, 2005, 11:10 PM
So, this is the only thing I have found anywhere that has actually worked on getting the wireless working on my Dell laptop. Makes me wonder why this only exists here and other people are either not having problems, or can get things working without help. Anyway a few comments:

1. I needed the bcmwl5a.inf file for the card, not a big deal.

2. I got the drivers from an update on the Dell web pages. The HOWTO here seems to suggest that people can copy this over from a Windows install on another partition. Are people actually using Windows out there, and have this installed on another partition? Weird. So, the driver update came from Dell as a self extracting file that ended with a *.exe. I had no idea really what to do with this, and neither did Ubuntu it seems. I had to install wine to handle this file, and get the small *.inf file out of it. Do people know if there is a better way to handle this? How do people deal with these *.exe files in Ubuntu?

3. The shell script for loop with cat piping into sed and piped into a file is a little cludgy in the HOWTO. perl can edit the files in place a little more cleanly with code like:

perl -pi -e 's/RadioState\|1/RadioState|0/' /etc/ndiswrapper/bcmwl5/*.conf

This one line will do the same as the last three lines of code in your point 3 in the HOWTO.

4. Is there someway to put ndiswrapper supported wireless cards into ubuntu support such that these cards will hopefully just work when the computer gets installed?

Thanks for the only working help for the card I have found so far.

schultzy
August 11th, 2005, 11:47 PM
Just wanted to say thanks for this walkthrough. It took me a couple of tries with different drivers, but it's working great! I've played with Linux from time to time, but always went back to windows because there was always something that I couldn't get working. This is the first distro I've tried that I could get everything working. Mainly due to the great how to's on these forums. Thanks to all that have posted them up. Hopefully, I will become savvy enough to post my own someday.

=D>

Byggarn
August 12th, 2005, 08:39 AM
Many thanks to everybody contributing in this thread, finally after 5 hours of tweaking and rebooting I got my Linksys WPC54G to work :smile: .

Greetings from sunny Sweden //Byggarn

MarkN
August 15th, 2005, 06:26 PM
I haven't checked this thread for about a week, so if the problem has already been solved then I give my apologies... :-)

If you are having trouble connecting to a wireless access point when using WEP, but it works perfectly when WEP is switched off, then try the following:

1. Open a terminal. Ensure that the ndiswrapper module is loaded and the card is activated (read the instructions on page 1).
2. Type: "sudo iwconfig wlan0 essid youressidgoeshere"
3. Type: "sudo iwconfig wlan0 key open yourwepkeygoeshere"
4. Now try to use the wireless network. If it works, go back to your terminal.
5. Using sudo, open an editor to edit the file "/etc/network/interfaces". (e.g. "sudo gedit /etc/network/interfaces").
6. In the section for "wlan0", insert the lines:
"wireless-mode Managed"
"wireless-keymode open"
7. Save the file.
8. Either restart the computer or type:
"sudo ifdown wlan0" then "sudo ifup wlan0" into the terminal.

Hope this helps!

lomomo
August 17th, 2005, 03:16 PM
i've been all day trying to setup a belkin pci wireless card, finally i managed to compile and install ndiswrapper 1.2 and now i've the wlan0 device. The pci card light is on and i can set an IP to the interface.

The problem is i can't see my AP.

When i do sudo iwlist scan i get this:


Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0 No scan results

I'm using the bcmwl5a driver becouse the bcmwl5 was not working.

When i do dmesg after modprobe ndiswrapper i get this:


ndiswrapper: using irq 17
wlan0: ndiswrapper ethernet device 00:11:50:3b:1a:69 using driver bcmwl5a, configuration file 14E4:4320.5.conf
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP

It seems to be all ok but i can see the AP. The AP is working fine and i'm using it with my laptop. I tryed to disable all security options on the AP but i got the same result. Any idea on how can i fix this?

S.nazari
August 19th, 2005, 02:37 AM
Broadcom wireless cards are tricky to set up in ubuntu, and the forums are full of frustrated users seeking advice. Broadcom provide no Linux support (feel free to complain to your hardware vendor or choose a different card if you haven't yet shelled out your cash), but they can be made to work - and you're in the right place if you want to know how.

First, you need to find out if this How To is for you. Broadcom wireless cards come under many brand names and, in particular, are used in many Dell and Acer laptops. Look for the drivers supplied with your card (Dell usually store a copy in C:/DRIVERS/NETWORK/ADDON); if you have a file called bcmwl5.inf or bcmwl5a.inf then keep on reading. You won't succeed without following these instructions!

0. Before you start, clear out any mess from existing failed attempts to use ndiswrapper. Note that you shouldn't use a root terminal to execute the code in this how-to; use a normal terminal session instead.
sudo modprobe -r bcmwl5
sudo rmmod ndiswrapper
sudo apt-get remove ndiswrapper-utils
sudo rm -r /etc/ndiswrapper/
sudo rm -r /etc/modprobe.d/ndiswrapperSome of these steps may report errors; just ignore them.

1. Copy the bcmwl5.inf and bcmwl5.sys files to your desktop

2. Follow the advice given here under How to add extra repositories (http://ubuntuguide.org/#extrarepositories)

3. Open a terminal session and enter this code. Note that you need an active network connection for this to work; I've assumed that if you have access to a wireless LAN, you also have access to a wired network as a fallback.
sudo apt-get install ndiswrapper-utils
sudo ndiswrapper -i ~/Desktop/bcmwl5.inf
sudo ndiswrapper -m
for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
done4. Reboot your PC. On restarting, the light on your wireless card should come on. If not, try entering
sudo modprobe ndiswrapper5. Your card is now working. Open the networking configuration tool System --> Administration --> Networking

6. Select your wireless network card (probably wlan0) and hit the properties button.

7. Tick the 'This device is configured' box, and enter your network name and connection settings. Ask your office network administrator for support if you don't know what this question means, or copy your settings from Windows.

8. BE CAREFUL entering your WEP key, if you're using one. You're expected to enter this in hexadecimal form; if you don't speak hex, prefix your key with s:

9. Click OK. The screen should close fairly quickly; if it hangs, you probably aren't connected properly.

10. Back in the Network Settings screen, select your wireless device as the default gateway device.

11. Click OK. Again, the screen should close fairly quickly.

12. Enjoy wireless nirvana. If everything works, you can delete the file from your desktop.

13. You might notice that the signal strength applet doesn't work properly. This is a known bug with these cards.

If you have trouble, try booting into Windows - if you dual boot - and checking that the card is enabled. Some laptops allow the wireless card to be switched off, usually with a special key combination, and I've not found a reliable way to make this work in Linux.

(Note: This how-to has been updated to reflect all comments from the thread up to 19 April)

loadndisdriver error / Ignoring config files at start up.
Problem with config file Radiostate editing form 1 to 0:
driver not loading during startup.
The command above written by jonny:

for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
done
May not work in some cases. My case was one of them.
How to find out if you affected? during start up you will get the error something along the lines of loadndisdriver error / Ignoring config, to check what caused it after entering the command given by jonny, go to the config directory. This is the directory that the above command effects. You will find that all the config files have no size at all. (have a look at the attached Screen Shot 1.)
The command above has deleted them or something has gone. Wrong.
I would recommend manual editing of all the cofig files in this directory instead of using the command above. Therefore you must uninstall and then reinstall the bcmwl5 drivers as mentioned above but this time instead of using the command above to edit the radio state in the config files you should open them one by one and follow below.
Alt3. Open each file and edit the RadioState|1 to RadioState|0

Alt3.1 Then save the changed files NOT TO THE SAME DIRECTORY (/ect/ndiswrapper/bcmwl5) but to another directory of you choice.

Alt3.2 After all four files have been changed and saved to an alternative directory form that above, select all the four Original corrupt config files (note that there is a short cut file also present, you do not need to do anything with this) to your desktop.

Alt3.3 As soon as you have done this move, you will see that the shortcut file mentioned above will disappear. Do not worry! it will reappear as soon as you put the FOUR EDITED FILES to the /ect/ndiswrapper/bcmwl5 directory.

Alt3.4 All you have to do now is restart the computer and the light on the card should come on.

Alt3.5 Use the GUI Networking tool in Ubuntu to activate the card and start your Internet connection, or you can use the command;

:~$ dhclient wlan0
And you should fine that an AP (access point is found), and an IP has been given to you computer.

(REMEMBER DO NOT SIMPLY OPEN THE CONIFG FILES AND SAVE TO THEIR ORIGINAL DIRECTORY, THE PROCESS MUST BE COMPLETELY MANUAL AS IN STEPS Alt3.-3.5)

dizbah
August 19th, 2005, 10:58 PM
I am having a problem with step 4. I get the following when running it:

FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-686-smp/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted


I have rebooted and my wifi lite is still unlit. I am using a dell 1350 wireless card and have the bcmwl5.inf saved on my desktop. I am very new new to linux and would greatly appreciate the assistance.

lyzer
August 21st, 2005, 06:32 AM
So, these are the AP's you can see - which is yours? If it's "@home" then try:

$ iwconfig wlan0 essid @home
$ iwconfig wlan0 key C0AD-9DDC-5AFD-BC8B-AA46-CAE5-98
$ dhclient wlan0

Should work (if the key is right too :))


after following the tut here and the one on the wiki with no luck i went and popped in my netgear M4A01 card from 4 years ago and ubuntu auto-detected and set it up no problem and i was running wifi. but my dell has an internal broadcom sooo i wanted to get it working, the only way i've gotten it to work is running the tutorials and then do

$ iwconfig wlan0 essid linksys
$ dhclient wlan0

thanks so much kmyram! you made my day :)

Julius
August 21st, 2005, 10:19 AM
You used gedit (Applications --> Accessories --> Text Editor) to do your amendments, right? By default, when gedit overwrites and existing file, it creates a backup file with the same name, but with a ~ character added to the end. These files can't be seen with Nautilus, even if you ask to see hidden files, but they're very real.

You can delete these files in a terminal session with the 'rm' command; that should make your problems go away. But it still doesn't explain why the how-to didn't work properly. Did you get any strange error messages when you tried the command to turn the zeroes into ones?
Yeah, some days ago I realized that those were the backups. I was using a root nautilus but I couldnt see them, but that was because the option of showing hidden files and backups wasnt checked.

The error I got was most likely access denied. I'm sorry I didn't copy the output for that command.

poetic_folly
August 23rd, 2005, 06:21 PM
please help! I am a complete noob here, and don't have access to anything other than wifi at the moment (well, without going to another house and setting stuff up).

Is there ANY way to make my wifi card work WITHOUT having a net connection first?

ChamPro
August 25th, 2005, 09:39 PM
Wireless and Ubuntu just don't mix well right now. It's enough trouble to get a Intel 2200 to work, but these Dell 1350 cards are impossible.

I tried following both sets of directions. The original set conks out on the "cat" command. If I run it in a root terminal, the command screws up all twenty of the .conf files by making them 0 bytes. Following the revised set of directions, I couldn't move the .conf files out of the directory in order to move the saved ones in.

So I'm stuck with unrecognized WiFi... and that crappy "Error inserting ndiswrapper (/lib/modules/2.6.10-5-686/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted".

Any suggestions?



loadndisdriver error / Ignoring config files at start up.
Problem with config file Radiostate editing form 1 to 0:
driver not loading during startup.
The command above written by jonny:

for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
done
May not work in some cases. My case was one of them.
How to find out if you affected? during start up you will get the error something along the lines of loadndisdriver error / Ignoring config, to check what caused it after entering the command given by jonny, go to the config directory. This is the directory that the above command effects. You will find that all the config files have no size at all. (have a look at the attached Screen Shot 1.)
The command above has deleted them or something has gone. Wrong.
I would recommend manual editing of all the cofig files in this directory instead of using the command above. Therefore you must uninstall and then reinstall the bcmwl5 drivers as mentioned above but this time instead of using the command above to edit the radio state in the config files you should open them one by one and follow below.
Alt3. Open each file and edit the RadioState|1 to RadioState|0

Alt3.1 Then save the changed files NOT TO THE SAME DIRECTORY (/ect/ndiswrapper/bcmwl5) but to another directory of you choice.

Alt3.2 After all four files have been changed and saved to an alternative directory form that above, select all the four Original corrupt config files (note that there is a short cut file also present, you do not need to do anything with this) to your desktop.

Alt3.3 As soon as you have done this move, you will see that the shortcut file mentioned above will disappear. Do not worry! it will reappear as soon as you put the FOUR EDITED FILES to the /ect/ndiswrapper/bcmwl5 directory.

Alt3.4 All you have to do now is restart the computer and the light on the card should come on.

Alt3.5 Use the GUI Networking tool in Ubuntu to activate the card and start your Internet connection, or you can use the command;

:~$ dhclient wlan0
And you should fine that an AP (access point is found), and an IP has been given to you computer.

(REMEMBER DO NOT SIMPLY OPEN THE CONIFG FILES AND SAVE TO THEIR ORIGINAL DIRECTORY, THE PROCESS MUST BE COMPLETELY MANUAL AS IN STEPS Alt3.-3.5)

kdavison007
August 26th, 2005, 02:19 PM
please help! I am a complete noob here, and don't have access to anything other than wifi at the moment (well, without going to another house and setting stuff up).

Is there ANY way to make my wifi card work WITHOUT having a net connection first?

Just download Nndiswrapper and your windows driver from your other workstation and use a key drive, floppy, built in LAN, or CD-ROM to copy it to your Ubuntu system.

The instructions in this thread are good, but I decided to get the latest ndiswrapper and then just follow the INSTALL instructions included with Ndiswrapper and I had it working in 5-10 minutes. My only problem now is an IRQ conflict with Ndiswrapper and ACPI when my Dell D600 boots from the battery it hard locks. Been working on that for a long time...

monpet
August 28th, 2005, 03:01 PM
I'm an experienced Windows user, but a LINUX newbie. Have tried KUBUNTU, but found out, that UBUNTU fits better for me. Both KUBUNTU and UBUNTU installed without problems on my laptop, and while the wired network worked from the box, the wlan drove me crazy. I use an ASUS WL 500g AP and an ASUS WL 100g PCMCIA card. Works great with Windows XP.
Have surfed three days (and nights) through almost every Google link. Had the newest ndiswrapper 1.2 pluss utilities via Synaptic and the bcmlw5-driver from the ASUS-cd. After the usual ndiswrapper procedure, which is also described in this HowTo, the card came up and was recognized both with terminal commands and in the Networksettings-window.
But whatever I did, I couldn't access the AP. Couldn't ping anything. Until I found this thread (havn't searched for Broadcom so much before).
Because I had done all the first described steps from a new install of UBUNTU 5.04 and after install and upgrade to ndiswrapper 1.2 pluss utilities via Synaptic before, I just edited the 3 *.conf files with
'sudo gedit /etc/ndiswrapper/bcmwl5/*.conf' (for * I filled in the number/letter combination of each file)
and found in all files the 'RadioState|1' line, which I changed to 'RadioState|0'.
Saving.
Reboot.
And nearly unexspected after three days frustration, both LED's on the card worked and I was connected to Internet and home-network.

You all have done an amazing job with this Howto and saved my weekend and me from 'the great depression' :razz: .

My specs:

CINET smartbook 830
Pentium M 1,7
512 RAM
30 Gb harddisk, dual boot Windows XP professional english and Ubuntu 5.04 german (this is workrelated)
ATI Randeon mobility M7 (7500)
Asus WL 100g PCMCIA card (recognizes as PCI card)
Asus WL 500g AP

ChamPro
August 30th, 2005, 08:38 PM
Wireless and Ubuntu just don't mix well right now. It's enough trouble to get a Intel 2200 to work, but these Dell 1350 cards are impossible.

I tried following both sets of directions. The original set conks out on the "cat" command. If I run it in a root terminal, the command screws up all twenty of the .conf files by making them 0 bytes. Following the revised set of directions, I couldn't move the .conf files out of the directory in order to move the saved ones in.

So I'm stuck with unrecognized WiFi... and that crappy "Error inserting ndiswrapper (/lib/modules/2.6.10-5-686/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted".

Any suggestions?

I gave up on Hoary and installed Breezy Colony 3. The instructions provided worked fine this time (and the video drivers work by default!).

The problem I'm having now is that I can't get an IP from DHCP. I've tried through the Gnome network properties and using GTKwifi 1.08.1, but it just fails at securing an IP. "Ndiswrapper -l" shows that they're installed, "dmesg" shows them working with no errors, and "iwlist wlan0 scan" shows the available APs with MAC addresses. However, iwconfig shows my card connected to an access point with no MAC address and DHCP just fails everytime. Hmmm.

cokhavim
September 1st, 2005, 11:09 AM
i'm having problems with the WEP key. my Broadcom wireless card works great when WEP is disabled on my router (thanks to this great HOW-TO), however, when WEP is enabled, wireless stops working.

i've tried using "s:" as a prefix to my WEP key (which is just numbers, btw), but it generated this error message:
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument.

i tried putting the key in quotes which did nothing.

i tried setting the keymode to open, and again, nothing.

can anyone help me? thanks.
jo

cokhavim
September 1st, 2005, 09:30 PM
well, i got it working.

what did i do?

drum roll....

i unplugged the router and plugged it back in again.

h17m4n
September 2nd, 2005, 01:45 AM
After I finish all the commands and restart, I try to do sudo modprobe ndiswrapper, and I get: FATAL: Module ndiswrapper not found.

skirkpatrick
September 4th, 2005, 02:18 AM
If I wasn't going bald before, I certainly am now. Configuring wifi on my HP Pavilion laptop was a piece of cake.

Okay, I've read every message in this topic and several others as well. I've followed almost every instruction given and some from links to other webpages. I've got an Acer 3002LCi with built-in Broadcom wifi. I have currently:

1) Built ndiswrapper v1.3rc1 and successfully installed it from a .deb (I've also tried v1.2).

2) I have installed the drivers that came with the Windows install and have even installed the ones specified on the ndiswrapper Wiki (currently installed).

3) I've installed acerhk and modprobed it as dictated on the ndiswrapper Wiki.

4) I've modprobed ndiswrapper and added it to /etc/modules.

5) All the .conf files have RadioState|0.

Dmesg looks fine, ifconfig looks fine, iwconfig looks fine. The problem is that "sudo iwlist wlan0 scan" always reports "no scan results". It's working fine in Windows, it's almost as if it's not turning on the radio but I can't find anything about turning it on in Linux.

Getting ACPI working correctly wasn't this hard.

JohnRM
September 5th, 2005, 04:39 PM
I've read most of the posts in this topic and many more in other topics.

I still cannot get my wireless card to power on, let alone access the internet. :)

I have a Belkin High-Speed-Mode G Wireless Card 7001, using the broadcom chipset. I have bcmwl5.inf, bcmwl5a.inf, and bcmwl5.sys at my disposal.

Here is the procedure I used:

1. Clean Install of Hoary 5.04
2. Installed ndiswrapper via Synaptic Package Manager
3. Copied bcmwl5.inf and .sys to my desktop
4. Opened a terminal, and executed the code that was described in step 3 of the original HOW-TO
5. When I do a ndiswrapper -l, I get bcmwl5- Invalid driver

6. When I do a modprobe ndiswrapper, I get a failed to insert error, followed by a permission denied or something like that.

After a -m, I reboot, and still the light does not come on my wireless card.

I'm still figuring out the radiostate and new versions of ndiswrapper, but I do NOT have LAN as a fallback, I have only wireless LAN to connect to the internet on that machine. I do have the Ubuntu CD-ROM, and that is how I installed ndiswrapper.

Thanks to anyone who can give me some extra help.

lost.sync
September 5th, 2005, 05:32 PM
just wanted to say thanks. this actually worked and wasn't 9x more complicated than it needed to be.

just installed ubuntu today. xp refugee. tried mandrake/mandriva, linspire (they were giving it away), and fedora core before this, but i think this'll be the one to stick.

lost.sync
September 5th, 2005, 05:38 PM
I have bcmwl5.inf, bcmwl5a.inf, and bcmwl5.sys at my disposal.

i have no idea if this might work for you, but it helped me. instead of using bcmwl5.inf, try bcmwl5a.inf. doing that made all the difference.

JohnRM
September 5th, 2005, 06:07 PM
i have no idea if this might work for you, but it helped me. instead of using bcmwl5.inf, try bcmwl5a.inf. doing that made all the difference.
Yes, I just tried that a few minutes ago.

Here's what my status is now:

When I installed the bcmwl5a.inf driver, -l says the driver is present, and hardware is present. I do a -m, and the light does not come on during boot. When back on the terminal, I type modprobe ndiswrapper, and then it goes to another blank prompt.

After doing a modprobe, the wireless connection appears in Network settings, and I ticked the "this connection is configured box", and filled in my SSID. (I have no WEP key)

Then I activated the connection. It took about 2 minutes to activate. Then I selected in as my default gateway, then pressed okay. It took about 2 minutes again to close. Whenever I come back to network settings, wlan0 is no longer the default gateway.

Still no light on my wireless card, and I cannot access the internet, even though the connection is activated.

One thing though. I have not changed any RadioState options in gedit, mainly because I cannot change permissions to writeable.

Still no connection. :(

skirkpatrick
September 6th, 2005, 01:29 AM
JohnRM, my reply is based on getting wifi to work on my HP laptop, not my son's Acer laptop that I'm still fighting.

1) You should be using sudo with your gedit to change the config files.

2) When my wirelss is active, my LED doesn't come on under Linux. I think with some laptops, it's not directly controlled by the wifi.

3) I have the same problem with wlan0 not being able to connect even though it is listed as the default gateway. I always have to deactivate eth0 even if it's not connected.

JohnRM
September 6th, 2005, 01:13 PM
JohnRM, my reply is based on getting wifi to work on my HP laptop, not my son's Acer laptop that I'm still fighting.

1) You should be using sudo with your gedit to change the config files.

2) When my wirelss is active, my LED doesn't come on under Linux. I think with some laptops, it's not directly controlled by the wifi.

3) I have the same problem with wlan0 not being able to connect even though it is listed as the default gateway. I always have to deactivate eth0 even if it's not connected.
I fixed the problem. I was doing so many things, I'm not sure which one fixed it! :)

But I'm pretty sure that the best explanation is to use bcmwl5a.inf, then follow the instructions at the beginning of the topic exactly.

I'm wireless now!

anitsirK
September 11th, 2005, 11:16 PM
I just wanted to add another solution to potential problems to this thread.

I followed all of the instructions, and got no errors, until I went to try to ifup wlan0. wlan0 wasn't recognized. I looked at dmesg's output, and it said something to the effect of:



loadndiswrapper failed (65280); check system log for messages from 'loadndisdriver'

So, I looked in KSystemLog and found this:


loadndisdriver: load_driver(273): couldn't read conf file 14E4:4320:144F:7050.5.conf for driver bcmwl5

Looked in /etc/ndiswrapper/bcmwl5 and found that
14E4:4320:144F:7050.5.conf and 14E4:4320:144F:7051.5.conf were both 0 byte files, but 14E4:4320:144F:7053.5.conf looked like it contained useful stuff. I did the following:



ln -b 14E4:4320:144F:7053.5.conf 14E4:4320:144F:7051.5.conf
ln -b 14E4:4320:144F:7053.5.conf 14E4:4320:144F:7050.5.conf


That links the two bad/empty files to the good one, and the -b backs up the old ones, just in case.

Rebooted, and did sudo modprobe ndiswrapper. After that, ifup wlan0 worked perfectly.
:D

bdwarr6
September 12th, 2005, 03:28 AM
ok guys i have done every single thing said in this thread and many others, I get no errors, i have eth0 off and wlan0 as primary and on configured my wep is on everything seems fine to me but I get nothing when I do ipconfig just the basic saying nothing connects all the 00,00, (id post exact thing but im no another pc
any ideas please help
Belkin f5d7011 wireless card used the dell drivers

dell latitude c600 laptop
I do have lights on my card
It shows up in network connections

It wont connect to anything, I also find no networks when I do a scan

mwarndt
September 12th, 2005, 04:23 AM
I receive the same error message. I performed an: sudo apt-get install linux-686. Then, I rebooted into 686.

Next, I perfomed a: sudo apt-get install ndiswrapper-utils. Then, I installed the broadcom driver with: sudo ndiswrapper -i <location of the driver>. Next, I entered: sudo ndiswrapper -m. Then, I rebooted.

After the reboot, I entered sudo modprobe ndiswrapper...without any problems! Yeah!

Now, I get to the KWifiManager (using Kubutnu), I Scan For Networks, but no networks are found even though I get signal. I go to Kcontrol via: sudo Kcontrol from the Shell. I attempt to enable my wlan0, but my wlan0 immediately disables.

I've attempted to ask others on #kubuntu in IRC, but I've received little help other than people telling me to try a different ndiswrapper, which doesn't make much sense to me because ndiswrapper is fine and is doing it's job. Plus, I've attempted to get "newer" ndiswrappers working without any success.

Please help...I will be forever in your debt!

](*,)

chipotlehero
September 13th, 2005, 01:40 AM
Hi I'm a linux/ubuntu noob but I can follow steps easily and know how to search forums for answers. I've searched the forum and this thread for my problem but it doesnt seem to come up, its probably just a small thing.

I go through all the steops in the first post in the thread and then when I type:



sudo modprobe ndiswrapper


i get the error:



FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted


anyone have any ideas of what I'm doing wrong?

mwarndt
September 13th, 2005, 03:19 AM
I upgraded the kernel using sudo apt-get install linux-686. I used the ndiswrapper-utils that came with Synaptic/Kynaptic, and I followed the usual steps, and things worked for me when it came to using sudo modprobe ndiswrapper.

hangfire
September 13th, 2005, 06:37 PM
Thanks for the info! I've gotten much further from this page than any other on my D800.

I have a slight correction. The shell snippet:

for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
done

has a problem. It can create 0 byte files. The reason is, the > $confile can be executed before the cat of the file. Thus the redirection zeros the file, shell cats a zero byte file, seds it, and rewrites it as empty.

This only happens some of the time, in my case, usually on the conf file corresponding to my network adapter. It can be fixed by writing to a file in /tmp and then copying that file back to the current directory.

HF

jrzy
September 21st, 2005, 04:28 AM
Guess www.ubuntuguide.org/#extrarepositories is down and I need the instructions for step No.2. Can someone help me out ??

skirkpatrick
September 21st, 2005, 12:40 PM
Here's a mirror for the Guide:
http://www.frankandjacq.com/ubuntuguide/5.04/index.html

tmmuk
September 25th, 2005, 12:39 PM
i followed this guide and after checking sudo ndiswrapper -l it says

Installed ndis drivers:
bcmwl5 invalid driver!

this is weird as I tried both bcmwl5 and bcmwl5a and they both came on the belkin cd

EDIT: nvm, downloaded the dell driver that was recommended, re installed using bcwml5a then removed bcmwl5

now when I go into KWifiManager it shows my card and its working

however when I scan for networks it doesn't find any even though there is one

rsankuratri
September 27th, 2005, 04:39 AM
I have been trying various distributions on my Inspiron 9100 without luck. That was until I came upon Ubuntu linux and am extremely pleased with it. Configuring the wireless network on my laptop has been the most easiest of all. Here is what I had done...
1. Opened a terminal and copied the windows driver from Dell (R102319) onto the Desktop. (I had extracted the drivers into a folder called R102319).
2. Entered the followinf command...
a. sudo bash
b. chmod -R 777 R102319/
3. Installed the default ndiswrapper that comes with the 5.10 distribution
4. Did a cd into the R102319 folder on my desktop and from within that folder (while still in the root terminal from step 2a) gave the following command...
ndiswrapper -i bcmwl5.inf
This resulted in output that stated that it was forcing the RadioState from 0 to RadioState 2
6. Entered the following command
ndiswrapper -m
7. Opened the network configuration tool from System --> Administration --> Networking and selected wlan0 and configured it as follows...
a. On the DNS tab entered the IP of the wreless router (192.168.1.1)
b. Selected the Wireless connection and clicked on the properties...
c. Selected the check box Enable this connection
d. Selected the ESSID of my router from the dropdown
e. Entered the WEP key with the Key type as Hexadecimal
f. Selected DHCP for the Connection Settings Configuration
g. Clliked OK. The window closed in about 15 seconds
h. Selected the Default gateway device as wlan0 in the Network Settings window and clicked OK. This window lso closed after about 15 seconds also.
8. Closed all windows and rebooted the laptop...
9. Opened a browser and started documenting what I did. :-)

Most of the steps are similar to the re-written procedure on page 4 of this discussion thread. But I did not go through the hassle of changing the RadioState in the conf files using the looping since it was one automatically for me when I installed the driver.

This is a repeatable procedure since this is the second time I did this. I had re-installed the Ubuntu 5.10 after a botched effort to install and see Fedora Core 4. If you have any questions let me know

hangfire
September 27th, 2005, 02:58 PM
i followed this guide and after checking sudo ndiswrapper -l it says

Installed ndis drivers:
bcmwl5 invalid driver!


Check and see if that some of the sed'd files are zero bytes long. If they are you are a victim of the bug I noted above.

skirkpatrick
October 3rd, 2005, 03:13 AM
My problems are now fixed: http://www.ubuntuforums.org/showthread.php?p=383723#post383723

markr
October 4th, 2005, 12:46 PM
Followed the instructions and my wireless network seems to work a treat - thanks for the info.

However, when I boot my machine now (without a router in sight) my machine hangs for around a minute before continuing.

I assume this is because it's trying to retreive an ip address. As I use my laptop standalone for alot of the time I was wondering what the best way of avoiding this delay when I'm not actually wanting to connect to the wireless router?

jonny
October 4th, 2005, 11:32 PM
Hit ctrl-c when you get the delay, or set up your network to use static ip addressing.

laforge
October 5th, 2005, 03:23 AM
Ok i get quite a few errors while doing everything.


#1
sudo modprobe -r bcmwl5
FATAL: Module bcmwl5 not found.
#2
sudo rmmod ndiswrapper
ERROR: Module ndiswrapper does not exist in /proc/modules
#3
for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
> sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
> done
bash: /etc/ndiswrapper/bcmwl5/14E4:4311:1028:0007.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4311.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4312:1028:0007.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4312.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4318:1028:0005.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4318:1028:0006.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4318.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4319:1028:0005.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4319:1028:0006.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4319.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320:1028:0001.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320:1028:0002.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320:1028:0003.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320:1028:0004.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324:1028:0001.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324:1028:0002.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324:1028:0003.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324:1028:0004.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324.conf: Permission denied


This is usually what i get. Got the uninstalling to work this time so i will restart and see what happends. Will edit if it works.

EDIT: Ok well i tried "sudo modprobe ndiswrapper" after and i got this "FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted"

I searched this thread but found no answers. Right now i am using LAN cable but its really annoying to keep around for school and it has to be positioned right to work. I would like this to be fixed. Also i like using Xfce4 but i will use Gnome or KDE to get wireless to work.

drogoh
October 5th, 2005, 03:50 AM
#3
for conffile in /etc/ndiswrapper/bcmwl5/*.conf; do
> sudo cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile
> done
bash: /etc/ndiswrapper/bcmwl5/14E4:4311:1028:0007.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4311.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4312:1028:0007.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4312.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4318:1028:0005.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4318:1028:0006.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4318.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4319:1028:0005.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4319:1028:0006.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4319.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320:1028:0001.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320:1028:0002.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320:1028:0003.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320:1028:0004.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4320.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324:1028:0001.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324:1028:0002.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324:1028:0003.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324:1028:0004.conf: Permission denied
bash: /etc/ndiswrapper/bcmwl5/14E4:4324.conf: Permission denied



You can't pipe something when using sudo. If you're piping anything and need root, sudo -s and do it again.

By the way, when/if I use sed, I always sed -i'' 's/foo/bar/' file

You don't need to mess with your catting and redirection, or even piping. My method does everything yours does but without external processes (you can alternately use -i.bak if you so choose, the -i'' means "no backup extension")

By the way, with -i'', that is two single quotes and not one double quote.

laforge
October 5th, 2005, 04:19 AM
Ok thanks but i still have a problem with

sudo modprobe ndiswrapper

drogoh
October 5th, 2005, 04:41 AM
Ok thanks but i still have a problem with

sudo modprobe ndiswrapper

sudo ndiswrapper -m

If that doesn't work, open up /etc/modules in your favorite text editor (under sudo, of course) and add ndiswrapper to the bottom on its own line.

laforge
October 5th, 2005, 04:51 AM
Ok thanks again. Now in Kwifimanager, it says not connect instead of not activated. So inprovement. What do i use to set up my wifi and all that jazz.

laforge
October 6th, 2005, 12:28 AM
Ok when i restarted i noticed, something failed while loading modules. Taking a closer look, low and behold its ndiswrapper. So, i need to restart again to see in full detail but a glance go me this

It loaded ndiswrapper, but failed to find device type, and can't find the .conf file. More in a min.

EDIT: Ok got most of it

It loaded ndiswrapper, but cound not find device type in settings. Then it said it can't find .conf file, 14E44319:1028:0006.conf

Dunno if that is of any help.

laforge
October 7th, 2005, 03:51 AM
still having trouble and off first page.

hangfire
October 7th, 2005, 07:02 PM
Will everyone PLEASE stop doing this PLEASE?

cat $conffile | sed -e 's/RadioState|1/RadioState|0/' > $conffile

Since bash interprets the > when it pleases, which may be FIRST, it can ZERO (empty) $confffile) BEFORE cat gets a chance to spew it! Remember, you are running this on a BASH command line, so even if "cat" comes first and > comes last, BASH is already there, nulling this file.

Yes, I am shouting here! This shell script is BROKEN, the HOWTO needs to be fixed. A fair number of people have GIVEN UP on wireless and/or Ubuntu because of this problem.

When I ran it, some files came out OK, some truncated, some with zero bytes. You know you're a victim if

ls -l /etc/ndiswrapper/bcmwl5/*.conf

shows some zero-byte files.

HF

Jipstyle
October 7th, 2005, 07:26 PM
Woohooo!

I have created an account simply to be able to post in this thread and thank everyone for their help. Particular thanks to the OP who started the thread and provided the initial script.

This was not an easy install, and I am not quite a linux n00b. I've been running Gentoo on my desktop for about 2 years, but I decided I want a 'compile free' distro for my laptop ... enter Ubuntu.

The card that I bought is the newest Linksys .. the WPC54GS w/ SpeedBooster (ooooh ... larger TCP frame .. lol).

I had the devil's own time trying to get it to work. First, I made the most hilarious error .. I miss typed RadioState as RadioShack ... and that didn't work out so well.

Next, I had the same error some have mentioned about 0 byte .conf files .. I fixed this by NOT forgetting to pipe the output from sed back to the conf files ( > $conffiles does not appear in my browser unless I scroll the embedded text window to the right and I missed it the first couple of times).

Finally, I was stumped so I read the .inf driver file and noticed that the .sys file declared in all caps in the .inf file. I made a copy of the sys file with the same name but all caps, and badabing badaboom, ndis was properly inserted on reboot.

Now, I just have to configure my settings so my network plays nicely with my laptop.

Thanks again, all .. you are a credit to the OSS community.

laforge
October 7th, 2005, 09:28 PM
Hangfire do you have a solution to the problem?

Jipstyle
October 7th, 2005, 10:43 PM
A quick fix for the problem is to manually edit the config files rather than using the concatenated sed command.

A more elegant fix is to use the perl command that someone posted in this thread .. I haven't the time to find it myself, but I did see it in this thread. I didn't test it, but I assume it works. If someone could test it and let us know, then perhaps the OP could edit his instructions in the first post.

Given the number of people for whom the sed command worked, though, I'm not sure this is a universal problem. Regardless, the perl command should work fine since the perl interpreter (to my knowledge) will not produce the same error as bash.

laforge
October 8th, 2005, 09:02 AM
What file am i suppose to config, and what to?

ifwntrends
October 8th, 2005, 10:12 AM
is there any way to extract the .inf files from the .exe driver istall application?

ifwntrends
October 8th, 2005, 10:16 AM
is there any way to extract the .inf files from the sp21307.exe windows binary?

MetalMusicAddict
October 8th, 2005, 01:35 PM
is there any way to extract the .inf files from the .exe driver istall application?
The 2 files you need are posted/hosted it this thread. Read through the thread. Theres lots more helpful info than just the 1st post. ;)

Protostar
October 10th, 2005, 05:15 AM
Hello all. I too am having problems with my Broadcom wireless adapter. I've done everything the original poster said, twice over and it still refuses to work. My card is recognized but when I run iwconfig it says PowerMode=Off. I don't know what to do. If push comes to shove, I'll buy a PC wireless network card because I refuse to switch back to windows.

N6REJ
October 10th, 2005, 10:21 AM
For the Belkin F5D7001 with 1101 on the bottom of box
Broadcom 4306 chipset
use the belkin drivers bcmwl5A. Also, when I installed it thought it was a firewire device so I had to remove that. After that change it worked perfectly. DON'T SKIP THE REBOOT STEP or this won't work. Just copy them from the windows cd, they are under files/drivers. You NEED BOTH the 5a.inf & 5a.sys

laforge
October 10th, 2005, 02:22 PM
5a.sys and 5a.inf? Do you need those? I have ones without the 5.

hangfire
October 10th, 2005, 05:44 PM
You don't have to edit all the .conf files by hand. Replace steps 'sudo gedit' and Step 4 with the following...


$ sed -e 's/RadioState|1/RadioState|0/' /etc/ndiswrapper/bcmwl5/*.conf

This dumps the edited contents of all the files to standard out.

hangfire
October 10th, 2005, 05:46 PM
I run iwconfig it says PowerMode=Off.

To fix this, I had to switch back to Windows temporarily to "Enable" (power on) the WLAN interface, then warm-boot back to Ubuntu. Apparently there is an API to power on some chipsets that is missing in the Linux drivers.

Buying another Wireless Lan adapter is not a bad idea. We need to punish Broadcom for their atrocious lack of support.

HF

hangfire
October 10th, 2005, 06:15 PM
Hangfire do you have a solution to the problem?

Sorry. Try this:

cd /etc/ndiswrapper/bcmwl5
for conffile in *.conf; do
sed -e 's/RadioState|1/RadioState|0/' $conffile > /tmp/$conffile
sudo mv /tmp/$conffile .
done

If sudo works as usual, you should only need to type the password in once. You have to cd to the working directory, or otherwise code the basename of the conf file, so you don't create something like /tmp/etc/ndiswrapper/bcmwl5/*.conf :(

HF

dizbah
October 10th, 2005, 10:50 PM
All, I haved done every step here and my wireless lite is still not coming on. Any additional information would be great at this point.](*,)

laforge
October 11th, 2005, 03:02 AM
All, I haved done every step here and my wireless lite is still not coming on. Any additional information would be great at this point.](*,)
I don't have a wirless light, but yea my wireless isn't working.

dizbah
October 11th, 2005, 11:25 PM
all, here is where I stand. Wireless light still off.

in device manager, it states the following:

Vendor: Broadcom Corporation
Device: BCM4306 802.11b/g Wireless Lan
Status: Status
Bus type: PCI

Device: Unknown
Capabilities: Unknown

ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present, hardware present

Also, I get the following error on modprobe:

modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-686-smp/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted


Any help would be great...Thanks

akb
October 13th, 2005, 07:38 AM
howdy guys :-)

well, after studying this thread (and many others) i finally got a step more into it... had the same problems like some others here: i could not activate the chip, which resulted in successfully "running" drivers and modules, but no found networks in range.

i now solved this by using the module "acer_acpi". now i can scan for networks and it shows me my home network correctly. but... i cannot connect to it :-/

any tipps on this? dhclient doesnt receive DHCPOFFERS, also when i restart the router. before you ask: it is configured to broadcast its ssid... ok, otherwise i couldnt even scan for it. nevermind.

but now... what do i have to do to get it running?
i tried by calling iwconfig essid blah; iwconfig enc blah and so on... restarted the pc, called dhclient (see above), tried to set it up in /etc/network/interfaces and so on... i even shut it down and got it up again (ifconfig wlan0 down/up).

any ideas or handy guides? *lol* :-)

edit: uh... now i tried to start the device with "systemsettings" (manager for network and so on on kubuntu/kde) and the notebook got freezed... now for about 3 minutes, dont think it just broadcasts or something.

markr
October 13th, 2005, 08:05 AM
I followed the instructions in this thread (Greate thread by the way!) and after rebooting my machine the wireless light did not come on.

entered "sudo modprobe ndiswrapper" and pop! on came the light.

Only problem is that when I reboot, I have to do the above command again to get my wireless working.

Is there anyway I can get this to start at boot so I don't have to issue the command every time I start my laptop?

Thanks

Mark.

akb
October 13th, 2005, 02:01 PM
YEEEEHAW
after sleeping a night over it, i got it running. just had to change the wireless_keymode to "open" manually (before it was not set). now i got access and can ping to outside. thx so much hunnys :->

the most funny thing: with windows the led lights up when the chip gets activated. now it flickers at it sends/receives data :D

so... your documentation from this thread + acer_acpi + keymode open = heaven :-)

skirkpatrick
October 13th, 2005, 02:23 PM
I followed the instructions in this thread (Greate thread by the way!) and after rebooting my machine the wireless light did not come on.

entered "sudo modprobe ndiswrapper" and pop! on came the light.

Only problem is that when I reboot, I have to do the above command again to get my wireless working.

Is there anyway I can get this to start at boot so I don't have to issue the command every time I start my laptop?

Thanks

Mark.


Mark, add the line "ndiswrapper" to the bottom of /etc/modules.

dizbah
October 14th, 2005, 01:43 AM
I followed the instructions in this thread (Greate thread by the way!) and after rebooting my machine the wireless light did not come on.

entered "sudo modprobe ndiswrapper" and pop! on came the light.


I still get the following when running the above command:

sudo modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted


What should I do?

dizbah
October 14th, 2005, 01:44 AM
I followed the instructions in this thread (Greate thread by the way!) and after rebooting my machine the wireless light did not come on.

entered "sudo modprobe ndiswrapper" and pop! on came the light.stalled


I still get the following when running the above command. My wireless light never comes on, yet the driver is installed and present. Message:

sudo modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.10-5-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Operation not permitted


What should I do?

skirkpatrick
October 14th, 2005, 01:53 AM
Ndiswrapper isn't getting loaded by the kernel. Did you build your own kernel or your own copy of ndiswrapper? Since ndiswrapper is a kernel loadable module, it needs to be built using the the kernel headers of the installed kernel. If you didn't build either of them but just pulled them from the repositories, they should be in sync.

noelferreira
October 16th, 2005, 04:03 AM
hi, people. i am new and thanks to you i almost have my wireless wlan0 card working. i have a compaq presario 1200 and an asus wl100g network pcmcia wireless card. i follow you instructions and i am connected to my router.
when i do ping 192.168.1.1 (router) everything is ok.

however i cannot browsing any site in the internet. doing ping www.xxxxx.com the packets are sended, no one is lost, but i don't receive it back.

sometimes i can open some pages but it is just for a few seconds.

can you help me?
thanks,

noel ferreira

triviab0y
October 17th, 2005, 01:27 PM
Noel

A few things to check:

1. Make sure you have a DNS entry so that you can resolve names to IP addresses. You can configure this in the network configuration applet in the "DNS" tab. Or you can do this manually by editing /etc/resolv.conf. Add the DNS servers given to you by your ISP.

2. Try bringing down any other network interfaces you might have, eg eth0. From the command line type: sudo ifdown eth0

Hope that helps.

Trivab0y

skirkpatrick
October 18th, 2005, 02:21 AM
Yes, wlan0 won't work correctly if eth0 is enabled.

MetalMusicAddict
October 18th, 2005, 03:01 AM
hi, people. i am new and thanks to you i almost have my wireless wlan0 card working. i have a compaq presario 1200 and an asus wl100g network pcmcia wireless card. i follow you instructions and i am connected to my router.
when i do ping 192.168.1.1 (router) everything is ok.

however i cannot browsing any site in the internet. doing ping www.xxxxx.com the packets are sended, no one is lost, but i don't receive it back.

sometimes i can open some pages but it is just for a few seconds.

can you help me?
thanks,

noel ferreira
I would make sure you MAC address is being allowed access.

anonOmus
October 19th, 2005, 04:02 PM
Thanks for the howto took ten minutes and now my little light is glowing and i can see my wireless card in the system. Just one problem now; will a sumbler program work with ndis wrappers? I have about 10 different wireless networks on my univeristy campus and I just want my machine to search for them and not have to talk to the admins to get all the ips and the rest of the crappola. Is there any way to do this while running ndis wrappers?

akb
October 19th, 2005, 05:19 PM
afaik the ndiswrapper seems to your kernel like any other module ("driver"), so it should also be handled the same way.

did you configure everything manually? i just used dhclient and the config where i had to put the essid and all this... (what should be handable with an external app)

triviab0y
October 19th, 2005, 09:23 PM
Anon

Kismet (Linux wifi scanner http://www.kismetwireless.net/) will not work with ndiswrapper, sadly. The card needs to be put into monitor mode (RFMON) which requires direct access to the hardware. Check out http://www.kismetwireless.net/documentation.shtml for supported cards.

Triviab0y


Thanks for the howto took ten minutes and now my little light is glowing and i can see my wireless card in the system. Just one problem now; will a sumbler program work with ndis wrappers? <snip>

anonOmus
October 19th, 2005, 10:45 PM
Thanks triva I had a feeling that was the case Damn! Well i suppose I can be still be happy. My machine is a 10 pound plus desktop replacement and rarel gets lugged around the university.

Thnx

N

Eagleevil
October 20th, 2005, 03:25 AM
I tried asking in another thread but got nothing, so maybe someone that looks at this one might have something.

I've been trying for a few days now to get my wireless card fully working and I'm having some trouble. I've tried the directions in this thread and still not working. I got the drivers working with ndiswrapper and so forth.

My problem is when I try to set the essid and other stuff, it just doesn't take. What I put in doesn't show up at all, except I actually got the key to get set, but nothing else.

Anyone know possibly how to fix this? If you need to know anything else, let me know.

triviab0y
October 20th, 2005, 09:49 PM
Eagle

What sort of system are you running? If its a laptop, is there a key combo or switch that enables the hardware? Make sure its enabled!

Other than this, do you get any errors? What hardware are you using? What have you tried?

Trivab0y


I tried asking in another thread but got nothing, so maybe someone that looks at this one might have something.

I've been trying for a few days now to get my wireless card fully working and I'm having some trouble. I've tried the directions in this thread and still not working. I got the drivers working with ndiswrapper and so forth.

My problem is when I try to set the essid and other stuff, it just doesn't take. What I put in doesn't show up at all, except I actually got the key to get set, but nothing else.

Anyone know possibly how to fix this? If you need to know anything else, let me know.

Eagleevil
October 20th, 2005, 10:05 PM
Yes, it's a laptop and there is no key combination or anything to enable it.

The card is a Linksys WPC45G and as far as I can find no errors, but maybe I'm not looking in the right place.

I've tried other drivers, and searched mutliple times to see what others have done and tried those things and always end up with the same problem it seems.

Could it possibly be that it is trying to use it as something else so there is some other program or whatever using it and therefore not letting me use it? If so how can I check this for sure?

Tsume
October 21st, 2005, 02:40 PM
Great guide! Only issue is I had to use this:

"cd /etc/ndiswrapper/bcmwl5
for conffile in *.conf; do
sed -e 's/RadioState|1/RadioState|0/' $conffile > /tmp/$conffile
sudo mv /tmp/$conffile .
done"

Instead of what was in the original post (otherwise I got a bunch of Permission Denied).

Now I've got a new problem and I'm hoping someone's got an idea.

Every time I have to reboot now, it takes 5-10 minutes to boot, and almost all of that time is spent on the stage configuring network interfaces and waiting for network interfaces to come up. When it finally boots, everything's working great. Any ideas? I use about 20% of my battery waiting for this thing to boot up.

skirkpatrick
October 21st, 2005, 06:42 PM
I have the same problem and haven't quite figured out how to fix it, although there is a thread around hear about disabling ntp on startup but I'd like to have ntp later. While it's waiting, I just hit Ctl-C and it continues on.

noelferreira
October 22nd, 2005, 11:47 AM
Noel

A few things to check:

1. Make sure you have a DNS entry so that you can resolve names to IP addresses. You can configure this in the network configuration applet in the "DNS" tab. Or you can do this manually by editing /etc/resolv.conf. Add the DNS servers given to you by your ISP.

2. Try bringing down any other network interfaces you might have, eg eth0. From the command line type: sudo ifdown eth0

Hope that helps.

Trivab0y

thanks for help,

could you be more spcecific? how can i get that DNS servers?

in fact, i am trying to intall debian sarge 3.0 in my laptop (netinstaller version). when it tries to reach security.debian.org and other times the mirroir i use to get packages, it fails. Most of times the system can't bring up eth0.

i am using a wireless router (modem). it is strange. i live in portugal. if i do for example $ ping www.uevora.pt, everything ok. for example, $ ping www.record.pt fails. some pings works and other, mostly, don't. there's something to do with the router?

i will give you my msn nick for a faster help if that is possible, of course.

noel@oniduo.pt

thanks for your help,
best regards,

noel ferreira

Eagleevil
October 24th, 2005, 03:05 AM
Well now I have a different problem I guess...

For some reason I can now connect using wireless and I don't really know why it's working now. But I can't seem to connect to a router that is using a WEP key, though I've only tried one router with WEP so far.

Could it just be that one router? I will probably have a chance to try another router sometime this week on campus.

If I have the same problem on campus, anyone know a way to fix this? or is it some problem that just exists right now with really no fix?

cajunaggie
October 30th, 2005, 11:37 PM
I'm running a WinXP-Badger dual-boot. I installed a Belkin Wireless G USB network adapter, but Badger won't recognize it, even during installation. I did a file search in XP for the bcmwl5a.inf and bcmwl5.inf files. I found nothing. Does this mean I don't have a Broadcom chipset in the Belkin adapter? Where can I go to find out who makes the chipset for the adapter?

seismicmike
October 31st, 2005, 07:39 PM
DUDE, You are my HERO!!! You should add this to the Wiki!!