PDA

View Full Version : HOWTO: Enable Chinese Input



DuKefeng
April 10th, 2005, 09:36 AM
Chinese Input for Ubuntu Hoary:
(version franšaise) (http://forum.ubuntu-fr.org/viewtopic.php?pid=17862#p17862)

1) install the following packages:
* scim
* scim-chinese
* scim-config-socket
* scim-frontend-socket
* scim-gtk2-immodule
* scim-server-socket
* scim-tables-zh (option)
* xfonts-intl-chinese
* xfonts-intl-chinese-big
* ttf-arphic-gbsn00lp
* ttf-arphic-gkai00mp
* ttf-arphic-bkai00mp
* ttf-arphic-bsmi00lp

accept all dependencies.

2) System -> Preferences -> Sessions

Startup Programs Tab -> Add Button
Startup Command: scim -d
Order: 80

3) Restart Gnome: CTRL+ALT+SUPPR

4) Open any software and press CTRL+SPACE to activate chinese input
------------------------------------------------------------------------------------------------------

IF not working you can as an alternative replace step 2) as follow:

2) alt+F2, gedit

type these few lines:

scim -d
export XMODIFIERS=@im=scim
export GTK_IM_MODULE=scim
gnome-session
Save them under your home directory name: .xsession

Then open a terminal and type:

$chmod +x .xsession
------------------------------------------------------------------------------------------------------

Tips

Additional Instructions for OpenOffice:
Tools=>Options=>Language Settings=>Languages: enable Asian languages support and choose the asian default language for document. (chinese simplified for example)
Tools=>Options=>Text Document=>Basic Fonts (Asian): change all of them for "AR PL Kaitim GB" or your favorite chinese font.

Clean Font
Add Firefly's font "AR PL New Sung"

Open a terminal and type


$wget http://firefly.idv.tw/apt/firefly-font/fireflysung-1.3.0.tar.gz
$tar zxvf fireflysung-1.3.0.tar.gz
$sudo cp fireflysung-1.3.0/fireflysung.ttf /usr/share/fonts/truetype/
$sudo fc-cache -f -v
Alternative repositories

$wget http://cle.linux.org.tw/fonts/FireFly/fireflysung-1.3.0.tar.gz
or
$wget http://apt.nc.hcc.edu.tw/pub/FC_src/fireflysung-1.3.0.tar.gz
or
$wget http://www.study-area.org/apt/firefly-font/fireflysung-1.3.0.tar.gz

More Fonts
Install msttcorefonts, open a terminal:


$sudo apt-get install msttcorefonts



现在能写中文

谢谢pierre (http://pierre.equoy.free.fr/blog/index.php?2005/03/28/36-taper-du-texte-chinois-sous-ubuntu) 与tzutolin (http://www.ubuntuforums.org/member.php?u=13973)

benkorkor
April 11th, 2005, 01:30 AM
Awesome, thanks.

mesocool
April 11th, 2005, 04:54 AM
Chinese input Hoary:

1) install the following packages:
* scim
* scim-chinese
* scim-config-socket
* scim-frontend-socket
* scim-gtk2-immodule
* scim-server-socket
* scim-tables-zh (option)
* xfonts-intl-chinese
* xfonts-intl-chinese-big
* ttf-arphic-gbsn00lp
* ttf-arphic-gkai00mp
* ttf-arphic-bkai00mp
* ttf-arphic-bsmi00lp

accept all dependencies.

2) Go to "System" -> "Preferences", and select "Sessions". In "Startup Programs", add the command "scim -d"

3) Restart Gnome: CTRL+ALT+SUPPR

4) Open any software and press CTRL+SPACE to enable chinese input

Additional Instructions for OpenOffice:
Tools=>Options=>Language Settings=>Languages: enable Asian languages support and choose the asian default language for document. (chinese simplified for example)
Tools=>Options=>Text Document=>Basic Fonts (Asian): change all of them for "AR PL Kaitim GB" or your favorite chinese font.

Tips to have a better choice of fonts, install msttcorefonts。

现在能写中文

谢谢pierre (http://pierre.equoy.free.fr/blog/index.php?2005/03/28/36-taper-du-texte-chinois-sous-ubuntu) 与tzutolin (http://www.ubuntuforums.org/member.php?u=13973)


I can read and write Chinese, but the words shown are blur.. Just not as clear as English characters.. How can I fix that?

benkorkor
April 11th, 2005, 05:22 AM
This is brilliant. I love it. Works very well.

DuKefeng
April 11th, 2005, 10:03 AM
I can read and write Chinese, but the words shown are blur.. Just not as clear as English characters.. How can I fix that?

Install firefly's font "AR PL New Sung"

Added in the HowTo

mesocool
April 12th, 2005, 03:42 AM
After I did the following, the Chinese characters are still blur as usual. Seems not changing anything. :-#

$wget http://firefly.idv.tw/apt/firefly-font/fireflysung-1.3.0.tar.gz
$tar zxvf fireflysung-1.3.0.tar.gz
$sudo cp fireflysung-1.3.0/fireflysung.ttf /usr/share/fonts/truetype/
$sudo fc-cache -f -v

DuKefeng
April 12th, 2005, 05:01 AM
Try this :

Disable anti-alias technology for Chinese fonts 16px or under (http://wiki.linux.org.hk/index.php/How_to_make_Debian_support_chinese_(eng)#Fontconfi g_Settings)

My local.fonts look like this now:


<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<include ignore_missing="yes">/var/lib/defoma/fontconfig.d/fonts.conf</include>
<!-- Uncomment below to enable bitmapped fonts -->
<!--
<dir>/usr/X11R6/lib/X11/fonts</dir>
-->
<!-- Uncomment below to enable subpixel rendering -->
<!--
<match target="font">
<test qual="all" name="rgba">
<const>unknown</const>
</test>
<edit name="rgba" mode="assign"><const>rgb</const></edit>
</match>
-->
<!-- Uncomment below to enable the freetype autohinter module -->
<!--
<match target="font">
<edit name="autohint" mode="assign">
<bool>true</bool>
</edit>
</match>
-->
<!-- Disable font alias for Chinese <= 16px -->
<match target="font">
<test qual="any" name="family" compare="eq">
<string>AR PL KaitiM Big5</string>
<string>AR PL KaitiM GB</string>
<string>AR PL Mingti2L Big5</string>
<string>AR PL SungtiL Big5</string>
<string>AR PL New Sung</string>
<string>AR PL SungtiL GB</string>
<string>Kochi Mincho</string>
<string>Baekmuk Dotum</string>
</test>
<test name="pixelsize" compare="less_eq">
<double>8</double>
</test>
<edit name="antialias">
<bool>false</bool>
</edit>
<edit name="hinting">
<bool>true</bool>
</edit>
</match>
</fontconfig>

But i don't see any differences. :-?

Another way is to type with fonts size bigger than 16 :grin:

Maybe you can post a screenshot to see how bad does it look?

jiyuu0
April 12th, 2005, 10:22 AM
added to ubuntuguide.org
http://ubuntuguide.org/#scim

only prob... seems like some chars can't be displayed in the scim
try the word 'wo' and then scroll... can see boxes (unknown chars)

wlx
April 12th, 2005, 11:01 AM
When I input chinese with scim, sometimes it will occurs firefox's terminate.

DuKefeng
April 12th, 2005, 11:49 AM
added to ubuntuguide.org
http://ubuntuguide.org/#scim

only prob... seems like some chars can't be displayed in the scim
try the word 'wo' and then scroll... can see boxes (unknown chars)

This is fonts related. Some of them are more complete than the other. Try to type 'wo' with differents chinese fonts and you will see the differences.

mesocool
April 12th, 2005, 10:12 PM
I made an attachment, a screenshot of NBA in China..

When I increase the size of words, they are not blur. But it also changes the frame of the website.. :roll:

DuKefeng
April 13th, 2005, 01:11 AM
Firefox->Edit->Preferences->General->Fonts & Colors

Change all possible fonts to AR PL New Sung
Minimum fonts size: 17
Screen Resolution: Others (it will find the optimized resolution)

Fonts are out of the frames but clear.

Maybe you should check this link for more answers:
http://wiki.linux.org.hk/index.php/How_to_make_Debian_support_chinese_(eng)

ddhytz
April 13th, 2005, 11:35 AM
How can Chinese be shown in other apps, such as Music Player playing mp3 songs?

ghost
April 13th, 2005, 01:14 PM
Thanks Buddy, I was just looking for Chinese Input software for my Hoary. ;-)

Do you know is there any tool I can use to convert Traditional Chinese to Simlplifed?

DuKefeng
April 14th, 2005, 02:14 AM
Overall, can you ask more precise questions. I like to help but I like people help me help them.



When I input chinese with scim, sometimes it will occurs firefox's terminate.
Before everything do a restart, if problem occurs again then reinstall the maybe faulty packages (mozilla-firefox, scim....) then if nothing is better ask yourself some questions:
You type in firefox or out of firefox? in the google bar, in the address bar or where? How often?
Check the forum, firefox terminate for obscur reasons for some members, maybe your problem is not Scim related?



How can Chinese be shown in other apps, such as Music Player playing mp3 songs?
You want to see chinese or to have your software in chinese?
If you want to see it, i presume that you have chinese MP3, send me one to try, i don't have any.
If you want your software to be displayed in chinese, you have to change your whole system in chinese. :grin:

Open a terminal


$sudo dpkg-reconfigure locales
choose any language you fancy plus: zh_CN GB2312 for simple chinese ou zh_TW BIG5 for traditionnal chinese

Restart gnome (ctrl+alt+del)
choose chinese as language and login

You are now in a chinese ubuntu with all software in chinese i guess, this is not the goal of my howto, so i will not answer any questions concerning chinese translation of software. Not to mention that this reconfiguration of languages screwed my scim, do it at your own risk.



Thanks Buddy, I was just looking for Chinese Input software for my Hoary. ;-)

Do you know is there any tool I can use to convert Traditional Chinese to Simlplifed?
I don't know any, i just tried a $sudo dpkg reconfigure-locales adding the BIG5, screwed up my scim, no more chinese input, no more testing. Sorry.

I'll try a fresh install by next week and go on with experimentation.

Maybe a better way of testing is to create a different user and try the reconfigure-locales without sudo, i had issue with this problem in Warty before, might be a solution. (see the thread of my french howto when i was playing with warty).

ddhytz
April 14th, 2005, 10:28 AM
You want to see chinese or to have your software in chinese?
If you want to see it, i presume that you have chinese MP3, send me one to try, i don't have any.


Just want to see Chinese name of the song. Instead of sending you one, can you change the name of any mp3 song you have to a Chinese name, then see if you can see it inside the music player? Thanks.

DuKefeng
April 14th, 2005, 11:04 AM
Look at my screenshot with GN'R attitude renamed 枪与玫瑰
The result on Rhythmbox is that i've got the whole name of the band with title and album title.

I'm not a specialized in multimedia or MP3 but i guess that i need to edit the MP3 file to change all these infos.

ddhytz
April 14th, 2005, 12:17 PM
Look at my screenshot with GN'R attitude renamed 枪与玫瑰
The result on Rhythmbox is that i've got the whole name of the band with title and album title.

I'm not a specialized in multimedia or MP3 but i guess that i need to edit the MP3 file to change all these infos.

IWhen Music Player imports a folder it changes file names to unreadable stuff after clicking 'Open'.

khc
April 14th, 2005, 07:21 PM
Make sure the names/titles/other attributes are encoded in utf8.

ddhytz
April 15th, 2005, 11:31 AM
Make sure the names/titles/other attributes are encoded in utf8.

This must be the key of whole trouble!! But I do not know how the name was encoded or if they can be converted in utf8. When I find how to display Chinese names properly I will be able to use Linux as my sole OS.

khc
April 16th, 2005, 06:24 AM
You may need to enter them again. I've never edited the metadatas other when I rip CDs, so I don't know what tools you can use.

Chia
April 26th, 2005, 01:14 PM
For displaying chinese mp3 song titles, I use beep-media-player in universe, make sure you have UTF-8 locale (locale -a) , if not, then
dpkg-reconfigure locales,
also run beep-media-player from a terminal with the following command

LC_ALL=zh_CN.gb2312 beep-media-player
or
LC_ALL=zh_CN.UTF-8 beep-media-player
or
LC_ALL=zh_TW.big5 beep-media-player

I also found set-m17n-env from package m17n-env is a good way to setup input environment using scim , without resorting to hand-editing the .xsession file. This way I can use Kubuntu (KDE) without having to run gnome-session from .xsession startup file.

ddhytz
April 27th, 2005, 01:01 PM
beep-media-player only shows mp3 song names like ???-???? (invalid UTF) in playlist. My locales are as follows
C
en_AU.utf8
en_GB.utf8
en_US.utf8
POSIX
zh_CN.utf8
zh_TW
zh_TW.big5
zh_TW.utf8

Any idea?

Chia
April 27th, 2005, 03:30 PM
Do you have the following locales? type locale -a to show them
zh_CN
zh_CN.gb2312
zh_CN.gbk
zh_TW.big5
zh_TW.utf8

If not then you need to run and select them:
sudo dpkg-reconfigure locales

and run beep-media-player as i mentioned earlier,
LC_ALL=zh_CN.gb2312 beep-media-player
or whichever language your mp3 ID3 is encoded at or create a shortcut in menu to run this everytime you clicked on it.

ddhytz
April 28th, 2005, 08:43 AM
Well, LC_CTYPE=zh_CN.gb2312 beep-media-player works. Thanks.

mrbass
April 28th, 2005, 11:39 PM
ok the openoffice stuff is not entirely needed but nice to set default fonts and other things. Now for chinese I tested all the input methods and these worked

[Simplified Chinese]
Smart Pinyin (press #)
UIM-py
UIM-m17n-zh-py

[Other]
UIM-pinyin-big5

These input methods did not
UIM-pyunihan
UIM-m17-zh-pinyin

Now here's my question what about the older folks who prefer Chinese Traditional? At my old work I remember setting up both Traditional and Simplified for a Chinese girl. She insisted on it.

mrbass
April 29th, 2005, 03:51 AM
Is that fireflysung font really needed? I'm tending to think it's not. Here's a screenshot...no I don't know how to type Chinese so it's nonsense but it gives you an idea of the fonts. Fonts 1 through 4 come with Ubuntu.

Don't you think font 3 AR PL Mingti2L Big 5 is almost exactly like font 5 AR PL New Sung (aka fireflysung)?

geminifire
May 7th, 2005, 02:51 AM
谢谢!

migo
May 8th, 2005, 04:59 AM
Thanks, I look forward to trying this out once I get my Hoary CD :D

wlx
May 8th, 2005, 04:17 PM
Overall, can you ask more precise questions. I like to help but I like people help me help them.

Before everything do a restart, if problem occurs again then reinstall the maybe faulty packages (mozilla-firefox, scim....) then if nothing is better ask yourself some questions:
You type in firefox or out of firefox? in the google bar, in the address bar or where? How often?
Check the forum, firefox terminate for obscur reasons for some members, maybe your problem is not Scim related?



Thanks for your help.

I don't know the reason of firefox's terminate,and I can't make it happen again.

Any more, I don't know why so many modules of scim existed,but if I just install three modules: scim,scim-chinese,scim-tables-zh, the system will more stable. ( I find this problem with planner. First I install the scim with all the modules as you mentioned, but sometimes the planner can't input any chars when I activate the scim, and when I remove other modules of scim, it is worked! )

lao_V
May 9th, 2005, 08:24 PM
Thanks for your help.

I don't know the reason of firefox's terminate,and I can't make it happen again.

Any more, I don't know why so many modules of scim existed,but if I just install three modules: scim,scim-chinese,scim-tables-zh, the system will more stable. ( I find this problem with planner. First I install the scim with all the modules as you mentioned, but sometimes the planner can't input any chars when I activate the scim, and when I remove other modules of scim, it is worked! )

Hi guys, the guide works great for gtk apps but can anyone tell me how I can enable chinese input for KDE apps? Thanks

erik-the-red
August 1st, 2005, 12:31 AM
Hi guys, the guide works great for gtk apps but can anyone tell me how I can enable chinese input for KDE apps? Thanks
I should install those ttf fonts if I want to view Chinese in OpenOffice, right?

ubuntutinger
November 11th, 2005, 03:07 AM
Chinese Input for Ubuntu Hoary:
(version franšaise) (http://forum.ubuntu-fr.org/viewtopic.php?pid=17862#p17862)

1) install the following packages:
* scim
* scim-chinese
* scim-config-socket
* scim-frontend-socket
* scim-gtk2-immodule
* scim-server-socket
* scim-tables-zh (option)
* xfonts-intl-chinese
* xfonts-intl-chinese-big
* ttf-arphic-gbsn00lp
* ttf-arphic-gkai00mp
* ttf-arphic-bkai00mp
* ttf-arphic-bsmi00lp

accept all dependencies.

2) System -> Preferences -> Sessions

Startup Programs Tab -> Add Button
Startup Command: scim -d
Order: 80

3) Restart Gnome: CTRL+ALT+SUPPR

4) Open any software and press CTRL+SPACE to activate chinese input
------------------------------------------------------------------------------------------------------

IF not working you can as an alternative replace step 2) as follow:

2) alt+F2, gedit

type these few lines:

scim -d
export XMODIFIERS=@im=scim
export GTK_IM_MODULE=scim
gnome-session
Save them under your home directory name: .xsession

Then open a terminal and type:

$chmod +x .xsession
------------------------------------------------------------------------------------------------------

Tips

Additional Instructions for OpenOffice:
Tools=>Options=>Language Settings=>Languages: enable Asian languages support and choose the asian default language for document. (chinese simplified for example)
Tools=>Options=>Text Document=>Basic Fonts (Asian): change all of them for "AR PL Kaitim GB" or your favorite chinese font.

Clean Font
Add Firefly's font "AR PL New Sung"

Open a terminal and type


$wget http://firefly.idv.tw/apt/firefly-font/fireflysung-1.3.0.tar.gz
$tar zxvf fireflysung-1.3.0.tar.gz
$sudo cp fireflysung-1.3.0/fireflysung.ttf /usr/share/fonts/truetype/
$sudo fc-cache -f -v
Alternative repositories

$wget http://cle.linux.org.tw/fonts/FireFly/fireflysung-1.3.0.tar.gz
or
$wget http://apt.nc.hcc.edu.tw/pub/FC_src/fireflysung-1.3.0.tar.gz
or
$wget http://www.study-area.org/apt/firefly-font/fireflysung-1.3.0.tar.gz

More Fonts
Install msttcorefonts, open a terminal:


$sudo apt-get install msttcorefonts



现在能写中文

谢谢pierre (http://pierre.equoy.free.fr/blog/index.php?2005/03/28/36-taper-du-texte-chinois-sous-ubuntu) 与tzutolin (http://www.ubuntuforums.org/member.php?u=13973)

This is excellent! The original step won't work for me. So I used your alternative 2nd step. It worked fine. However, it seems the input system is only for current user after installation. Once I change to another user the input system icon is not there. How can I make the input system available for all users?

Thanks,

ubuntutinger
November 15th, 2005, 11:13 AM
This is excellent! The original step won't work for me. So I used your alternative 2nd step. It worked fine. However, it seems the input system is only for current user after installation. Once I change to another user the input system icon is not there. How can I make the input system available for all users?

Thanks,

Now, I followed the same steps to setup Chinese input on Kubuntu. It did not work. Here is what I did:

1. Open system>Package Manager(Adept)>Manage Repositories
enable
deb http://tw.archive.ubuntu.com/ubuntu breezy universe
deb-src http://tw.archive.ubuntu.com/ubuntu breezy universe

install
scim
scim-chinese
scim-chewing
scim-config-socket
scim-frontend-socket
scim-gtk2-immodule
scim-server-socket
xfonts-intl-chinese
ttf-arphic-gbsn00lp
ttf-arphic-gkai00mp
ttf-arphic-bkai00mp
ttf-arphic-bsmi00lp

2) alt+F2, kate

type these few lines:

Code:
scim -d
export XMODIFIERS=@im=scim
export GTK_IM_MODULE=scim
startkde

Save as: .xsession in /home/username

Then open a terminal and type:

Code:
$chmod +x .xsession

3. restart X: Alt-Ctrl-Backspace

I did not see input icon nor can I Ctrl-Space to get Chinese Input.

What did I do wrong?

ezphilosophy
November 22nd, 2005, 06:19 PM
This is a nightmare. It doesn't recongnize what is the next character nor does it even type the right one. I typed "wei shen me" and it can't even input "wei". This is huge problem since Ubuntu is "for humanity". There is no way Ubuntu can reach the 1/4 of the world's population with ****** language input methods. If Windows can do it, why the hell can't Linux do it? There are way more "smart" people working on linux. Seems that people think this is small problem when actually, it's one of the biggest. I'm not Chinese, I'm just an American living in China who deals with Chinese documents all the time. I don't want to switch over to Windows for any reason other to play command and conquer. :-) So, I'm hoping something can be done for the 1/4 of the WORLD'S population. (maybe 1/3?).

Ubuntu is Awesome.

-e

ubuntutinger
November 23rd, 2005, 02:28 AM
This is a nightmare. It doesn't recongnize what is the next character nor does it even type the right one. I typed "wei shen me" and it can't even input "wei". This is huge problem since Ubuntu is "for humanity". There is no way Ubuntu can reach the 1/4 of the world's population with ****** language input methods. If Windows can do it, why the hell can't Linux do it? There are way more "smart" people working on linux. Seems that people think this is small problem when actually, it's one of the biggest. I'm not Chinese, I'm just an American living in China who deals with Chinese documents all the time. I don't want to switch over to Windows for any reason other to play command and conquer. :-) So, I'm hoping something can be done for the 1/4 of the WORLD'S population. (maybe 1/3?).

Ubuntu is Awesome.

-e

Hello,

I have followed DuKefeng's instruction to install Chinese input on Ubuntu Breezy. It worked perfectly. If you use Ubuntu Breezy, please see my previous message. My problem is on Kubuntu version.

DuKefeng
November 30th, 2005, 05:04 AM
my howto only work for gnome. :???:

i'm trying to find an easy way to do it on kde, but failed so far... :(

haven't tried on xfce, anyone did?

ezphilosophy
December 11th, 2005, 09:05 PM
Well, I happened to do a fresh install and now it all seems to work fine. It really puzzles me to what happened before.

Anyway, I have another problem. Why is it that Chinese characters don't show up in the folders, yet they show up in other programs such as totem.
(note screenshot)

djib
December 16th, 2005, 02:33 AM
Hello everyone.
For use of SCIM with KDE, you need to have a .xsession as follow:

scim -d
export LC_CTYPE=zh_CN.UTF-8
export XMODIFIERS="@im=SCIM"
startkde

This means that you must add zh_CN.UTF-8 to your locales by doing a

sudo dpkg-reconfigure locales
Of course you can still select the locale you want as you default locale.

PS: this solution is not perfect because, I cannot type letters like 'ŕ' anymore (ie: ^ is no longer a dead key).

polt
February 12th, 2006, 08:46 AM
is the SCIM compatable with openoffice.org2? i have gotten it to work with most of my programs, but when i try to type in openoffice writer2, it just shows up in romanized characters. the font is set to AR PL New Sung so i have no idea what the problem is.

t_huankiat
October 29th, 2006, 01:07 AM
thanks for the archives and how-tos, I can finally start using inputs in chinese! and finally I figured out how to use 智能拼音 with traditional chinese output!
now i have one more thing to cross out from my windows to linux conversion!:mrgreen:

FrankVdb
November 12th, 2006, 02:38 AM
I tried to install the ttf Arphic fonts (under Edgy) but ran into an error:
"Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defome at line 108."

The error repeats itself for each Arphic font I try to install.

This seems to be a known bug:
http://lists.alioth.debian.org/pipermail/pkg-fonts-devel/2006-August/000167.html

Anyone who knows a workaround?

precinto
November 15th, 2006, 08:39 PM
I'm trying to use SCIM under xgl/beryl. Under my Gnome session I just followed the tutorial, but it didn't work adding 'scim -d' to the startup programs (scim started and sat on the system tray but i couldn't activate anything and the input methods menu didn't show up when left clicking) so i had to try the second method, editing .xsession, which worked. Now under Xgl I'm having the same problem, but the script doesn't seem to work, could someone tell me what would the correct script for xgl?

Should I replace the "gnome-session" line with "startxgl" (the name of the xgl script)? Like this?


scim -d
export XMODIFIERS=@im=scim
export GTK_IM_MODULE=scim
/usr/local/bin/startxgl.sh

Because I've tried and it is not working.

Thanks for your help.

ginbuntu
September 18th, 2007, 12:13 AM
HI, I also have problem with some chinese characters not displaying. But I did the following and it fixed the problem.

go to:

System -> Preferences -> Fonts

On the font preferences box, select "Best Contrast" instead of "Subpixel smoothing" and you can also click on details and play around with the options and see what you like best.

Hope this helps. :)

chngej1991
October 18th, 2007, 04:19 AM
谢谢thanks a lot

areskz
November 22nd, 2007, 01:41 AM
Thank author for this howto, it works nice for me.

I have just one question: what IMEngine I should use? There are several available for simplified and several fro traditional? Which one should I use for traditional and which one for simplified?

lanchongzi
December 3rd, 2007, 07:28 AM
does it work in Gutsy as well?
what about the input in aMSN and Skype?

franksxf
June 14th, 2008, 06:05 AM
Thanks!
The second method works for me and now I could input Chinese.
多谢!

hqlong
October 25th, 2008, 11:44 AM
It's works for me anywhere,thank very much!
呵呵,我这里也可以输中文了。谢谢!:guitar:

shenchen8571
June 10th, 2009, 08:42 AM
Cheers man, work executed fine.

cdubet
June 28th, 2009, 10:59 AM
For ubuntu 9.04, there are a few changes from the original post

1)install the following packages:
some are missing, do not worry, it works with only the one you find in synaptic

2) System -> Preferences -> Sessions
Startup Programs Tab -> Add Button
Startup Command: scim -d
No more port setting

3) sudo apt-get install msttcorefonts

4) im-switch -z fr_FR -s scim (if you are french, en_US for USA. you get yours by using "locale" in your console)

5) log again (or ctrl alt backspace is you have installed dont zap)

6) on the top of the screen (menu bar, at right) you get a keyboard logo: it is scim. right click on it, interface configure, set your keyboard type (fr, us ..)
you can also remove the charset you do not need (ex chinese traditionel is only for taiwan).
Right click and choose menu item reload config
6) select something where you can type (console, google textfield in firefox ..) and press ctrl+space . you will see at the bottom of the screen on the right the input choice windows of SCIM :-)

aixilin
July 21st, 2009, 02:26 PM
Thanks very much. Now I get great Chinese.
哈哈。。。 哈哈。。。我爱中文。。。。

peacelake
December 21st, 2009, 11:12 PM
Chinese Input for Ubuntu Hoary:
(version franšaise) (http://forum.ubuntu-fr.org/viewtopic.php?pid=17862#p17862)

1) install the following packages:
* scim
* scim-chinese
* scim-config-socket
* scim-frontend-socket
* scim-gtk2-immodule
* scim-server-socket
* scim-tables-zh (option)
* xfonts-intl-chinese
* xfonts-intl-chinese-big
* ttf-arphic-gbsn00lp
* ttf-arphic-gkai00mp
* ttf-arphic-bkai00mp
* ttf-arphic-bsmi00lp

accept all dependencies.

2) System -> Preferences -> Sessions

Startup Programs Tab -> Add Button
Startup Command: scim -d
Order: 80

Excuse me, where to get the packages? And I dont' see any "Sessions" on System=> perference

ABuNeNe
December 29th, 2009, 07:24 PM
Excuse me, where to get the packages? And I dont' see any "Sessions" on System=> perference

It have been changed to "Startup Applications". Below is the updated HOWTO.



1) install the following packages:
* scim
* scim-chinese
* scim-config-socket
* scim-frontend-socket
* scim-gtk2-immodule
* scim-server-socket
* scim-tables-zh (option)
* xfonts-intl-chinese
* xfonts-intl-chinese-big
* ttf-arphic-gbsn00lp
* ttf-arphic-gkai00mp
* ttf-arphic-bkai00mp
* ttf-arphic-bsmi00lp

2) System -> Preferences -> Startup Applications
Startup Programs Tab -> Add Button
Startup Command: scim -d

3) sudo apt-get install msttcorefonts (if you encounter Checksum mismatch for arial32.exe, aborting! error, do a remove and install again)

4) im-switch -z fr_FR -s scim (if you are french, en_US for USA. you get yours by using "locale" in your console)

5) log again (or ctrl alt backspace is you have installed dont zap)

FatalChaos
December 30th, 2009, 03:55 AM
In Ubuntu 9.04 (Karmic Koala) ibus is supposed to replace scim as an input manager I think. Go to system -> administration -> language support and install the Chinese language (simplified or traditional, doesn't matter). Then set keyboard input system to ibus. Next, go to system -> ibus preferences, and click on the input method tab to add Chinese. If it asks to start the ibus daemon, do that, and it may also ask you to add some lines to the bashrc file in your home folder. If you can't get ibus to work, make sure to do that too, although ibus worked w/o doing that for me.

nightfall77
July 4th, 2010, 05:04 PM
can someone tell me where to get the chinese input package?
i just install ubuntu today and have no idea where to look for it.
thanks for your help.

areskz
July 4th, 2010, 05:34 PM
nightfall77,
Go to System -> Administration -> Language Support, then click "Install / Remove languages...", find 'chinese' and tick all boxes at the bottom of the window (one of them is 'input'). Press "Apply changes", Ubuntu will download all the neccessary packages.

Then, in "Language & Text" windows, set "Keyboard input method system" to "ibus". Some can advise you set it to "scim", but I prefer "ibus". It is easier to configure, I think.

Feel free to ask questions.

nightfall77
July 6th, 2010, 12:51 AM
Thanks, man that works !!:D

Koshakee
August 17th, 2010, 05:11 AM
Hi, I've followed the instructions to try and get ibus working but still don't know how to change the language. I have installed the Chinese language package and ibus and done the bit above that says, "Then, in "Language & Text" windows, set "Keyboard input method system" to "ibus"."

Where do I go from here? Thanks!

gnulab
November 22nd, 2010, 06:16 PM
Hi, I've followed the instructions to try and get ibus working but still don't know how to change the language. I have installed the Chinese language package and ibus and done the bit above that says, "Then, in "Language & Text" windows, set "Keyboard input method system" to "ibus"."

Where do I go from here? Thanks!

In order to switch input method, the default is hotkey is CTRL + SPACE.