PDA

View Full Version : DevC++ for Ubuntu Drake



pikeblodd
September 1st, 2006, 05:21 AM
Hi all, new as the snow here, and trying to figure my way around. Back on windows I was using Bloodshed Dev C++ for writing programs and was wondering if anyone knew if there is an Ubu equivilant. I found a 'supposed' Dev C++ for linux but unfortunately my n00biness has prevented me from actually loading the bugger.

p.s. anyone getting any weird Gedit failures? whenever i try to use it, it encounters and error and closes, had to use nano to update my libraries

JonahRowley
September 1st, 2006, 07:10 AM
I don't think there is a Dev-C++ for Linux. Ironically, I believe it's written in Delphi, and I don't really know if there are any compilers available for Linux. It's not very good anyway, I don't think you'll be missing much.

I don't use an IDE at all. I use vim (a very powerful editor, but with a learning curve) for editing, and make for project management (again, there's a learning curve). There are, of course, IDEs available such as Eclipse (very large, supposedly good, but I've never tried it), KDevelop (very good from what I've seen) and Anjuta (never really liked that one).

GEdit should _not_ be crashing. Do other things crash unexpectedly? Random, unexplained crashes are not good things, and can often be a sign of hardware problems. An easy test is memtest (I think it comes on the Ubuntu CD), run it for a few minutes to rule out memory errors.

X.Cyclop
September 4th, 2006, 05:08 AM
Try Code::Blocks. ;)

Mr Egg
September 4th, 2006, 08:32 AM
Kylix is a linux alternative to Delphi. So try porting it to linux :D It would be grand if you did.

Hacim
September 4th, 2006, 04:56 PM
if you want to use something like devC++ than I'd take a look at Anjuta it looks very similar.Or you could just use your favorite text editor and a program like make or (I prefere) scons.

skywatcher
March 19th, 2007, 12:42 PM
You may have discovered by now that there is in fact a DevC++ version for Linux. I'm just wondering if anyone is using it? I installed it, but it wont' run -- I keep getting the 'libqt.so.2' error, even though I installed Qt as required.

Is there someone who can help with this?