View Full Version : Guild Wars under Wine

August 30th, 2006, 01:03 AM
I am tying to get Guild Wars installed under Wine, several people have reported partial sucess (Bronze rating) with Dapper http://appdb.winehq.org/appview.php?iVersionId=5386&iTestingId=5258

I can't seem to get the install completed, it always says I have no DirectX installed after doing all the downloads. I have tried the Wine package from the multiverse and also the latest one from
deb http://wine.budgetdedicated.com/apt dapper main

Same results in both cases.

Has anyone managed to get it installed if so how?

BTW. I am not interested in using Cedega as a quick fix, I am specifically trying to get is installed on Wine, I know it won't run properly but it should improve over time as more DirectX functions get implemented.

August 30th, 2006, 03:42 AM
The state of play, is still no play! :( (http://ubuntuforums.org/showthread.php?t=241002&highlight=guild+wars)

Post #9 may interest you...

August 30th, 2006, 05:23 AM
The state of play, is still no play! :( (http://ubuntuforums.org/showthread.php?t=241002&highlight=guild+wars)

Post #9 may interest you...

Thanks, I will try compiling it from source like the poster did.

October 30th, 2007, 01:46 AM
I'm trying to run Guild Wars on Wine but I keep getting this error, fixme:d3d:state_zfunc D3DCMP_NOTEQUAL and D3DCMP_EQUAL do not work correctly yet, is there something I can do to fix it?