PDA

View Full Version : [SOLVED] Force alt + tab to switch only on current workspace in Ubuntu 16



bodo101
September 9th, 2019, 08:19 AM
Going crazy not being able to only switch windows in current active workspace when pressing Alt-Tab. When pressing alt+tab, the window switcher goes thru all windows in ALL workspaces, jumping between workspaces like crazy. I just want to switch windows in the current workspace! Was able to do that before on Ubuntu 14.
Googled and found stuff like:
https://askubuntu.com/questions/464946/force-alt-tab-to-switch-only-on-current-workspace-in-gnome-shell

But my Ubuntu 16 installation doesn't seem to use/have gnome shell? (not sure how to verify this)
Appreciate any hint to get out of this madness.

CatKiller
September 9th, 2019, 01:13 PM
By default Ubuntu 16.04 uses Unity as its desktop environment. You can control the desktop effects in Unity with Compiz Config Settings Manager, which is in the repositories.

bodo101
September 9th, 2019, 03:46 PM
I've used ccsm to change alt+tab behavior for window management, like using Static Application Switcher. But haven't found where I can control to only switch between windows in current workspace when switching windows. Surely this must be the default behavior people expects?

CatKiller
September 9th, 2019, 04:19 PM
It's the keybindings that you want to look at: there are separate entries for "current workspace" and "all workspaces." You just need to set Alt-Tab to be the one for "current workspace" and something else (or nothing) for "all workspaces."

deadflowr
September 9th, 2019, 06:51 PM
The behavior is set in ccsm > ubuntu unity plugin > switcher.

bodo101
September 10th, 2019, 08:12 AM
Thanks CatKiller, deadflowr! Simple as that!

I like the Unity switcher and it's previews, but using the Static switcher because I prefer windows ungrouped. Any way to achieve ungrouping with Unity plugin?