View Full Version : [kubuntu] 18.04 new installation on M.2

September 2nd, 2019, 09:36 PM
I built a new system MSI Gaming with Ryzen 7 and M.2 SSD.
Attempted install from USB and CD both faled. No AHCI found
I get dropped to initramfs>
I tried Legacy and UEFI using both works. UEFI by itself cannot see M.2 Tried RAID worse could not see CD nor SSD
Went into key mode >F6>Escape> changed initrd quiet splash to initrd nvme_load=yes or YES or "YES" all failed to continue to the install screen.
Is their a command in INITRAMFS that I can use?

September 2nd, 2019, 10:23 PM
Is your firmware up to date (check with the vendor)? Try the acpi=no at the "quiet splash" and get rid of quiet to see any errors. If the install works, you can refine the acpi a bit, turning it off may have drastic consequences like seeing only one CPU.

September 3rd, 2019, 01:16 PM
Have you enabled AHCI in your BIOS?

September 5th, 2019, 07:14 AM
Yes I have AHCI selected.
Bios version June 2019, Not sure about the Silicon Power 1TB NVMe PCIe Gen3x4 M.2 2280 TLC R/W up to 3,400/3,000MB/s SSD version.
I have been reading up on Unetbootin but don't see how to run it at initial boot. I will try the ACPI=no to see if that works on Friday.
If not I thought of using a temporary drive to get into the drive menus to initially mount the ssd. Bios sees it but Installer does not.
I also thought of a Windows repair boot to put a format on the drive, not sure about that.
Have to hit the sack now 11 hour work days. Thank you!

I get an error on boot NO Ahci controller available.
INItramfs unable to find a medium containing a live file system.

will type in acpi=no and get back to you

yep It was the same with

September 6th, 2019, 12:48 AM
Have you checked to see if you have UEFI/BIOS update?
And SSD firmware update?

Older models need UEFI update & very newest must have a UEFI update.
MSI Tomahawk B350 with Ryzen R5 1600 New UEFI required

AMD UEFI/BIOS update for Ryzen 3000 series
AMD Releases BIOS Fix To Motherboard Partners For Booting Newer Linux Distributions July 2019

September 6th, 2019, 01:33 AM
okay thanks I will check into it.

The bios build date is 6-4-2019. There is a newer bios August of 19. I will try it but, If the bios is already seeing the device and I can list it in the Boot section...This means that the bios sees the ssd. The SSD is the latest SSD out. It seems to me that I need a grub program to identify the SSD in Ubuntu. Am I wrong?

So from what I understand.
1. update bios
2. Create a bootable drive with a MSDOS FAT32 partition
3. format the M.2 ssd
4. Extract the ISO files to the M.2 drive
I think thats the process.

September 9th, 2019, 04:27 AM
It not extracting ISO, but booting it from UEFI & then using it to do an install to your drive.

September 9th, 2019, 04:52 AM
What exact Ryzen cpu model do you have? The 3000 series has all sorts of additional problems, and may take the very latest kernel to work. I know the acpi=no was sufficient to get a Ryzen 2400 working on a asus ROG STRIX X370 mb, but only one CPU would show. That allowed the installation from a USB, and the system to run, but still some additional work necessary to get all 8 cpus to show.
Update the BIOS first. Create the bootable install media, on a USB ( see https://tutorials.ubuntu.com/tutorial/tutorial-create-a-usb-stick-on-ubuntu#0 ). Typically, you just run an application to "burn" the ISO to the USB -- you shouldn't have to put any filesystem on the USB frist. In some cases, a UEFI install media may actually be set up by copying the ISO files to a FAT filesystem, but that would be a last case resort to set up the install media. In no case would you ever try to set up Ubuntu by just copying the files off an ISO. You should be able to boot the install media (maybe with achi=no,...), and from it, partition the m2 your want to use for the install. The installer will then proceed to set up the proper filesystem and copy the necessary files into place. Then you probably need (achi=no,...) to boot the installed system, until you figure out the minimum necessary kernel flags to use which let you use the whole system. The 18.04 system uses kernel 4.15 by default, so consider a 9 month support system like 19.04 or even a beta like 19.10 to get a later kernel, which may work better with the very latest hardware.

September 11th, 2019, 05:16 AM
Will do.

Updated bios from A10 to A20. A30 just came out yesterday. With .A20 Bios Ubuntu 16. and Kubuntu 18.04 and Kubuntu 19. errored out.

16 had the most errors with AMD-Vi and ATA errors

18 &19 showing both showing No AHCI controller unavailable! errors

Tonight I will download and unzip .A30 8-30-19 bios and try it again.

I think MSI stands for Microsoft Standard Instrument. LoL The 5 day Best Buy Return has ran out so I am stuck with it for now. Any suggestions on a Ubuntu friendly Motherboard?

Back to the headache grind stone.

Ryzen 7 3600, 1tb M.2 3rd gen.

September 13th, 2019, 04:34 AM
AMD released to vendors new UEFI update, but it was only for 19.04.
So best not even to try any older versions for now.

AMD UEFI/BIOS update for Ryzen 3000 series
AMD Releases BIOS Fix To Motherboard Partners For Booting Newer Linux Distributions July 2019

September 13th, 2019, 08:03 AM
Ok Thanks will check later. Updated to .A30 8-29-19 On 18.04 stlll have the problem with No AHCI controller and an 08000000008... error

Will look into the links tomorrow or Sat. Did not try on 19.0 but will try that too. Thanks again!

September 13th, 2019, 03:33 PM
More info on AHCI

September 14th, 2019, 04:51 AM
I tried 19.04 downloaded 9-2-19 Same. Some type of memory fault x08000000... and No AHCI controller available.

There are some Initramfs commands that address these problems for older systems.

Guess I will wait for the next bios update. Not installing Windows. Pure Kubuntu. Raid wants 2 hard drives, not doing that.

I saw one old one that said just install an external controller. No, not wasting more money on this board.

I have other projects I need to address for now. Will probably get a different manufactured motherboard like ASUS -Plain and simple they just work.

Thank you all for your assistance, I do appreciate you. Guess I will leave this post open in case another Bios update arrives.

I did not try the Beta 19.10 Let me try that one.

September 14th, 2019, 05:15 AM
With your pretty current BIOS, I suppose you could try a 5.2.14 kernel from https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.2.14/
That series supposedly fixed some Ryzen problems. I've had good luck in the past just adding in a kernel without messing with the X server etc.

September 14th, 2019, 05:27 PM
Okay I downloaded the ...All.deb patch. How do I apply this to the installation usb?

My system is bare due to the non recognition of the SATA controller.

September 14th, 2019, 09:17 PM
Easiest way might be to do the install of your choice release on another system, add in the 5.2 deb files (dkkg -i ....deb), run sudo update-grub and try a reboot, selecting the 5.2 ekrnel, then move back to your original system. You wont get 5.2 kernel updates, but if your system runs, you can simply download new 5.2 deb files. At some point, the hwe packages will catch up with a working kernel for you. Maybe another possibility is trying to create a new ISO with the new kernel (again on another system) using the isorespin.sh from http://linuxiumcomau.blogspot.com/2017/09/new-version-of-iso-respin-script.html

September 15th, 2019, 04:34 PM
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
curl : Depends: libcurl4 (= 7.58.0-2ubuntu3.8) but 7.58.0-2ubuntu3.7 is to be installed
winusb : Depends: libwxbase2.8-0 (>= but it is not installable
Depends: libwxgtk2.8-0 (>= but it is not installable
Depends: gksu but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Arguhh I always have a problem loading new programs and dependencies... xorriso is being a problem. Still working on isorespin

i think i got it sudo apt --fix-broken install

okay, this one did it

sudo apt -y install xorriso

okay this worked

sudo apt -y install squashfs-tools rsync unzip wget findutils xorriso


sudo isorespin.sh

That brought up the menu for isorespin


this route helped too

Rufus is for windows

Gparted only loads global ISO to usb
unetbootin cannot be found

ddrescue - worked

I must have been using Installer in the Systems list
I just tried gparted and it is diffrent and seems to work.

September 15th, 2019, 10:36 PM
Gparted did not make it bootable, went into software center and found Start up disk creator for usb. It worked for building a boot able ISO.

September 16th, 2019, 12:17 AM
Okay, installing the Kernel v5.2.14 in Kubuntu 18 and 19 did not resolve issues x080000000 and AHCi no controller -errors as pictured before.

September 17th, 2019, 05:43 PM
Getting with MSI to see why I am getting these errors. I'm pretty sure it is the Bios that is the culprit. Will keep yall updated.

September 22nd, 2019, 03:26 AM
I was correct MSI stands for Microsoft Instrument... The MSI MPG x570 Gaming Plus is designed for Windows 10.

MSI Support flat out told me that they do not support Linux platforms.

Please mark as Solved! Purchasing an ASUS Prime x570-Pro.

x570-p would work as well but has less newer features.

It seems that MSI and I believe Gigabit boards use a trimmed Asmedia-Controller

Where AMD made it's own EFI controller which is friendly to Linux platforms.

Thank you all for your help!