View Full Version : [SOLVED] Ubiquity crashed trying to install

July 28th, 2019, 01:17 AM
so i downloaded ubuntu today to try and install it side by side with windows like Ive done a million times before... granted it was years ago.
anyway im running a dell xps 8930 and the install gets almost 99% of the way done and ubiquity crashes.
what commands can i use to help resolve this situation ie give you real linux gurus and idea of where to start

i was reading i may need AHCI drivers in windows which are not available apparently at least not on dells website... kind of at a loss here. haven't messed with any of this stuff in years

July 28th, 2019, 05:09 AM
Usually Dell does not start an install without AHCI mode. And yes you need the Windows AHCI driver for Windows.
Dell normally needs UEFI update and if a SSD firmware update for SSD.
Windows fast start up must be off. Best to have UEFI fast boot off also.

Dell 9380 Dell has 18.04 image with correct drivers

General UEFI install instructions in link in my signature below.

Windows AHCI instructions
AHCI enable - May have to unlock bitlocker if used

July 29th, 2019, 01:40 AM
i can boot into live CD no issue while using uefi
ubuntu can see my windows partition etc etc etc
the install procedure runs just fine but just dies at the end?
would that still have something to do with bios settings?
also noting most of these guides are all laptop based, I'm running a desktop... that dell offers no image for?

July 29th, 2019, 04:31 AM
If at end, is it the install of grub?
And then are you installing in UEFI mode?
If UEFI, you need an ESP - efi system partition for grub to correctly install.

Otherwise it may just be a bad download of the ISO, or flash drive has error so not correct for installing. Some re-download, use different tool to create installer, use different USB port or use different flash drive, and then it works. No consistent fix, just one or several of a variety of changes & then it works.

July 29th, 2019, 03:21 PM
i would assume it to be the install of grub, because if i try to install again it recognizes the ubuntu install
ive tried 18.04 and 19.04
ill try a different flash drive and port.

ive been trying this guide if it helps

ill post results a little later today

July 29th, 2019, 03:38 PM
Guide seems ok.
You do not need swap partition, now as Ubuntu creates a swap file.

Installer should use the ESP - efi system partition that Windows has, unless you installed Windows in BIOS mode and now you are installing Ubuntu in UEFI mode. Pre-installed by Dell would be UEFI as Microsoft has required vendors to install in UEFI mode since Windows 8 released in 2012.

July 29th, 2019, 08:08 PM
turns out just a crap usb drive. put the same iso i had on a different drive, differet port. installed no issue.
i feel like an idiot for not trying that in the first place. thanks