View Full Version : Ubuntu 18.04 on Lenovo IdeaPad d330

July 11th, 2019, 06:34 PM
Im currently trying to install Ubuntu on my Convertible as dual boot, but I have some graphics card related problem.
The device has a Intel UHD Graphics 600 and the screen stays blank when booting the live usb. Otherwise it boots just fine, as I can hear the sound feedback from the login screen when i press the arrow keys.

Any idea for a solution? I already tried nomodeset, but I can't even get to that option. The only menu I see is the one where I can select between trying ubuntu, installing ubuntu (Both options get the blank screen) and oem install.

Thanks in advance :)

July 11th, 2019, 08:01 PM
Have you updated UEFI from Lenovo? And if SSD, updated SSD firmware?

Intel graphics are supposed to just work.
You may need other boot parameter? And should get grub menu if booting in UEFI boot mode.
Or at least remove quiet splash to see boot process and where it stops. Usually not last line posted, but errors or warnings several lines above.

Shows installer with screen shots. Both BIOS purple accessibility screen & UEFI black grub menu screen

Often issues are common across many
models of same brand. Different issues if AMD or Intel.

Lenovo boot screen can be accessed by Fn + F2 keys, boot device selection by Fn + F12.
Ubuntu on Lenovo ThinkPad E470 Pre-installed Ubuntu
Lenovo Y700 Ideapad Windows 10 & Ubuntu SSD & HDD
Lenovo Legion Y520-15I Installer does not detect SSD and HDD: Ubuntu 16.04 LTS
Lenovo 110s Experience Installing and Using Linux on my Lenovo 110s UEFI settings better support than 100

July 12th, 2019, 11:33 AM
No, I didn't update the UEFI, do I have to do that?
I have no SSD, just eMMC-storage.

I don't get any purple screen, the screen stays black after the grub, so I can't give any screenshots.

Booting without quiet splash also doesn't work, screen stays black and doesn't give any feedback.
It doesn't stop the boot process at any point as far as I can hear, it sounds like I got to the login screen.

Rotating the screen also doesn't work, like stated in this article: https://www.rojtberg.net/1652/ubuntu-on-the-lenovo-d330/

Edit: I tried nomodeset again, now it "worked":
I opened the terminal in this picture.
How do I fix this?

July 12th, 2019, 04:23 PM
I had a similar screen on a reboot.

But I have both nVidia & Intel & use nVidia with the open source driver in most of my installs.
I have multiple Ubuntu installs and use 18.04 as main working install, but rebooted into 19.04 & 19.10 to test something & on reboot via a Debian version of grub into 18.04 got that screen. But on reboot it worked normally, so was not sure of issue. Perhaps a firmware version issue as Ubuntu also loads firmware.

You need to update UEFI.
Both Windows & Ubuntu have updated kernels. But UEFI also needs updates for this, but vendors also fixing other issues with updates.

July 14th, 2019, 02:00 AM
Okay, I'll try that tomorrow. There's a brand new update released yesterday on the lenovo website, I hope it works.

July 22nd, 2019, 10:14 PM
The Bios update installer didn't work at first (It just extracted some files and then restarted itself). Now, after a week it randomly popped up and I was able to install it, but unfortunately it had no effect on the linux problem.

July 22nd, 2019, 11:41 PM
Are you getting the grub menu shown here for UEFI boot?
Shows installer with screen shots. Both BIOS purple accessibility screen & UEFI black grub menu screen

October 3rd, 2019, 10:02 AM
How do I fix this?

Add the following to your grub config (/boot/grub/grub.cfg):

set gfxmode=1280x800
set gfxpayload=800x1280

I'm guessing these are reversed due to the rotation issue (it won't fix the rotation of the touch).

October 4th, 2019, 02:39 PM
Do not edit grub.cfg, but edit settings in /etc/default/grub.
Every update to grub or kernel creates new grub.cfg from several scripts & the settings file.

October 4th, 2019, 03:13 PM
Is there a way to add these lines using the default? I've tried several options and none of them worked.

I found a way but it's pretty ugly, I can add these manually to `/etc/grub.d/10_linux.cfg` (not sure about the suffix) and it will add these to all the linux entries whatsoever.

October 4th, 2019, 04:35 PM
You edit grub's files & then update it which creates a new grub.cfg.

sudo nano -B /etc/default/grub

sudo update-grub