PDA

View Full Version : 16.04 server freeze after upgrade to kernel 4.4.0-145 (gfxmode text to solve it)



skochxxl
June 27th, 2019, 06:04 PM
Hi,

I upgraded my 16.04 server (apt upgrade) to the latest kernel and after that all the time it freezes when reaching the login screen.

I figured out that when using an older kernel 4.4.0-143 all is fine but newer kernels (145 / 151) got the freezing error.

I'm able to get the system running when I modify the grub start parameter prior booting (pressing 'e').

I modify
gfxmode $linux_gfx_mode to
gfxmode text and everything is fine.

Tried to modify /etc/default/grub with
GRUB_GFXMODE="text" or
GRUB_GFXPAYLOAD_LINUX="text" (and than update-grub) does not work.

What is causing the problem and how can I solve it permanent?

System: AMD FX(tm)-9590, GeForce GT 710

1fallen
June 27th, 2019, 06:08 PM
To help others to help you, include this please:

cat /etc/default/grub

skochxxl
June 27th, 2019, 06:44 PM
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
# important for power off
GRUB_CMDLINE_LINUX_DEFAULT="acpi=force apm=power_off"
# important for not stopping in grub after boot failure
GRUB_RECORDFAIL_TIMEOUT=20
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

1fallen
June 27th, 2019, 07:54 PM
Try adding "reboot=pci" to the end of GRUB_CMDLINE_LINUX_DEFAULT variable
run as root: "update-grub"
If the system hangs on reboot (system might hang, turn off/on manually)
reboot (this time it should work)

skochxxl
June 27th, 2019, 08:45 PM
It does not hang on reboot but on normal booting. Some seconds after the server login screen appears, the system freezes completely.

1fallen
June 27th, 2019, 08:53 PM
Understood but did you try it?
And all your updates completed successfully right?

smithclarkson01
June 27th, 2019, 09:02 PM
I'm having the same issue on ubuntu server. Just updated it, and 4.4.0-108 doesn't boot.. just a black screen. Going back to 4.4.0-78 works fine.

Regards

9Apps (https://9appsapk.com) 9Apps (https://apk9apps.com) VidMate (https://vidmate.vin/)

skochxxl
June 28th, 2019, 06:07 AM
Adding "reboot=pci" did not help

Adding "gfxmode=text" to the end of GRUB_CMDLINE_LINUX_DEFAULT variable also does not help. I still need to manually add "gfxmode text" before booting.

skochxxl
June 28th, 2019, 08:18 AM
No I switched from my Mini HDMI Monitor with 1280x800 resolution to standard VGA Monitor with 1280x1024 and the problem is gone.

So I assume it has something to do with the Nvidia graphic driver. My interim solution is to use the VGA Monitor.