View Full Version : Problems with installing of the openssh-server

February 9th, 2019, 06:04 PM

We installed 16.04 Ubuntu into LattePanda minicomputer (https://www.lattepanda.com/blog-tag/linux) and wanted to install ssh server for remote access.

What we received after our attempt to do it:
apt-get install openssh-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
openssh-server : Depends: openssh-client (= 1:7.1p1-4)
Depends: openssh-sftp-server but it is not going to be installed
Recommends: ssh-import-id but it is not going to be installed E: Unable to correct problems, you have held broken packages.

February 9th, 2019, 06:07 PM
Show your /etc/apt/sources.list. Also files in /etc/apt/sources.list.d if it's not empty.

February 9th, 2019, 06:18 PM
Thank you about your good answer. I will do it at Monday. I worked all day today with Ubuntu and LattePanda.

February 12th, 2019, 10:11 AM
1) The source from FTP server with LattePanda apt sources
2) The source from FTP server with other Ubuntu computer

February 12th, 2019, 10:43 AM
Thank you!
This difficult task is fully solved -
service sshd status
● ssh.service - OpenBSD Secure Shell server
Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
Active: active (running) since 二 2019-02-12 17:31:28 CST; 9min ago
Main PID: 15622 (sshd)
CGroup: /system.slice/ssh.service
└─15622 /usr/sbin/sshd -D

2月 12 17:31:28 admin systemd[1]: Started OpenBSD Secure Shell server.
2月 12 17:31:28 admin sshd[15622]: Server listening on port 22.
2月 12 17:31:28 admin sshd[15622]: Server listening on :: port 22.
2月 12 17:31:56 admin sshd[15630]: Accepted password for admin from port 39084 ssh2
2月 12 17:31:56 admin sshd[15630]: pam_unix(sshd:session): session opened for user admin by (uid=0)

How it was solved?
I have used this web-page fpr solving difficult task:
Method 2: Use Aptitude Aptitude is an alternative of apt-get which you can use as a higher-level package manager. You can use it to try and install your package with it, instead of apt-get, but first you need to install aptitude.

Press simultaneously the Ctrl, Alt, and T keys on your keyboard to open a
Type in sudo apt-get install aptitude and press Enter to execute the command.
Type in sudo aptitude install PACKAGENAME, where PACKAGENAME is the package you’re installing, and press Enter to execute it. This will try to install the package via aptitude instead of apt-get, which should potentially fix the unmet dependencies issue.


February 12th, 2019, 10:49 AM
Web-page - https://appuals.com/fix-unmet-dependencies-error-ubuntu/