View Full Version : [ubuntu] update-manager error crashed with SystemError in open():

January 22nd, 2019, 08:20 AM
I can really use some help
Hi all

I've been having a lot of trouble trying to update 16.04. The other day I noticed I wasn't getting regular updates as usual. I opened the system & updates and there was a very long list of various updates I had not done. I did not D/L right then and went looking for some what or why information, but I didn't find anything on-point.

I went ahead and starting the updates. I can't say exactly how many there were, but them my system started having multiple crashes. It seemed to start the updates and then crashed time after time. It kept asking me to send an error report, but then crashed before it was submitted.

I went looking for anything I could find, but no luck.

Prior to this incident I had another problem. I'm not sure if they are related. For a long time (months) I had a error notice in the top right menu bar. It is a red circle with a white line. I did not have time to deal with it and my system continued working. A right click showed "Ubuntu Error Package manager - "right click or Apt-Get in terminal . "error: opening the cache (E: could not read from /var /lib /apt/lists/us.archive.ubuntu.com _dists_xenial-updates_in release-get line (21: is a directory) E: the package lists or status file could not be parsed or opened.) : this is usually means that your installed packages have unmet dependencies
I did not really understand the message, but I tried entering the entire string in the terminal which did not work. Then I tried fsck /dev/sda9
hoping that would solve this problem. I've sometimes done this and it seemed to work in the past.
But it must have been the wrong thing to do because then I started having the multiple crashes etc.

So, now I am so far in the weeds I can't find a way out. Aside from the error messages and the general gumming up of my system, I can boot and use my machine. But I still have not done the long list of updates to make my system stable. I think there were a few other things I've done, but I can't recall them.

If the screenshot is not readable I'll post the full image if necessary.file:///home/jess/Desktop/Ubuntu%20error%20Screenshot01-12-2019.png

My most recent attempt to update failed and I got the error message showing in the attached screen shot. I'd like to get this fixed. If anyone can guide me through it, I'll appreciate it.https://ubuntuforums.org/attachment.php?attachmentid=282253&d=1548030281&thumb=1 (https://ubuntuforums.org/attachment.php?attachmentid=282253&d=1548030281)

January 22nd, 2019, 11:40 AM
Please do not start multiple threads for the same problem, it dilutes the community's ability to help and can get confusing when people reply.

Duplicate of https://ubuntuforums.org/showthread.php?t=2410794 closed.