View Full Version : [SOLVED] My system cannot boot.(Failed to open \EFI\BOOT\mmx64.efi -Not found......)

January 13th, 2019, 05:11 AM
The following is the error message when i am booting my computer.
Failed to open \EFI\BOOT\mmx64.efi -Not Found
Failed to load image \EFI\BOOT\mmx64.efi -Not Found
Failed to start MokManage: Not Found
Something has gone serious wrong:import_mok_state() failed

Before this,I has run some command to make the vmware workstation can run vm's.
these commnad lines are in lines:

137 cp vmmon.ko /lib/modules/4.15.0-20-generic/misc/vmmon.ko
138 sudo cp vmmon.ko /lib/modules/4.15.0-20-generic/misc/vmmon.ko
139 modprobe vmmon
140 sudo modprobe vmmon
141 openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=VMware/"
142 sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmmon)
143 sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmnet)
144 sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmnet
145 uname -r
146 mokutil --import MOK.der
147 openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=VMware/"
148 sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmmon)
149 sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmnet)
150 sudo mokutil --import MOK.der
151 sudo update-grub
152 history
153 sudo mount -t ntfs /dev/sda6 /media/philip/sda6
154 modprobe vmmon
155 sudo modprobe vmmon
156 cd /boot/grub/

January 13th, 2019, 05:28 AM
Please use code tags - if you are using New Reply button - highlight text and use the # button in the text box header.

If using Quick Reply then
at the beginning and at the end.

January 13th, 2019, 05:40 AM
Several others have had similar error.
The mmx64.efi is the key manager. Canonical cannot certify third party drivers, but a user can.
It used to be that you just turned off UEFI Secure boot. But Some want Secure Boot and proprietary drivers, so they have created a way for you to self certify (if from a source you trust).
The fix seems to be to copy mmx64.efi, if you have it, or copy grubx64.efi or any other boot file and rename it to mmx64.efi as temporary fix. Full install will have that file.

System fails to boot with \EFI\BOOT\mmx64.efi - Not Found

January 14th, 2019, 04:38 AM
Thank oldfred

i copied the file \EFI\ubuntu\mmx64.efi to directory \EFI\BOOT\

and my computer can boot!

January 14th, 2019, 05:24 AM
Glad that worked, you can change to [Solved].