View Full Version : 18.04 / 18.10 Server Installation Menu Keeps Restarting Every ~1-2s with NUC8i5BEK

January 3rd, 2019, 08:00 PM
I have a new NUC8i5BEK with a 500GB M2 Samsung 970 and a single stick of Crucial 2400MHz 16GB RAM that is updated to the latest 2018/11/28 BIOS/Firmware. With both the 18.04 and 18.10 server ISO images I am able to boot via USB just fine, but once it gets to the language selection menu, the screen flashes back briefly to a grey background one with a single line of text at the top that says something to the effect of "Ubuntu Server 18.xx LTS", and then returns to the language selection menu again for a second or two. I think the grey screen is the installation menu app starting up and basically this app is restarting every second or two. If you hit enter quickly, you can get through a page or two of the menus, but it always restarts so you can never complete anything. I have had one or two instances where after leaving it cycling like this for a half-hour or so, it eventually stops and you can interact with the menus, but once I go past the networking selection screen it restarts again. I want to emphasize that the machine is not rebooting back to grub, etc. - it is very quickly hopping between the installation menu screen and this grey screen.

Has anyone seen this behavior before? I would think if I had a bad hardware or BIOS configuration it wouldn't get this far.


I was able to get this to finally install, but I never really solved the problem I had initially. Here is what happened:

The 18.10 server install eventually stopped restarting after 10min or so. I went ahead with the 18.10 install and everything went fine.
Wanting to be on 18.04 LTS instead, I tried booting that install image but I couldn't get it to stop restarting by waiting even 30min or more.
I opted to downgrade from 18.10 to 18.04 using this guide https://linuxconfig.org/how-to-downgrade-ubuntu-linux-system-to-its-previous-version
Everything is working fine now (assuming I don't need to boot an installer from USB again)

January 4th, 2019, 09:23 PM
Hi cboles (https://ubuntuforums.org/member.php?u=24724),

Can you please make the following changes in the BIOS and let us know if this has helped resolve your issue:

Under Boot:

- No secure boot
- No boot from optical, LAN network, or thunderbolt

Under Power:

- No wake from LAN or thunderbolt
- Turn off PCIe ASPM Support
- Turn on Native ACPI PCIe support

January 5th, 2019, 08:41 PM
Thanks for your help. I made all of the BIOS changes you mentioned and the result was the same. From my searching before posting, the BIOS changes you mention seem to help people who have problems getting the install USB to boot at all. My bootup seems to work fine, I only start to have problems once I'm at the install menu.

January 5th, 2019, 09:12 PM
Hi cboles (https://ubuntuforums.org/member.php?u=24724),

As a test, can you please try installing Ubuntu 18.10 Desktop and let us know if you are still experiencing the same issue?

January 6th, 2019, 08:41 AM
I will give this a try, since I don't have to go through the install to see if the problem exists.

May 14th, 2019, 09:14 PM
I will give this a try, since I don't have to go through the install to see if the problem exists.

I have this same issue can you tell me how you fixed this?

May 24th, 2019, 12:39 AM
Make sure ram is listed as supported. Had same problem on a nuc awhile back. Once i got supported ram it worked flawlessly.