View Full Version : [SOLVED] Failed installation prevents further attempts

December 26th, 2018, 12:00 AM
I was in the process of installing Ubuntu 18.04 on my laptop when the screen timed out. Moving the mouse and using the keyboard would not bring back the screen, and after a couple hours I was forced to power cycle the laptop after I was unable to resume.

When I attempt to boot off the liveCD again to again attempt installation I get an error message that it is unable to find /BOOT/EFI/mmx64.efi and the laptop shuts off immediately afterwards; however I am able to boot to windows 10 with the DVD removed. After looking online for a solution and playing around with the EFI partition I have not progressed any further than I was before. Every solution I have found online assumes that either the user can boot Ubuntu or is able to boot off the liveCD, which I can do neither. Does anyone have any idea what the way ahead is to be able to install ubuntu?

I have also attempted to scrub the EFI partition to just leave Windows; however I still have a BBS priority option for Ubuntu. Is there somewhere else on the hard drive I need to look? I am assuming if I can remove all traces of the previous installation that I can just install off the liveCD like I tried to do originally.

I am running a MSI GT72S, and I am attempting to dual-boot with Windows 10.

December 26th, 2018, 05:48 AM
Some work arounds here:
System fails to boot with \EFI\BOOT\mmx64.efi - Not Found
Some just copy grubx64.efi into /EFI/Boot and rename it to mmx64.efi. but make sure Secure Boot is off.
It seems some tools to create the live installer, do not correctly configure /EFI/Boot.

The mmx64.efi in an install is the UEFI key manager for Secure boot on added files. If you have UEFI Secure boot on and want to install proprietary drivers, Canonical cannot verify secure boot process, but a user can (but then assumes responsibility). Before you just had to have Secure boot off.

Some other MSI installs & issues they had to resolve.

MSI GS65 Boot parameter: modprobe.blacklist=nouveau
MSI GE63 Update UEFI then acpi=off not required
https://askubuntu.com/questions/1059029/18-04lts-msi-ge63-boot-issues &
MSi GT72VR-6RE Dominator Pro - some settings required
Failing to Boot Ubuntu 16.10 in MSI GP72
[SOLVED] MSI GT72S 6QE - Freezes on boot unless acpi=off is used

December 31st, 2018, 01:40 AM
Thanks for the reply. Trying another image of 18.10 failed to work as well; however 18.04 threw the same error but proceeded to let me install on my external hard drive, so success! Anyone having the same problem I would recommend trying the 18.04 LTS image to see if that will let you proceed.