View Full Version : [SOLVED] Ubuntu installer does not recognize SSD

December 24th, 2018, 04:51 PM

The Ubuntu 18.04.1 installer does not recognize the SSD hard drive, where I have a pre-installed version of Windows 10 that I want to erase.

According to the posts
https://ubuntuforums.org/showthread.php?t=2380454, (https://ubuntuforums.org/showthread.php?t=2380454)


I have enabled AHCI Sata Mode and disabled secure boot, fast boot and Windows hibernation, but nothing worked.

System details:
Intel i7-8750H
SSD (not detected by the installer): 256 GB INTEL® 760p M.2 NVMe PCIe SSD
SSHD (detected by the installer): 500 SSHD SEAGATE FIRECUDA

Apparently, the BIOS doesn't detect the SSD either.

Could you please help me?

Thank you

December 24th, 2018, 05:17 PM
Many SSD also need firmware updated.

But if UEFI/BIOS does not see it, then no software can either.
Double check motherboard and how NVMe device is connected.
Some UEFI also have settings to turn on/off a drive. You may want to also check those.

December 25th, 2018, 12:05 PM
The pre-installed version of W10 does see the SSD, so it must be well connected. However, if I try Ubuntu without installing and use GParted, the SSD drive doesn't show up. I don't see any options in the BIOS to turn off/on the Drive.

December 25th, 2018, 03:42 PM
Then have you updated UEFI & SSD firmware?


December 27th, 2018, 02:25 PM
I am trying to update the SSD firmware. I have downloaded the iso file in the link https://downloadcenter.intel.com/download/28174/Intel-SSD-Firmware-Update-Tool?product=134583, burned it to a bootable USB and run the USB from UEFI. Then I see the message "GNU GRUB version 2.00... Minimal BASH-like line editing is supported... grub>". What do I have to do now?

December 27th, 2018, 03:16 PM
If you are getting grub you probably are reverting to your system?
Did you extract ISO or copy it to flash drive?
Not sure what tools the ISO expects.
Did it have more detailed instructions somewhere?

December 27th, 2018, 05:48 PM
I only see the grub console when I attempt to boot from the SSD controller bootable USB. Otherwise, Ubuntu (which I have installed provisionally at the SSHD) starts fine.

I have burned the ISO file to the USB as indicated in the post https://fossbytes.com/create-bootable-usb-media-from-iso-ubuntu/ (I chose the third way).

I think the USB is fine because I can start it from Virtual Box. However, it stucks there in "Decompressing Linux... done... Booting the kernel".

I was wrong when I said the BIOS didn't recognize the SSD. It does recognize it but I didn't see it.

The only way I have found for Ubuntu to recognize my SSD is to close the screen and to open it again. After sleeping, Ubuntu is perfectly able to see my SSD.

December 27th, 2018, 05:53 PM
Here are more detailed instructions: https://www.intel.com/content/www/us/en/support/articles/000020439/memory-and-storage.html

December 27th, 2018, 06:27 PM
It is interesting that you have to boot Intel update tool with Legacy boot mode.

Intel was the developer of EFI (now UEFI v1) which then became UEFI. And UEFI has been the standard on Apple Mac since Apple converted to Intel chips. And Microsoft made UEFI standard on PC when it released Windows 8 five years ago.

December 27th, 2018, 08:00 PM
My BIOS menu is very limited and it doesn't seem to allow me to switch between Legacy/UEFI modes. What I see is the classical BIOS menu, so I think I must be bootuing from BIOS.

The fact that Ubuntu is able to detect the SSD after sleeping doesn't have anything to do with the problem?

December 27th, 2018, 08:29 PM
Following the post https://askubuntu.com/questions/1099048/18-04-and-18-10-fail-to-boot-nvme0-failed-to-set-apst-feature-19, I have added the modification
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvme_core.default_ps_max_latency_us=200"
to the /etc/default/grub file in the SSHD, and updated grub with sudo update-grub.

Now, the Ubuntu OS installed in the SSHD detects the SSD since I boot the computer.

I have tried the following. I have booted from the USB and selected "Try Ubuntu". The live Ubuntu didn't recognize the SSD. Therefore, I slept the computer and awaked it. Then, the live Ubuntu was able to see the SSD, and I installed Ubuntu in the SSD. However, I am unable to modify the grub file of the SSD's installation and, then, I am unable to succesfully boot the SSD partition.

Do you know how can I fix this problem?

December 27th, 2018, 10:06 PM
You can edit grub2's boot parameters the same way you edit for the nomodeset boot parameter which is one of the most common required parameters.

At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset.
How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
How to add boot parameters, grub menu after install (also grub when UEFI)
https://wiki.ubuntu.com/Kernel/KernelBootParameters &

Instructions above should be changed to use sudo -H with any graphical app like gedit.
sudo -H gedit /etc/default/grub
sudo nano /etc/default/grub

December 28th, 2018, 02:10 PM
Thank you very much, Oldfred, it worked by changing grub booting options.

I am going to mark the post as [Solved] but, before, I am going to summarize all the process so that the post can be helpful to other people in the future.

December 28th, 2018, 02:34 PM
Steps to make Ubuntu see the SSD and to install Ubuntu there:

1) Boot from the USB with Ubuntu's live installation.

2) When the grub's menu appears with the options, "Try Ubuntu", "Install Ubuntu", press "e" and you will be able to edit grub's booting options. You will see something similar to this: https://wiki.ubuntu.com/Kernel/KernelBootParameters.

3) Go to the "linux" line and, after
quiet splash, add the words
nvme_core.default_ps_max_latency_us=200 (see also https://askubuntu.com/questions/1099048/18-04-and-18-10-fail-to-boot-nvme0-failed-to-set-apst-feature-19). Then press Ctrl+X to boot with these new option included.

4) The Ubuntu installer should now be able to see the SSD. Proceed to install.

5) Steps 1 to 4 only manage to make the Ubuntu installer to see SSD. The new Ubuntu SSD installation will present the same problem: it will not be able to see the SSD at all and will not be able to boot properly. Thus, when booting the new Ubuntu SSD installation for the first time, press "e" at the grub menu ("Ubuntu", "Advanced options for Ubuntu", etc) and repeat steps 1 to 3.

6) Now the Ubuntu SSD installation should be able to boot properly, but the previous modifications are only provisional. In order to make the booting option
nvme_core.default_ps_max_latency_us=200 permanent, open the grub file

sudo nano /etc/default/grub

make the modification

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvme_core.default_ps_max_latency_us=200"

save the file, and update the grub

sudo update-grub

7) Enjoy!