View Full Version : Failed to install ubuntu

December 22nd, 2018, 07:00 PM
Hi all,
My laptop is xps 13 256 ssd. I tried everything I can and watched a lot of tutorials, but it still stuck at installation type. I was trying to install 18.04 LTS after boot from USB as UEFI MBR. 282000282001.

December 22nd, 2018, 09:34 PM

That's a contradiction-in-terms. MBR is for the old-and-crusty BIOS. GPT is the method for the new-and-shiny UEFI.

Boot the LiveUSB in UEFI mode and it will do a UEFI installation. Boot it in Legacy mode and it will do an MBR installation. You can't really mix-and-match.

December 22nd, 2018, 09:36 PM
Do you have Windows installed on the SSD? Is that the only disk? Did you check it for having basic partitions instead of "dynamic" (You'd need to convert to basic in that case so you could shrink one to make room for Ubuntu ). Why MBR instead of gpt? If UEFI Windows is involved, it will have to be gpt, even though Ubuntu would not care.

December 22nd, 2018, 10:43 PM
it's really weird that when I burn it as GPT, the boot option from USB is gone.

I did double checked the disc and it is basic, and my laptop only have one disc which is that ssd and windows system installed in it. I just tried GPT, it encountered the same situation.

December 22nd, 2018, 11:33 PM
You'll need to boot into Windows and turn off fast boot. Windows hibernates rather than shutting down properly, which leaves the disk inaccessible.

December 23rd, 2018, 12:03 AM
You need several things with new Dell
You need to add AHCI driver to Windows and then change drive in UEFI from RAID or Intel SRT to AHCI.
You need to update Dell's UEFI and SSD's firmware.
After update you probably need to redo UEFI settings like AHCI, Secure boot off, fast start up off etc.

Just about all recent versions of Dell system use same UEFI. Bigger difference if Intel or AMD chip.
Dell update UEFI/BIOS from Linux
Dell support - Update on XPS 13/15 2016 Developer Edition availability
Dell UEFI Dual boot instructions using Something Else
Dell with NVMe needs AHCI & boot option nvme_load=YES
Dell XPS 13 9560 install without issues


December 23rd, 2018, 01:56 AM
Thanks all. Finally, it works. The reason why it won't work is because of the windows works on RAID and Linux works in AHCI. It has to be changed in system configuration under SATA setting.

December 23rd, 2018, 10:37 PM
For future users: here you can find all the process for Dell Xps 15 clearly explained, with a few nice tips at the end. I think it can easily be used of Xps 13 and most likely other Dell PCs too.


December 23rd, 2018, 11:38 PM
Once you install the nVidia driver, you will not want, nor need the nomodeset boot parameter. It may even conflict or prevent use of nVidia driver.

December 24th, 2018, 01:25 AM
Once you install the nVidia driver, you will not want, nor need the nomodeset boot parameter. It may even conflict or prevent use of nVidia driver.

If you read all the process till the end you would have noticed that nomodeset is indeed removed.