View Full Version : Installing Ubuntu 16.04 on Uefi mode on Dell Precision 5820

December 3rd, 2018, 05:45 PM
I'm struggling to install Ubuntu 16.04 in a Workstation Precision 5820

I started with Secure Boot and UEFI Enabled and no Success.
I tried with Secure Boot Disabled and UEFI Enabled and no Success

In both case the result is the same during the boot at certain point i have black screen with a blinking cursor on the top-left of the screen.
The only way to boot a media to install Ubuntu in Disable both Secure Boot and UEFI. There is any things that i can to so install Ubuntu with at least UEFI enabled?

December 3rd, 2018, 06:29 PM
Generally Dell needs UEFI update from Dell, SSD firmware update if SSD.
If nVidia you will need nomodeset boot parameter.
And Dell needs drive changed in UEFI from RAID/Intel srt to AHCI, unless you have RAID 0. But if still using Windows you have to install the AHCI driver into Windows first for it to keep working.
Dell issues are common across many models as similar UEFI used, just different options for different models.
General install instructions in link in my signature, below.

Dell UEFI Dual boot instructions using Something Else
https://www.dell.com/support/article/us/en/19/SLN301754/how-to-install-ubuntu-and-a-recent-windows-operating-system-as-a-dual-boot-on-your-dell-pc?lang=EN (https://www.dell.com/support/article/us/en/19/SLN301754/how-to-install-ubuntu-and-a-recent-windows-operating-system-as-a-dual-boot-on-your-dell-pc?lang=EN)

Dell Precision 5820 with PCI NVME SSD UEFI update & SSD firmware update

DELL Precision 5820 tower and NVMe M.2 front-panel SSD issues Secure boot off, RAID on

Dell update UEFI/BIOS from Linux

December 5th, 2018, 11:42 AM
We had some 5820 with and additional NVME SSD and we'll have to face it, but for the moment we're trying to install in a workstation that has only one HDD and Nvidia Card and no OS present.
The only way to make the Live DVD(os USB Stick) works disable all. For the moment i've changed only the sata operation from RAID to AHCI but nothing has Changed.

After booted the live CD i tried to edit the boot menu adding the parameter nomodeset after quiet splash but i still have the same problem. i can enter into a terminal with CTRL-ALT-F1.....CTRL-ALT-F2...but no GUI to proceed with the installation..

I'm not so good in linux...and it's possible i made some mistake...

December 5th, 2018, 02:28 PM
Did you update firmware, UEFI & SSD?

December 5th, 2018, 03:01 PM
the model i'm working now is without SSD, however i have downloaded the latest BIOS From Dell, but tried booting in DOS mode but that update does not run in DOS Mode. I could try to run the bios upgrade by a Windows Live CD?

December 5th, 2018, 04:07 PM
My Dell is a Small form factor system & I update from UEFI.
I saved Update into my ESP which is FAT32 and what UEFI requires.

Also many Dell now can be updated directly from Linux.
Dell update UEFI/BIOS from Linux
Your 5820 is on the list:

December 5th, 2018, 04:32 PM
i have updated the bios to the last version available 5820T_1.8.3 using a Windows 10 Live, but nothing has changed, same issue. Black Screen with a blinking cursor on the top left.

Probably the only way is to disables UEFI and Using Legacy Boot....i don't know....

December 5th, 2018, 05:02 PM
Generally black screen is not UEFI or BIOS issue, but graphics.
If nVidia you do need nomodeset until you install nVidia graphics driver from Ubuntu repository, but also may have UEFI settings for internal or external video card. Check those settings, also.

Both of the links I have above seemed to install without major video issue to same model as yours.

December 5th, 2018, 05:33 PM
I'm not a linux guru so i don't know why enabling UEFI gave us problems with the Nvidia VideoCard. However i tried to use another Videocard, still a NVIDIA but quite old and the problem is the same(even with the parameter nomodeset)

Tomorrow i will try, if i found with a GPU not Nvidia

December 6th, 2018, 12:11 PM
just to update. I have installed Ubuntu Server and later added Ubuntu Deskop with the proper Nvidia Driver......same issue

December 6th, 2018, 02:10 PM
If you switched to an older nVidia card, you have to change nVidia drivers. And new driver does not correctly replace an old one, and must be totally purged before a new/changed nVidia driver is installed.

If wrong nVidia driver or upgrade, you must purge & install correct driver

December 12th, 2018, 01:30 PM
At the end the only way was disabled UEFI.