View Full Version : [SOLVED] 18.04 not showing boot options menu

November 22nd, 2018, 05:20 PM
earlier this week I had just installed 18.04 along side windows 7, but due to some unknown fumbles, I inadvertantly blew everything away and had to start from scratch.

Windows 7 reinstall easily.
then I reinstalled Ubuntu 18.04, with / on a 30gb partition and /home on a seperate 130gb partition.
I think that bothare Legacy installs.

However, on reboot I do not get the menu where Ubuntu is the default and there is an option of Windows 7. It just boots straight into Windows 7.

I thought I must have messed up the install (as I choose Something Else even though the first line was "Install alongside Windows 7?" and so I started to re-reinstall Ubuntu.
but at the Installation type Page it is showing me "this computer currently has Windows 7 and Ubuntu 18.04 installed. what would you like to do?" So it appears to be recognizing both OSes.

what is going wrong? how do I get 18.04 as the default but also get that startup option list

there are a lot of threads out there on this problem, but I am not seeing a fix that I trust.

November 22nd, 2018, 06:22 PM
It appears that the default Ubuntu Grub bootloader was not properly installed. Best to get details using the Ubuntu install usb and going to the site below, downloading and running boot repair per the instructions on the page. Be sure to select the 2nd option to download it and when running select the option to Create BootInfo Summary and do NOT try to make repairs. Post the link you get here and someone should be able to suggest a solution. ,


November 23rd, 2018, 11:35 PM
As yancek above has said it will help us a lot more to see exactly where you are at present so go to Boot-Repair in my signature below and follow the instructions there to run the Boot-Info-Script.

Do not run the default repair just yet but simply copy back here the pastebin link you get which will show us a lot more about your system.

When you did this last time in your original thread https://ubuntuforums.org/showthread.php?t=2406391 there were no partition showing so let's check that again now that you've reinstalled.

November 24th, 2018, 12:47 AM
thank you .
in fact I ran Boot Repair and on reboot everything came up roses. So I think on this system at least I am all set.