View Full Version : [ubuntu] Ubuntu installation issues on MSI GF63 8RD

November 17th, 2018, 10:36 AM
Hi to everyone! :)

I'm trying to install Ubuntu 16.04 or 18.04 on my new laptop. I've made everythings, starting from the UEFI settings to GPT or MBR settings.

At first nothings worked, till i've made an USB boot with a disk image (not ISO), so it start in live mode. I've checked that everythings worked and it seems like it.

So i started with the installation, it worked good, but at the end of the installation (when ubuntu ask to reboot your pc) my laptop when freezed, so i forced the shut down and rebooted manually. The Grub worked good and so i tried to launch Ubuntu. Nothing the laptop when freezed another time. I tried to change the kernel from .39 to .29, also i tried the recovery mode but it didn't work.

After a long search i've found a thread - https://gist.github.com/mari-linhares/cef4cb3440408e44963d1447a7db5ae0 - that gives the advice to find in the Ubuntu installation option to find the line that starts with linux then add modprobe.blacklist=nouveau after quiet splash.

I've tried also this but nothing changed.

So what's happening? I've been thinking that could be an issues of the chipset. But if Ubuntu start in the "live mode" why it doesn't work after the installation?

Thanks to everyone that could and would help me!


November 17th, 2018, 02:21 PM
Have you updated UEFI from MSI?

Other threads on similar models also have some different boot parameters:
MSI GS65 Boot parameter: modprobe.blacklist=nouveau
MSI GE63 Update UEFI then acpi=off not required
MSi GT72VR-6RE Dominator Pro - some settings required
Failing to Boot Ubuntu 16.10 in MSI GP72
[SOLVED] MSI GT72S 6QE - Freezes on boot unless acpi=off is used

November 17th, 2018, 06:23 PM
I didn't try to update it. Now i'll do it! Thank you! :)

November 26th, 2018, 10:11 PM
Did you have any luck with this?

I'm currently trying to install ubuntu 18.10 on my GF63 8RC. So far I cannot even get the installer to boot. I've tried disabling secure boot and everything no but luck. Could you point me towards the installer image you used?

December 8th, 2018, 07:25 PM
Hey there Loch87!
I am having exactly the same problem on this laptop and currently I am booting it with acpi=off and quiet splash enabled in grub. It allows me to boot but I cannot see battery, cannot use hotkeys.
I wonder if you tried updating the UEFI or anything else? If you have managed to get Ubuntu working properly on this laptop, can you share what you did? thanks


December 25th, 2018, 04:13 AM
Hi guys,

I have the same laptop. Yesterday I tried to install Linux and had the same issue.
I'm not a Linux guru but after hours of pain, I was able to install Ubuntu (Linux Mint 19.1 that is based on Ubuntu 18.04).
"Live mode" works because it uses an open source driver but after installation it probably uses the nvidia drivers.

So I did something like this:
1. Secure boot disable (change this in BIOS, reboot the system and press delete a couple of times before the OS is loaded)
2. Install Ubuntu "normally"
3. Reboot and try to open a terminal:

Possible problem: Screen freezing while installing/rebooting
-Reboot system
-Go to the Install Ubuntu option (BUT DONT PRESS ENTER)
-Press e
-Replace "quiet splash" with "nomodeset".

4. Remove all the nvidia drivers and install the open source video drivers:

$ sudo apt purge nvidia-driver*
$ sudo apt autoremove
$ ubuntu-drivers devices (this command will show you a list of nvidia drivers and one open source driver, use the name of the open source one in the next command)
$ sudo apt install xserver-xorg-video-nouveau
$ sudo reboot

After this, Ubuntu should start normally. Install something like timeshift (and create a snapshot of your system) before trying to install the nvidia drivers.

It seems other people are having a similar issue:
Please, go to the previous link and let them know the issue affects you.

For now, I'm using the open source video drivers, maybe in some days I 'll try to install the nvidia drivers or I'll wait until somebody with more knowledge could give us a better/permanent solution.

I hope this helps.

Oscar R