PDA

View Full Version : [SOLVED] Upgrade from 18.04 to 18.10 not starting after clicking "upgrade" button



ccrs8
October 19th, 2018, 11:37 PM
Just as the subject says. I get a message from Software Updater saying that (x)Ubuntu 18.10 is available (I'm on 18.04), but when I click on the "Upgrade" button, nothing happens. The message window goes away, but no upgrade window appears. Literally nothing happens. I can continue using my computer as normal, and if I search for updates again I get the same message, and the "upgrade" button again does nothing. Any suggestions? This is happening on both my desktop and laptop, so it's not limited to just one machine.

mdrb
October 20th, 2018, 11:25 AM
Hi, I have the same issue.

ccrs8
October 21st, 2018, 08:24 PM
I fixed my own issue. For some reason, the software updater GUI thought I had all of my software in 18.04 up-to-date, but in reality I was missing something. Going to the terminal and doing

sudo apt-get update && sudo apt-get upgrade
updated a few more components. Then going back to Software Updater took me to the same message window I got before, but this time clicking "Upgrade" worked.